[PATCH] gnu: Add speedometer.

  • Done
  • quality assurance status badge
Details
2 participants
  • Foo Chuan Wei
  • Maxim Cournoyer
Owner
unassigned
Submitted by
Foo Chuan Wei
Severity
normal
F
F
Foo Chuan Wei wrote on 25 Nov 2021 09:56
(address . guix-patches@gnu.org)
PU1PR01MB21552B429089FAB97E9C08B08D629@PU1PR01MB2155.apcprd01.prod.exchangelabs.com
* gnu/packages/networking.scm (speedometer): New variable.
---
gnu/packages/networking.scm | 30 ++++++++++++++++++++++++++++++
1 file changed, 30 insertions(+)

Toggle diff (52 lines)
diff --git a/gnu/packages/networking.scm b/gnu/packages/networking.scm
index b583d2531f..2e0ccf62bb 100644
--- a/gnu/packages/networking.scm
+++ b/gnu/packages/networking.scm
@@ -44,6 +44,7 @@
;;; Copyright © 2021 Justin Veilleux <terramorpha@cock.li>
;;; Copyright © 2021 Vinicius Monego <monego@posteo.net>
;;; Copyright © 2021 Milkey Mouse <milkeymouse@meme.institute>
+;;; Copyright © 2021 Foo Chuan Wei <chuanwei.foo@hotmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -4208,6 +4209,35 @@ on hub/switched networks. It is based on @acronym{ARP} packets, it will send
(home-page "https://github.com/netdiscover-scanner/netdiscover")
(license license:gpl3+)))
+(define-public speedometer
+ (package
+ (name "speedometer")
+ (version "2.8")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "Speedometer" version))
+ (sha256
+ (base32 "0qgpjmahy0wlfszqxg0067ck2xab5k6j42d0ifxg1j281yqnm9bx"))))
+ (build-system python-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'fix-script
+ (lambda _
+ (substitute* "setup.py"
+ (("'scripts': \\['speedometer.py'\\],")
+ "'packages': ['.'],")))))
+ #:python ,python-2))
+ (propagated-inputs
+ `(("python2-urwid" ,python2-urwid)))
+ (home-page "https://excess.org/speedometer/")
+ (synopsis "Measure and display the rate of data across a network connection")
+ (description
+ "Console monitor of the rate of data across a network connection or data
+being stored in a file.")
+ (license license:lgpl2.1+)))
+
(define-public putty
(package
(name "putty")

base-commit: 4fd6aabeaabae9184407276f3ae2436284bbcf63
--
2.25.1
M
M
Maxim Cournoyer wrote on 4 Jan 2023 01:48
(name . Foo Chuan Wei)(address . chuanwei.foo@hotmail.com)(address . 52094-done@debbugs.gnu.org)
877cy3xgz5.fsf@gmail.com
Hi,

Foo Chuan Wei <chuanwei.foo@hotmail.com> writes:

Toggle quote (44 lines)
> * gnu/packages/networking.scm (speedometer): New variable.
> ---
> gnu/packages/networking.scm | 30 ++++++++++++++++++++++++++++++
> 1 file changed, 30 insertions(+)
>
> diff --git a/gnu/packages/networking.scm b/gnu/packages/networking.scm
> index b583d2531f..2e0ccf62bb 100644
> --- a/gnu/packages/networking.scm
> +++ b/gnu/packages/networking.scm
> @@ -44,6 +44,7 @@
> ;;; Copyright © 2021 Justin Veilleux <terramorpha@cock.li>
> ;;; Copyright © 2021 Vinicius Monego <monego@posteo.net>
> ;;; Copyright © 2021 Milkey Mouse <milkeymouse@meme.institute>
> +;;; Copyright © 2021 Foo Chuan Wei <chuanwei.foo@hotmail.com>
> ;;;
> ;;; This file is part of GNU Guix.
> ;;;
> @@ -4208,6 +4209,35 @@ on hub/switched networks. It is based on @acronym{ARP} packets, it will send
> (home-page "https://github.com/netdiscover-scanner/netdiscover")
> (license license:gpl3+)))
>
> +(define-public speedometer
> + (package
> + (name "speedometer")
> + (version "2.8")
> + (source
> + (origin
> + (method url-fetch)
> + (uri (pypi-uri "Speedometer" version))
> + (sha256
> + (base32 "0qgpjmahy0wlfszqxg0067ck2xab5k6j42d0ifxg1j281yqnm9bx"))))
> + (build-system python-build-system)
> + (arguments
> + `(#:phases
> + (modify-phases %standard-phases
> + (add-after 'unpack 'fix-script
> + (lambda _
> + (substitute* "setup.py"
> + (("'scripts': \\['speedometer.py'\\],")
> + "'packages': ['.'],")))))
> + #:python ,python-2))
> + (propagated-inputs
> + `(("python2-urwid" ,python2-urwid)))

Thanks for this contribution!

Unfortunately, depending on python2-urwid is a problem; we are trying to
purge Python 2 packages from Guix so do not want to add new ones.

Since the latest version is Speedometer 2.8 - 2011-12-08, according to
[0], I think it's fair to say that it is unmaintained and refuse adding
it to our collection on this basis.

I'll close the issue; feel free to send a Python 3 version if and when
it becomes a thing.


Thanks,

Maxim
Closed
?