[PATCH] gnu: Add byacc.

  • Done
  • quality assurance status badge
Details
2 participants
  • Foo Chuan Wei
  • Ludovic Courtès
Owner
unassigned
Submitted by
Foo Chuan Wei
Severity
normal
F
F
Foo Chuan Wei wrote on 25 Nov 2021 04:47
(address . guix-patches@gnu.org)
PU1PR01MB21554FBCB9C96E05F80D65088D629@PU1PR01MB2155.apcprd01.prod.exchangelabs.com
* gnu/packages/c.scm (byacc): New variable.
---
gnu/packages/c.scm | 23 +++++++++++++++++++++++
1 file changed, 23 insertions(+)

Toggle diff (45 lines)
diff --git a/gnu/packages/c.scm b/gnu/packages/c.scm
index e37c173fc0..4bd53debcd 100644
--- a/gnu/packages/c.scm
+++ b/gnu/packages/c.scm
@@ -12,6 +12,7 @@
;;; Copyright © 2020 Maxim Cournoyer <maxim.cournoyer@gmail.com>
;;; Copyright © 2020, 2021 Greg Hogan <code@greghogan.com>
;;; Copyright © 2021 David Dashyan <mail@davie.li>
+;;; Copyright © 2021 Foo Chuan Wei <chuanwei.foo@hotmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -550,6 +551,28 @@ portability.")
(license (list license:bsd-2 ;all files except...
license:bsd-3)))) ;...the unidef.1 manual page
+(define-public byacc
+ (package
+ (name "byacc")
+ (version "20210808")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://invisible-mirror.net/archives/byacc/byacc-"
+ version ".tgz"))
+ (sha256
+ (base32
+ "10rsgnygn11358jr2dn6bbjj7sj9d9hqf6piqxil4nfhx6dm4n7i"))))
+ (build-system gnu-build-system)
+ (home-page "https://invisible-island.net/byacc/byacc.html")
+ (synopsis "Berkeley Yacc LALR parser generator")
+ (description
+ "Berkeley Yacc is an LALR(1) parser generator. Yacc reads the grammar
+specification from a file and generates an LALR(1) parser for it. The parsers
+consist of a set of LALR(1) parsing tables and a driver routine written in the
+C programming language.")
+ (license license:public-domain)))
+
(define-public aws-c-common
(package
(name "aws-c-common")

base-commit: f9b1bb916c284bea00dd5549a43e0894b219d650
--
2.25.1
L
L
Ludovic Courtès wrote on 5 May 2022 23:54
(address . 52088-done@debbugs.gnu.org)
87mtfv63xs.fsf@gnu.org
Hi,

Foo Chuan Wei <chuanwei.foo@hotmail.com> skribis:

Toggle quote (2 lines)
> * gnu/packages/c.scm (byacc): New variable.

Finally applied, thanks!

Ludo’.
Closed
?