[PATCH] gnu: gst-plugins/selection: Fix behaviour when using flags as-is.

  • Done
  • quality assurance status badge
Details
One participant
  • Liliana Marie Prikler
Owner
unassigned
Submitted by
Liliana Marie Prikler
Severity
normal
L
L
Liliana Marie Prikler wrote on 21 Nov 2021 18:41
(address . guix-patches@gnu.org)
3521e930d03c2eb55ee37074565d4218a28c73ad.camel@gmail.com
When using this gst-plugins/selection without setting configure-flags, the
existing flags are simply inherited. This leads to an issue with
unquote-splicing when looking at quoted lists, e.g. as used by
gst-plugins-bad.

* gnu/packages/gstreamer.scm (gst-plugins-selection)[#:configure-flags]:
Only splice user-provided configure-flags, simply unquote those from existing
packages.

Reported-by: unmatched-paren, nckx (IRC)
---
gnu/packages/gstreamer.scm | 6 ++++--
1 file changed, 4 insertions(+), 2 deletions(-)

Toggle diff (24 lines)
diff --git a/gnu/packages/gstreamer.scm b/gnu/packages/gstreamer.scm
index 2927055240..f7d0808b98 100644
--- a/gnu/packages/gstreamer.scm
+++ b/gnu/packages/gstreamer.scm
@@ -924,13 +924,15 @@ (define-public gst-plugins/selection
(package/inherit pkg
(arguments
(substitute-keyword-arguments (package-arguments pkg)
- ((#:configure-flags flags `(,@(or configure-flags '())))
+ ((#:configure-flags flags ''())
`(append
(list
,@(map (lambda (plugin)
(string-append "-D" plugin "=enabled"))
plugins))
- (list ,@(or configure-flags flags))))
+ ,(if configure-flags
+ `(list ,@configure-flags)
+ flags)))
((#:phases phases)
`(modify-phases ,phases
(add-after 'unpack 'disable-auto-plugins
--
2.34.0
L
L
Liliana Marie Prikler wrote on 9 Sep 2022 18:19
(address . 52022-done@debbugs.gnu.org)
db5c2c1f74f91b2176af575f1820e91c044d53df.camel@gmail.com
Am Sonntag, dem 21.11.2021 um 18:41 +0100 schrieb Liliana Marie
Prikler:
Toggle quote (13 lines)
> When using this gst-plugins/selection without setting configure-
> flags, the
> existing flags are simply inherited.  This leads to an issue with
> unquote-splicing when looking at quoted lists, e.g. as used by
> gst-plugins-bad.
>
> * gnu/packages/gstreamer.scm (gst-plugins-selection)[#:configure-
> flags]:
> Only splice user-provided configure-flags, simply unquote those from
> existing
> packages.
>
> Reported-by: unmatched-paren, nckx (IRC)
This patch appears rather outdated and has been superseded by one I
applied to staging. Thus closing.
Closed
?