[PATCH] gnu: Add gnome-shell-extension-customize-ibus.

  • Done
  • quality assurance status badge
Details
One participant
  • Songlin Jiang
Owner
unassigned
Submitted by
Songlin Jiang
Severity
normal
S
S
Songlin Jiang wrote on 21 Nov 2021 07:38
(name . guix-patches)(address . guix-patches@gnu.org)
tencent_B09D5E0F7D013923D3859FF5ECEC41F59D0A@qq.com
* gnu/packages/gnome-xyz.scm (gnome-shell-extension-customize-ibus): New variable
---
gnu/packages/gnome-xyz.scm | 36 ++++++++++++++++++++++++++++++++++++
1 file changed, 36 insertions(+)
Toggle diff (53 lines)
diff --git a/gnu/packages/gnome-xyz.scm b/gnu/packages/gnome-xyz.scm
index 6d8d02fb9c..51a746e143 100644
--- a/gnu/packages/gnome-xyz.scm
+++ b/gnu/packages/gnome-xyz.scm
@@ -11,6 +11,7 @@
;;; Copyright © 2020 Ellis Kenyo <me@elken.dev>
;;; Copyright © 2020 Stefan Reichör <stefan@xsteve.at>
;;; Copyright © 2021 Vinicius Monego <monego@posteo.net>
+;;; Copyright © 2021 Songlin Jiang <hollowman@hollowman.ml>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -990,3 +991,38 @@ palette.")
outputs notifications to STDOUT in order to allow the user to process
notifications any way they prefer.")
(license license:expat))))
+
+(define-public gnome-shell-extension-customize-ibus
+ (package
+ (name "gnome-shell-extension-customize-ibus")
+ (version "78")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/openSUSE/Customize-IBus.git")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1hnnsjriq7xaakk8biwz55mn077lnm9nsmi4wz5zk7clgxmasvq9"))))
+ (build-system copy-build-system)
+ (arguments
+ '(#:install-plan
+ '(("_build" "share/gnome-shell/extensions/customize-ibus@hollowman.ml"))
+ #:phases
+ (modify-phases %standard-phases
+ (add-before 'install 'compile-everything
+ (lambda _
+ (with-directory-excursion "."
+ (invoke "make"
+ "_build"
+ "VERSION=78"))
+ #t)))))
+ (native-inputs
+ `(("gettext" ,gettext-minimal)
+ ("glib:bin" ,glib "bin")))
+ (home-page "https://github.com/openSUSE/Customize-IBus")
+ (synopsis "GNOME Shell Extension for IBus Customization")
+ (description "Customize IBus provides full customization of appearance,
+behavior, system tray and input source indicator for IBus")
+ (license license:gpl3+)))
--
2.31.1
S
S
Songlin Jiang wrote on 21 Nov 2021 10:02
(name . 52015)(address . 52015@debbugs.gnu.org)
tencent_794ECFE07730A1E2CE52AE75BFB89C13E809@qq.com
Duplicate with #52012 , closing...
Attachment: file
S
S
Songlin Jiang wrote on 21 Nov 2021 10:04
(name . 52015-done)(address . 52015-done@debbugs.gnu.org)
tencent_4D3BED509467E5D70A5F94CE2F7425671F08@qq.com
Close the thread.
Attachment: file
Closed
?