[PATCH] gnu: Add xfoil.

  • Done
  • quality assurance status badge
Details
2 participants
  • Foo Chuan Wei
  • Ludovic Courtès
Owner
unassigned
Submitted by
Foo Chuan Wei
Severity
normal
F
F
Foo Chuan Wei wrote on 20 Nov 2021 08:54
(address . guix-patches@gnu.org)
PU1PR01MB21551A696B38950183AC3BB88D9D9@PU1PR01MB2155.apcprd01.prod.exchangelabs.com
Attachment: file
F
F
Foo Chuan Wei wrote on 21 Nov 2021 11:40
[PATCH v2] gnu: Add xfoil.
(address . 51996@debbugs.gnu.org)
PU1PR01MB21552B912C9D263F18933DA38D9E9@PU1PR01MB2155.apcprd01.prod.exchangelabs.com
Attachment: file
L
L
Ludovic Courtès wrote on 18 Dec 2021 20:04
Re: bug#51996: [PATCH] gnu: Add xfoil.
(name . Foo Chuan Wei)(address . chuanwei.foo@hotmail.com)(address . 51996-done@debbugs.gnu.org)
87mtkxohtb.fsf_-_@gnu.org
Hi,

Foo Chuan Wei <chuanwei.foo@hotmail.com> skribis:

Toggle quote (2 lines)
> * gnu/packages/engineering.scm (xfoil): New variable.

Applied with the changes below.

Thanks!

Ludo’.
Toggle diff (27 lines)
diff --git a/gnu/packages/engineering.scm b/gnu/packages/engineering.scm
index 42f5544a54..e0fe0f354f 100644
--- a/gnu/packages/engineering.scm
+++ b/gnu/packages/engineering.scm
@@ -2961,6 +2961,10 @@ (define-public xfoil
(with-directory-excursion "orrs"
(invoke "bin/osgen" "osmaps_ns.lst"))
(invoke "make" "-C" "plotlib")
+ (substitute* "bin/Makefile_gfortran"
+ (("^FFLAGS =(.*)$" _ suffix)
+ (string-append "FFLAGS = -fallow-argument-mismatch "
+ suffix "\n")))
(invoke "make" "-C" "bin" "-f" "Makefile_gfortran")))
(replace 'install
(lambda* (#:key outputs #:allow-other-keys)
@@ -2976,9 +2980,9 @@ (define-public xfoil
(install-file "xfoil_doc.txt" doc-dir)))))
#:tests? #f))
(inputs
- `(("libx11" ,libx11)))
+ (list libx11))
(native-inputs
- `(("gfortran" ,gfortran)))
+ (list gfortran))
(home-page "https://web.mit.edu/drela/Public/web/xfoil/")
(synopsis "Program for the design and analysis of subsonic airfoils")
(description
Closed
?