[PATCH core-updates-frozen 0/2] wlroots now uses libseat

  • Done
  • quality assurance status badge
Details
3 participants
  • Aiko Kyle
  • Josselin Poiret
  • Ludovic Courtès
Owner
unassigned
Submitted by
Josselin Poiret
Severity
normal
J
J
Josselin Poiret wrote on 19 Nov 2021 12:04
(address . guix-patches@gnu.org)(name . Josselin Poiret)(address . dev@jpoiret.xyz)
20211119110454.4265-1-dev@jpoiret.xyz
Hello,

wlroots now uses libseat rather than elogind directly, and the
'-Dlogind_provider=elogind' configure flag was not letting it build
anymore. Here is a fix for seatd to propagate elogind as a dependency
because it is required by its pkg-config, and for wlroots to remove
the flag and dependency to elogind.

Happy core-updates-frozen use,
Josselin

Josselin Poiret (2):
gnu: seatd: Make elogind a propagated input.
gnu: wlroots: Remove unneeded elogind dependency.

gnu/packages/freedesktop.scm | 2 +-
gnu/packages/wm.scm | 4 +---
2 files changed, 2 insertions(+), 4 deletions(-)

--
2.33.1
J
J
Josselin Poiret wrote on 19 Nov 2021 12:08
[PATCH core-updates-frozen 1/2] gnu: seatd: Make elogind a propagated input.
(name . Josselin Poiret)(address . dev@jpoiret.xyz)(address . 51970@debbugs.gnu.org)
20211119110818.4471-1-dev@jpoiret.xyz
* gnu/packages/freedesktop.scm (seatd): Do it.
---
gnu/packages/freedesktop.scm | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)

Toggle diff (15 lines)
diff --git a/gnu/packages/freedesktop.scm b/gnu/packages/freedesktop.scm
index c1485fed6e..06b1fc952c 100644
--- a/gnu/packages/freedesktop.scm
+++ b/gnu/packages/freedesktop.scm
@@ -876,7 +876,7 @@ (define-public seatd
(native-inputs
`(("pkg-config" ,pkg-config)
("scdoc" ,scdoc)))
- (inputs
+ (propagated-inputs
`(("elogind" ,elogind)))
(home-page "https://sr.ht/~kennylevinsen/seatd")
(synopsis "Seat management daemon and library")
--
2.33.1
J
J
Josselin Poiret wrote on 19 Nov 2021 12:08
[PATCH core-updates-frozen 2/2] gnu: wlroots: Remove unneeded elogind dependency.
(name . Josselin Poiret)(address . dev@jpoiret.xyz)(address . 51970@debbugs.gnu.org)
20211119110818.4471-2-dev@jpoiret.xyz
* gnu/packages/wm.scm (wlroots): Remove it.
---
gnu/packages/wm.scm | 4 +---
1 file changed, 1 insertion(+), 3 deletions(-)

Toggle diff (24 lines)
diff --git a/gnu/packages/wm.scm b/gnu/packages/wm.scm
index 7b7d04eb93..6361530534 100644
--- a/gnu/packages/wm.scm
+++ b/gnu/packages/wm.scm
@@ -1480,8 +1480,7 @@ (define-public wlroots
(base32 "1sshp3lvlkl1i670kxhwsb4xzxl8raz6769kqvgmxzcb63ns9ay1"))))
(build-system meson-build-system)
(arguments
- `(#:configure-flags '("-Dlogind-provider=elogind")
- #:phases
+ `(#:phases
(modify-phases %standard-phases
(add-before 'configure 'hardcode-paths
(lambda* (#:key inputs #:allow-other-keys)
@@ -1492,7 +1491,6 @@ (define-public wlroots
#t)))))
(propagated-inputs
`(;; As required by wlroots.pc.
- ("elogind" ,elogind)
("eudev" ,eudev)
("libinput" ,libinput)
("libxkbcommon" ,libxkbcommon)
--
2.33.1
L
L
Ludovic Courtès wrote on 19 Nov 2021 14:22
Re: bug#51970: [PATCH core-updates-frozen 0/2] wlroots now uses libseat
(name . Josselin Poiret)(address . dev@jpoiret.xyz)(address . 51970-done@debbugs.gnu.org)
87mtm0l1q6.fsf@gnu.org
Hi!

Josselin Poiret <dev@jpoiret.xyz> skribis:

Toggle quote (6 lines)
> wlroots now uses libseat rather than elogind directly, and the
> '-Dlogind_provider=elogind' configure flag was not letting it build
> anymore. Here is a fix for seatd to propagate elogind as a dependency
> because it is required by its pkg-config, and for wlroots to remove
> the flag and dependency to elogind.

Good catch.

Toggle quote (3 lines)
> gnu: seatd: Make elogind a propagated input.
> gnu: wlroots: Remove unneeded elogind dependency.

Applied, thanks!

Ludo’.
Closed
A
A
Aiko Kyle wrote on 2 Jan 2022 05:31
(address . control@debbugs.gnu.org)
CAPWcbYHj6sZwotqquUZDVjZR0fskgzaZ=GqjpREUum_YDD4W2Q@mail.gmail.com
unarchive 51970
A
A
Aiko Kyle wrote on 2 Jan 2022 05:32
(address . 51970@debbugs.gnu.org)
CAPWcbYGNr5hu3ZNOJ3wPP8xbBBt-66rZ4bh+yM9VTvMGNs75bQ@mail.gmail.com
I was wondering if sway still works for you? Sometime between guix
v1.3.0 and now sway broke for me and I think it may have to do with
this update to sway requiring seatd. When I try run sway I get the
error:

00:00:00.007 [ERROR] [wlr] [libseat] [libseat/backend/seatd.c:78]
Could not connect to socket /run/seatd.sock: No such file or directory
00:00:00.017 [ERROR] [wlr] [libseat] [libseat/backend/logind.c:267]
Could not activate session: Interactive authentication required.
00:00:00.017 [ERROR] [wlr] [libseat] [libseat/libseat.c:73] No backend
was able to open a seat
00:00:00.017 [ERROR] [wlr] [backend/session/session.c:84] Unable to
create seat: Function not implemented
00:00:00.017 [ERROR] [wlr] [backend/session/session.c:218] Failed to
load session backend
00:00:00.017 [ERROR] [wlr] [backend/backend.c:353] Failed to start a DRM session
00:00:00.017 [ERROR] [sway/server.c:53] Unable to create backend
?