python-libvirt build failure on core-updates-frozen

  • Done
  • quality assurance status badge
Details
2 participants
  • Jack Hill
  • Ricardo Wurmus
Owner
unassigned
Submitted by
Jack Hill
Severity
normal
J
J
Jack Hill wrote on 19 Nov 2021 06:34
(address . guix-patches@gnu.org)
alpine.DEB.2.21.2111190019050.13935@marsh.hcoop.net
Hi Guix,

python-libvirt currently (commit dab4ce01044b2d960da7375735e9543a259f97d3)
fails to build for me with:

starting phase `build'
running "python setup.py" with command "build" and parameters ()
running build
/gnu/store/wc7lqi6kgki5qzr01g3gvriwdadjiwpc-pkg-config-0.29.2/bin/pkg-config --print-errors --atleast-version=0.9.11 libvirt
/gnu/store/3282r97il61j9jkv2aaifa3nwdylzfsv-python-wrapper-3.9.6/bin/python generator.py libvirt /gnu/store/qzm4ggs2k0wsi0wxvvcaq5kmrmpjrpzv-libvirt-7.9.0/share/libvirt/api/libvirt-api.xml
Found 492 functions in /gnu/store/qzm4ggs2k0wsi0wxvvcaq5kmrmpjrpzv-libvirt-7.9.0/share/libvirt/api/libvirt-api.xml
Found 0 functions in libvirt-override-api.xml
Generated 402 wrapper functions
Missing type converters:
int *:1
ERROR: failed virNodeDeviceGetAutostart
error: command '/gnu/store/3282r97il61j9jkv2aaifa3nwdylzfsv-python-wrapper-3.9.6/bin/python' failed with exit code 1
error: in phase 'build': uncaught exception:
%exception #<&invoke-error program: "python" arguments: ("-c" "import setuptools, tokenize;__file__='setup.py';f=getattr(tokenize, 'open', open)(__file__);code=f.read().replace('\\r\\n', '\\n');f.close();exec(compile(code, __file__, 'exec'))" "build") exit-status: 1 term-signal: #f stop-signal: #f>
phase `build' failed after 0.2 seconds
command "python" "-c" "import setuptools, tokenize;__file__='setup.py';f=getattr(tokenize, 'open', open)(__file__);code=f.read().replace('\\r\\n', '\\n');f.close();exec(compile(code, __file__, 'exec'))" "build" failed with status 1
builder for `/gnu/store/c8gchxa3f1xq33a118bp6hfvn02dr93c-python-libvirt-7.3.0.drv' failed with exit code 1
build of /gnu/store/c8gchxa3f1xq33a118bp6hfvn02dr93c-python-libvirt-7.3.0.drv failed
View build log at '/var/log/guix/drvs/c8/gchxa3f1xq33a118bp6hfvn02dr93c-python-libvirt-7.3.0.drv.bz2'.
guix build: error: build of `/gnu/store/c8gchxa3f1xq33a118bp6hfvn02dr93c-python-libvirt-7.3.0.drv' failed

Updating python-libvirt to the latest release, 7.9.0 solves the problem.
The only dependent package, virt-manager, as reported by `guix refresh -l`
builds and works (I was able to connect to the graphical console of a VM
running on a remote host). Tested on x86_64-linux.

Best,
Jack
J
J
Jack Hill wrote on 19 Nov 2021 06:36
[PATCH core-updates-frozen] gnu: python-libvirt: Update to 7.9.0.
(address . 51962@debbugs.gnu.org)
20211119053639.29161-1-jackhill@jackhill.us
* gnu/packages/virtualization.scm (python-libvirt): Update to 7.9.0.
---
gnu/packages/virtualization.scm | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)

Toggle diff (23 lines)
diff --git a/gnu/packages/virtualization.scm b/gnu/packages/virtualization.scm
index 4eacbed224..e3e8beab6d 100644
--- a/gnu/packages/virtualization.scm
+++ b/gnu/packages/virtualization.scm
@@ -1368,14 +1368,14 @@ (define-public libvirt-glib
(define-public python-libvirt
(package
(name "python-libvirt")
- (version "7.3.0")
+ (version "7.9.0")
(source
(origin
(method url-fetch)
(uri (string-append "https://libvirt.org/sources/python/libvirt-python-"
version ".tar.gz"))
(sha256
- (base32 "15pn8610ybf03xff3vbz3apz2ph42k2kh6k19r020l9nvc6jcv37"))))
+ (base32 "0nakisj2ady5a41k4zc95k0kp749f4ppmxgr91b1h1dzbzxcydc5"))))
(build-system python-build-system)
(arguments
`(#:phases
--
2.33.1
R
R
Ricardo Wurmus wrote on 21 Nov 2021 09:11
python-libvirt build failure on core-updates-frozen
(address . 51962-done@debbugs.gnu.org)
87czmugc5x.fsf@elephly.net
Thank you, I just applied your patch.

--
Ricardo
Closed
?