[PATCH] gnu: Add python-mwparserfromhell

  • Done
  • quality assurance status badge
Details
2 participants
  • Alice BRENON
  • Ricardo Wurmus
Owner
unassigned
Submitted by
Alice BRENON
Severity
normal
A
A
Alice BRENON wrote on 16 Nov 2021 16:16
(address . guix-patches@gnu.org)
20211116161636.3f805384@ens-lyon.fr
Hi list,

Here's a patch to add a guix package for the mwparserfromhell python
library.

Best regards,

Alice
From c256fc3aed7fe38acb7d2490f0adc8854ea3d6ed Mon Sep 17 00:00:00 2001
From: Alice BRENON <alice.brenon@ens-lyon.fr>
Date: Tue, 16 Nov 2021 16:04:02 +0100
Subject: [PATCH] gnu: Add python-mwparserfromhell.

* gnu/packages/python-web.scm (python-mwparserfromhell): New variable.
---
gnu/packages/python-web.scm | 30 ++++++++++++++++++++++++++++++
1 file changed, 30 insertions(+)

Toggle diff (47 lines)
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index 4ddf89c207..785889200f 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -46,6 +46,7 @@
;;; Copyright © 2021 Pradana Aumars <paumars@courrier.dev>
;;; Copyright © 2021 Arun Isaac <arunisaac@systemreboot.net>
;;; Copyright © 2021 jgart <jgart@dismail.de>
+;;; Copyright © 2021 Alice Brenon <alice.brenon@ens-lyon.fr>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -6348,3 +6349,32 @@ (define-public python-flask-combo-jsonapi
Flask-RESTful to quickly build APIs that fit the complexity of existing
real-life projects with legacy data and diverse storage providers.")
(license license:expat)))
+
+(define-public python-mwparserfromhell
+ (package
+ (name "python-mwparserfromhell")
+ (version "0.6.3")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "mwparserfromhell" version))
+ (sha256
+ (base32 "0zh9zaqbac18s7mivqk8am9xw97lfkgcj9hhxj0d4208pkqpkmqs"))))
+ (build-system python-build-system)
+ (native-inputs
+ `(("python-pytest" ,python-pytest)
+ ("python-pytest-runner" ,python-pytest-runner)))
+ (home-page "https://github.com/earwig/mwparserfromhell")
+ (synopsis "Python parser for MediaWiki wikicode")
+ (description
+ "The MediaWiki Parser From Hell is a python library package that provides a
+parser for MediaWiki.
+
+It exposes parses as normal string objects with additional methods giving
+access to the special Wikicode features it contains (hyperlinks, tags,
+templates…). The parser doesn't interpolate strings at all, it remains at a
+purely formal level.
+
+Full documentation may be found at
+@uref{https://mwparserfromhell.readthedocs.io, ReadTheDocs}")
+ (license license:expat)))
--
2.33.1
R
R
Ricardo Wurmus wrote on 1 Dec 2021 11:23
(address . alice.brenon@ens-lyon.fr)(address . 51895-done@debbugs.gnu.org)
87o860sjwe.fsf@elephly.net
Thank you for the patch! I applied it to the “master” branch with
trivial indentation changes.

--
Ricardo
Closed
?