[PATCH 00/12] Removal of broken Python 2 packages

  • Done
  • quality assurance status badge
Details
2 participants
  • Ricardo Wurmus
  • zimoun
Owner
unassigned
Submitted by
zimoun
Severity
normal
Z
Z
zimoun wrote on 15 Nov 2021 15:23
(address . guix-patches@gnu.org)(name . zimoun)(address . zimon.toutoune@gmail.com)
20211115142355.46498-1-zimon.toutoune@gmail.com
Hi,

This series removes packages depending only on themselves.


Cheers,
simon


zimoun (12):
gnu: python2-spectra: Remove package.
gnu: python2-colormath: Remove package.
gnu: python2-traitlets: Remove package.
gnu: python2-pylibmc: Remove package.
gnu: python2-relatorio: Remove package.
gnu: python2-sadisplay: Remove package.
gnu: python2-sql: Remove package.
gnu: python2-factor-boy: Remove package.
gnu: python2-faker: Remove package.
gnu: python2-munkres: Remove package.
gnu: python2-discogs-client: Remove package.
gnu: python2-validators: Remove package.

gnu/packages/databases.scm | 9 -------
gnu/packages/music.scm | 3 ---
gnu/packages/python-xyz.scm | 50 +------------------------------------
3 files changed, 1 insertion(+), 61 deletions(-)


base-commit: ce9b9e7cba87f648dff911d5c055e2a833c25c43
--
2.32.0
Z
Z
zimoun wrote on 15 Nov 2021 15:26
[PATCH 01/12] gnu: python2-spectra: Remove package.
(address . 51870@debbugs.gnu.org)(name . zimoun)(address . zimon.toutoune@gmail.com)
20211115142616.46751-1-zimon.toutoune@gmail.com
* gnu/packages/python-xyz.scm (python2-spectra): Delete variable.
---
gnu/packages/python-xyz.scm | 3 ---
1 file changed, 3 deletions(-)

Toggle diff (16 lines)
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 79ac39e817..31270dc2c4 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -5548,9 +5548,6 @@ (define-public python-spectra
@end enumerate\n")
(license license:expat)))
-(define-public python2-spectra
- (package-with-python2 python-spectra))
-
(define-public python-pyspnego
(package
(name "python-pyspnego")
--
2.32.0
Z
Z
zimoun wrote on 15 Nov 2021 15:26
[PATCH 02/12] gnu: python2-colormath: Remove package.
(address . 51870@debbugs.gnu.org)(name . zimoun)(address . zimon.toutoune@gmail.com)
20211115142616.46751-2-zimon.toutoune@gmail.com
* gnu/packages/python-xyz.scm (python2-colormath): Delete variable.
---
gnu/packages/python-xyz.scm | 3 ---
1 file changed, 3 deletions(-)

Toggle diff (16 lines)
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 31270dc2c4..03264a5604 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -5463,9 +5463,6 @@ (define-public python-colormath
"This is a Python library for color math and conversions.")
(license license:bsd-3)))
-(define-public python2-colormath
- (package-with-python2 python-colormath))
-
(define-public python-sparse
(package
(name "python-sparse")
--
2.32.0
Z
Z
zimoun wrote on 15 Nov 2021 15:26
[PATCH 03/12] gnu: python2-traitlets: Remove package.
(address . 51870@debbugs.gnu.org)(name . zimoun)(address . zimon.toutoune@gmail.com)
20211115142616.46751-3-zimon.toutoune@gmail.com
* gnu/packages/python-xyz.scm (python2-traitlets): Delete variable.
(python-traitlets)[properties]: Remove.
---
gnu/packages/python-xyz.scm | 8 --------
1 file changed, 8 deletions(-)

Toggle diff (28 lines)
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 03264a5604..efbd7a8c7f 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -8291,7 +8291,6 @@ (define-public python-traitlets
("python-six" ,python-six)))
(native-inputs
`(("python-pytest" ,python-pytest)))
- (properties `((python2-variant . ,(delay python2-traitlets))))
(home-page "https://ipython.org")
(synopsis "Configuration system for Python applications")
(description
@@ -8303,13 +8302,6 @@ (define-public python-traitlets
without using the configuration machinery.")
(license license:bsd-3)))
-(define-public python2-traitlets
- (let ((traitlets (package-with-python2 (strip-python2-variant python-traitlets))))
- (package/inherit traitlets
- (propagated-inputs
- `(("python2-enum34" ,python2-enum34)
- ,@(package-propagated-inputs traitlets))))))
-
(define-public python-jupyter-core
(package
(name "python-jupyter-core")
--
2.32.0
Z
Z
zimoun wrote on 15 Nov 2021 15:26
[PATCH 04/12] gnu: python2-pylibmc: Remove package.
(address . 51870@debbugs.gnu.org)(name . zimoun)(address . zimon.toutoune@gmail.com)
20211115142616.46751-4-zimon.toutoune@gmail.com
* gnu/packages/databases.scm (python2-pylibmc): Delete variable.
---
gnu/packages/databases.scm | 3 ---
1 file changed, 3 deletions(-)

Toggle diff (16 lines)
diff --git a/gnu/packages/databases.scm b/gnu/packages/databases.scm
index de161e1864..571746878d 100644
--- a/gnu/packages/databases.scm
+++ b/gnu/packages/databases.scm
@@ -612,9 +612,6 @@ (define-public python-pylibmc
replacement for the code@{python-memcached} library.")
(license license:bsd-3)))
-(define-public python2-pylibmc
- (package-with-python2 python-pylibmc))
-
(define-public mycli
(package
(name "mycli")
--
2.32.0
Z
Z
zimoun wrote on 15 Nov 2021 15:26
[PATCH 05/12] gnu: python2-relatorio: Remove package.
(address . 51870@debbugs.gnu.org)(name . zimoun)(address . zimon.toutoune@gmail.com)
20211115142616.46751-5-zimon.toutoune@gmail.com
* gnu/packages/python-xyz.scm (python2-relatorio): Delete variable.
---
gnu/packages/python-xyz.scm | 3 ---
1 file changed, 3 deletions(-)

Toggle diff (16 lines)
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index efbd7a8c7f..e1c9c043a2 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -18723,9 +18723,6 @@ (define-public python-relatorio
for more filetypes can be easily added by creating plugins for them.")
(license license:gpl3+)))
-(define-public python2-relatorio
- (package-with-python2 python-relatorio))
-
(define-public python-radon
(package
(name "python-radon")
--
2.32.0
Z
Z
zimoun wrote on 15 Nov 2021 15:26
[PATCH 06/12] gnu: python2-sadisplay: Remove package.
(address . 51870@debbugs.gnu.org)(name . zimoun)(address . zimon.toutoune@gmail.com)
20211115142616.46751-6-zimon.toutoune@gmail.com
* gnu/packages/databases.scm (python2-sadisplay): Delete variable.
---
gnu/packages/databases.scm | 3 ---
1 file changed, 3 deletions(-)

Toggle diff (16 lines)
diff --git a/gnu/packages/databases.scm b/gnu/packages/databases.scm
index 571746878d..1d56062d29 100644
--- a/gnu/packages/databases.scm
+++ b/gnu/packages/databases.scm
@@ -3379,9 +3379,6 @@ (define-public python-sadisplay
database).")
(license license:bsd-3)))
-(define-public python2-sadisplay
- (package-with-python2 python-sadisplay))
-
(define-public yoyo-migrations
(package
(name "yoyo-migrations")
--
2.32.0
Z
Z
zimoun wrote on 15 Nov 2021 15:26
[PATCH 07/12] gnu: python2-sql: Remove package.
(address . 51870@debbugs.gnu.org)(name . zimoun)(address . zimon.toutoune@gmail.com)
20211115142616.46751-7-zimon.toutoune@gmail.com
* gnu/packages/databases.scm (python2-sql): Delete variable.
---
gnu/packages/databases.scm | 3 ---
1 file changed, 3 deletions(-)

Toggle diff (16 lines)
diff --git a/gnu/packages/databases.scm b/gnu/packages/databases.scm
index 1d56062d29..e670512f82 100644
--- a/gnu/packages/databases.scm
+++ b/gnu/packages/databases.scm
@@ -3677,9 +3677,6 @@ (define-public python-sql
transforms idiomatic python function calls to well-formed SQL queries.")
(license license:bsd-3)))
-(define-public python2-sql
- (package-with-python2 python-sql))
-
(define-public python-pypika
(package
(name "python-pypika")
--
2.32.0
Z
Z
zimoun wrote on 15 Nov 2021 15:26
[PATCH 08/12] gnu: python2-factor-boy: Remove package.
(address . 51870@debbugs.gnu.org)(name . zimoun)(address . zimon.toutoune@gmail.com)
20211115142616.46751-8-zimon.toutoune@gmail.com
* gnu/packages/python-xyz.scm (python2-factor-boy): Delete variable.
---
gnu/packages/python-xyz.scm | 3 ---
1 file changed, 3 deletions(-)

Toggle diff (16 lines)
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index e1c9c043a2..61ed859c56 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -18580,9 +18580,6 @@ (define-public python-factory-boy
current test, while only declaring the test-specific fields")
(license license:expat)))
-(define-public python2-factory-boy
- (package-with-python2 python-factory-boy))
-
(define-public python-translate-toolkit
(package
(name "python-translate-toolkit")
--
2.32.0
Z
Z
zimoun wrote on 15 Nov 2021 15:26
[PATCH 09/12] gnu: python2-faker: Remove package.
(address . 51870@debbugs.gnu.org)(name . zimoun)(address . zimon.toutoune@gmail.com)
20211115142616.46751-9-zimon.toutoune@gmail.com
* gnu/packages/python-xyz.scm (python2-faker): Delete variable.
(python-faker)[properties]: Remove.
---
gnu/packages/python-xyz.scm | 24 +-----------------------
1 file changed, 1 insertion(+), 23 deletions(-)

Toggle diff (37 lines)
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 61ed859c56..5300e18ef5 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -16033,29 +16033,7 @@ (define-public python-faker
(description
"Faker is a Python package that generates fake data such as names,
addresses, and phone numbers.")
- (license license:expat)
- (properties `((python2-variant . ,(delay python2-faker))))))
-
-;; Faker 4.0 dropped Python 2 support, so we stick with this older version here.
-(define-public python2-faker
- (let ((base (package-with-python2 (strip-python2-variant
- python-faker))))
- (package
- (inherit base)
- (version "3.0.1")
- (source (origin
- (method url-fetch)
- (uri (pypi-uri "Faker" version))
- (sha256
- (base32
- "11cr0qvspkdh6198rqy56qildk7bnp6llj8kyy1dan5sp5n4dxy7"))))
- (native-inputs
- `(("python-mock" ,python2-mock)
- ,@(package-native-inputs base)))
- (propagated-inputs
- `(("python2-ipaddress" ,python2-ipaddress)
- ("python2-six" ,python2-six)
- ,@(package-propagated-inputs base))))))
+ (license license:expat)))
(define-public python-pyaml
(package
--
2.32.0
Z
Z
zimoun wrote on 15 Nov 2021 15:26
[PATCH 10/12] gnu: python2-munkres: Remove package.
(address . 51870@debbugs.gnu.org)(name . zimoun)(address . zimon.toutoune@gmail.com)
20211115142616.46751-10-zimon.toutoune@gmail.com
* gnu/packages/python-xyz.scm (python2-munkres): Delete variable.
---
gnu/packages/python-xyz.scm | 3 ---
1 file changed, 3 deletions(-)

Toggle diff (16 lines)
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 5300e18ef5..4dddb94a21 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -14309,9 +14309,6 @@ (define-public python-munkres
useful for solving the Assignment Problem.")
(license license:bsd-3)))
-(define-public python2-munkres
- (package-with-python2 python-munkres))
-
(define-public python-whoosh
(package
(name "python-whoosh")
--
2.32.0
Z
Z
zimoun wrote on 15 Nov 2021 15:26
[PATCH 11/12] gnu: python2-discogs-client: Remove package.
(address . 51870@debbugs.gnu.org)(name . zimoun)(address . zimon.toutoune@gmail.com)
20211115142616.46751-11-zimon.toutoune@gmail.com
* gnu/packages/music.scm (python2-discogs-client): Delete variable.
---
gnu/packages/music.scm | 3 ---
1 file changed, 3 deletions(-)

Toggle diff (16 lines)
diff --git a/gnu/packages/music.scm b/gnu/packages/music.scm
index 60cff2cc28..6ebdfd55e4 100644
--- a/gnu/packages/music.scm
+++ b/gnu/packages/music.scm
@@ -4757,9 +4757,6 @@ (define-public python-discogs-client
inventory, and orders.")
(license license:bsd-2)))
-(define-public python2-discogs-client
- (package-with-python2 python-discogs-client))
-
(define-public libsmf
(package
(name "libsmf")
--
2.32.0
Z
Z
zimoun wrote on 15 Nov 2021 15:26
[PATCH 12/12] gnu: python2-validators: Remove package.
(address . 51870@debbugs.gnu.org)(name . zimoun)(address . zimon.toutoune@gmail.com)
20211115142616.46751-12-zimon.toutoune@gmail.com
* gnu/packages/python-xyz.scm (python2-validators): Delete variable.
---
gnu/packages/python-xyz.scm | 3 ---
1 file changed, 3 deletions(-)

Toggle diff (16 lines)
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 4dddb94a21..3a5a6c3875 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -19180,9 +19180,6 @@ (define-public python-validators
some input.")
(license license:expat)))
-(define-public python2-validators
- (package-with-python2 python-validators))
-
(define-public python-validate-email
(package
(name "python-validate-email")
--
2.32.0
R
R
Ricardo Wurmus wrote on 25 Nov 2021 00:23
[PATCH 00/12] Removal of broken Python 2 packages
(address . 51870-done@debbugs.gnu.org)
87o869rvcb.fsf@elephly.net
Applied to core-updates-frozen. Thank you!

--
Ricardo
Closed
?