[PATCH] gnu: Add ghc-lrucache.

  • Open
  • quality assurance status badge
Details
One participant
  • Daniel Meißner
Owner
unassigned
Submitted by
Daniel Meißner
Severity
normal
D
D
Daniel Meißner wrote on 12 Nov 2021 10:11
(address . guix-patches@gnu.org)(name . Daniel Meißner)(address . daniel.meissner-i4k@ruhr-uni-bochum.de)
20211112091104.21189-1-daniel.meissner-i4k@ruhr-uni-bochum.de
* gnu/packages/haskell-xyz.scm (ghc-lrucache): New variable.
---
gnu/packages/haskell-xyz.scm | 22 ++++++++++++++++++++++
1 file changed, 22 insertions(+)

Toggle diff (32 lines)
diff --git a/gnu/packages/haskell-xyz.scm b/gnu/packages/haskell-xyz.scm
index ae077f7400..d8382252d0 100644
--- a/gnu/packages/haskell-xyz.scm
+++ b/gnu/packages/haskell-xyz.scm
@@ -16683,3 +16683,25 @@ (define-public ghc-singleton-bool
"This package provides Type-level booleans.")
(license license:bsd-3)))
+(define-public ghc-lrucache
+ (package
+ (name "ghc-lrucache")
+ (version "1.2.0.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://hackage.haskell.org/package/lrucache/lrucache-"
+ version
+ ".tar.gz"))
+ (sha256
+ (base32 "11avhnjnb89rvn2s41jhh5r40zgp7r6kb5c0hcfiibpabqvv46pw"))))
+ (build-system haskell-build-system)
+ (inputs `(("ghc-contravariant" ,ghc-contravariant)))
+ (home-page "https://github.com/chowells79/lrucache")
+ (synopsis "Simple, Pure LRU cache")
+ (description
+ "This package contains a simple, pure LRU cache, implemented in terms of
+@code{Data.Map}. It also contains a mutable IO wrapper providing atomic
+updates to an LRU cache.")
+ (license license:bsd-3)))
--
2.33.1
?