[PATCH 0/2] gnu: Add bloomberg-bde.

  • Done
  • quality assurance status badge
Details
2 participants
  • Greg Hogan
  • Ludovic Courtès
Owner
unassigned
Submitted by
Greg Hogan
Severity
normal
G
L
L
Ludovic Courtès wrote on 1 Dec 2021 16:50
(name . Greg Hogan)(address . code@greghogan.com)(address . 51592@debbugs.gnu.org)
871r2w2ukh.fsf@gnu.org
Hi,

Greg Hogan <code@greghogan.com> skribis:

Toggle quote (7 lines)
> From 9fc2c247d937d587c54b634ec6fcca2b77e22f37 Mon Sep 17 00:00:00 2001
> From: Greg Hogan <code@greghogan.com>
> Date: Wed, 3 Nov 2021 15:22:19 +0000
> Subject: [PATCH 2/2] gnu: Add bloomberg-bde.
>
> * gnu/packages/cpp.scm (bloomberg-bde): New variable.

[...]

Toggle quote (9 lines)
> + (name "bloomberg-bde")
> + ; Recent releases are not tagged so commit must be used for checkout.
> + (version "3.93.0.0")
> + (source (origin
> + (method git-fetch)
> + (uri (git-reference
> + (url "https://github.com/bloomberg/bde")
> + (commit commit)))

There are several bundled code bases, including pcre2, which is already
packaged.

Could you look into unbundling at least pcre2, and ideally all of these?
You can remove ‘thirdparty/’ subdirectories from the snippet.

If some of them are too hard to unbundle, we can leave a FIXME and
address them later.

Nitpick: Please use two semicolons to introduce comments that are on a
line of their own. :-)

Thanks in advance, and apologies for the delay!

Ludo’.
G
G
Greg Hogan wrote on 21 Dec 2021 02:26
(name . Ludovic Courtès)(address . ludo@gnu.org)(address . 51592@debbugs.gnu.org)
CA+3U0Zny45RMqeCpj7Qxov8iLvW1Ocro3eML8G5hbf5Sbnp45g@mail.gmail.com
On Wed, Dec 1, 2021 at 10:50 AM Ludovic Courtès <ludo@gnu.org> wrote:

Toggle quote (33 lines)
> Hi,
>
> Greg Hogan <code@greghogan.com> skribis:
>
> > From 9fc2c247d937d587c54b634ec6fcca2b77e22f37 Mon Sep 17 00:00:00 2001
> > From: Greg Hogan <code@greghogan.com>
> > Date: Wed, 3 Nov 2021 15:22:19 +0000
> > Subject: [PATCH 2/2] gnu: Add bloomberg-bde.
> >
> > * gnu/packages/cpp.scm (bloomberg-bde): New variable.
>
> [...]
>
> > + (name "bloomberg-bde")
> > + ; Recent releases are not tagged so commit must be used for
> checkout.
> > + (version "3.93.0.0")
> > + (source (origin
> > + (method git-fetch)
> > + (uri (git-reference
> > + (url "https://github.com/bloomberg/bde")
> > + (commit commit)))
>
> There are several bundled code bases, including pcre2, which is already
> packaged.
>
> Could you look into unbundling at least pcre2, and ideally all of these?
> You can remove ‘thirdparty/’ subdirectories from the snippet.
>
> If some of them are too hard to unbundle, we can leave a FIXME and
> address them later.
>

I added a FIXME. It is noted that the third-party sources are modified.


Toggle quote (4 lines)
> Nitpick: Please use two semicolons to introduce comments that are on a
> line of their own. :-)
>

Fixed. Thanks for the reminder.


Toggle quote (3 lines)
> Thanks in advance, and apologies for the delay!
>

In addition to rebasing against master and updating the inputs formatting,
I was able to switch the native-input dependency from python2 to python
since my simple patch was accepted upstream. Always nice to see that.


Toggle quote (3 lines)
> Ludo’.
>

Greg
Attachment: file
G
G
Greg Hogan wrote on 4 Feb 2022 22:23
Re: [bug#51592] [PATCH 0/2] gnu: Add bloomberg-bde.
(name . Ludovic Courtès)(address . ludo@gnu.org)(address . 51592@debbugs.gnu.org)
CA+3U0ZkdS2O_bFKzvkTr-Zj17FsBk42-bT8hF4=MvXVv3_YNWw@mail.gmail.com
I have updated the attached patches to the latest versioned commits. I
believe the recommended fixes are all in place.

Thanks,
Greg

Toggle quote (1 lines)
>
Attachment: file
L
L
Ludovic Courtès wrote on 8 Feb 2022 18:19
(name . Greg Hogan)(address . code@greghogan.com)(address . 51592-done@debbugs.gnu.org)
878rul9sz3.fsf@gnu.org
Hi Greg,

Greg Hogan <code@greghogan.com> skribis:

Toggle quote (14 lines)
> From fa9d62133973705b08f4f0952cf55189ff9cdb7b Mon Sep 17 00:00:00 2001
> From: Greg Hogan <code@greghogan.com>
> Date: Wed, 3 Nov 2021 15:20:51 +0000
> Subject: [PATCH 1/2] gnu: Add bloomberg-bde-tools.
>
> * gnu/packages/cpp.scm (bloomberg-bde-tools): New variable.

> From 5b6114f4ee2c3801858d2984d706a490cd34f50e Mon Sep 17 00:00:00 2001
> From: Greg Hogan <code@greghogan.com>
> Date: Wed, 3 Nov 2021 15:22:19 +0000
> Subject: [PATCH 2/2] gnu: Add bloomberg-bde.
>
> * gnu/packages/cpp.scm (bloomberg-bde): New variable.

Applied both, sorry for the delay!

However, I hit a test failure in one case:

Toggle snippet (28 lines)
513/950 Test #513: bslh_defaultseededhashalgorithm.t .................. Passed 0.05 sec
Start 514: bslh_fibonaccibadhashwrapper.t
514/950 Test #514: bslh_fibonaccibadhashwrapper.t ..................... Passed 0.05 sec
Start 515: bslh_hash.t
515/950 Test #515: bslh_hash.t ........................................***Failed 0.05 sec
[11:23:07] TEST START
[11:23:07] CASE 1: SUCCESS
[11:23:07] CASE 2: SUCCESS
[11:23:07] CASE 3: FAILURE (rc 1)
TEST /tmp/guix-build-bloomberg-bde-3.98.0.0.drv-0/source/groups/bsl/bslh/bslh_hash.t.cpp CASE 3
1463: 1463 alg.getLength(): 10 size: 16
Error, non-zero test status = 1.
Error /tmp/guix-build-bloomberg-bde-3.98.0.0.drv-0/source/groups/bsl/bslh/bslh_hash.t.cpp(1463): alg.getLength() == size (failed)

[11:23:07] CASE 4: SUCCESS
[11:23:07] CASE 5: SUCCESS
[11:23:07] CASE 6: SUCCESS
[11:23:07] CASE 7: SUCCESS
[11:23:07] CASE 8: SUCCESS

Start 516: bslh_hashoptional.t
516/950 Test #516: bslh_hashoptional.t ................................ Passed 0.05 sec
Start 517: bslh_hashtuple.t
517/950 Test #517: bslh_hashtuple.t ................................... Passed 0.05 sec
Start 518: bslh_hashvariant.t
518/950 Test #518: bslh_hashvariant.t ................................. Passed 0.05 sec

It’d be worth monitoring ci.guix to see if it happens reproducibly.

Thanks,
Ludo’.
Closed
?