Add --quiet option to guix-install.sh

  • Done
  • quality assurance status badge
Details
3 participants
  • Jacob Hrbek
  • Maxim Cournoyer
  • zimoun
Owner
unassigned
Submitted by
Jacob Hrbek
Severity
normal
J
J
Jacob Hrbek wrote on 30 Oct 2021 04:45
(name . bug-guix@gnu.org)(address . bug-guix@gnu.org)
dBtH1BJiLb5ZPewOpGLrI1_e0CP__XjPhLlWs5PwI7DsadAioH65a9cw9IGU5_LSkjpuUva5kxiJHS-BVj_rmfVjddx_bJ7XKyTkaqv31mc=@rixotstudio.cz
I can't cache the docker step to perform guix-install.sh, because it requires a user input which causes the `docker build -t guix:latest path/to/directory/with/Dockerfile` to ERR1.

Proposing to add command line option `--quiet` for the installer to not ask

Relevant dockerfile:

```dockerfile
#@ All rights reserved (C) Jacob Hrbek <rsa4096/0x31AE4020956E0A9A> in 30/10/2021-EU 01:22:40 UTC

# TODO(Krey): Set as FLOSS once finished

###!!! HALTED(Krey): The guix-install.sh requires an interactive shell blocking the deployment

# 30/10/2021-EU 01:44:14 UTC
FROM debian:bullseye-20211011-slim
LABEL Description="Minimal Debian Linux Image with GUIX package manager designed for testing"
# 30/10/2021-EU 01:24:54 UTC
LABEL Version="30102021012454"

ENV DEBIAN_FRONTEND="noninteractive"

# OUTSOURCED(Krey): Guix's official way to install the package manager on non-GUIX system is using https://git.savannah.gnu.org/cgit/guix.git/plain/etc/guix-install.sh
# 30/10/2021-EU 01:24:54 UTC
ENV guixInstall_commit="e4ed0b3969ddbe44347c468c96ccfa057b2dd256"
RUN true \
&& apt-get update \
&& apt-get install --yes --quiet --no-install-recommends \
wget \
gnupg \
xz-utils \
# NOTE(Krey): We need this otherwise wget will fail with `ERROR: The certificate of '' is not trusted`
ca-certificates \
# Add guix-install dependencies
&& chmod +x guix-install.sh \
&& sh guix-install.sh \
&& apt-get remove --yes \
wget \
gnupg \
xz-utils \
&& apt-get autoremove --yes \
&& apt-get clean --yes \
&& rm -rf \
/var/cache/debconf/* \
/var/lib/apt/lists/* \
/tmp/* \
/var/tmp/*

```

-- Jacob "Kreyren" Hrbek

Sent with ProtonMail Secure Email.
Attachment: file
Attachment: signature.asc
Z
Z
zimoun wrote on 2 Nov 2021 11:39
(name . Jacob Hrbek)(address . kreyren@rixotstudio.cz)(address . 51506@debbugs.gnu.org)
86h7cuzvse.fsf@gmail.com
Hi,

On Sat, 30 Oct 2021 at 02:45, Jacob Hrbek <kreyren@rixotstudio.cz> wrote:
Toggle quote (7 lines)
> I can't cache the docker step to perform guix-install.sh, because it
> requires a user input which causes the `docker build -t guix:latest
> path/to/directory/with/Dockerfile` to ERR1.
>
> Proposing to add command line option `--quiet` for the installer to
> not ask

I think your proposal already exists.

Toggle quote (6 lines)
> Relevant dockerfile:
>
> ```dockerfile
> #@ All rights reserved (C) Jacob Hrbek <rsa4096/0x31AE4020956E0A9A> in 30/10/2021-EU 01:22:40 UTC
> # TODO(Krey): Set as FLOSS once finished

[...]

Toggle quote (3 lines)
> && chmod +x guix-install.sh \
> && sh guix-install.sh \

Replace this latter line by:

yes | ./guix-install.sh

should do what you are asking, IIUC.

Toggle quote (5 lines)
> && apt-get remove --yes \
> wget \
> gnupg \
> xz-utils \

[...]

Toggle quote (2 lines)
> ```

Does it not work for you?


Cheers,
simon
J
J
Jacob Hrbek wrote on 3 Nov 2021 20:53
Re: bug#51506: Acknowledgement (Add --quiet option to guix-install.sh)
(address . 51506@debbugs.gnu.org)
C66XgCVfzo2fE3RjXURqQeMWONge0fGdrFY2ewV9lEtmYKqwQgj1QafyA3sQ6_1xq6XLZduE3jmuGS8B8TrPn9XZSROi17mpiCyhMz3HK4Q=@rixotstudio.cz
Yes, that seems to work, thanks

-- Jacob "Kreyren" Hrbek

Sent with ProtonMail Secure Email.

??????? Original Message ???????

On Saturday, October 30th, 2021 at 10:18 AM, <help-debbugs@gnu.org> wrote:

Toggle quote (43 lines)
> Thank you for filing a new bug report with debbugs.gnu.org.
>

> This is an automatically generated reply to let you know your message
>

> has been received.
>

> Your message is being forwarded to the package maintainers and other
>

> interested parties for their attention; they will reply in due course.
>

> Your message has been sent to the package maintainer(s):
>

> bug-guix@gnu.org
>

> If you wish to submit further information on this problem, please
>

> send it to 51506@debbugs.gnu.org.
>

> Please do not send mail to help-debbugs@gnu.org unless you wish
>

> to report a problem with the Bug-tracking system.
>

> -----------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------
>

> 51506: http://debbugs.gnu.org/cgi/bugreport.cgi?bug=51506
>

> GNU Bug Tracking System
>

> Contact help-debbugs@gnu.org with problems
Attachment: signature.asc
M
M
Maxim Cournoyer wrote on 5 Nov 2021 05:49
Re: bug#51506: Add --quiet option to guix-install.sh
(name . Jacob Hrbek)(address . kreyren@rixotstudio.cz)(address . 51506-done@debbugs.gnu.org)
87h7cr4364.fsf_-_@gmail.com
Hello,

Jacob Hrbek <kreyren@rixotstudio.cz> writes:

Toggle quote (2 lines)
> Yes, that seems to work, thanks

Great, thanks for the reply, and thanks for Simon for the solution!

Closing.

Maxim
Closed
?