[PATCH] Getting rid of some ocaml4.07-* packages.

  • Done
  • quality assurance status badge
Details
3 participants
  • Julien Lepiller
  • Ricardo Wurmus
  • zimoun
Owner
unassigned
Submitted by
Julien Lepiller
Severity
normal
J
J
Julien Lepiller wrote on 23 Oct 2021 19:52
(address . guix-patches@gnu.org)
20211023195212.4baaee5e@tachikoma.lepiller.eu
Hi Guix! this small patch series is a step forward to removing ocaml4.07
packages. There are a few leaf packages that still depend on ocaml
4.07, and this series takes care of fftw3, by building it with our
latest ocaml package (4.11, even though 4.13 is out; wip...).

The last patch is a bit messy. I didn't want to change to much from it,
but its source is no longer available. When testing the patch, guix was
able to use disarchive to get the content from SWH, but after a GC, and
one day, I am no longer able to download the sources. I know of the new
place, should I use it instead?

Trying to use Disarchive to assemble
/gnu/store/jxqnv4y2gyccsfhlbf1n7s5vn1rqgvxc-ocaml-charinfo-width-1.1.0.tar.gz...
Assembling the directory ocaml4.07-charinfo-width-1.1.0 Downloading
/gnu/store/jxqnv4y2gyccsfhlbf1n7s5vn1rqgvxc-ocaml-charinfo-width-1.1.0.tar.gz
from Software Heritage... tar extraction failure 32512 Could not
resolve directory reference failed to download
"/gnu/store/jxqnv4y2gyccsfhlbf1n7s5vn1rqgvxc-ocaml-charinfo-width-1.1.0.tar.gz"
builder for
`/gnu/store/hshfvzxby5cfwmd5fzn8w82pxj525xjr-ocaml-charinfo-width-1.1.0.tar.gz.drv'
failed to produce output path
`/gnu/store/jxqnv4y2gyccsfhlbf1n7s5vn1rqgvxc-ocaml-charinfo-width-1.1.0.tar.gz'
J
J
Julien Lepiller wrote on 23 Oct 2021 19:58
[PATCH 1/4] gnu: Add ocaml-lacaml.
(address . 51358@debbugs.gnu.org)
842202eb6abc579a6d64b64ff41733a3536ff76b.1635011212.git.julien@lepiller.eu
* gnu/packages/ocaml.scm (ocaml4.07-lacaml): Replace with...
(ocaml-lacaml): ...this. Use latest ocaml package.
---
gnu/packages/ocaml.scm | 11 ++++-------
1 file changed, 4 insertions(+), 7 deletions(-)

Toggle diff (39 lines)
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index f640acca35..b128a4d19a 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -6757,7 +6757,7 @@ (define-public ocaml4.07-fftw3
("fftwf" ,fftwf)))
(native-inputs
`(("ocaml-cppo" ,(package-with-ocaml4.07 ocaml-cppo))
- ("ocaml-lacaml" ,ocaml4.07-lacaml)))
+ ("ocaml-lacaml" ,(package-with-ocaml4.07 ocaml-lacaml))))
(home-page
"https://github.com/Chris00/fftw-ocaml")
(synopsis
@@ -6767,9 +6767,9 @@ (define-public ocaml4.07-fftw3
library FFTW.")
(license license:lgpl2.1))) ; with static linking exception.
-(define-public ocaml4.07-lacaml
+(define-public ocaml-lacaml
(package
- (name "ocaml4.07-lacaml")
+ (name "ocaml-lacaml")
(version "11.0.5")
(source
(origin
@@ -6783,10 +6783,7 @@ (define-public ocaml4.07-lacaml
"180yb79a3qgx067qcpm50q12hrimjygf06rgkzbish9d1zfm670c"))))
(build-system dune-build-system)
(arguments
- `(#:tests? #f ; No test target.
- #:ocaml ,ocaml-4.07
- #:findlib ,ocaml4.07-findlib
- #:dune ,ocaml4.07-dune))
+ `(#:tests? #f)) ; No test target.
(native-inputs
`(("openblas" ,openblas)
("lapack" ,lapack)
--
2.33.0
J
J
Julien Lepiller wrote on 23 Oct 2021 19:58
[PATCH 2/4] gnu: Add ocaml-fftw3.
(address . 51358@debbugs.gnu.org)
d433b171f5f8171e35017580a63391be75ba6284.1635011212.git.julien@lepiller.eu
* gnu/packages/ocaml.scm (ocaml4.07-fftw3): Replace with...
(ocaml-fftw3) ...this. Use latest ocaml package.
---
gnu/packages/ocaml.scm | 10 +++-------
1 file changed, 3 insertions(+), 7 deletions(-)

Toggle diff (31 lines)
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index b128a4d19a..4bd805edcc 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -6731,9 +6731,9 @@ (define-public ocaml4.07-odoc
("ocaml-uutf" ,ocaml-uutf)))
(properties '()))))
-(define-public ocaml4.07-fftw3
+(define-public ocaml-fftw3
(package
- (name "ocaml4.07-fftw3")
+ (name "ocaml-fftw3")
(version "0.8.4")
(source
(origin
@@ -6747,11 +6747,7 @@ (define-public ocaml4.07-fftw3
"0l66yagjkwdcib6q55wd8wiap50vi23qiahkghlvm28z7nvbclfk"))))
(build-system dune-build-system)
(arguments
- `(#:tests? #t
- #:test-target "tests"
- #:ocaml ,ocaml-4.07
- #:findlib ,ocaml4.07-findlib
- #:dune ,ocaml4.07-dune))
+ `(#:test-target "tests"))
(propagated-inputs
`(("fftw" ,fftw)
("fftwf" ,fftwf)))
--
2.33.0
J
J
Julien Lepiller wrote on 23 Oct 2021 19:58
[PATCH 3/4] gnu: Add ocaml-gsl.
(address . 51358@debbugs.gnu.org)
62ba40aedaa4174e8787e9e1a2893ea078057d39.1635011212.git.julien@lepiller.eu
* gnu/packages/ocaml.scm (ocaml4.07-gsl): Replace with...
(ocaml-gsl): ...this. Use latest ocaml package.
(ocaml4.07-gsl-1): Adapt accordingly.
---
gnu/packages/ocaml.scm | 53 +++++++++++++++++++-----------------------
1 file changed, 24 insertions(+), 29 deletions(-)

Toggle diff (84 lines)
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index 4bd805edcc..9f94762a85 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -4650,9 +4650,9 @@ (define-public ocaml-merlin
Atom.")
(license license:expat)))
-(define-public ocaml4.07-gsl
+(define-public ocaml-gsl
(package
- (name "ocaml4.07-gsl")
+ (name "ocaml-gsl")
(version "1.24.0")
(source
(origin
@@ -4672,16 +4672,12 @@ (define-public ocaml4.07-gsl
(add-after 'unpack 'fix-gsl-directory
(lambda* (#:key inputs #:allow-other-keys)
(substitute* "src/config/discover.ml"
- (("/usr") (assoc-ref inputs "gsl")))
- #t)))
- #:ocaml ,ocaml-4.07
- #:findlib ,ocaml4.07-findlib
- #:dune ,ocaml4.07-dune))
+ (("/usr") (assoc-ref inputs "gsl"))))))))
(inputs
`(("gsl" ,gsl)))
(propagated-inputs
- `(("ocaml-base" ,(package-with-ocaml4.07 ocaml-base))
- ("ocaml-stdio" ,(package-with-ocaml4.07 ocaml-stdio))))
+ `(("ocaml-base" ,ocaml-base)
+ ("ocaml-stdio" ,ocaml-stdio)))
(home-page "https://mmottl.github.io/gsl-ocaml")
(synopsis "Bindings to the GNU Scientific Library")
(description
@@ -4690,26 +4686,25 @@ (define-public ocaml4.07-gsl
(license license:gpl3+)))
(define-public ocaml4.07-gsl-1
- (package
- (inherit ocaml4.07-gsl)
- (version "1.19.3")
- (source (origin
- (method url-fetch)
- (uri (string-append "https://github.com/mmottl/gsl-ocaml"
- "/releases/download/v"
- version "/gsl-ocaml-" version ".tar.gz"))
- (sha256
- (base32
- "0nzp43hp8pbjqkrxnwp5lgjrabxayf61h18fjaydi0s5faq6f3xh"))))
- (build-system ocaml-build-system)
- (inputs
- `(("gsl" ,gsl)))
- (native-inputs
- `(("ocamlbuild" ,(package-with-ocaml4.07 ocamlbuild))))
- (arguments
- `(#:ocaml ,ocaml-4.07
- #:findlib ,ocaml4.07-findlib))
- (propagated-inputs '())))
+ (package-with-ocaml4.07
+ (package
+ (inherit ocaml-gsl)
+ (version "1.19.3")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "https://github.com/mmottl/gsl-ocaml"
+ "/releases/download/v"
+ version "/gsl-ocaml-" version ".tar.gz"))
+ (sha256
+ (base32
+ "0nzp43hp8pbjqkrxnwp5lgjrabxayf61h18fjaydi0s5faq6f3xh"))))
+ (build-system ocaml-build-system)
+ (inputs
+ `(("gsl" ,gsl)))
+ (native-inputs
+ `(("ocamlbuild" ,ocamlbuild)))
+ (arguments '())
+ (propagated-inputs '()))))
(define-public cubicle
(package
--
2.33.0
J
J
Julien Lepiller wrote on 23 Oct 2021 19:58
[PATCH 4/4] gnu: Add ocaml-charinfo-width.
(address . 51358@debbugs.gnu.org)
94c892169535f0c144d606d4eb657d5cdadfabf4.1635011212.git.julien@lepiller.eu
* gnu/packages/ocaml.scm (ocaml4.07-charinfo-width): Replace with...
(ocaml-charinfo-width): ...this. Use latest ocaml package.
---
gnu/packages/ocaml.scm | 16 ++++++----------
1 file changed, 6 insertions(+), 10 deletions(-)

Toggle diff (46 lines)
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index 9f94762a85..af081756c8 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -3882,9 +3882,9 @@ (define-public ocaml-camomile
;; with an exception for linked libraries to use a different license
(license license:lgpl2.0+)))
-(define-public ocaml4.07-charinfo-width
+(define-public ocaml-charinfo-width
(package
- (name "ocaml4.07-charinfo-width")
+ (name "ocaml-charinfo-width")
(version "1.1.0")
(source (origin
(method url-fetch)
@@ -3895,15 +3895,11 @@ (define-public ocaml4.07-charinfo-width
(base32
"00bv4p1yqs8y0z4z07wd9w9yyv669dikp9b04dcjbwpiy2wy0086"))))
(build-system dune-build-system)
- (arguments
- `(#:ocaml ,ocaml-4.07
- #:findlib ,ocaml4.07-findlib
- #:dune ,ocaml4.07-dune))
(propagated-inputs
- `(("ocaml-result" ,(package-with-ocaml4.07 ocaml-result))
- ("ocaml-camomile" ,(package-with-ocaml4.07 ocaml-camomile))))
+ `(("ocaml-result" ,ocaml-result)
+ ("ocaml-camomile" ,ocaml-camomile)))
(native-inputs
- `(("ocaml-ppx-expect" ,(package-with-ocaml4.07 ocaml-ppx-expect))))
+ `(("ocaml-ppx-expect" ,ocaml-ppx-expect)))
(properties
`((upstream-name . "charInfo_width")))
(home-page "https://bitbucket.org/zandoye/charinfo_width/")
@@ -3933,7 +3929,7 @@ (define-public ocaml4.07-zed
#:dune ,ocaml4.07-dune))
(propagated-inputs
`(("ocaml-camomile" ,(package-with-ocaml4.07 ocaml-camomile))
- ("ocaml-charinfo-width" ,ocaml4.07-charinfo-width)
+ ("ocaml-charinfo-width" ,(package-with-ocaml4.07 ocaml-charinfo-width))
("ocaml-react" ,(package-with-ocaml4.07 ocaml-react))))
(home-page "https://github.com/diml/zed")
(synopsis "Abstract engine for text editing in OCaml")
--
2.33.0
Z
Z
zimoun wrote on 25 Oct 2021 15:56
Re: bug#51358: [PATCH] Getting rid of some ocaml4.07-* packages.
(name . Julien Lepiller)(address . julien@lepiller.eu)(address . 51358@debbugs.gnu.org)
86ilxlky2y.fsf_-_@gmail.com
Hi Julien,

On sam., 23 oct. 2021 at 19:58, Julien Lepiller <julien@lepiller.eu> wrote:
Toggle quote (6 lines)
> * gnu/packages/ocaml.scm (ocaml4.07-lacaml): Replace with...
> (ocaml-lacaml): ...this. Use latest ocaml package.
> ---
> gnu/packages/ocaml.scm | 11 ++++-------
> 1 file changed, 4 insertions(+), 7 deletions(-)

Maybe I am missing something. I fail to build it:

Toggle snippet (16 lines)
$ ./pre-inst-env guix build ocaml-lacaml --no-grafts

[...]

File "src/config/make_prec_dep.ml", line 1:
Error: /gnu/store/nly2n0llgm0x7hdr4x2xrm28v0qcadxf-ocaml4.07-base-0.11.1/lib/ocaml/site-lib/base/base.cmi
is not a compiled interface for this version of OCaml.
It seems to be for an older version of OCaml.
command "dune" "build" "@install" "--release" failed with status 1
builder for `/gnu/store/1xnqbgnxhvjjfzbsdsgz6blf7ascwwvm-ocaml-lacaml-11.0.5.drv' failed with exit code 1
build of /gnu/store/1xnqbgnxhvjjfzbsdsgz6blf7ascwwvm-ocaml-lacaml-11.0.5.drv failed
View build log at '/var/log/guix/drvs/1x/nqbgnxhvjjfzbsdsgz6blf7ascwwvm-ocaml-lacaml-11.0.5.drv.bz2'.
guix build: error: build of `/gnu/store/1xnqbgnxhvjjfzbsdsgz6blf7ascwwvm-ocaml-lacaml-11.0.5.drv' failed


Cheers,
simon
J
J
Julien Lepiller wrote on 26 Oct 2021 00:05
(name . zimoun)(address . zimon.toutoune@gmail.com)(address . 51358@debbugs.gnu.org)
20211026000536.1b19cf19@tachikoma.lepiller.eu
Le Mon, 25 Oct 2021 15:56:05 +0200,
zimoun <zimon.toutoune@gmail.com> a écrit :

Toggle quote (37 lines)
> Hi Julien,
>
> On sam., 23 oct. 2021 at 19:58, Julien Lepiller <julien@lepiller.eu>
> wrote:
> > * gnu/packages/ocaml.scm (ocaml4.07-lacaml): Replace with...
> > (ocaml-lacaml): ...this. Use latest ocaml package.
> > ---
> > gnu/packages/ocaml.scm | 11 ++++-------
> > 1 file changed, 4 insertions(+), 7 deletions(-)
>
> Maybe I am missing something. I fail to build it:
>
> --8<---------------cut here---------------start------------->8---
> $ ./pre-inst-env guix build ocaml-lacaml --no-grafts
>
> [...]
>
> File "src/config/make_prec_dep.ml", line 1:
> Error:
> /gnu/store/nly2n0llgm0x7hdr4x2xrm28v0qcadxf-ocaml4.07-base-0.11.1/lib/ocaml/site-lib/base/base.cmi
> is not a compiled interface for this version of OCaml. It seems to be
> for an older version of OCaml. command "dune" "build" "@install"
> "--release" failed with status 1 builder for
> `/gnu/store/1xnqbgnxhvjjfzbsdsgz6blf7ascwwvm-ocaml-lacaml-11.0.5.drv'
> failed with exit code 1 build of
> /gnu/store/1xnqbgnxhvjjfzbsdsgz6blf7ascwwvm-ocaml-lacaml-11.0.5.drv
> failed View build log at
> '/var/log/guix/drvs/1x/nqbgnxhvjjfzbsdsgz6blf7ascwwvm-ocaml-lacaml-11.0.5.drv.bz2'.
> guix build: error: build of
> `/gnu/store/1xnqbgnxhvjjfzbsdsgz6blf7ascwwvm-ocaml-lacaml-11.0.5.drv'
> failed --8<---------------cut
> here---------------end--------------->8---
>
>
> Cheers,
> simon

Ah, thanks for catching this. It looks like I went too fast when
submitting this series... My intention was to update in a separate
patch, but I only tested the updated version. My bad. Since I can't
build the new version with the old ocaml either, I'm updating in a
single patch.

I also noticed a mistake in the second patch, so I'll resend the series.
J
J
Julien Lepiller wrote on 26 Oct 2021 00:06
[PATCH 1/4] gnu: Add ocaml-lacaml.
(address . 51358@debbugs.gnu.org)
6309f0761c6c6eb56e103a12f8265f3f5bed5cbd.1635199548.git.julien@lepiller.eu
* gnu/packages/ocaml.scm (ocaml4.07-lacaml): Replace with...
(ocaml-lacaml): ...this. Use latest ocaml package.
---
gnu/packages/ocaml.scm | 15 ++++++---------
1 file changed, 6 insertions(+), 9 deletions(-)

Toggle diff (45 lines)
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index f640acca35..65f311f9bf 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -6757,7 +6757,7 @@ (define-public ocaml4.07-fftw3
("fftwf" ,fftwf)))
(native-inputs
`(("ocaml-cppo" ,(package-with-ocaml4.07 ocaml-cppo))
- ("ocaml-lacaml" ,ocaml4.07-lacaml)))
+ ("ocaml-lacaml" ,(package-with-ocaml4.07 ocaml-lacaml))))
(home-page
"https://github.com/Chris00/fftw-ocaml")
(synopsis
@@ -6767,10 +6767,10 @@ (define-public ocaml4.07-fftw3
library FFTW.")
(license license:lgpl2.1))) ; with static linking exception.
-(define-public ocaml4.07-lacaml
+(define-public ocaml-lacaml
(package
- (name "ocaml4.07-lacaml")
- (version "11.0.5")
+ (name "ocaml-lacaml")
+ (version "11.0.8")
(source
(origin
(method git-fetch)
@@ -6780,13 +6780,10 @@ (define-public ocaml4.07-lacaml
(file-name (git-file-name name version))
(sha256
(base32
- "180yb79a3qgx067qcpm50q12hrimjygf06rgkzbish9d1zfm670c"))))
+ "115535kphchh2a434b48b408x9794j8zzrsdmacsgqdsrgy3rck4"))))
(build-system dune-build-system)
(arguments
- `(#:tests? #f ; No test target.
- #:ocaml ,ocaml-4.07
- #:findlib ,ocaml4.07-findlib
- #:dune ,ocaml4.07-dune))
+ `(#:tests? #f)) ; No test target.
(native-inputs
`(("openblas" ,openblas)
("lapack" ,lapack)
--
2.33.0
J
J
Julien Lepiller wrote on 26 Oct 2021 00:06
[PATCH 2/4] gnu: Add ocaml-fftw3.
(address . 51358@debbugs.gnu.org)
fda39ee673e434164fa3abd2896177784dc79957.1635199548.git.julien@lepiller.eu
* gnu/packages/ocaml.scm (ocaml4.07-fftw3): Replace with...
(ocaml-fftw3) ...this. Use latest ocaml package.
---
gnu/packages/ocaml.scm | 14 +++++---------
1 file changed, 5 insertions(+), 9 deletions(-)

Toggle diff (39 lines)
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index 65f311f9bf..f0469940aa 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -6731,9 +6731,9 @@ (define-public ocaml4.07-odoc
("ocaml-uutf" ,ocaml-uutf)))
(properties '()))))
-(define-public ocaml4.07-fftw3
+(define-public ocaml-fftw3
(package
- (name "ocaml4.07-fftw3")
+ (name "ocaml-fftw3")
(version "0.8.4")
(source
(origin
@@ -6747,17 +6747,13 @@ (define-public ocaml4.07-fftw3
"0l66yagjkwdcib6q55wd8wiap50vi23qiahkghlvm28z7nvbclfk"))))
(build-system dune-build-system)
(arguments
- `(#:tests? #t
- #:test-target "tests"
- #:ocaml ,ocaml-4.07
- #:findlib ,ocaml4.07-findlib
- #:dune ,ocaml4.07-dune))
+ `(#:test-target "tests"))
(propagated-inputs
`(("fftw" ,fftw)
("fftwf" ,fftwf)))
(native-inputs
- `(("ocaml-cppo" ,(package-with-ocaml4.07 ocaml-cppo))
- ("ocaml-lacaml" ,(package-with-ocaml4.07 ocaml-lacaml))))
+ `(("ocaml-cppo" ,ocaml-cppo)
+ ("ocaml-lacaml" ,ocaml-lacaml)))
(home-page
"https://github.com/Chris00/fftw-ocaml")
(synopsis
--
2.33.0
J
J
Julien Lepiller wrote on 26 Oct 2021 00:06
[PATCH 3/4] gnu: Add ocaml-gsl.
(address . 51358@debbugs.gnu.org)
38172f3c92b0ab3462985efef82e155dbe4025ad.1635199548.git.julien@lepiller.eu
* gnu/packages/ocaml.scm (ocaml4.07-gsl): Replace with...
(ocaml-gsl): ...this. Use latest ocaml package.
(ocaml4.07-gsl-1): Adapt accordingly.
---
gnu/packages/ocaml.scm | 53 +++++++++++++++++++-----------------------
1 file changed, 24 insertions(+), 29 deletions(-)

Toggle diff (84 lines)
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index f0469940aa..a6e8af8bcf 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -4650,9 +4650,9 @@ (define-public ocaml-merlin
Atom.")
(license license:expat)))
-(define-public ocaml4.07-gsl
+(define-public ocaml-gsl
(package
- (name "ocaml4.07-gsl")
+ (name "ocaml-gsl")
(version "1.24.0")
(source
(origin
@@ -4672,16 +4672,12 @@ (define-public ocaml4.07-gsl
(add-after 'unpack 'fix-gsl-directory
(lambda* (#:key inputs #:allow-other-keys)
(substitute* "src/config/discover.ml"
- (("/usr") (assoc-ref inputs "gsl")))
- #t)))
- #:ocaml ,ocaml-4.07
- #:findlib ,ocaml4.07-findlib
- #:dune ,ocaml4.07-dune))
+ (("/usr") (assoc-ref inputs "gsl"))))))))
(inputs
`(("gsl" ,gsl)))
(propagated-inputs
- `(("ocaml-base" ,(package-with-ocaml4.07 ocaml-base))
- ("ocaml-stdio" ,(package-with-ocaml4.07 ocaml-stdio))))
+ `(("ocaml-base" ,ocaml-base)
+ ("ocaml-stdio" ,ocaml-stdio)))
(home-page "https://mmottl.github.io/gsl-ocaml")
(synopsis "Bindings to the GNU Scientific Library")
(description
@@ -4690,26 +4686,25 @@ (define-public ocaml4.07-gsl
(license license:gpl3+)))
(define-public ocaml4.07-gsl-1
- (package
- (inherit ocaml4.07-gsl)
- (version "1.19.3")
- (source (origin
- (method url-fetch)
- (uri (string-append "https://github.com/mmottl/gsl-ocaml"
- "/releases/download/v"
- version "/gsl-ocaml-" version ".tar.gz"))
- (sha256
- (base32
- "0nzp43hp8pbjqkrxnwp5lgjrabxayf61h18fjaydi0s5faq6f3xh"))))
- (build-system ocaml-build-system)
- (inputs
- `(("gsl" ,gsl)))
- (native-inputs
- `(("ocamlbuild" ,(package-with-ocaml4.07 ocamlbuild))))
- (arguments
- `(#:ocaml ,ocaml-4.07
- #:findlib ,ocaml4.07-findlib))
- (propagated-inputs '())))
+ (package-with-ocaml4.07
+ (package
+ (inherit ocaml-gsl)
+ (version "1.19.3")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "https://github.com/mmottl/gsl-ocaml"
+ "/releases/download/v"
+ version "/gsl-ocaml-" version ".tar.gz"))
+ (sha256
+ (base32
+ "0nzp43hp8pbjqkrxnwp5lgjrabxayf61h18fjaydi0s5faq6f3xh"))))
+ (build-system ocaml-build-system)
+ (inputs
+ `(("gsl" ,gsl)))
+ (native-inputs
+ `(("ocamlbuild" ,ocamlbuild)))
+ (arguments '())
+ (propagated-inputs '()))))
(define-public cubicle
(package
--
2.33.0
J
J
Julien Lepiller wrote on 26 Oct 2021 00:06
[PATCH 4/4] gnu: Add ocaml-charinfo-width.
(address . 51358@debbugs.gnu.org)
e4c3684d11791b840b2ae6c24dfdba04164c5d96.1635199548.git.julien@lepiller.eu
* gnu/packages/ocaml.scm (ocaml4.07-charinfo-width): Replace with...
(ocaml-charinfo-width): ...this. Use latest ocaml package.
---
gnu/packages/ocaml.scm | 16 ++++++----------
1 file changed, 6 insertions(+), 10 deletions(-)

Toggle diff (46 lines)
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index a6e8af8bcf..c0bb1675a2 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -3882,9 +3882,9 @@ (define-public ocaml-camomile
;; with an exception for linked libraries to use a different license
(license license:lgpl2.0+)))
-(define-public ocaml4.07-charinfo-width
+(define-public ocaml-charinfo-width
(package
- (name "ocaml4.07-charinfo-width")
+ (name "ocaml-charinfo-width")
(version "1.1.0")
(source (origin
(method url-fetch)
@@ -3895,15 +3895,11 @@ (define-public ocaml4.07-charinfo-width
(base32
"00bv4p1yqs8y0z4z07wd9w9yyv669dikp9b04dcjbwpiy2wy0086"))))
(build-system dune-build-system)
- (arguments
- `(#:ocaml ,ocaml-4.07
- #:findlib ,ocaml4.07-findlib
- #:dune ,ocaml4.07-dune))
(propagated-inputs
- `(("ocaml-result" ,(package-with-ocaml4.07 ocaml-result))
- ("ocaml-camomile" ,(package-with-ocaml4.07 ocaml-camomile))))
+ `(("ocaml-result" ,ocaml-result)
+ ("ocaml-camomile" ,ocaml-camomile)))
(native-inputs
- `(("ocaml-ppx-expect" ,(package-with-ocaml4.07 ocaml-ppx-expect))))
+ `(("ocaml-ppx-expect" ,ocaml-ppx-expect)))
(properties
`((upstream-name . "charInfo_width")))
(home-page "https://bitbucket.org/zandoye/charinfo_width/")
@@ -3933,7 +3929,7 @@ (define-public ocaml4.07-zed
#:dune ,ocaml4.07-dune))
(propagated-inputs
`(("ocaml-camomile" ,(package-with-ocaml4.07 ocaml-camomile))
- ("ocaml-charinfo-width" ,ocaml4.07-charinfo-width)
+ ("ocaml-charinfo-width" ,(package-with-ocaml4.07 ocaml-charinfo-width))
("ocaml-react" ,(package-with-ocaml4.07 ocaml-react))))
(home-page "https://github.com/diml/zed")
(synopsis "Abstract engine for text editing in OCaml")
--
2.33.0
Z
Z
zimoun wrote on 27 Oct 2021 15:39
Re: bug#51358: [PATCH] Getting rid of some ocaml4.07-* packages.
(name . Julien Lepiller)(address . julien@lepiller.eu)(address . 51358@debbugs.gnu.org)
86fssmlh7f.fsf_-_@gmail.com
Hi Julien

On mar., 26 oct. 2021 at 00:06, Julien Lepiller <julien@lepiller.eu> wrote:
Toggle quote (6 lines)
> * gnu/packages/ocaml.scm (ocaml4.07-lacaml): Replace with...
> (ocaml-lacaml): ...this. Use latest ocaml package.
> ---
> gnu/packages/ocaml.scm | 15 ++++++---------
> 1 file changed, 6 insertions(+), 9 deletions(-)

LGTM.


However, I am not able to apply the rest of the serie. Probably because
of the base-commit. Against which commit, do your patches apply?

I wanted to build them before saying that LGTM -- although at first
sight, they look good to me. :-)


Cheers,
simon
J
J
Julien Lepiller wrote on 27 Oct 2021 17:27
(name . zimoun)(address . zimon.toutoune@gmail.com)(address . 51358@debbugs.gnu.org)
B861291A-A36D-4244-8300-52B147D66173@lepiller.eu
Le 27 octobre 2021 09:39:48 GMT-04:00, zimoun <zimon.toutoune@gmail.com> a écrit :
Toggle quote (22 lines)
>Hi Julien
>
>On mar., 26 oct. 2021 at 00:06, Julien Lepiller <julien@lepiller.eu> wrote:
>> * gnu/packages/ocaml.scm (ocaml4.07-lacaml): Replace with...
>> (ocaml-lacaml): ...this. Use latest ocaml package.
>> ---
>> gnu/packages/ocaml.scm | 15 ++++++---------
>> 1 file changed, 6 insertions(+), 9 deletions(-)
>
>LGTM.
>
>
>However, I am not able to apply the rest of the serie. Probably because
>of the base-commit. Against which commit, do your patches apply?
>
>I wanted to build them before saying that LGTM -- although at first
>sight, they look good to me. :-)
>
>
>Cheers,
>simon

Ha, I built that series on top of previous (unrelated) patches: #51351 and #51356
Z
Z
zimoun wrote on 15 Nov 2021 13:45
Re: [bug#51358] [PATCH 4/4] gnu: Add ocaml-charinfo-width.
86wnl9bn9r.fsf@gmail.com
Hi Julien,

On Tue, 26 Oct 2021 at 00:06, Julien Lepiller <julien@lepiller.eu> wrote:
Toggle quote (6 lines)
> * gnu/packages/ocaml.scm (ocaml4.07-charinfo-width): Replace with...
> (ocaml-charinfo-width): ...this. Use latest ocaml package.
> ---
> gnu/packages/ocaml.scm | 16 ++++++----------
> 1 file changed, 6 insertions(+), 10 deletions(-)

LGTM.

Aside, I note that ’ocaml4.07-charinfo-width’ fails to build because
Dune version issue. Fix or remove?


Cheers,
simon
Z
Z
zimoun wrote on 15 Nov 2021 14:10
Re: bug#51358: [PATCH] Getting rid of some ocaml4.07-* packages.
(name . Julien Lepiller)(address . julien@lepiller.eu)(address . 51358@debbugs.gnu.org)
86r1bhbm4g.fsf@gmail.com
Hi Julien,

On Wed, 27 Oct 2021 at 11:27, Julien Lepiller <julien@lepiller.eu> wrote:

Toggle quote (6 lines)
>>However, I am not able to apply the rest of the serie. Probably because
>>of the base-commit. Against which commit, do your patches apply?
>>
>>I wanted to build them before saying that LGTM -- although at first
>>sight, they look good to me. :-)

[...]

Toggle quote (2 lines)
> Ha, I built that series on top of previous (unrelated) patches: #51351 and #51356

Bah I still have some issue. Probably because of base-commit. From my
point of view, specifying “git format-patch --base=<commit>” where
<commit> is the last commit on the top of the branch against the series
applies help for synchronizing the Git tree since it moves really fast
these days. :-) For instance, I use “--base=origin/master” is the
divergence starts there.

Anyway. The series LGTM.


Cheers,
simon
J
J
Julien Lepiller wrote on 20 Nov 2021 19:56
(name . zimoun)(address . zimon.toutoune@gmail.com)(address . 51358-done@debbugs.gnu.org)
20211120195615.0a0da783@tachikoma.lepiller.eu
Pushed to master as e9d3f3656bd8a16deb1f643c9ed9f5706a6f9eaf to
0846e7d3265f9fc1b7d83676ef75c55f78faa587.

Now only three leaf packages are left: pplacer, bap and ocaml4.07-core.
I'll see what I can do. Removing the last one should be relatively
easy. Bap needs an update to 2.3.0 in addition to switching to
ocaml-4.11, but the update requires some more packages, so I'll need a
bit of time. pplacer is stuck, the version we have is not even
compatible with 4.07, but was heavily patched by Ricardo once. I'm
hoping for another miracle :)
Closed
Z
Z
zimoun wrote on 22 Nov 2021 10:14
(address . 51358-done@debbugs.gnu.org)
CAJ3okZ2TAomm2xeYBySdycP6AO-ZM9qHWOgNaLZqgg04ZTbj2A@mail.gmail.com
Hi,

On Sat, 20 Nov 2021 at 19:56, Julien Lepiller <julien@lepiller.eu> wrote:

Toggle quote (4 lines)
> pplacer is stuck, the version we have is not even
> compatible with 4.07, but was heavily patched by Ricardo once. I'm
> hoping for another miracle :)

Why not simply remove 'pplacer' from master and move it to guix-past?


Cheers,
simon
Closed
R
R
Ricardo Wurmus wrote on 22 Nov 2021 20:40
(name . zimoun)(address . zimon.toutoune@gmail.com)
8735novv06.fsf@elephly.net
zimoun <zimon.toutoune@gmail.com> writes:

Toggle quote (13 lines)
> Hi,
>
> On Sat, 20 Nov 2021 at 19:56, Julien Lepiller
> <julien@lepiller.eu> wrote:
>
>> pplacer is stuck, the version we have is not even
>> compatible with 4.07, but was heavily patched by Ricardo
>> once. I'm
>> hoping for another miracle :)
>
> Why not simply remove 'pplacer' from master and move it to
> guix-past?

I agree. This is a good idea.

--
Ricardo
Closed
?