[PATCH website] website: Fix build.

  • Done
  • quality assurance status badge
Details
2 participants
  • Julien Lepiller
  • zimoun
Owner
unassigned
Submitted by
Julien Lepiller
Severity
normal
J
J
Julien Lepiller wrote on 23 Oct 2021 17:38
(address . guix-patches@gnu.org)
20211023173830.6151a138@tachikoma.lepiller.eu
Hi Guix!

I just noticed an issue building the website: with a recent change, the
code would check explicitely for GUIX_WEB_SITE_LOCAL in the
environment, but .guix.scm doesn't set it, so it fails with:

;;; (repl-version (repl-version 0 1 1))
Running 'haunt build' for lingua de_DE...
Backtrace:
In haunt/ui.scm:
125:6 19 (run-haunt-command _ . _)
In haunt/ui/build.scm:
60:4 18 (haunt-build . _)
In haunt/site.scm:
130:14 17 (build-site _)
In haunt/utils.scm:
64:11 16 (flat-map _ . _)
In srfi/srfi-1.scm:
586:29 15 (map1 _)
586:29 14 (map1 _)
586:29 13 (map1 _)
586:29 12 (map1 _)
586:17 11 (map1 (#<procedure 7fffed0befc0 at ice-9/boot-9.scm:…> …))
In unknown file:
10 (_ #<procedure 7fffeb2950a0 at ice-9/boot-9.scm:798:28…> …)
In ice-9/eval.scm:
155:9 9 (_ _)
155:9 8 (_ _)
173:39 7 (_ #(#(#<directory (apps packages builder) 7ffff49b…>) …))
293:34 6 (_ #(#(#(#<directory (apps packages builder) 7ffff…>)) …))
159:9 5 (_ #(#(#(#<directory (apps packages builder) 7ffff…>)) …))
159:9 4 (_ _)
196:43 3 (_ _)
In unknown file:
2 (force #<promise #<procedure 7fffed0f3480 at ice-9/eval…>)
In ice-9/eval.scm:
245:16 1 (_ #(#(#(#<directory (apps packages data) 7ffff49b…>)) …))
In unknown file:
0 (string=? "yes" #f)

ERROR: In procedure string=?:
In procedure string=: Wrong type argument in position 2 (expecting
string): #f building pages in '/tmp/gnu.org/software/guix'...
Backtrace:
3 (primitive-load "/gnu/store/8amiibdjbp3chrj8cnbg6v1162g?")
In ice-9/boot-9.scm:
260:13 2 (for-each #<procedure 7ffff5fb1140 at ice-9/eval.scm:3?> ?)
In ice-9/eval.scm:
619:8 1 (_ #(#(#<directory (guile-user) 7ffff5fefc80>) "de_DE"))
In guix/build/utils.scm:
654:6 0 (invoke _ . _)

guix/build/utils.scm:654:6: In procedure invoke:
ERROR:
1. &invoke-error:
program:
"/gnu/store/2p1zk377cvxs1dz0iasj2l5wp2jlpcx2-haunt-0.2.5/bin/haunt"
arguments: ("build") exit-status: 1
term-signal: #f
stop-signal: #f

The attached patch fixes the issue.
From 6be425e7e917f93ae5a0cb7bbb047d0c4c1f4c78 Mon Sep 17 00:00:00 2001
From: Julien Lepiller <julien@lepiller.eu>
Date: Sat, 23 Oct 2021 17:30:59 +0200
Subject: [PATCH] website: Fix build.

* website/.guix.scm: Set GUIX_WEB_SITE_LOCAL explicitely.
---
website/.guix.scm | 1 +
1 file changed, 1 insertion(+)

Toggle diff (14 lines)
diff --git a/website/.guix.scm b/website/.guix.scm
index f656d47..a7a6d36 100644
--- a/website/.guix.scm
+++ b/website/.guix.scm
@@ -111,6 +111,7 @@
(setvbuf (current-output-port) 'line)
(setvbuf (current-error-port) 'line)
+ (setenv "GUIX_WEB_SITE_LOCAL" "no")
(copy-recursively #$source ".")
;; Set 'GUILE_LOAD_PATH' so that Haunt find the Guix modules and
--
2.33.0
Z
Z
zimoun wrote on 23 Oct 2021 19:56
861r4bbp70.fsf@gmail.com
Hi Julien,

On Sat, 23 Oct 2021 at 17:38, Julien Lepiller <julien@lepiller.eu> wrote:

Toggle quote (4 lines)
> I just noticed an issue building the website: with a recent change, the
> code would check explicitely for GUIX_WEB_SITE_LOCAL in the
> environment, but .guix.scm doesn't set it, so it fails with:

Oops! My bad.

Toggle quote (21 lines)
> From 6be425e7e917f93ae5a0cb7bbb047d0c4c1f4c78 Mon Sep 17 00:00:00 2001
> From: Julien Lepiller <julien@lepiller.eu>
> Date: Sat, 23 Oct 2021 17:30:59 +0200
> Subject: [PATCH] website: Fix build.
>
> * website/.guix.scm: Set GUIX_WEB_SITE_LOCAL explicitely.
> ---
> website/.guix.scm | 1 +
> 1 file changed, 1 insertion(+)
>
> diff --git a/website/.guix.scm b/website/.guix.scm
> index f656d47..a7a6d36 100644
> --- a/website/.guix.scm
> +++ b/website/.guix.scm
> @@ -111,6 +111,7 @@
> (setvbuf (current-output-port) 'line)
> (setvbuf (current-error-port) 'line)
>
> + (setenv "GUIX_WEB_SITE_LOCAL" "no")
> (copy-recursively #$source ".")

LGTM!

Cheers,
simon
J
J
Julien Lepiller wrote on 23 Oct 2021 23:22
(name . zimoun)(address . zimon.toutoune@gmail.com)(address . 51353-done@debbugs.gnu.org)
20211023232231.28f676ac@tachikoma.lepiller.eu
Pushed along with a translation update, hopefully we can see the
updated website soon :)
Closed
?