[PATCH 0/2] Add GiNaC (computer algebra library).

  • Done
  • quality assurance status badge
Details
2 participants
  • Ludovic Courtès
  • Vinicius Monego
Owner
unassigned
Submitted by
Vinicius Monego
Severity
normal
V
V
Vinicius Monego wrote on 22 Oct 2021 05:06
(address . guix-patches@gnu.org)(name . Vinicius Monego)(address . monego@posteo.net)
20211022030655.415185-1-monego@posteo.net
Vinicius Monego (2):
gnu: Add cln.
gnu: Add ginac.

gnu/packages/algebra.scm | 32 +++++++++++++++++++++++++++++++-
gnu/packages/multiprecision.scm | 24 ++++++++++++++++++++++++
2 files changed, 55 insertions(+), 1 deletion(-)


base-commit: 2782cb38a3bc68c530d6e95f6834ae0cb7ed16aa
prerequisite-patch-id: 01467a57e2c7d6c0266979c26fc35408e886972b
--
2.30.2
V
V
Vinicius Monego wrote on 22 Oct 2021 05:08
[PATCH 2/2] gnu: Add ginac.
(address . 51326@debbugs.gnu.org)(name . Vinicius Monego)(address . monego@posteo.net)
20211022030810.415328-2-monego@posteo.net
* gnu/packages/algebra.scm (ginac): New variable.
---
gnu/packages/algebra.scm | 32 +++++++++++++++++++++++++++++++-
1 file changed, 31 insertions(+), 1 deletion(-)

Toggle diff (52 lines)
diff --git a/gnu/packages/algebra.scm b/gnu/packages/algebra.scm
index 3c21a1b556..58873c7a60 100644
--- a/gnu/packages/algebra.scm
+++ b/gnu/packages/algebra.scm
@@ -12,7 +12,7 @@
;;; Copyright © 2020 Björn Höfling <bjoern.hoefling@bjoernhoefling.de>
;;; Copyright © 2020 Jakub K?dzio?ka <kuba@kadziolka.net>
;;; Copyright © 2020 Vincent Legoll <vincent.legoll@gmail.com>
-;;; Copyright © 2020 Vinicius Monego <monego@posteo.net>
+;;; Copyright © 2020, 2021 Vinicius Monego <monego@posteo.net>
;;; Copyright © 2021 Lars-Dominik Braun <ldb@leibniz-psychology.org>
;;;
;;; This file is part of GNU Guix.
@@ -986,6 +986,36 @@ Optional thin wrappers allow usage of the library from other languages.")
(license (list license:expat ;SymEngine
license:bsd-3)))) ;3rd party code
+(define-public ginac
+ (package
+ (name "ginac")
+ (version "1.8.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://www.ginac.de/ginac-"
+ version ".tar.bz2"))
+ (sha256
+ (base32 "1az1ypfcny4jdz0mic1kywwa9nynr547cl5s7zpn2w0qdfymssgi"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:configure-flags (list "--disable-static")))
+ (native-inputs
+ `(("bison" ,bison)
+ ("flex" ,flex)
+ ("pkg-config" ,pkg-config)
+ ("python" ,python-wrapper))) ; Python is required
+ (inputs
+ `(("cln" ,cln)
+ ("readline" ,readline)))
+ (home-page "https://www.ginac.de/")
+ (synopsis "Library for symbolic computation")
+ (description "GiNaC is a C++ library for symbolic computation. Contrary
+to other CAS it does not try to provide extensive algebraic capabilities and a
+simple programming language but instead accepts a given language (C++) and
+extends it by a set of algebraic capabilities.")
+ (license license:gpl2+)))
+
(define-public eigen
(package
(name "eigen")
--
2.30.2
V
V
Vinicius Monego wrote on 22 Oct 2021 05:08
[PATCH 1/2] gnu: Add cln.
(address . 51326@debbugs.gnu.org)(name . Vinicius Monego)(address . monego@posteo.net)
20211022030810.415328-1-monego@posteo.net
* gnu/packages/multiprecision.scm (cln): New variable.
---
gnu/packages/multiprecision.scm | 24 ++++++++++++++++++++++++
1 file changed, 24 insertions(+)

Toggle diff (44 lines)
diff --git a/gnu/packages/multiprecision.scm b/gnu/packages/multiprecision.scm
index 733e6548b9..7861e2f589 100644
--- a/gnu/packages/multiprecision.scm
+++ b/gnu/packages/multiprecision.scm
@@ -7,6 +7,7 @@
;;; Copyright © 2018, 2019 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2018 Eric Bavier <bavier@member.fsf.org>
;;; Copyright © 2018, 2019, 2021 Efraim Flashner <efraim@flashner.co.il>
+;;; Copyright © 2021 Vinicius Monego <monego@posteo.net>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -256,6 +257,29 @@ and (for Fortran-90 programs) read/write statements need to be changed. PSLQ
and numerical quadrature programs are included.")
(license bsd-3)))
+(define-public cln
+ (package
+ (name "cln")
+ (version "1.3.6")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://www.ginac.de/CLN/cln-"
+ version ".tar.bz2"))
+ (sha256
+ (base32 "0jlq9l4hphk7qqlgqj9ihjp4m3rwjbhk6q4v00lsbgbri07574pl"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:configure-flags (list "--disable-static")))
+ (inputs
+ `(("gmp" ,gmp)))
+ (home-page "https://www.ginac.de/CLN/")
+ (synopsis "Library for arbitrary precision computations")
+ (description "CLN is a C++ library for efficient computations with all
+kinds of numbers in arbitrary precision. It provides a rich set of number
+classes and elementary, logical and transcendental functions.")
+ (license gpl2+)))
+
(define-public tomsfastmath
(package
(name "tomsfastmath")
--
2.30.2
L
L
Ludovic Courtès wrote on 28 Oct 2021 20:58
Re: bug#51326: [PATCH 0/2] Add GiNaC (computer algebra library).
(name . Vinicius Monego)(address . monego@posteo.net)(address . 51326-done@debbugs.gnu.org)
87sfwl3rja.fsf@gnu.org
Hi Vinicius,

Vinicius Monego <monego@posteo.net> skribis:

Toggle quote (7 lines)
> gnu: Add cln.
> gnu: Add ginac.
>
> gnu/packages/algebra.scm | 32 +++++++++++++++++++++++++++++++-
> gnu/packages/multiprecision.scm | 24 ++++++++++++++++++++++++
> 2 files changed, 55 insertions(+), 1 deletion(-)

Applied, thanks!

Ludo’.
Closed
?