[PATCH 0/5] Update openttd to 12.0.

  • Done
  • quality assurance status badge
Details
3 participants
  • Efraim Flashner
  • Felix Gruber
  • Liliana Marie Prikler
Owner
unassigned
Submitted by
Felix Gruber
Severity
normal
F
F
Felix Gruber wrote on 19 Oct 2021 08:58
(address . guix-patches@gnu.org)(name . Felix Gruber)(address . felgru@posteo.net)
20211019065829.3853-1-felgru@posteo.net
Felix Gruber (5):
gnu: openttd-engine: Update to 12.0.
gnu: openttd-opengfx: Update to 7.1.
gnu: openttd-opensfx: Update to 1.0.2.
gnu: openttd-openmsx: Update to 0.4.2.
gnu: openttd: Fix build failure.

gnu/packages/games.scm | 19 ++++++++++---------
1 file changed, 10 insertions(+), 9 deletions(-)

--
2.30.2
F
F
Felix Gruber wrote on 19 Oct 2021 09:01
[PATCH 1/5] gnu: openttd-engine: Update to 12.0.
(address . 51280@debbugs.gnu.org)(name . Felix Gruber)(address . felgru@posteo.net)
20211019070201.4635-1-felgru@posteo.net
* gnu/packages/games.scm (openttd-engine): Update engine to 12.0.
---
gnu/packages/games.scm | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)

Toggle diff (23 lines)
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index 38852a2874..adf8dec02a 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -4287,14 +4287,14 @@ world}, @uref{http://evolonline.org, Evol Online} and
(define openttd-engine
(package
(name "openttd-engine")
- (version "1.11.2")
+ (version "12.0")
(source
(origin (method url-fetch)
(uri (string-append "https://cdn.openttd.org/openttd-releases/"
version "/openttd-" version "-source.tar.xz"))
(sha256
(base32
- "0v9f93lsdcv3ia28y8iihx9nj9zp6fpf5hkdrpl4ypw159d97fhg"))))
+ "1p1j5cf4ry57dcgm7qx2g2s00z1c6qgjabb4kqjp00yz00wgv85v"))))
(build-system cmake-build-system)
(inputs
`(("allegro" ,allegro)
--
2.30.2
F
F
Felix Gruber wrote on 19 Oct 2021 09:01
[PATCH 2/5] gnu: openttd-opengfx: Update to 7.1.
(address . 51280@debbugs.gnu.org)(name . Felix Gruber)(address . felgru@posteo.net)
20211019070201.4635-2-felgru@posteo.net
* packages/games.scm (openttd-opengfx): Update to 7.1.
[arguments]: Use cc-for-target.
---
gnu/packages/games.scm | 6 +++---
1 file changed, 3 insertions(+), 3 deletions(-)

Toggle diff (28 lines)
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index adf8dec02a..7afcbe860f 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -4324,7 +4324,7 @@ engine. When you start it you will be prompted to download a graphics set.")
(define openttd-opengfx
(package
(name "openttd-opengfx")
- (version "0.6.1")
+ (version "7.1")
(source
(origin
(method url-fetch)
@@ -4332,10 +4332,10 @@ engine. When you start it you will be prompted to download a graphics set.")
version "/opengfx-" version "-source.tar.xz"))
(sha256
(base32
- "0jgy8xv7r72m127qn09vr3rxhnbakl2990f7lldsk0d5d8n993vd"))))
+ "0nhzlk6s73qvznm5fdwcs1b42g2plf26s5ag39fvck45zm7m48jk"))))
(build-system gnu-build-system)
(arguments
- '(#:make-flags (list "CC=gcc"
+ `(#:make-flags (list (string-append "CC=" ,(cc-for-target))
(string-append "INSTALL_DIR="
(assoc-ref %outputs "out")
"/share/games/openttd/baseset/opengfx"))
--
2.30.2
F
F
Felix Gruber wrote on 19 Oct 2021 09:01
[PATCH 3/5] gnu: openttd-opensfx: Update to 1.0.2.
(address . 51280@debbugs.gnu.org)(name . Felix Gruber)(address . felgru@posteo.net)
20211019070201.4635-3-felgru@posteo.net
* packages/games.scm (openttd-opensfx): Update to 1.0.2.
---
gnu/packages/games.scm | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)

Toggle diff (24 lines)
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index 7afcbe860f..fe3d4fbe18 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -4383,7 +4383,7 @@ OpenGFX provides you with...
(define openttd-opensfx
(package
(name "openttd-opensfx")
- (version "1.0.1")
+ (version "1.0.2")
(source
(origin
(method url-fetch)
@@ -4392,7 +4392,7 @@ OpenGFX provides you with...
version "/opensfx-" version "-source.tar.xz"))
(sha256
(base32
- "06vycppqcxbfdqlxzna5xr303zgcmpcvj6ylw5b2ws0ssph2f1s0"))))
+ "0aym026lg0r7dp3jxxs9c0rj8lwy1fz3v9hmk3mml6sycsg3fv42"))))
(build-system gnu-build-system)
(native-inputs
`(("catcodec" ,catcodec)
--
2.30.2
F
F
Felix Gruber wrote on 19 Oct 2021 09:02
[PATCH 4/5] gnu: openttd-openmsx: Update to 0.4.2.
(address . 51280@debbugs.gnu.org)(name . Felix Gruber)(address . felgru@posteo.net)
20211019070201.4635-4-felgru@posteo.net
* packages/games.scm (openttd-openmsx): Update to 0.4.2.
---
gnu/packages/games.scm | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)

Toggle diff (24 lines)
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index fe3d4fbe18..3fcca77926 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -4433,7 +4433,7 @@ the original Transport Tycoon Deluxe.")
(define openttd-openmsx
(package
(name "openttd-openmsx")
- (version "0.4.0")
+ (version "0.4.2")
(source
(origin
(method url-fetch)
@@ -4442,7 +4442,7 @@ the original Transport Tycoon Deluxe.")
version "/openmsx-" version "-source.tar.xz"))
(sha256
(base32
- "0prjljsdgdxqdhhcriqskqha004ybs575xcjq80zha3pqnmrdk0k"))))
+ "1bwfql9540bp9czna0df6apsm6kr15pjghlmg4viixim8jckbrzx"))))
(build-system gnu-build-system)
(native-inputs
`(("grfcodec" ,grfcodec)
--
2.30.2
F
F
Felix Gruber wrote on 19 Oct 2021 09:02
[PATCH 5/5] gnu: openttd: Fix build failure.
(address . 51280@debbugs.gnu.org)(name . Felix Gruber)(address . felgru@posteo.net)
20211019070201.4635-5-felgru@posteo.net
* packages/games.scm (openttd)[native-inputs]: Use gcc-9 to fix build
failure.
---
gnu/packages/games.scm | 1 +
1 file changed, 1 insertion(+)

Toggle diff (14 lines)
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index 3fcca77926..78e885e0a0 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -4495,6 +4495,7 @@ Transport Tycoon Deluxe.")
`(("opengfx" ,openttd-opengfx)
("openmsx" ,openttd-openmsx)
("opensfx" ,openttd-opensfx)
+ ("gcc" ,gcc-9) ; for #include <charconv>
,@(package-native-inputs openttd-engine)))))
(define openrct2-title-sequences
--
2.30.2
E
E
Efraim Flashner wrote on 3 Nov 2021 15:20
Re: [bug#51280] [PATCH 4/5] gnu: openttd-openmsx: Update to 0.4.2.
(name . Felix Gruber)(address . felgru@posteo.net)(address . 51280@debbugs.gnu.org)
YYKaqnYOMmcjUtty@3900XT
On Tue, Oct 19, 2021 at 07:02:00AM +0000, Felix Gruber wrote:
Toggle quote (28 lines)
> * packages/games.scm (openttd-openmsx): Update to 0.4.2.
> ---
> gnu/packages/games.scm | 4 ++--
> 1 file changed, 2 insertions(+), 2 deletions(-)
>
> diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
> index fe3d4fbe18..3fcca77926 100644
> --- a/gnu/packages/games.scm
> +++ b/gnu/packages/games.scm
> @@ -4433,7 +4433,7 @@ the original Transport Tycoon Deluxe.")
> (define openttd-openmsx
> (package
> (name "openttd-openmsx")
> - (version "0.4.0")
> + (version "0.4.2")
> (source
> (origin
> (method url-fetch)
> @@ -4442,7 +4442,7 @@ the original Transport Tycoon Deluxe.")
> version "/openmsx-" version "-source.tar.xz"))
> (sha256
> (base32
> - "0prjljsdgdxqdhhcriqskqha004ybs575xcjq80zha3pqnmrdk0k"))))
> + "1bwfql9540bp9czna0df6apsm6kr15pjghlmg4viixim8jckbrzx"))))
> (build-system gnu-build-system)
> (native-inputs
> `(("grfcodec" ,grfcodec)

I was looking to review this patch set and I got a hash mismatch on the
source download here. Can you check into what may have happened? Thanks.

--
Efraim Flashner <efraim@flashner.co.il> ????? ?????
GPG key = A28B F40C 3E55 1372 662D 14F7 41AA E7DC CA3D 8351
Confidentiality cannot be guaranteed on emails sent or received unencrypted
-----BEGIN PGP SIGNATURE-----

iQIzBAABCgAdFiEEoov0DD5VE3JmLRT3Qarn3Mo9g1EFAmGCmqoACgkQQarn3Mo9
g1F77Q//S0oq85qiUIJbNmiRH4J3HdL+pJwunrphBypi1+0BbxHyX+VkueGdi5aa
ve+12YOTcWjAR9TMukaD5rthe+Od1m8KH6oAwwhqLmu1WQ4Yc1EL2snmr7smXxHg
ghoYmYtvyqwfyz+VLbgEQB9c7H6Nsworf8AS+fC+V0bm49jSxAwszo0wbUnC5i6S
khu/m93h1ck4PI/qJ9Z/m8eQmLtZpW7Q5120Ntmh8SJAtfiiO643WW+Cy9APjd9F
XC6UpjGIw7Gnw05sGHBxRebYf4O35BYy0n08ZiXhxEOzjn9tCS9kgccYA3KUFDz/
kfpQFZi5cClxe74bAqrkVvQtZuth/dYZvzJVn/FaWlbE/6eTERkS/GGQBMB7GlZL
tP7S1b4ZGyOiGOLcL+9w28lFmnXo47ts0ebWvagbQcHTmQj+Ct/bXN1YaG4RRlYU
+EKc3nug6bQhmQMgANfGAIGtpAmSmrPx+K5xRAVBSaJ5EPDZQeQkMa02IPNcXGPd
dL3CjQcRz9VFhyE3Cro7kp5hOy38nSAYjLMZL/50YOifVHZZTI4Pnv7v7I7+F4mu
NYMheELUsxc0q72Pi8aBZjVogM3AqD792x2n2myW8paVf2sKYqAMx8ErPhOexkFT
vyd7vzbLR/zcTVD+ZpesxPKyGX3rGhrdhvL25cRqbpQbxAHmRVM=
=sNa4
-----END PGP SIGNATURE-----


F
F
Felix Gruber wrote on 6 Nov 2021 11:21
73598c07-5259-5b33-7416-2963bdc7ae8a@posteo.net
Hi Efraim,

On 11/3/21 3:20 PM, Efraim Flashner wrote:
Toggle quote (3 lines)
> I was looking to review this patch set and I got a hash mismatch on the
> source download here. Can you check into what may have happened? Thanks.

It looks like the source tarball for openmsx 0.4.2 originally contained
the sources for 0.4.1 and was later replaced with the correct tarball.
I've run diffoscope against the two tarballs (you can find the full diff
in the attachment). This diff is consistent with the diff


in openmsx's git repository between the untagged 0.4.1 at commit
345efabba2eca1117ff0747d67529f0d334d770c and the tag 0.4.2.

I will create a new version of my patchset with the correct hash
0h583d8fxy78kc3jvpp78r76a48qhxrhm4q7jbnj74aw0kwrcl8g corresponding to
the updated 0.4.2 tarball.
This will also allow me to replace python-2 with python in all openttd
packages, as I've realized their latest versions were all made
compatible with Python 3.


Best,
Felix
F
F
Felix Gruber wrote on 6 Nov 2021 11:40
[PATCH v2 0/5] Update openttd to 12.0.
(name . Felix Gruber)(address . felgru@posteo.net)
20211106104040.34751-1-felgru@posteo.net
This updated patchset fixes the hash for openttd-openmsx, whose source
tarball was recently replaced [1]. It also changes the native-inputs of
all openttd packages to use python instead of python-2.


Felix Gruber (5):
gnu: openttd-engine: Update to 12.0.
gnu: openttd-opengfx: Update to 7.1.
gnu: openttd-opensfx: Update to 1.0.2.
gnu: openttd-openmsx: Update to 0.4.2.
gnu: openttd: Fix build failure.

gnu/packages/games.scm | 25 +++++++++++++------------
1 file changed, 13 insertions(+), 12 deletions(-)

--
2.30.2
F
F
Felix Gruber wrote on 6 Nov 2021 11:40
[PATCH v2 1/5] gnu: openttd-engine: Update to 12.0.
(name . Felix Gruber)(address . felgru@posteo.net)
20211106104040.34751-2-felgru@posteo.net
* gnu/packages/games.scm (openttd-engine): Update engine to 12.0.
---
gnu/packages/games.scm | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)

Toggle diff (23 lines)
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index 782c2b9c2e..3704704135 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -4287,14 +4287,14 @@ world}, @uref{http://evolonline.org, Evol Online} and
(define openttd-engine
(package
(name "openttd-engine")
- (version "1.11.2")
+ (version "12.0")
(source
(origin (method url-fetch)
(uri (string-append "https://cdn.openttd.org/openttd-releases/"
version "/openttd-" version "-source.tar.xz"))
(sha256
(base32
- "0v9f93lsdcv3ia28y8iihx9nj9zp6fpf5hkdrpl4ypw159d97fhg"))))
+ "1p1j5cf4ry57dcgm7qx2g2s00z1c6qgjabb4kqjp00yz00wgv85v"))))
(build-system cmake-build-system)
(inputs
`(("allegro" ,allegro)
--
2.30.2
F
F
Felix Gruber wrote on 6 Nov 2021 11:40
[PATCH v2 2/5] gnu: openttd-opengfx: Update to 7.1.
(name . Felix Gruber)(address . felgru@posteo.net)
20211106104040.34751-3-felgru@posteo.net
* packages/games.scm (openttd-opengfx): Update to 7.1.
[native-inputs]: Replace python-2 with python.
[arguments]: Use cc-for-target.
---
gnu/packages/games.scm | 8 ++++----
1 file changed, 4 insertions(+), 4 deletions(-)

Toggle diff (37 lines)
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index 3704704135..2a429f4662 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -4324,7 +4324,7 @@ engine. When you start it you will be prompted to download a graphics set.")
(define openttd-opengfx
(package
(name "openttd-opengfx")
- (version "0.6.1")
+ (version "7.1")
(source
(origin
(method url-fetch)
@@ -4332,10 +4332,10 @@ engine. When you start it you will be prompted to download a graphics set.")
version "/opengfx-" version "-source.tar.xz"))
(sha256
(base32
- "0jgy8xv7r72m127qn09vr3rxhnbakl2990f7lldsk0d5d8n993vd"))))
+ "0nhzlk6s73qvznm5fdwcs1b42g2plf26s5ag39fvck45zm7m48jk"))))
(build-system gnu-build-system)
(arguments
- '(#:make-flags (list "CC=gcc"
+ `(#:make-flags (list (string-append "CC=" ,(cc-for-target))
(string-append "INSTALL_DIR="
(assoc-ref %outputs "out")
"/share/games/openttd/baseset/opengfx"))
@@ -4363,7 +4363,7 @@ engine. When you start it you will be prompted to download a graphics set.")
("grfcodec" ,grfcodec)
("nml" ,nml)
("which" ,which)
- ("python" ,python-2)))
+ ("python" ,python)))
(home-page "http://dev.openttdcoop.org/projects/opengfx")
(synopsis "Base graphics set for OpenTTD")
(description
--
2.30.2
F
F
Felix Gruber wrote on 6 Nov 2021 11:40
[PATCH v2 3/5] gnu: openttd-opensfx: Update to 1.0.2.
(name . Felix Gruber)(address . felgru@posteo.net)
20211106104040.34751-4-felgru@posteo.net
* packages/games.scm (openttd-opensfx): Update to 1.0.2.
[native-inputs]: Replace python-2 with python.
---
gnu/packages/games.scm | 6 +++---
1 file changed, 3 insertions(+), 3 deletions(-)

Toggle diff (29 lines)
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index 2a429f4662..a6602fe4f6 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -4383,7 +4383,7 @@ OpenGFX provides you with...
(define openttd-opensfx
(package
(name "openttd-opensfx")
- (version "1.0.1")
+ (version "1.0.2")
(source
(origin
(method url-fetch)
@@ -4392,11 +4392,11 @@ OpenGFX provides you with...
version "/opensfx-" version "-source.tar.xz"))
(sha256
(base32
- "06vycppqcxbfdqlxzna5xr303zgcmpcvj6ylw5b2ws0ssph2f1s0"))))
+ "0aym026lg0r7dp3jxxs9c0rj8lwy1fz3v9hmk3mml6sycsg3fv42"))))
(build-system gnu-build-system)
(native-inputs
`(("catcodec" ,catcodec)
- ("python" ,python-2)
+ ("python" ,python)
("tar" ,tar)))
(arguments
`(#:make-flags
--
2.30.2
F
F
Felix Gruber wrote on 6 Nov 2021 11:40
[PATCH v2 4/5] gnu: openttd-openmsx: Update to 0.4.2.
(name . Felix Gruber)(address . felgru@posteo.net)
20211106104040.34751-5-felgru@posteo.net
* packages/games.scm (openttd-openmsx): Update to 0.4.2.
[native-inputs]: Replace python-2 with python.
---
gnu/packages/games.scm | 6 +++---
1 file changed, 3 insertions(+), 3 deletions(-)

Toggle diff (29 lines)
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index a6602fe4f6..8e92e04daa 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -4433,7 +4433,7 @@ the original Transport Tycoon Deluxe.")
(define openttd-openmsx
(package
(name "openttd-openmsx")
- (version "0.4.0")
+ (version "0.4.2")
(source
(origin
(method url-fetch)
@@ -4442,11 +4442,11 @@ the original Transport Tycoon Deluxe.")
version "/openmsx-" version "-source.tar.xz"))
(sha256
(base32
- "0prjljsdgdxqdhhcriqskqha004ybs575xcjq80zha3pqnmrdk0k"))))
+ "0h583d8fxy78kc3jvpp78r76a48qhxrhm4q7jbnj74aw0kwrcl8g"))))
(build-system gnu-build-system)
(native-inputs
`(("grfcodec" ,grfcodec)
- ("python" ,python-2)
+ ("python" ,python)
("tar" ,tar)))
(arguments
`(#:make-flags
--
2.30.2
F
F
Felix Gruber wrote on 6 Nov 2021 11:40
[PATCH v2 5/5] gnu: openttd: Fix build failure.
(name . Felix Gruber)(address . felgru@posteo.net)
20211106104040.34751-6-felgru@posteo.net
* packages/games.scm (openttd)[native-inputs]: Use gcc-9 to fix build
failure.
---
gnu/packages/games.scm | 1 +
1 file changed, 1 insertion(+)

Toggle diff (14 lines)
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index 8e92e04daa..346bceed37 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -4495,6 +4495,7 @@ Transport Tycoon Deluxe.")
`(("opengfx" ,openttd-opengfx)
("openmsx" ,openttd-openmsx)
("opensfx" ,openttd-opensfx)
+ ("gcc" ,gcc-9) ; for #include <charconv>
,@(package-native-inputs openttd-engine)))))
(define openrct2-title-sequences
--
2.30.2
L
L
Liliana Marie Prikler wrote on 6 Nov 2021 13:34
Re: [PATCH v2 4/5] gnu: openttd-openmsx: Update to 0.4.2.
47c06752fa8cc7376347c3b783ad1ade07d9300d.camel@gmail.com
Hi,

Am Samstag, den 06.11.2021, 10:40 +0000 schrieb Felix Gruber:
Toggle quote (33 lines)
> * packages/games.scm (openttd-openmsx): Update to 0.4.2.
> [native-inputs]: Replace python-2 with python.
> ---
> gnu/packages/games.scm | 6 +++---
> 1 file changed, 3 insertions(+), 3 deletions(-)
>
> diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
> index a6602fe4f6..8e92e04daa 100644
> --- a/gnu/packages/games.scm
> +++ b/gnu/packages/games.scm
> @@ -4433,7 +4433,7 @@ the original Transport Tycoon Deluxe.")
> (define openttd-openmsx
> (package
> (name "openttd-openmsx")
> - (version "0.4.0")
> + (version "0.4.2")
> (source
> (origin
> (method url-fetch)
> @@ -4442,11 +4442,11 @@ the original Transport Tycoon Deluxe.")
> version "/openmsx-" version "-source.tar.xz"))
> (sha256
> (base32
> - "0prjljsdgdxqdhhcriqskqha004ybs575xcjq80zha3pqnmrdk0k"))))
> + "0h583d8fxy78kc3jvpp78r76a48qhxrhm4q7jbnj74aw0kwrcl8g"))))
> (build-system gnu-build-system)
> (native-inputs
> `(("grfcodec" ,grfcodec)
> - ("python" ,python-2)
> + ("python" ,python)
> ("tar" ,tar)))
> (arguments
> `(#:make-flags
OpenTTD fails to find this version of opensmx (as opposed to failing to
play any sound for it, which is the current behaviour on master). Do
you have a guess as to why this is the case?

Regards,
Liliana
L
L
Liliana Marie Prikler wrote on 6 Nov 2021 13:34
bde41f6b854d23d729a0db1c6501709c76dbbf1a.camel@gmail.com
Am Samstag, den 06.11.2021, 13:34 +0100 schrieb Liliana Marie Prikler:
Toggle quote (1 lines)
> OpenTTD fails to find this version of opensmx
Should be openmsx, always typo on that one
F
F
Felix Gruber wrote on 7 Nov 2021 21:06
feb3fb5b-79f0-8f3e-74c5-66109ea474c6@posteo.net
Hi Liliana,

On 11/6/21 1:34 PM, Liliana Marie Prikler wrote:
Toggle quote (4 lines)
> OpenTTD fails to find this version of opensmx (as opposed to failing to
> play any sound for it, which is the current behaviour on master). Do
> you have a guess as to why this is the case?

It looks like the script that generates the midi files in openmsx
silently failed after I've replaced the python2 native-input with
python, because the Python scripts in openmsx refer in their #! to
Python as python and not python3. When I instead use the native-input
python-wrapper, the midi files are correctly built and we are back to
the old behaviour with openttd showing the midi tracks but being unable
to play them.

I'll send an updated patch for openmsx.

Best,
Felix
F
F
Felix Gruber wrote on 7 Nov 2021 21:11
[PATCH v3 4/5] gnu: openttd-openmsx: Update to 0.4.2.
(name . Felix Gruber)(address . felgru@posteo.net)
20211107201129.382979-1-felgru@posteo.net
* packages/games.scm (openttd-openmsx): Update to 0.4.2.
[native-inputs]: Replace python-2 with python-wrapper.
---
gnu/packages/games.scm | 8 +++++---
1 file changed, 5 insertions(+), 3 deletions(-)

Toggle diff (31 lines)
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index 4764021f73..0b4f8c6bfe 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -4433,7 +4433,7 @@ the original Transport Tycoon Deluxe.")
(define openttd-openmsx
(package
(name "openttd-openmsx")
- (version "0.4.0")
+ (version "0.4.2")
(source
(origin
(method url-fetch)
@@ -4442,11 +4442,13 @@ the original Transport Tycoon Deluxe.")
version "/openmsx-" version "-source.tar.xz"))
(sha256
(base32
- "0prjljsdgdxqdhhcriqskqha004ybs575xcjq80zha3pqnmrdk0k"))))
+ "0h583d8fxy78kc3jvpp78r76a48qhxrhm4q7jbnj74aw0kwrcl8g"))))
(build-system gnu-build-system)
(native-inputs
`(("grfcodec" ,grfcodec)
- ("python" ,python-2)
+ ; Scripts are Python3 compatible, but call the interpreter as
+ ; python instead of python3.
+ ("python" ,python-wrapper)
("tar" ,tar)))
(arguments
`(#:make-flags
--
2.30.2
L
L
Liliana Marie Prikler wrote on 8 Nov 2021 21:50
Re: [PATCH v2 0/5] Update openttd to 12.0.
1d279f861bd66b620aa22d097a5da727b7250263.camel@gmail.com
Am Samstag, den 06.11.2021, 10:40 +0000 schrieb Felix Gruber:
Toggle quote (8 lines)
> gnu: openttd-engine: Update to 12.0.
> gnu: openttd-opengfx: Update to 7.1.
> gnu: openttd-opensfx: Update to 1.0.2.
> gnu: openttd-openmsx: Update to 0.4.2.
> gnu: openttd: Fix build failure.
>
> gnu/packages/games.scm | 25 +++++++++++++------------
> 1 file changed, 13 insertions(+), 12 deletions(-)
Forgot to send out the mail, but I pushed v2 (with the v3 on openmsx).

Thanks
Closed
?