[PATCH] Update pipewire and add wireplumber

  • Done
  • quality assurance status badge
Details
4 participants
  • Morgan.J.Smith
  • Timmy Douglas
  • Maxim Cournoyer
  • Morgan Smith
Owner
unassigned
Submitted by
Morgan.J.Smith
Severity
normal
M
M
Morgan.J.Smith wrote on 14 Oct 2021 21:14
[PATCH] gnu: pipewire-0.3: Update to 0.3.38.
(address . guix-patches@gnu.org)(name . Morgan Smith)(address . Morgan.J.Smith@outlook.com)
BYAPR05MB4023B67DB85B0F7C6D079310C5B89@BYAPR05MB4023.namprd05.prod.outlook.com
From: Morgan Smith <Morgan.J.Smith@outlook.com>

* gnu/packages/linux.scm (pipewire-0.3): Update to 0.3.38.
[meson] Use meson-0.55.
[phases] Don't delete shrink-runpath.
[native-inputs] Add pipewire native-inputs to enable documentation generation.
---

I installed this on my system and it works great. I also read the release notes
but none of them mention to newer meson dependency so maybe that's not a good
metric to determine if any more changes are needed :P.


gnu/packages/linux.scm | 17 ++++++++---------
1 file changed, 8 insertions(+), 9 deletions(-)

Toggle diff (53 lines)
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 0088dbad4a..ee5c78c0e1 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -80,6 +80,7 @@ (define-module (gnu packages linux)
#:use-module (gnu packages bash)
#:use-module (gnu packages bison)
#:use-module (gnu packages boost)
+ #:use-module (gnu packages build-tools)
#:use-module (gnu packages calendar)
#:use-module (gnu packages check)
#:use-module (gnu packages cpio)
@@ -8046,7 +8047,7 @@ (define-public pipewire-0.3
(package
(inherit pipewire)
(name "pipewire")
- (version "0.3.29")
+ (version "0.3.38")
(source (origin
(method git-fetch)
(uri (git-reference
@@ -8055,23 +8056,21 @@ (define-public pipewire-0.3
(file-name (git-file-name name version))
(sha256
(base32
- "16jjxcnahxqfcawz77ywx837ybhwzcivn7hgqb9cmlp1y2syy8gk"))))
+ "15alnzwdgjbjrmphyinwdbaa1bi9cqbk8gkhrb4y6akjqph76hs0"))))
(arguments
- '(#:configure-flags
+ `(#:meson ,meson-0.55
+ #:configure-flags
(list (string-append "-Dudevrulesdir=" (assoc-ref %outputs "out")
"/lib/udev/rules.d")
- "-Dsystemd=disabled")
- #:phases
- (modify-phases %standard-phases
- ;; Skip shrink-runpath, otherwise validate-runpath fails.
- (delete 'shrink-runpath))))
+ "-Dsystemd=disabled")))
(inputs
(append (package-inputs pipewire)
`(("bluez" ,bluez)
("jack" ,jack-2)
("pulseaudio" ,pulseaudio)
("vulkan-loader" ,vulkan-loader)
- ("vulkan-headers" ,vulkan-headers))))))
+ ("vulkan-headers" ,vulkan-headers))))
+ (native-inputs (package-native-inputs pipewire))))
(define-public ell
(package
--
2.33.0
M
M
Morgan.J.Smith wrote on 14 Oct 2021 21:23
[PATCH v2] gnu: pipewire-0.3: Update to 0.3.38.
(address . 51212@debbugs.gnu.org)(name . Morgan Smith)(address . Morgan.J.Smith@outlook.com)
BYAPR05MB4023A6DC2CDDDB31768E34CAC5B89@BYAPR05MB4023.namprd05.prod.outlook.com
From: Morgan Smith <Morgan.J.Smith@outlook.com>

* gnu/packages/linux.scm (pipewire-0.3): Update to 0.3.38.
[phases] Don't delete shrink-runpath.
[native-inputs] Add pkg-config and python-docutils to enable documentation generation.
---

Little mistake sorry!

gnu/packages/linux.scm | 19 ++++++++++---------
1 file changed, 10 insertions(+), 9 deletions(-)

Toggle diff (55 lines)
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 0088dbad4a..dcc919dc8a 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -80,6 +80,7 @@ (define-module (gnu packages linux)
#:use-module (gnu packages bash)
#:use-module (gnu packages bison)
#:use-module (gnu packages boost)
+ #:use-module (gnu packages build-tools)
#:use-module (gnu packages calendar)
#:use-module (gnu packages check)
#:use-module (gnu packages cpio)
@@ -8046,7 +8047,7 @@ (define-public pipewire-0.3
(package
(inherit pipewire)
(name "pipewire")
- (version "0.3.29")
+ (version "0.3.38")
(source (origin
(method git-fetch)
(uri (git-reference
@@ -8055,23 +8056,23 @@ (define-public pipewire-0.3
(file-name (git-file-name name version))
(sha256
(base32
- "16jjxcnahxqfcawz77ywx837ybhwzcivn7hgqb9cmlp1y2syy8gk"))))
+ "15alnzwdgjbjrmphyinwdbaa1bi9cqbk8gkhrb4y6akjqph76hs0"))))
(arguments
- '(#:configure-flags
+ `(#:meson ,meson-0.55
+ #:configure-flags
(list (string-append "-Dudevrulesdir=" (assoc-ref %outputs "out")
"/lib/udev/rules.d")
- "-Dsystemd=disabled")
- #:phases
- (modify-phases %standard-phases
- ;; Skip shrink-runpath, otherwise validate-runpath fails.
- (delete 'shrink-runpath))))
+ "-Dsystemd=disabled")))
(inputs
(append (package-inputs pipewire)
`(("bluez" ,bluez)
("jack" ,jack-2)
("pulseaudio" ,pulseaudio)
("vulkan-loader" ,vulkan-loader)
- ("vulkan-headers" ,vulkan-headers))))))
+ ("vulkan-headers" ,vulkan-headers))))
+ (native-inputs
+ `(("pkg-config" ,pkg-config)
+ ("python-docutils" ,python-docutils)))))
(define-public ell
(package
--
2.33.0
M
M
Morgan Smith wrote on 24 Oct 2021 03:27
Re: bug#51212: [PATCH] gnu: pipewire-0.3: Update to 0.3.38.
(address . 51212@debbugs.gnu.org)
BYAPR05MB4023D1D51695A973E49923C1C5829@BYAPR05MB4023.namprd05.prod.outlook.com
I just wanted to let you guys know that I've been using this package of
pipewire since I posted this patch with no issues. So it's probably
pretty good. Although they already released 0.3.39 so this patch is
already out of date :P
M
M
Morgan.J.Smith wrote on 3 Nov 2021 00:26
Update pipewire and add wireplumber
(address . 51212@debbugs.gnu.org)
BYAPR05MB40237CDF99CB885D9A1C5EE0C58B9@BYAPR05MB4023.namprd05.prod.outlook.com
The latest and greatest pipewire stopped bundling session managers into the repo so now we gotta build a session manager separately.
M
M
Morgan.J.Smith wrote on 3 Nov 2021 00:26
[PATCH v3 1/2] gnu: pipewire-0.3: Update to 0.3.39.
(address . 51212@debbugs.gnu.org)(name . Morgan Smith)(address . Morgan.J.Smith@outlook.com)
BYAPR05MB4023AC07E886D2B25227904CC58B9@BYAPR05MB4023.namprd05.prod.outlook.com
From: Morgan Smith <Morgan.J.Smith@outlook.com>

* gnu/packages/linux.scm (pipewire-0.3): Update to 0.3.39.
[origin]: Use official gitlab source instead of github mirror.
[arguments]: Use meson-0.55. Don't build any session-managers.
[phases] Don't delete shrink-runpath.
[native-inputs] Add pkg-config and python-docutils to enable documentation generation.
---
gnu/packages/linux.scm | 22 +++++++++++-----------
1 file changed, 11 insertions(+), 11 deletions(-)

Toggle diff (50 lines)
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index f4c1867c5d..48cfc70bc7 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -81,6 +81,7 @@ (define-module (gnu packages linux)
#:use-module (gnu packages bash)
#:use-module (gnu packages bison)
#:use-module (gnu packages boost)
+ #:use-module (gnu packages build-tools)
#:use-module (gnu packages calendar)
#:use-module (gnu packages check)
#:use-module (gnu packages cpio)
@@ -8047,25 +8048,24 @@ (define-public pipewire-0.3
(package
(inherit pipewire)
(name "pipewire")
- (version "0.3.29")
+ (version "0.3.39")
(source (origin
(method git-fetch)
(uri (git-reference
- (url "https://github.com/PipeWire/pipewire")
+ (url "https://gitlab.freedesktop.org/pipewire/pipewire/")
(commit version)))
(file-name (git-file-name name version))
(sha256
(base32
- "16jjxcnahxqfcawz77ywx837ybhwzcivn7hgqb9cmlp1y2syy8gk"))))
+ "0crfhyaqac42lam5fylivi3l2vi5wwxg1vxssrh1chvfwgbx5r55"))))
(arguments
- '(#:configure-flags
- (list (string-append "-Dudevrulesdir=" (assoc-ref %outputs "out")
- "/lib/udev/rules.d")
- "-Dsystemd=disabled")
- #:phases
- (modify-phases %standard-phases
- ;; Skip shrink-runpath, otherwise validate-runpath fails.
- (delete 'shrink-runpath))))
+ `(#:meson ,meson-0.55
+ #:configure-flags
+ (list
+ "-Dsession-managers="
+ (string-append "-Dudevrulesdir=" (assoc-ref %outputs "out")
+ "/lib/udev/rules.d")
+ "-Dsystemd=disabled")))
(inputs
(append (package-inputs pipewire)
`(("bluez" ,bluez)
--
2.33.1
M
M
Morgan.J.Smith wrote on 3 Nov 2021 00:26
[PATCH v3 2/2] gnu: Add wireplumber.
(address . 51212@debbugs.gnu.org)(name . Morgan Smith)(address . Morgan.J.Smith@outlook.com)
BYAPR05MB4023B50E80EC4F8A09AE62BEC58B9@BYAPR05MB4023.namprd05.prod.outlook.com
From: Morgan Smith <Morgan.J.Smith@outlook.com>

* gnu/packages/linux.scm (wireplumber): New variable.
---
gnu/packages/linux.scm | 33 +++++++++++++++++++++++++++++++++
1 file changed, 33 insertions(+)

Toggle diff (53 lines)
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 48cfc70bc7..beac03eb72 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -132,6 +132,7 @@ (define-module (gnu packages linux)
#:use-module (gnu packages sdl)
#:use-module (gnu packages serialization)
#:use-module (gnu packages slang)
+ #:use-module (gnu packages sphinx)
#:use-module (gnu packages sqlite)
#:use-module (gnu packages texinfo)
#:use-module (gnu packages tls)
@@ -8074,6 +8075,38 @@ (define-public pipewire-0.3
("vulkan-loader" ,vulkan-loader)
("vulkan-headers" ,vulkan-headers))))))
+(define-public wireplumber
+ (package
+ (name "wireplumber")
+ (version "0.4.4")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://gitlab.freedesktop.org/pipewire/wireplumber")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0vr84xlnwlhrfq9l13rxh8cb8s389wlyafvi6bah444acmpx1lwv"))))
+ (build-system meson-build-system)
+ (arguments
+ `(#:meson ,meson-next ;; Needs at least 0.56.0
+ #:configure-flags (list "-Dsystem-lua=true")))
+ (native-inputs
+ `(("pkg-config" ,pkg-config)
+ ("glib-bin" ,glib "bin")))
+ (inputs
+ `(("dbus" ,dbus)
+ ("glib" ,glib)
+ ("lua" ,lua)
+ ("pipewire" ,pipewire-0.3)))
+ (home-page "https://pipewire.org/")
+ (synopsis "Modular session and policy manager for PipeWire")
+ (description "WirePlumber is a daemon that links streams from applications to their
+appropriate device. For example WirePlumber could link an audio stream to a
+speaker.")
+ (license license:expat)))
+
(define-public ell
(package
(name "ell")
--
2.33.1
M
M
Morgan Smith wrote on 3 Nov 2021 05:13
control message for bug #51212
(address . control@debbugs.gnu.org)
BYAPR05MB402313D77AFFCBA6EA9A83ECC58C9@BYAPR05MB4023.namprd05.prod.outlook.com
retitle 51212 [PATCH] Update pipewire and add wireplumber
quit
T
T
Timmy Douglas wrote on 16 Dec 2021 20:30
Re: [bug#51212] Update pipewire and add wireplumber
87a6h01h6j.fsf@timmydouglas.com
Morgan.J.Smith@outlook.com writes:

Toggle quote (3 lines)
> The latest and greatest pipewire stopped bundling session managers
> into the repo so now we gotta build a session manager separately.

+1. I just upgraded and noticed my audio stopped working now that
pipewire-media-session is gone. I just noticed this patch set:


which also adds it and cleans a few things up.
M
M
Maxim Cournoyer wrote on 24 Jun 2022 02:40
Re: bug#51212: [PATCH] Update pipewire and add wireplumber
(address . Morgan.J.Smith@outlook.com)(address . 51212-done@debbugs.gnu.org)
87zgi228s7.fsf_-_@gmail.com
Hi,

pipewire was updated by Tobias to 0.3.43 and wireplumber added by
Josselin and updated to 0.4.6 by Tobias.


I think we're covered :-). Thanks for the contribution.

Closing.

Maxim
Closed
?