[PATCH] gnu: Add cl-montezuma

  • Done
  • quality assurance status badge
Details
2 participants
  • Foo Chuan Wei
  • Guillaume Le Vaillant
Owner
unassigned
Submitted by
Foo Chuan Wei
Severity
normal
F
F
Foo Chuan Wei wrote on 13 Oct 2021 22:01
(address . guix-patches@gnu.org)
PU1PR01MB21555E27F5D076F59E2C25648DB79@PU1PR01MB2155.apcprd01.prod.exchangelabs.com
* gnu/packages/lisp-xyz.scm (cl-montezuma, ecl-montezuma, sbcl-montezuma):
New variables.
---
gnu/packages/lisp-xyz.scm | 48 +++++++++++++++++++++++++++++++++++++++
1 file changed, 48 insertions(+)

Toggle diff (60 lines)
diff --git a/gnu/packages/lisp-xyz.scm b/gnu/packages/lisp-xyz.scm
index 29d79e481e..151d31d9f5 100644
--- a/gnu/packages/lisp-xyz.scm
+++ b/gnu/packages/lisp-xyz.scm
@@ -19072,3 +19072,51 @@ libyaml.")
(define-public ecl-cl-yaml
(sbcl-package->ecl-package sbcl-cl-yaml))
+
+(define-public sbcl-montezuma
+ (let ((commit "ee2129eece7065760de4ebbaeffaadcb27644738")
+ (revision "1"))
+ (package
+ (name "sbcl-montezuma")
+ (version (git-version "0.0.0" revision commit))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/sharplispers/montezuma")
+ (commit commit)))
+ (file-name (git-file-name "cl-montezuma" version))
+ (sha256
+ (base32
+ "0svmvsbsirydk3c1spzfvj8qmkzcs9i69anpfvk1843i62wb7x2c"))))
+ (build-system asdf-build-system/sbcl)
+ (arguments `(#:phases
+ (modify-phases %standard-phases
+ ;; The _darcs directory contains a second copy of
+ ;; montezuma-indexfiles.asd. Remove the directory to
+ ;; prevent build failure caused by .asd files that have
+ ;; the same filename.
+ (add-after 'unpack 'remove-darcs-directory
+ (lambda _
+ (delete-file-recursively
+ "contrib/montezuma-indexfiles/_darcs"))))
+ ;; Tests fail with: :FORCE and :FORCE-NOT arguments not
+ ;; allowed in a nested call to ASDF/OPERATE:OPERATE unless
+ ;; identically to toplevel
+ #:tests? #f))
+ (inputs `(("cl-ppcre" ,sbcl-cl-ppcre)
+ ("cl-fad" ,sbcl-cl-fad)
+ ("babel" ,sbcl-babel)))
+ (native-inputs `(("trivial-timeout" ,sbcl-trivial-timeout)))
+ (home-page "https://github.com/sharplispers/montezuma")
+ (synopsis "Full-text indexing and search for Common Lisp")
+ (description
+ "Montezuma is a text search engine library for Lisp based on the Ferret
+library for Ruby, which is itself based on the Lucene library for Java.")
+ (license (list license:expat ; montezuma
+ license:gpl3+))))) ; contrib/montezuma-indexfiles
+
+(define-public cl-montezuma
+ (sbcl-package->cl-source-package sbcl-montezuma))
+
+(define-public ecl-montezuma
+ (sbcl-package->ecl-package sbcl-montezuma))

base-commit: 393315a98ef0b1cbafb661be5c36bbd4f30dba2e
--
2.25.1
G
G
Guillaume Le Vaillant wrote on 15 Oct 2021 11:21
(name . Foo Chuan Wei)(address . chuanwei.foo@hotmail.com)(address . 51191-done@debbugs.gnu.org)
87wnme3am1.fsf@kitej
Patch pushed as 2bd04fd3be1ca310308055b3d9ee2264271e268f with some
modifications. I fixed the tests for SBCL.
Thanks.
-----BEGIN PGP SIGNATURE-----

iIUEAREKAC0WIQTLxZxm7Ce5cXlAaz5r6CCK3yH+PwUCYWlIhg8cZ2x2QHBvc3Rl
by5uZXQACgkQa+ggit8h/j9sMgD9H8Ku6L8vmCiraYjuzs9AnqiF5Eb54zJ/fMb6
WHMd+gAA/15b9omhjxpOm/rjqqOgEym47aOOHRmRjtZZ755uG0Km
=aM8x
-----END PGP SIGNATURE-----

Closed
?