[PATCH] gnu: Add r-gghalves.

  • Done
  • quality assurance status badge
Details
2 participants
  • Ricardo Wurmus
  • Wiktor ?elazny
Owner
unassigned
Submitted by
Wiktor ?elazny
Severity
normal
W
W
Wiktor ?elazny wrote on 13 Oct 2021 19:01
(address . guix-patches@gnu.org)
20211013170151.1128-1-wz@freeshell.de
* gnu/packages/cran.scm (r-gghalves): New variable.
---
gnu/packages/cran.scm | 25 +++++++++++++++++++++++++
1 file changed, 25 insertions(+)
Toggle diff (37 lines)
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 937f53784e..265abd9f78 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -32063,3 +32063,28 @@ setting individual scales per panel, resizing panels and providing nested
facets. It also allows multiple colour, fill scales per plot and hosts a
smaller collection of stats, geoms and axis guides.")
(license license:expat)))
+
+(define-public r-gghalves
+ (package
+ (name "r-gghalves")
+ (version "0.1.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "gghalves" version))
+ (sha256
+ (base32
+ "1w4j8grir1i8ar7fdsk4f6czkl5j2wwn67y746mis2diwnzhcil3"))))
+ (properties `((upstream-name . "gghalves")))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-ggplot2" ,r-ggplot2)
+ ("r-gtable" ,r-gtable)))
+ (native-inputs
+ `(("r-knitr" ,r-knitr)))
+ (home-page "https://github.com/erocoar/gghalves")
+ (synopsis "Compose half-half plots using your favourite geoms")
+ (description "This package provides a @code{ggplot2} extension for easy
+plotting of half-half geom combinations. Think half boxplot and half
+jitterplot, or half violinplot and half dotplot.")
+ (license license:expat)))
base-commit: 95c9e65a21ab5688cc069da322184e4ee5eabcba
--
2.33.0
R
R
Ricardo Wurmus wrote on 18 Jun 2022 10:51
(address . 51185-done@debbugs.gnu.org)
87h74ie4lu.fsf@elephly.net
Thank you for the patch! Unfortunately, this fell through the cracks.
I just applied it after upgrading to 0.1.3 and using the new input
style.

--
Ricardo
Closed
?