[PATCH] gnu: Add vim-tagbar

  • Done
  • quality assurance status badge
Details
2 participants
  • Foo Chuan Wei
  • Efraim Flashner
Owner
unassigned
Submitted by
Foo Chuan Wei
Severity
normal
F
F
Foo Chuan Wei wrote on 12 Oct 2021 17:48
(address . guix-patches@gnu.org)
PU1PR01MB21551A5FA87F0D2B4136821B8DB69@PU1PR01MB2155.apcprd01.prod.exchangelabs.com
* gnu/packages/vim.scm (vim-tagbar): New variable.
---
gnu/packages/vim.scm | 30 ++++++++++++++++++++++++++++++
1 file changed, 30 insertions(+)

Toggle diff (42 lines)
diff --git a/gnu/packages/vim.scm b/gnu/packages/vim.scm
index 92189b7094..316db2fcdb 100644
--- a/gnu/packages/vim.scm
+++ b/gnu/packages/vim.scm
@@ -1069,3 +1069,33 @@ your code every time you make a change. @code{Vim-slime} is an attempt at
getting some of these features into Vim. It works with any REPL and isn't tied
to Lisp.")
(license license:expat))))
+
+(define-public vim-tagbar
+ (package
+ (name "vim-tagbar")
+ (version "3.0.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/preservim/tagbar")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1fqfs8msmr6d4kpvxqp14sdjvp5fj52q5w5kz71myzcd4kqzmirp"))))
+ (build-system copy-build-system)
+ (arguments
+ '(#:install-plan
+ '(("autoload" "share/vim/vimfiles/")
+ ("doc" "share/vim/vimfiles/")
+ ("plugin" "share/vim/vimfiles/")
+ ("syntax" "share/vim/vimfiles/"))))
+ (home-page "https://github.com/preservim/tagbar")
+ (synopsis " Vim plugin that displays tags in a window, ordered by scope")
+ (description
+ "Tagbar is a Vim plugin that provides an easy way to browse the tags of
+the current file and get an overview of its structure. It does this by creating
+a sidebar that displays the ctags-generated tags of the current file, ordered
+by their scope. This means that for example methods in C++ are displayed under
+the class they are defined in.")
+ (license license:vim)))

base-commit: b9c7bbba38f4fb12d2735f2683a40c035f4e7f5f
--
2.25.1
E
E
Efraim Flashner wrote on 31 Oct 2021 14:31
(name . Foo Chuan Wei)(address . chuanwei.foo@hotmail.com)(address . 51164-done@debbugs.gnu.org)
YX6ayaHVDBFobZwF@3900XT
Patch pushed. I added a follow-up patch to add the location for Guix's
universal-ctags as a fallback location when searching $PATH for ctags.

--
Efraim Flashner <efraim@flashner.co.il> ????? ?????
GPG key = A28B F40C 3E55 1372 662D 14F7 41AA E7DC CA3D 8351
Confidentiality cannot be guaranteed on emails sent or received unencrypted
-----BEGIN PGP SIGNATURE-----

iQIzBAABCgAdFiEEoov0DD5VE3JmLRT3Qarn3Mo9g1EFAmF+mskACgkQQarn3Mo9
g1F7lw/8DbreFJS0CebKXMQlTWVWFwJ6MI4gJvjMIFcRILk4smjBO9lZ6o6B22rG
b+tHJcnkfS+KmhOgHPfUYD7reSZWcD76ETv9Dz2A+vYha24nAfh8ID+amqW0zbJi
6BzckgszetpvqO2XweR5V3jtEGBTqDTSPCrQbC6GcmbjzUT0t4UK/RgkfHHwMlTP
qIceXKlZdf9Tovl7yO043cN78abXQY9RNgar8duYnSbKQEIN+rgmVs0Igk04RQ1S
h7XzQTnJQqW1MElfBmPU87tTpwRmh4F7mgA5ANdXI+rV8zGElNffsLU7jo33ESMx
kgCCOfCxTmcpwSYXFxOjxKhxRRR/X1dZ3/5vyiLi6MLl4t3RyJnn3CSDoA9lqMSv
mPz+2pfPjGlqnGuwnhDCQjeYHdN4Y/TLSNvzAlvmZTVPafPBaX6kK2t/4a3dAYA2
uWCzKqzFH45aKfC5fYqXrrQTQ3N93dkrJpyguNowoevBfZtCfIp3R065QGITJ3qL
nUGUNOsItKH1JaOJvoqetJH6awmH2v/FEKAD9uuKgg3nAa5K+3H6tmVyhxyiIfat
aVaC10wiQl20qPplN4ZT3IQbFhHOWqenQL7VW9j8R/wAiamTLdgq5JRNpCvnYvgn
kZ9bydZhnOAhzOsG/XhfXL6IeObkaUvN2xXiQfbMgsUTIHJZ4a0=
=AGxY
-----END PGP SIGNATURE-----


Closed
?