[PATCH] gnu: Add vim-nerdcommenter

  • Done
  • quality assurance status badge
Details
2 participants
  • Foo Chuan Wei
  • Efraim Flashner
Owner
unassigned
Submitted by
Foo Chuan Wei
Severity
normal
F
F
Foo Chuan Wei wrote on 12 Oct 2021 16:13
(address . guix-patches@gnu.org)
PU1PR01MB21554E125A15BDCFAABBF9148DB69@PU1PR01MB2155.apcprd01.prod.exchangelabs.com
* gnu/packages/vim.scm (vim-nerdcommenter): New variable.
---
gnu/packages/vim.scm | 26 ++++++++++++++++++++++++++
1 file changed, 26 insertions(+)

Toggle diff (38 lines)
diff --git a/gnu/packages/vim.scm b/gnu/packages/vim.scm
index 92189b7094..f668aa0867 100644
--- a/gnu/packages/vim.scm
+++ b/gnu/packages/vim.scm
@@ -1069,3 +1069,29 @@ your code every time you make a change. @code{Vim-slime} is an attempt at
getting some of these features into Vim. It works with any REPL and isn't tied
to Lisp.")
(license license:expat))))
+
+(define-public vim-nerdcommenter
+ (package
+ (name "vim-nerdcommenter")
+ (version "2.5.2")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/preservim/nerdcommenter")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0s862kzhvv9qpr7gxd3h52hczjvm55zyff5qn0z5095072pr3wjx"))))
+ (build-system copy-build-system)
+ (arguments
+ '(#:install-plan
+ '(("doc" "share/vim/vimfiles/")
+ ("plugin" "share/vim/vimfiles/"))))
+ (home-page "https://github.com/preservim/nerdcommenter")
+ (synopsis "Vim plugin for easy commenting of code")
+ (description
+ "NERD commenter is a Vim plugin that provides many different commenting
+operations and styles which are invoked via key mappings and a menu. These
+operations are available for most filetypes.")
+ (license license:cc0)))

base-commit: 35aaf1fe10488ae9ed732fb2c383d09a70c109c0
--
2.25.1
E
E
Efraim Flashner wrote on 25 Oct 2021 09:03
(address . 51159@debbugs.gnu.org)
YXZWuOZrsuuN/jhO@3900XT
I see that the latest tag is several years old and there has been
continued development since then. Does it make sense to package a newer
commit?

Also, if you add all the patches to the bottom of the file then they all
conflict with each other and it makes it harder to apply them.

On Tue, Oct 12, 2021 at 02:13:20PM +0000, Foo Chuan Wei wrote:
Toggle quote (48 lines)
> * gnu/packages/vim.scm (vim-nerdcommenter): New variable.
> ---
> gnu/packages/vim.scm | 26 ++++++++++++++++++++++++++
> 1 file changed, 26 insertions(+)
>
> diff --git a/gnu/packages/vim.scm b/gnu/packages/vim.scm
> index 92189b7094..f668aa0867 100644
> --- a/gnu/packages/vim.scm
> +++ b/gnu/packages/vim.scm
> @@ -1069,3 +1069,29 @@ your code every time you make a change. @code{Vim-slime} is an attempt at
> getting some of these features into Vim. It works with any REPL and isn't tied
> to Lisp.")
> (license license:expat))))
> +
> +(define-public vim-nerdcommenter
> + (package
> + (name "vim-nerdcommenter")
> + (version "2.5.2")
> + (source
> + (origin
> + (method git-fetch)
> + (uri (git-reference
> + (url "https://github.com/preservim/nerdcommenter")
> + (commit version)))
> + (file-name (git-file-name name version))
> + (sha256
> + (base32 "0s862kzhvv9qpr7gxd3h52hczjvm55zyff5qn0z5095072pr3wjx"))))
> + (build-system copy-build-system)
> + (arguments
> + '(#:install-plan
> + '(("doc" "share/vim/vimfiles/")
> + ("plugin" "share/vim/vimfiles/"))))
> + (home-page "https://github.com/preservim/nerdcommenter")
> + (synopsis "Vim plugin for easy commenting of code")
> + (description
> + "NERD commenter is a Vim plugin that provides many different commenting
> +operations and styles which are invoked via key mappings and a menu. These
> +operations are available for most filetypes.")
> + (license license:cc0)))
>
> base-commit: 35aaf1fe10488ae9ed732fb2c383d09a70c109c0
> --
> 2.25.1
>
>
>
>

--
Efraim Flashner <efraim@flashner.co.il> ????? ?????
GPG key = A28B F40C 3E55 1372 662D 14F7 41AA E7DC CA3D 8351
Confidentiality cannot be guaranteed on emails sent or received unencrypted
-----BEGIN PGP SIGNATURE-----

iQIzBAABCgAdFiEEoov0DD5VE3JmLRT3Qarn3Mo9g1EFAmF2VrUACgkQQarn3Mo9
g1GFEA/9FJpTL9FgZdQ9EC5RxQV1sbDdcGETDXJACqxX6M8c2BsDYLJWNuy3k9/W
pvrzO0cDbDQPJ/57sruUlVANgq8XOIcWoOxnKQUb9P6jm4Q785gBm+FePl0X7Y44
4N/clrkg+yg/RfPBECTfLc2OluYe7IY3NdeT2ZnU3vNQq6kKNJuKc2b6QAlJ7I4I
YUmV5KB8jjrs2vVGTxJ2N4AwYfb1Epd8WdUULhi5DFYwBigBds7Qt1lyWfLNtovF
ugsia68WC9kAoGsjDZ7FltQJkF610YnB4xP9ZazLVGMZpUewpTUtAYqqeMR9WfDJ
2ByE+Qa6vHQI764jYgSU5BMQk8TVbilxBebx1NIYaVSb4Y3ybKvRHo6gHCccYKEw
456aAFUGlj/eH8hqnS0RaRb6pdwv67aJssKRpoyAf920Dm8u9r9bZLYoRxyx3Eu3
HnOegKf3SWFQAoqcMZJPj9NTVGToQNr6Vzaqjxt6oQEoqvUH2RfMsJMONV92f6Ms
HaezDPuHfzg0e6qFMVZU8sCHwdiZ+PeNZtqrkMKRF8rC5FiXGEaCv4eHlUS06I3h
G+mcDqDkxrhhYnHlrx06NMF7fgDQ/WmuKLZDQZufoa3RhWkKlgXIEeoI8sicTs4G
1jt8H7P2GUtEvkeVjLTLnWlySVHh+xfJfxt4VFzaLMo1sVLEUFA=
=N2Kp
-----END PGP SIGNATURE-----


F
F
Foo Chuan Wei wrote on 1 Nov 2021 05:53
[PATCH v2] gnu: Add vim-nerdcommenter.
(address . 51159@debbugs.gnu.org)
PU1PR01MB2155D49C3B18D0529F492C998D8A9@PU1PR01MB2155.apcprd01.prod.exchangelabs.com
* gnu/packages/vim.scm (vim-nerdcommenter): New variable.
---
gnu/packages/vim.scm | 29 +++++++++++++++++++++++++++++
1 file changed, 29 insertions(+)

Toggle diff (41 lines)
diff --git a/gnu/packages/vim.scm b/gnu/packages/vim.scm
index 8792e178ab..2ff043cd9c 100644
--- a/gnu/packages/vim.scm
+++ b/gnu/packages/vim.scm
@@ -1295,3 +1295,32 @@ a sidebar that displays the ctags-generated tags of the current file, ordered
by their scope. This means that for example methods in C++ are displayed under
the class they are defined in.")
(license license:vim)))
+
+(define-public vim-nerdcommenter
+ (let ((commit "a65465d321f2f8a74b2ffa540b9b87563f7e12e8")
+ (revision "1"))
+ (package
+ (name "vim-nerdcommenter")
+ (version (git-version "2.5.2" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/preservim/nerdcommenter")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "00ir65iv8jfbgzjmj7332fmydh0qhabbhx8zbvd3j6pgfxqpaafw"))))
+ (build-system copy-build-system)
+ (arguments
+ '(#:install-plan
+ '(("autoload" "share/vim/vimfiles/")
+ ("doc" "share/vim/vimfiles/")
+ ("plugin" "share/vim/vimfiles/"))))
+ (home-page "https://github.com/preservim/nerdcommenter")
+ (synopsis "Vim plugin for easy commenting of code")
+ (description
+ "NERD commenter is a Vim plugin that provides many different commenting
+operations and styles which are invoked via key mappings and a menu. These
+operations are available for most filetypes.")
+ (license license:cc0))))

base-commit: f3d5d572debe59839afe29683965c6df39cb782c
--
2.25.1
E
E
Efraim Flashner wrote on 4 Nov 2021 14:33
(address . 51159-done@debbugs.gnu.org)
YYPhET+I50cCGOLI@3900XT
Patch pushed. Thanks!

--
Efraim Flashner <efraim@flashner.co.il> ????? ?????
GPG key = A28B F40C 3E55 1372 662D 14F7 41AA E7DC CA3D 8351
Confidentiality cannot be guaranteed on emails sent or received unencrypted
-----BEGIN PGP SIGNATURE-----

iQIzBAABCgAdFiEEoov0DD5VE3JmLRT3Qarn3Mo9g1EFAmGD4REACgkQQarn3Mo9
g1Hhvw/8CmUPskttqOkfmh+siiB+N/T7kEuSJCQY7QdaXyQsED6K4IFvfc+trtd3
xHCwShzsS71je3AY21FWa964997+lZF6UTVbA32l2Q/bitmOo2szw5pJJN3rtwLd
sZhBvSc2M9mXSJFIv48FJuKAggu0hJxEajecfvJ0cKp59Y4tUMPeT49c0ys0q224
vIImjnkGkoeiXFkYYwt1JoWloIEx1CLeBtwKqaUjvXCScd9L/IOJ9Lej/miKA5vT
2ZGJM/plU1gyzQmrf75Tbj3nWbkMGI0BYfzioNcXtIXcj6tCDdExoj6/JWFa79Pm
4jJc/7UCBZycZ6lXCuegUP4Nie9wtAl2VI1JYNcygV+p/XclYBksKbNowiOD/Y3s
StHYHOQ5RnHoAv0pAMv/dRysV501X7HaNWyrqUFH6ZC4QF+r2lIYMI182Rh0pHfP
J2w6XgCjs01k4pQR7MtiTUs6O6sirWxfaAX20f5cu0HQiy2aNRtOWhRo7T4wArGn
70L+KMSIb75KbIFwDATYDXgRcKfcr9J6DKxihvT7e9TLzguixc/ETLNFNLReVkhy
Sc3Io6wF2tfEz8Di5s6AojqAOlIzCwYINxzIiMboeBWuxqM1iMUZQ1Rf6s4sfaSk
TejfPp7zICRTxyPBN2/op/3/KBSz5+ra7gp57N3hQEzNk0ZRRDE=
=XLVl
-----END PGP SIGNATURE-----


Closed
?