Subject: [PATCH] gnu: Add python-ropgadget.

  • Done
  • quality assurance status badge
Details
2 participants
  • phodina
  • Vagrant Cascadian
Owner
unassigned
Submitted by
phodina
Severity
normal
P
P
phodina wrote on 6 Oct 2021 01:08
(name . phodina via Guix-patches via)(address . guix-patches@gnu.org)
dAMRKkcWaLhtSbb6veqqpkgxWuD8K5hHIMWu6E3u1ha4gAtIfcRvQZCUAEdGjVEDA2SYWKlhmjB1akwru0QNC7t1YNm_rr5kTXpfc_z2bHI=@protonmail.com
Hi,

I had to put this package into engineering.scm as it depends on python-capstone and therefore placing it into python-xyz.scm and importing engineering creates circular dependency.

Petr

Toggle snippet (37 lines)
* gnu/packages/python-xyz.scm (python-ropgadget): New variable.

diff --git a/gnu/packages/engineering.scm b/gnu/packages/engineering.scm
index 073d524955..f891b25696 100644
--- a/gnu/packages/engineering.scm
+++ b/gnu/packages/engineering.scm
@@ -1595,6 +1595,26 @@ bindings for Python, Java, OCaml and more.")
bootloader in Espressif ESP8266 & ESP32 series chips.")
(license license:gpl2+)))

+(define-public python-ropgadget
+ (package
+ (name "python-ropgadget")
+ (version "6.6")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "ROPGadget" version))
+ (sha256
+ (base32
+ "08ms7x4af07970ij9899l75sghnxsa7xyx73gkn6gv0l05p1hqfw"))))
+ (build-system python-build-system)
+ (propagated-inputs
+ `(("python-capstone" ,python-capstone)))
+ (home-page "https://github.com/JonathanSalwan/ROPgadget")
+ (synopsis "Search binaries to facilitate ROP exploitation")
+ (description "This tool lets you search your gadgets on binaries
+to facilitate your ROP exploitation.")
+ (license license:bsd-3)))
+
(define-public radare2
(package
(name "radare2")
--
2.32.0
V
V
Vagrant Cascadian wrote on 1 Sep 2023 22:47
871qfhtybn.fsf@wireframe
On 2021-10-05, phodina wrote:
Toggle quote (4 lines)
> I had to put this package into engineering.scm as it depends on
> python-capstone and therefore placing it into python-xyz.scm and
> importing engineering creates circular dependency.

This appears to be packaged as "ropgadget" in cybersecurity.scm as of
commit 60eee3e6de2a11b425496bbdf90bfe1f807c8f49

Marking as done.

live well,
vagrant
-----BEGIN PGP SIGNATURE-----

iHUEARYKAB0WIQRlgHNhO/zFx+LkXUXcUY/If5cWqgUCZPJN/AAKCRDcUY/If5cW
qtLDAQDwYIO3zOFqCOl48w4MATolyOBdqmSjVMsk5WKQJ/724AD/azpJUOVQpdOt
GiN4rBjVNiF7TwWWfIlGozLB5fjEnA8=
=u+5h
-----END PGP SIGNATURE-----

Closed
?