[PATCH] gnu: Add gr-framework.

  • Done
  • quality assurance status badge
Details
One participant
  • Efraim Flashner
Owner
unassigned
Submitted by
Efraim Flashner
Severity
normal
E
E
Efraim Flashner wrote on 5 Oct 2021 14:34
(address . guix-patches@gnu.org)(name . Efraim Flashner)(address . efraim@flashner.co.il)
b7ee29f323c352d576379ed97c080379c2ee94bc.1633437253.git.efraim@flashner.co.il
* gnu/packages/graphics.scm (gr-framework): New variable.
---
gnu/packages/graphics.scm | 50 +++++++++++++++++++++++++++++++++++++++
1 file changed, 50 insertions(+)

Toggle diff (65 lines)
diff --git a/gnu/packages/graphics.scm b/gnu/packages/graphics.scm
index 3f2be5766c..9a5e2f2195 100644
--- a/gnu/packages/graphics.scm
+++ b/gnu/packages/graphics.scm
@@ -1254,6 +1254,56 @@ (define-public openscenegraph-3.4
`(("libjpeg" ,libjpeg-turbo)
,@(package-inputs openscenegraph)))))
+(define-public gr-framework
+ (package
+ (name "gr-framework")
+ (version "0.58.1")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/sciapp/gr")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0q1rz4iyxbh0dc22y4w28ry3hr0yypdwdm6pw2zlwgjya7wkbvsw"))
+ (modules '((guix build utils)))
+ (snippet
+ '(begin
+ (delete-file-recursively "3rdparty")
+ #t))))
+ (build-system cmake-build-system)
+ (arguments
+ `(#:tests? #f)) ; no test target
+ (inputs
+ `(("bzip2" ,bzip2)
+ ("cairo" ,cairo)
+ ("fontconfig" ,fontconfig)
+ ("ffmpeg" ,ffmpeg)
+ ("freetype" ,freetype)
+ ("ghostscript" ,ghostscript)
+ ("glfw" ,glfw)
+ ("libjpeg-turbo" ,libjpeg-turbo)
+ ("libpng" ,libpng)
+ ("libtiff" ,libtiff)
+ ("libx11" ,libx11)
+ ("libxft" ,libxft)
+ ("libxt" ,libxt)
+ ("pixman" ,pixman)
+ ("qtbase" ,qtbase-5)
+ ("qhull" ,qhull)
+ ("zlib" ,zlib)))
+ (home-page "https://gr-framework.org/")
+ (synopsis "Graphics library for visualisation applications")
+ (description "GR is a universal framework for cross-platform visualization
+applications. It offers developers a compact, portable and consistent graphics
+library for their programs. Applications range from publication quality 2D
+graphs to the representation of complex 3D scenes. GR is essentially based on
+an implementation of a @acronym{GKS, Graphical Kernel System}. As a
+self-contained system it can quickly and easily be integrated into existing
+applications (i.e. using the @code{ctypes} mechanism in Python or @code{ccall}
+in Julia).")
+ (license license:expat)))
(define-public openmw-openscenegraph
;; OpenMW prefers its own fork of openscenegraph:

base-commit: b54bf075c577b9f78041362035383dbbfb456617
--
2.33.0
E
E
Efraim Flashner wrote on 19 Oct 2021 10:18
Re: bug#51033: Acknowledgement ([PATCH] gnu: Add gr-framework.)
(address . 51033-done@debbugs.gnu.org)
YW5/TBvNt4ahI6WF@3900XT
Patch pushed.

--
Efraim Flashner <efraim@flashner.co.il> ????? ?????
GPG key = A28B F40C 3E55 1372 662D 14F7 41AA E7DC CA3D 8351
Confidentiality cannot be guaranteed on emails sent or received unencrypted
-----BEGIN PGP SIGNATURE-----

iQIzBAABCgAdFiEEoov0DD5VE3JmLRT3Qarn3Mo9g1EFAmFuf0wACgkQQarn3Mo9
g1FQwRAAh4q8eIEOoU6MKcWOnC/wgqT1T72nwlZ/P+2XC1APGGSuBYlKOi+CLIl8
tHrkkrn18jgNZiPFniEJ26QIC8eFKgiOR6xQ2qWjh4s/9UzJ6pBiiiHQeSyJ8nF9
qb+xjBwf0MIv75ToRtqdtaSDPl1OEq+deSHz830bW6BywUHBQYu5LZeNBXebs9A4
+4laC0Nu3Wx4sEtIlx4aalysDHAIdl7snvY6YGK65c0jPitT5cj4p4g7BBMFy3O7
X8dXSVuQhInYmIwZWYU39vVs05kV1BUBCJgpr6oiCrDqX619BqrOOBPKd4Cq/YXF
xdVntAZYVBKzXoM7kEg7niLSb4QdGx3ExCj1yjxQRwWGWn837Y977eCv5ICI8skM
aoTR+Fdcm7k/ixrI/WJjwpxagKKQSmv6TcygsO4ERSLPB2H/KenwmhyYZ+34zZWj
gbOj1/DgXD538/gfSO85C5aLk4pNSFVHDZGMjWicdeqnA8U8wGV9jLOU6eFXWNGi
bmDHRNY2b/r4o6TMam8M+tQytSl83o4hsShhCp0giPmeP9p2UlXaIeyzVwVONW/l
Wy7VYkcMXhaaI742vD+wBFo2UJeWIuJK2T3QjFiOAeiuJP+cehMeOncR2SPJ4Acx
PONCnfdQ7GVMe75vdwEi9WbeC7rmSKlDtZFFViRUdWOgH0Gp0cI=
=qQAt
-----END PGP SIGNATURE-----


Closed
?