[PATCH] Add Random Identity Generator (rig)

  • Done
  • quality assurance status badge
Details
3 participants
  • Chuan Wei Foo
  • Liliana Marie Prikler
  • Ludovic Courtès
Owner
unassigned
Submitted by
Chuan Wei Foo
Severity
normal
C
C
Chuan Wei Foo wrote on 4 Oct 2021 17:35
(address . guix-patches@gnu.org)
PU1PR01MB2155F7CACB67ADAA58FAF72F8DAE9@PU1PR01MB2155.apcprd01.prod.exchangelabs.com
---
gnu/packages/patches/rig.patch | 42 ++++++++++++++++++++++++++++++++++
gnu/packages/shellutils.scm | 29 +++++++++++++++++++++++
2 files changed, 71 insertions(+)
create mode 100644 gnu/packages/patches/rig.patch

Toggle diff (94 lines)
diff --git a/gnu/packages/patches/rig.patch b/gnu/packages/patches/rig.patch
new file mode 100644
index 0000000000..34b4ff6533
--- /dev/null
+++ b/gnu/packages/patches/rig.patch
@@ -0,0 +1,42 @@
+--- rig-1.11.orig/Makefile
++++ rig-1.11/Makefile
+@@ -1,20 +1,23 @@
+-PREFIX=/usr/local
++PREFIX=${out}
+ BINDIR=${PREFIX}/bin
+ MANDIR=${PREFIX}/man
+ DATADIR=${PREFIX}/share/rig
++CXX=g++
+
+ all: rig rig.6
+ rig: rig.cc
+- g++ -g rig.cc -o rig -Wall -DDATADIR="\"$(DATADIR)\""
++ ${CXX} -O2 -g rig.cc -o rig -Wall -DDATADIR="\"$(DATADIR)\""
+
+ rig.6: rig.6.in
+ sed s@DATADIR@"$(DATADIR)"@g < rig.6.in > rig.6
+
+ install: rig rig.6
+- install -g 0 -m 755 -o 0 -s rig $(BINDIR)
+- install -g 0 -m 644 -o 0 rig.6 $(MANDIR)/man6/rig.6
+- install -g 0 -m 755 -o 0 -d $(DATADIR)
+- install -g 0 -m 644 -o 0 data/*.idx $(DATADIR)
++ install -m 755 -d $(DESTDIR)$(BINDIR)
++ install -m 755 -d $(DESTDIR)$(DATADIR)
++ install -m 755 -d $(DESTDIR)$(MANDIR)/man6/
++ install -m 755 rig $(DESTDIR)$(BINDIR)/rig
++ install -m 644 data/*.idx $(DESTDIR)$(DATADIR)
++ install -m 644 rig.6 $(DESTDIR)$(MANDIR)/man6/rig.6
+
+ clean:
+ rm -rf *~ *.rej *.orig *.o rig rig.6
+--- rig-1.11.orig/rig.cc
++++ rig-1.11/rig.cc
+@@ -26,6 +26,7 @@
+ #include <time.h>
+ #include <errno.h>
+ #include <assert.h>
++#include <string.h>
+
+ using namespace std;
+
diff --git a/gnu/packages/shellutils.scm b/gnu/packages/shellutils.scm
index 94b5536df7..ef93977eb9 100644
--- a/gnu/packages/shellutils.scm
+++ b/gnu/packages/shellutils.scm
@@ -35,6 +35,7 @@
#:use-module (guix build-system gnu)
#:use-module (guix build-system go)
#:use-module (guix build-system python)
+ #:use-module (gnu packages)
#:use-module (gnu packages autotools)
#:use-module (gnu packages base)
#:use-module (gnu packages bison)
@@ -398,3 +399,31 @@ the UNIX philosophy, these commands are designed to be composed via pipes. A
large collection of functions such as basename, replace, contains or is_dir
are provided as arguments to these commands.")
(license license:expat)))
+
+(define-public rig
+ (package
+ (name "rig")
+ (version "1.11")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "mirror://sourceforge/rig/rig/"
+ version "/rig-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "1f3snysjqqlpk2kgvm5p2icrj4lsdymccmn3igkc2f60smqckgq0"))
+ (patches (search-patches "rig.patch"))))
+ (build-system gnu-build-system)
+ (arguments '(#:phases (modify-phases %standard-phases
+ (delete 'configure))
+ #:tests? #f))
+ (synopsis "Random identity generator")
+ (description
+ "RIG (Random Identity Generator) is a free replacement for a shareware
+program out there called 'fake'. It generates random, yet real-looking,
+personal data. It is useful if you need to feed a name to a Web site,
+BBS, or real person, and are too lazy to think of one yourself. Also,
+if the Web site/BBS/person you are giving the information to tries to
+cross-check the city, state, zip, or area code, it will check out.")
+ (home-page "http://rig.sourceforge.net")
+ (license license:gpl2))
--
2.25.1
C
C
Chuan Wei Foo wrote on 5 Oct 2021 07:11
(address . 51015@debbugs.gnu.org)
PU1PR01MB2155D537AB0CCA00535F695F8DAF9@PU1PR01MB2155.apcprd01.prod.exchangelabs.com
This is my first patch submission to GNU Guix.

A few possible issues:

1. I have placed the package in gnu/packages/shellutils.scm. Is that the
right place?

2. I copied the package description from Debian, Ubuntu, and NixOS. Is
that allowed?

3. Code indentation may be incorrect.
L
L
Liliana Marie Prikler wrote on 5 Oct 2021 15:22
df9ce3cb7666d5b84544b1f5f48b9f221f79b4e6.camel@gmail.com
Hi,

Am Montag, den 04.10.2021, 23:35 +0800 schrieb Chuan Wei Foo:
Toggle quote (1 lines)
> ---
The commit message is missing here. In particular, a ChangeLog is
always required, see “info '(guix)Submitting Patches'”.

Toggle quote (42 lines)
> gnu/packages/patches/rig.patch | 42
> ++++++++++++++++++++++++++++++++++
> gnu/packages/shellutils.scm | 29 +++++++++++++++++++++++
> 2 files changed, 71 insertions(+)
> create mode 100644 gnu/packages/patches/rig.patch
>
> diff --git a/gnu/packages/patches/rig.patch
> b/gnu/packages/patches/rig.patch
> new file mode 100644
> index 0000000000..34b4ff6533
> --- /dev/null
> +++ b/gnu/packages/patches/rig.patch
> @@ -0,0 +1,42 @@
> +--- rig-1.11.orig/Makefile
> ++++ rig-1.11/Makefile
> +@@ -1,20 +1,23 @@
> +-PREFIX=/usr/local
> ++PREFIX=${out}
> + BINDIR=${PREFIX}/bin
> + MANDIR=${PREFIX}/man
> + DATADIR=${PREFIX}/share/rig
> ++CXX=g++
> +
> + all: rig rig.6
> + rig: rig.cc
> +- g++ -g rig.cc -o rig -Wall -DDATADIR="\"$(DATADIR)\""
> ++ ${CXX} -O2 -g rig.cc -o rig -Wall -DDATADIR="\"$(DATADIR)\""
> +
> + rig.6: rig.6.in
> + sed s@DATADIR@"$(DATADIR)"@g < rig.6.in > rig.6
> +
> + install: rig rig.6
> +- install -g 0 -m 755 -o 0 -s rig $(BINDIR)
> +- install -g 0 -m 644 -o 0 rig.6 $(MANDIR)/man6/rig.6
> +- install -g 0 -m 755 -o 0 -d $(DATADIR)
> +- install -g 0 -m 644 -o 0 data/*.idx $(DATADIR)
> ++ install -m 755 -d $(DESTDIR)$(BINDIR)
> ++ install -m 755 -d $(DESTDIR)$(DATADIR)
> ++ install -m 755 -d $(DESTDIR)$(MANDIR)/man6/
> ++ install -m 755 rig $(DESTDIR)$(BINDIR)/rig
> ++ install -m 644 data/*.idx $(DESTDIR)$(DATADIR)
> ++ install -m 644 rig.6 $(DESTDIR)$(MANDIR)/man6/rig.6
You could provide the right #:make-flags, but more accurately replacing
the install phase would also work for this, no?
Toggle quote (12 lines)
> + clean:
> + rm -rf *~ *.rej *.orig *.o rig rig.6
> +--- rig-1.11.orig/rig.cc
> ++++ rig-1.11/rig.cc
> +@@ -26,6 +26,7 @@
> + #include <time.h>
> + #include <errno.h>
> + #include <assert.h>
> ++#include <string.h>
> +
> + using namespace std;
> +
This one could technically be patched with a substitute* after unpack,
which is probably better than shipping a patch for it.

Toggle quote (51 lines)
> diff --git a/gnu/packages/shellutils.scm
> b/gnu/packages/shellutils.scm
> index 94b5536df7..ef93977eb9 100644
> --- a/gnu/packages/shellutils.scm
> +++ b/gnu/packages/shellutils.scm
> @@ -35,6 +35,7 @@
> #:use-module (guix build-system gnu)
> #:use-module (guix build-system go)
> #:use-module (guix build-system python)
> + #:use-module (gnu packages)
> #:use-module (gnu packages autotools)
> #:use-module (gnu packages base)
> #:use-module (gnu packages bison)
> @@ -398,3 +399,31 @@ the UNIX philosophy, these commands are designed
> to be composed via pipes. A
> large collection of functions such as basename, replace, contains or
> is_dir
> are provided as arguments to these commands.")
> (license license:expat)))
> +
> +(define-public rig
> + (package
> + (name "rig")
> + (version "1.11")
> + (source (origin
> + (method url-fetch)
> + (uri (string-append "mirror://sourceforge/rig/rig/"
> + version "/rig-"
> + version ".tar.gz"))
> + (sha256
> + (base32
> + "1f3snysjqqlpk2kgvm5p2icrj4lsdymccmn3igkc2f60smqck
> gq0"))
> + (patches (search-patches "rig.patch"))))
> + (build-system gnu-build-system)
> + (arguments '(#:phases (modify-phases %standard-phases
> + (delete 'configure))
> + #:tests? #f))
> + (synopsis "Random identity generator")
> + (description
> + "RIG (Random Identity Generator) is a free replacement for a
> shareware
> +program out there called 'fake'. It generates random, yet real-
> looking,
> +personal data. It is useful if you need to feed a name to a Web
> site,
> +BBS, or real person, and are too lazy to think of one yourself.
> Also,
> +if the Web site/BBS/person you are giving the information to tries
> to
> +cross-check the city, state, zip, or area code, it will check out.")
I think we can do without references to non-free software in that
description.
Toggle quote (2 lines)
> + (home-page "http://rig.sourceforge.net")
> + (license license:gpl2))
License is actually GPL2+.

Regards,
Liliana
F
F
Foo Chuan Wei wrote on 6 Oct 2021 17:23
[PATCH v2] gnu: Add Random Identity Generator (rig)
(address . 51015@debbugs.gnu.org)
PU1PR01MB2155CA1B3DCC21A4446628E58DB09@PU1PR01MB2155.apcprd01.prod.exchangelabs.com
* gnu/packages/shellutils.scm (rig): New public variable.
---
gnu/packages/patches/rig.patch | 42 ++++++++++++++++++++++++++++++++++
gnu/packages/shellutils.scm | 29 +++++++++++++++++++++++
2 files changed, 71 insertions(+)
create mode 100644 gnu/packages/patches/rig.patch

Toggle diff (96 lines)
diff --git a/gnu/packages/patches/rig.patch b/gnu/packages/patches/rig.patch
new file mode 100644
index 0000000000..34b4ff6533
--- /dev/null
+++ b/gnu/packages/patches/rig.patch
@@ -0,0 +1,42 @@
+--- rig-1.11.orig/Makefile
++++ rig-1.11/Makefile
+@@ -1,20 +1,23 @@
+-PREFIX=/usr/local
++PREFIX=${out}
+ BINDIR=${PREFIX}/bin
+ MANDIR=${PREFIX}/man
+ DATADIR=${PREFIX}/share/rig
++CXX=g++
+
+ all: rig rig.6
+ rig: rig.cc
+- g++ -g rig.cc -o rig -Wall -DDATADIR="\"$(DATADIR)\""
++ ${CXX} -O2 -g rig.cc -o rig -Wall -DDATADIR="\"$(DATADIR)\""
+
+ rig.6: rig.6.in
+ sed s@DATADIR@"$(DATADIR)"@g < rig.6.in > rig.6
+
+ install: rig rig.6
+- install -g 0 -m 755 -o 0 -s rig $(BINDIR)
+- install -g 0 -m 644 -o 0 rig.6 $(MANDIR)/man6/rig.6
+- install -g 0 -m 755 -o 0 -d $(DATADIR)
+- install -g 0 -m 644 -o 0 data/*.idx $(DATADIR)
++ install -m 755 -d $(DESTDIR)$(BINDIR)
++ install -m 755 -d $(DESTDIR)$(DATADIR)
++ install -m 755 -d $(DESTDIR)$(MANDIR)/man6/
++ install -m 755 rig $(DESTDIR)$(BINDIR)/rig
++ install -m 644 data/*.idx $(DESTDIR)$(DATADIR)
++ install -m 644 rig.6 $(DESTDIR)$(MANDIR)/man6/rig.6
+
+ clean:
+ rm -rf *~ *.rej *.orig *.o rig rig.6
+--- rig-1.11.orig/rig.cc
++++ rig-1.11/rig.cc
+@@ -26,6 +26,7 @@
+ #include <time.h>
+ #include <errno.h>
+ #include <assert.h>
++#include <string.h>
+
+ using namespace std;
+
diff --git a/gnu/packages/shellutils.scm b/gnu/packages/shellutils.scm
index 94b5536df7..662ca84d94 100644
--- a/gnu/packages/shellutils.scm
+++ b/gnu/packages/shellutils.scm
@@ -35,6 +35,7 @@
#:use-module (guix build-system gnu)
#:use-module (guix build-system go)
#:use-module (guix build-system python)
+ #:use-module (gnu packages)
#:use-module (gnu packages autotools)
#:use-module (gnu packages base)
#:use-module (gnu packages bison)
@@ -398,3 +399,31 @@ the UNIX philosophy, these commands are designed to be composed via pipes. A
large collection of functions such as basename, replace, contains or is_dir
are provided as arguments to these commands.")
(license license:expat)))
+
+(define-public rig
+ (package
+ (name "rig")
+ (version "1.11")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "mirror://sourceforge/rig/rig/"
+ version "/rig-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "1f3snysjqqlpk2kgvm5p2icrj4lsdymccmn3igkc2f60smqckgq0"))
+ (patches (search-patches "rig.patch"))))
+ (build-system gnu-build-system)
+ (arguments '(#:phases (modify-phases %standard-phases
+ (delete 'configure))
+ #:tests? #f))
+ (synopsis "Random identity generator")
+ (description
+ "RIG (Random Identity Generator) is a free replacement for a shareware
+program out there called 'fake'. It generates random, yet real-looking,
+personal data. It is useful if you need to feed a name to a Web site,
+BBS, or real person, and are too lazy to think of one yourself. Also,
+if the Web site/BBS/person you are giving the information to tries to
+cross-check the city, state, zip, or area code, it will check out.")
+ (home-page "http://rig.sourceforge.net")
+ (license license:gpl2+)))

base-commit: f868ed2a75b55400107b80fcc1e41dcfb6b3c28c
--
2.25.1
F
F
Foo Chuan Wei wrote on 12 Oct 2021 11:12
[PATCH v3] gnu: Add Random Identity Generator (rig)
(address . 51015@debbugs.gnu.org)
PU1PR01MB21551531EBEAB287FE8EA16C8DB69@PU1PR01MB2155.apcprd01.prod.exchangelabs.com
* gnu/packages/shellutils.scm (rig): New variable.
---
gnu/packages/patches/rig-makefile.patch | 27 ++++++++++++++++++
gnu/packages/shellutils.scm | 38 +++++++++++++++++++++++++
2 files changed, 65 insertions(+)
create mode 100644 gnu/packages/patches/rig-makefile.patch

Toggle diff (90 lines)
diff --git a/gnu/packages/patches/rig-makefile.patch b/gnu/packages/patches/rig-makefile.patch
new file mode 100644
index 0000000000..24cc1c5810
--- /dev/null
+++ b/gnu/packages/patches/rig-makefile.patch
@@ -0,0 +1,27 @@
+diff -ur rig-1.11-orig/Makefile rig-1.11/Makefile
+--- rig-1.11-orig/Makefile
++++ rig-1.11/Makefile
+@@ -5,16 +5,18 @@
+
+ all: rig rig.6
+ rig: rig.cc
+- g++ -g rig.cc -o rig -Wall -DDATADIR="\"$(DATADIR)\""
++ ${CXX} -O2 -g rig.cc -o rig -Wall -DDATADIR="\"$(DATADIR)\""
+
+ rig.6: rig.6.in
+ sed s@DATADIR@"$(DATADIR)"@g < rig.6.in > rig.6
+
+ install: rig rig.6
+- install -g 0 -m 755 -o 0 -s rig $(BINDIR)
+- install -g 0 -m 644 -o 0 rig.6 $(MANDIR)/man6/rig.6
+- install -g 0 -m 755 -o 0 -d $(DATADIR)
+- install -g 0 -m 644 -o 0 data/*.idx $(DATADIR)
++ install -m 755 -d $(DESTDIR)$(BINDIR)
++ install -m 755 -d $(DESTDIR)$(DATADIR)
++ install -m 755 -d $(DESTDIR)$(MANDIR)/man6/
++ install -m 755 rig $(DESTDIR)$(BINDIR)/rig
++ install -m 644 data/*.idx $(DESTDIR)$(DATADIR)
++ install -m 644 rig.6 $(DESTDIR)$(MANDIR)/man6/rig.6
+
+ clean:
+ rm -rf *~ *.rej *.orig *.o rig rig.6
diff --git a/gnu/packages/shellutils.scm b/gnu/packages/shellutils.scm
index 94b5536df7..1a1b35d48b 100644
--- a/gnu/packages/shellutils.scm
+++ b/gnu/packages/shellutils.scm
@@ -35,6 +35,7 @@
#:use-module (guix build-system gnu)
#:use-module (guix build-system go)
#:use-module (guix build-system python)
+ #:use-module (gnu packages)
#:use-module (gnu packages autotools)
#:use-module (gnu packages base)
#:use-module (gnu packages bison)
@@ -398,3 +399,40 @@ the UNIX philosophy, these commands are designed to be composed via pipes. A
large collection of functions such as basename, replace, contains or is_dir
are provided as arguments to these commands.")
(license license:expat)))
+
+(define-public rig
+ (package
+ (name "rig")
+ (version "1.11")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "mirror://sourceforge/rig/rig/"
+ version "/rig-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "1f3snysjqqlpk2kgvm5p2icrj4lsdymccmn3igkc2f60smqckgq0"))
+ (patches (search-patches "rig-makefile.patch"))))
+ (build-system gnu-build-system)
+ (arguments `(#:make-flags
+ (list (string-append "CXX=" ,(cxx-for-target))
+ (string-append "PREFIX=" %output))
+ #:phases
+ (modify-phases %standard-phases
+ (delete 'configure)
+ (add-after 'unpack 'fix-build
+ (lambda _
+ (substitute* "rig.cc"
+ (("^#include <string>")
+ "#include <cstring>"))
+ #t)))
+ #:tests? #f))
+ (home-page "http://rig.sourceforge.net")
+ (synopsis "Random identity generator")
+ (description
+ "RIG (Random Identity Generator) generates random, yet real-looking,
+personal data. It is useful if you need to feed a name to a Web site, BBS, or
+real person, and are too lazy to think of one yourself. Also, if the Web
+site/BBS/person you are giving the information to tries to cross-check the
+city, state, zip, or area code, it will check out.")
+ (license license:gpl2+)))

base-commit: 35aaf1fe10488ae9ed732fb2c383d09a70c109c0
--
2.25.1
L
L
Ludovic Courtès wrote on 26 Oct 2021 12:43
Re: bug#51015: [PATCH] Add Random Identity Generator (rig)
(name . Foo Chuan Wei)(address . chuanwei.foo@hotmail.com)(address . 51015@debbugs.gnu.org)
87v91khxrf.fsf_-_@gnu.org
Hi,

Foo Chuan Wei <chuanwei.foo@hotmail.com> skribis:

Toggle quote (2 lines)
> * gnu/packages/shellutils.scm (rig): New variable.

[...]

Toggle quote (8 lines)
> + install: rig rig.6
> +- install -g 0 -m 755 -o 0 -s rig $(BINDIR)
> +- install -g 0 -m 644 -o 0 rig.6 $(MANDIR)/man6/rig.6
> +- install -g 0 -m 755 -o 0 -d $(DATADIR)
> +- install -g 0 -m 644 -o 0 data/*.idx $(DATADIR)
> ++ install -m 755 -d $(DESTDIR)$(BINDIR)
> ++ install -m 755 -d $(DESTDIR)$(DATADIR)

As Liliana wrote regarding PREFIX, please use ‘substitute*’ instead of a
patch to modify these bits.

Could you send an updated patch?

With this change in place, the patch will be ready to go!

Thanks,
Ludo’.
F
F
Foo Chuan Wei wrote on 29 Oct 2021 08:53
[PATCH v4] gnu: Add Random Identity Generator (rig)
(name . Ludovic Courtès)(address . ludo@gnu.org)(address . 51015@debbugs.gnu.org)
PU1PR01MB2155EE23D29A95D82D02A66D8D879@PU1PR01MB2155.apcprd01.prod.exchangelabs.com
* gnu/packages/shellutils.scm (rig): New variable.
---
gnu/packages/shellutils.scm | 50 +++++++++++++++++++++++++++++++++++++
1 file changed, 50 insertions(+)

Toggle diff (76 lines)
diff --git a/gnu/packages/shellutils.scm b/gnu/packages/shellutils.scm
index 3ded0ee897..6271b6e375 100644
--- a/gnu/packages/shellutils.scm
+++ b/gnu/packages/shellutils.scm
@@ -12,6 +12,7 @@
;;; Copyright © 2021 Brice Waegeneire <brice@waegenei.re>
;;; Copyright © 2021 Alexandr Vityazev <avityazev@posteo.org>
;;; Copyright © 2021 Xinglu Chen <public@yoctocell.xyz>
+;;; Copyright © 2021 Foo Chuan Wei <chuanwei.foo@hotmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -37,6 +38,7 @@
#:use-module (guix build-system gnu)
#:use-module (guix build-system go)
#:use-module (guix build-system python)
+ #:use-module (gnu packages)
#:use-module (gnu packages autotools)
#:use-module (gnu packages base)
#:use-module (gnu packages bison)
@@ -463,3 +465,51 @@ the UNIX philosophy, these commands are designed to be composed via pipes. A
large collection of functions such as basename, replace, contains or is_dir
are provided as arguments to these commands.")
(license license:expat)))
+
+(define-public rig
+ (package
+ (name "rig")
+ (version "1.11")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "mirror://sourceforge/rig/rig/"
+ version "/rig-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "1f3snysjqqlpk2kgvm5p2icrj4lsdymccmn3igkc2f60smqckgq0"))))
+ (build-system gnu-build-system)
+ (arguments `(#:make-flags
+ (list (string-append "CXX=" ,(cxx-for-target))
+ (string-append "PREFIX=" %output))
+ #:phases
+ (modify-phases %standard-phases
+ (delete 'configure)
+ (add-after 'unpack 'fix-build
+ (lambda _
+ (substitute* "rig.cc"
+ (("^#include <string>")
+ "#include <cstring>"))
+ (substitute* "Makefile"
+ (("g\\+\\+")
+ "${CXX} -O2")
+ (("install -g 0 -m 755 -o 0 -s rig \\$\\(BINDIR\\)")
+ "install -m 755 -d $(DESTDIR)$(BINDIR)\n\t\
+install -m 755 rig $(DESTDIR)$(BINDIR)/rig")
+ (("install -g 0 -m 644 -o 0 rig.6 \\$\\(MANDIR\\)/man6/rig.6")
+ "install -m 755 -d $(DESTDIR)$(MANDIR)/man6/\n\t\
+install -m 644 rig.6 $(DESTDIR)$(MANDIR)/man6/rig.6")
+ (("install -g 0 -m 755 -o 0 -d \\$\\(DATADIR\\)")
+ "install -m 755 -d $(DESTDIR)$(DATADIR)")
+ (("install -g 0 -m 644 -o 0 data/\\*.idx \\$\\(DATADIR\\)")
+ "install -m 644 data/*.idx $(DESTDIR)$(DATADIR)")))))
+ #:tests? #f))
+ (home-page "http://rig.sourceforge.net")
+ (synopsis "Random identity generator")
+ (description
+ "RIG (Random Identity Generator) generates random, yet real-looking,
+personal data. It is useful if you need to feed a name to a Web site, BBS, or
+real person, and are too lazy to think of one yourself. Also, if the Web
+site/BBS/person you are giving the information to tries to cross-check the
+city, state, zip, or area code, it will check out.")
+ (license license:gpl2+)))

base-commit: ad39268cdf075f4c4eeb87ed78ce46ca6f817675
--
2.25.1
L
L
Ludovic Courtès wrote on 30 Oct 2021 16:10
(address . 51015-done@debbugs.gnu.org)
8735oivc0y.fsf@gnu.org
Hi,

Foo Chuan Wei <chuanwei.foo@hotmail.com> skribis:

Toggle quote (2 lines)
> * gnu/packages/shellutils.scm (rig): New variable.

I fixed one ‘guix lint’ warning and applied, thanks!

Ludo’.
Closed
?