[PATCH] gnu: Add naev.

  • Done
  • quality assurance status badge
Details
2 participants
  • Ludovic Courtès
  • Nicolas Goaziou
Owner
unassigned
Submitted by
Nicolas Goaziou
Severity
normal
N
N
Nicolas Goaziou wrote on 1 Oct 2021 22:32
(address . guix-patches@gnu.org)
87mtnso5a5.fsf@nicolasgoaziou.fr
Hello,

Here comes a patch for the Naev game.

Regards,
--
Nicolas Goaziou
From 00610d682ebf6653144d63e4cd09e9d896f3bf5c Mon Sep 17 00:00:00 2001
From: Nicolas Goaziou <mail@nicolasgoaziou.fr>
Date: Fri, 1 Oct 2021 22:29:19 +0200
Subject: [PATCH] gnu: Add naev.

* gnu/packages/games.scm (naev): New variable.
---
gnu/packages/games.scm | 60 ++++++++++++++++++++++++++++++++++++++++++
1 file changed, 60 insertions(+)

Toggle diff (73 lines)
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index dabbbe6ea1..b3ea7de5dd 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -7998,6 +7998,66 @@ ncurses for text display.")
(home-page "http://frotz.sourceforge.net")
(license license:gpl2+)))
+(define-public naev
+ (package
+ (name "naev")
+ (version "0.8.2")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/naev/naev")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "02rk2fv2nhx5xsi0cariisamab3dpncwps4q3i3ki0y27xpwxzfx"))))
+ (build-system meson-build-system)
+ (arguments
+ ;; XXX: Do not add debugging symbols, which cause the build to fail.
+ `(#:configure-flags (list "--buildtype=release")
+ #:tests? #f ;sole test fails with a missing "/dev/dri" error
+ #:meson ,meson-0.55))
+ (native-inputs
+ `(("gettext" ,gettext-minimal)
+ ("pkg-config" ,pkg-config)))
+ (inputs
+ `(("freetype" ,freetype)
+ ("glpk" ,glpk)
+ ("libpng" ,libpng)
+ ("libvorbis" ,libvorbis)
+ ("libwebp" ,libwebp)
+ ("libxml2" ,libxml2)
+ ("luajit" ,luajit)
+ ("openal" ,openal)
+ ("openblas" ,openblas)
+ ("physfs" ,physfs)
+ ("sdl" ,(sdl-union (list sdl2 sdl2-image sdl2-mixer)))
+ ("suitesparse" ,suitesparse)))
+ (home-page "https://naev.org/")
+ (synopsis "Game about space exploration, trade and combat")
+ (description
+ "Naev is a 2d action/rpg space game that combines elements from
+the action, RPG and simulation genres. You pilot a spaceship from
+a top-down perspective, and are more or less free to do what you want.
+As the genre name implies, you’re able to trade and engage in combat
+at will. Beyond that, there’s an ever-growing number of story-line
+missions, equipment, and ships; even the galaxy itself grows larger
+with each release. For the literacy-inclined, there are large amounts
+of lore accompanying everything from planets to equipment.")
+ (license (list license:gpl3
+ license:public-domain
+ license:expat ;edtaa3func.c
+ license:bsd-2 ;distance_field.c
+ license:bsd-3 ;perlin.c
+ ;; Assets.
+ license:silofl1.1
+ license:gpl2+
+ license:cc0
+ license:cc-by3.0
+ license:cc-by-sa3.0
+ license:cc-by4.0
+ license:cc-by-sa4.0))))
+
(define-public frotz-dumb-terminal
(package
(name "frotz-dumb-terminal")
--
2.33.0
L
L
Ludovic Courtès wrote on 30 Oct 2021 19:08
(name . Nicolas Goaziou)(address . mail@nicolasgoaziou.fr)(address . 50952@debbugs.gnu.org)
87k0husani.fsf@gnu.org
Hi,

Nicolas Goaziou <mail@nicolasgoaziou.fr> skribis:

Toggle quote (7 lines)
>>From 00610d682ebf6653144d63e4cd09e9d896f3bf5c Mon Sep 17 00:00:00 2001
> From: Nicolas Goaziou <mail@nicolasgoaziou.fr>
> Date: Fri, 1 Oct 2021 22:29:19 +0200
> Subject: [PATCH] gnu: Add naev.
>
> * gnu/packages/games.scm (naev): New variable.

[...]

Toggle quote (4 lines)
> + (build-system meson-build-system)
> + (arguments
> + ;; XXX: Do not add debugging symbols, which cause the build to fail.

That sounds weird. Perhaps ‘--buildtype=release’ does something beyond
removing ‘-g’, which would explain that it doesn’t fail?

Otherwise LGTM!

Ludo’.
N
N
Nicolas Goaziou wrote on 2 Nov 2021 21:33
(name . Ludovic Courtès)(address . ludo@gnu.org)(address . 50952-done@debbugs.gnu.org)
87o872uwk5.fsf@nicolasgoaziou.fr
Hello,

Ludovic Courtès <ludo@gnu.org> writes:

Toggle quote (13 lines)
>> Subject: [PATCH] gnu: Add naev.
>>
>> * gnu/packages/games.scm (naev): New variable.
>
> [...]
>
>> + (build-system meson-build-system)
>> + (arguments
>> + ;; XXX: Do not add debugging symbols, which cause the build to fail.
>
> That sounds weird. Perhaps ‘--buildtype=release’ does something beyond
> removing ‘-g’, which would explain that it doesn’t fail?

I couldn't spot anything suspicious in the code base. However, upstream
mention that "--buildtype=release" should be used for a regular
installation.

Toggle quote (2 lines)
> Otherwise LGTM!

Pushed. Thank you!

Regards,
--
Nicolas Goaziou
Closed
?