[PATCH] gnu: Add svkbd.

  • Done
  • quality assurance status badge
Details
3 participants
  • Antero Mejr
  • ???
  • phodina
Owner
unassigned
Submitted by
Antero Mejr
Severity
normal
A
A
Antero Mejr wrote on 25 Sep 2021 20:53
(address . guix-patches@gnu.org)(name . Antero Mejr)(address . antero@mailbox.org)
20210925185311.9140-1-antero@mailbox.org
* gnu/packages/suckless.scm (svkbd): New variable.
---
gnu/packages/suckless.scm | 45 +++++++++++++++++++++++++++++++++++++++
1 file changed, 45 insertions(+)

Toggle diff (55 lines)
diff --git a/gnu/packages/suckless.scm b/gnu/packages/suckless.scm
index b24eced379..dc313c10e3 100644
--- a/gnu/packages/suckless.scm
+++ b/gnu/packages/suckless.scm
@@ -901,3 +901,48 @@ chat output in the background.")
Single daemon and configuration file. Log to stdout or syslog. No mail
support.")
(license license:expat)))
+
+(define-public svkbd
+ (package
+ (name "svkbd")
+ (version "0.4")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://dl.suckless.org/tools/svkbd-"
+ version ".tar.gz"))
+ (sha256
+ (base32 "0pydmf7frbn8b3zr2is212npbafkyrbs8qxg2ivwjvqwzvkmdm4g"))))
+ (build-system gnu-build-system)
+ (native-inputs
+ `(("pkg-config" ,pkg-config)
+ ("locales" ,glibc-utf8-locales)))
+ (inputs
+ `(("freetype" ,freetype)
+ ("libx11" ,libx11)
+ ("libxtst" ,libxtst)
+ ("libxft" ,libxft)
+ ("libxinerama" ,libxinerama)))
+ (arguments
+ `(#:tests? #f
+ #:make-flags
+ (list (string-append "CC=" ,(cc-for-target))
+ (string-append "PREFIX=" %output))
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'patch
+ (lambda* (#:key inputs outputs #:allow-other-keys)
+ (substitute* "config.mk"
+ (("/usr/local")
+ (assoc-ref outputs "out"))
+ (("/usr/X11R6")
+ (assoc-ref inputs "libx11"))
+ (("/usr/include/freetype2")
+ (string-append (assoc-ref inputs "freetype")
+ "/include/freetype2")))))
+ (delete 'configure)))) ; no configure script
+ (home-page "https://tools.suckless.org/x/svkbd")
+ (synopsis "Virtual on-screen keyboard")
+ (description "svkbd is a simple virtual keyboard, intended to be used in
+environments, where no keyboard is available.")
+ (license license:expat)))
--
2.30.2
P
P
phodina wrote on 5 Nov 2021 07:55
(name . 50805@debbugs.gnu.org)(address . 50805@debbugs.gnu.org)
_DpSVR3Z2-M65u9pY1kMbiZiRRocFt99gfeaenNAj6QxnXkaef2vW8P0rj52NxTPgIomPlopqvHYk9g1a8vsFzCrdhXb6MuNdq4d7fDhBIo=@protonmail.com
Hi Antero,

Thanks for the patch. The lint found one issue:

gnu/packages/suckless.scm:1007:15: svkbd@0.4: permanent redirect from https://tools.suckless.org/x/svkbdto https://tools.suckless.org/x/svkbd/

Otherwise builds and works. LGTM

Could you send updated patch please?

Petr
A
A
Antero Mejr wrote on 7 Mar 2022 17:50
[PATCH] gnu: Add svkbd.
(address . 50805@debbugs.gnu.org)(name . Antero Mejr)(address . antero@mailbox.org)
20220307165019.514051-1-antero@mailbox.org
* gnu/packages/suckless.scm (svkbd): New variable.
---
Linted and updated to version 0.4.1.

gnu/packages/suckless.scm | 46 +++++++++++++++++++++++++++++++++++++++
1 file changed, 46 insertions(+)

Toggle diff (63 lines)
diff --git a/gnu/packages/suckless.scm b/gnu/packages/suckless.scm
index 708eb2c338..f75fd8054d 100644
--- a/gnu/packages/suckless.scm
+++ b/gnu/packages/suckless.scm
@@ -11,6 +11,7 @@
;;; Copyright © 2021 Raghav Gururajan <rg@raghavgururajan.name>
;;; Copyright © 2021 Alexandru-Sergiu Marton <brown121407@posteo.ro>
;;; Copyright © 2021 Nikolay Korotkiy <sikmir@disroot.org>
+;;; Copyright © 2022 Antero Mejr <antero@mailbox.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -1083,3 +1084,48 @@ (define-public sfeed
various other formats. There are also some programs and scripts included to
import and export OPML and to fetch, filter, merge and order feed items.")
(license license:isc)))
+
+(define-public svkbd
+ (package
+ (name "svkbd")
+ (version "0.4.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://dl.suckless.org/tools/svkbd-"
+ version ".tar.gz"))
+ (sha256
+ (base32 "0nhgmr38pk1a8zrcrxd1ygh0m843a3bdchkv8phl508x7vy63hpv"))))
+ (build-system gnu-build-system)
+ (native-inputs
+ `(("pkg-config" ,pkg-config)
+ ("glibc-utf8-locales" ,glibc-utf8-locales)))
+ (inputs
+ `(("freetype" ,freetype)
+ ("libx11" ,libx11)
+ ("libxtst" ,libxtst)
+ ("libxft" ,libxft)
+ ("libxinerama" ,libxinerama)))
+ (arguments
+ `(#:tests? #f
+ #:make-flags
+ (list (string-append "CC=" ,(cc-for-target))
+ (string-append "PREFIX=" %output))
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'patch
+ (lambda* (#:key inputs outputs #:allow-other-keys)
+ (substitute* "config.mk"
+ (("/usr/local")
+ (assoc-ref outputs "out"))
+ (("/usr/X11R6")
+ (assoc-ref inputs "libx11"))
+ (("/usr/include/freetype2")
+ (string-append (assoc-ref inputs "freetype")
+ "/include/freetype2")))))
+ (delete 'configure)))) ; no configure script
+ (home-page "https://tools.suckless.org/x/svkbd/")
+ (synopsis "Virtual on-screen keyboard")
+ (description "svkbd is a simple virtual keyboard, intended to be used in
+environments, where no keyboard is available.")
+ (license license:expat)))
--
2.32.0
A
A
Antero Mejr wrote on 29 May 2022 04:10
(address . 50805@debbugs.gnu.org)(name . Antero Mejr)(address . antero@mailbox.org)
20220529021026.339745-1-antero@mailbox.org
Updated to use the new gexps, then re-tested.

* gnu/packages/suckless.scm (svkbd): New variable.
---
gnu/packages/suckless.scm | 37 +++++++++++++++++++++++++++++++++++++
1 file changed, 37 insertions(+)

Toggle diff (54 lines)
diff --git a/gnu/packages/suckless.scm b/gnu/packages/suckless.scm
index 5aa37657b9..759643a33b 100644
--- a/gnu/packages/suckless.scm
+++ b/gnu/packages/suckless.scm
@@ -12,6 +12,7 @@
;;; Copyright © 2021 Alexandru-Sergiu Marton <brown121407@posteo.ro>
;;; Copyright © 2021 Nikolay Korotkiy <sikmir@disroot.org>
;;; Copyright © 2022 Jai Vetrivelan <jaivetrivelan@gmail.com>
+;;; Copyright © 2022 Antero Mejr <antero@mailbox.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -1084,3 +1085,39 @@ (define-public sfeed
various other formats. There are also some programs and scripts included to
import and export OPML and to fetch, filter, merge and order feed items.")
(license license:isc)))
+
+(define-public svkbd
+ (package
+ (name "svkbd")
+ (version "0.4.1")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "https://dl.suckless.org/tools/svkbd-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "0nhgmr38pk1a8zrcrxd1ygh0m843a3bdchkv8phl508x7vy63hpv"))))
+ (build-system gnu-build-system)
+ (arguments
+ (list #:tests? #f
+ #:make-flags
+ #~(list (string-append "CC=" #$(cc-for-target))
+ (string-append "PREFIX=" #$output))
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'unpack 'patch
+ (lambda* (#:key inputs outputs #:allow-other-keys)
+ (substitute* "config.mk"
+ (("/usr/local") #$output)
+ (("/usr/X11R6") #$libx11)
+ (("/usr/include/freetype2") (string-append #$freetype
+ "/include/freetype2")))))
+ (delete 'configure)))) ;no configure script
+ (native-inputs (list pkg-config))
+ (inputs (list freetype libx11 libxft libxtst libxinerama))
+ (propagated-inputs (list glibc-utf8-locales))
+ (home-page "https://tools.suckless.org/x/svkbd/")
+ (synopsis "Virtual on-screen keyboard")
+ (description "svkbd is a simple virtual keyboard, intended to be used in
+environments, where no keyboard is available.")
+ (license license:expat)))
--
2.36.1
?
(name . Antero Mejr)(address . antero@mailbox.org)(address . 50805-done@debbugs.gnu.org)
87wnbnxnmd.fsf_-_@envs.net
Antero Mejr <antero@mailbox.org> writes:

Toggle quote (4 lines)
> Updated to use the new gexps, then re-tested.
>
> * gnu/packages/suckless.scm (svkbd): New variable.

Pushed, thank you!
Closed
?