[PATCH] gnu: Add runitor

  • Done
  • quality assurance status badge
Details
2 participants
  • Ludovic Courtès
  • Stephen Paul Weber
Owner
unassigned
Submitted by
Stephen Paul Weber
Severity
normal
S
S
Stephen Paul Weber wrote on 25 Sep 2021 04:44
(address . guix-patches@gnu.org)(name . Stephen Paul Weber)(address . singpolyma@singpolyma.net)
20210925024439.15575-1-singpolyma@singpolyma.net
* gnu/packages/admin.scm (runitor): New variable.
---
gnu/packages/admin.scm | 28 ++++++++++++++++++++++++++++
1 file changed, 28 insertions(+)

Toggle diff (38 lines)
diff --git a/gnu/packages/admin.scm b/gnu/packages/admin.scm
index 9ee371be71..1e3082d36b 100644
--- a/gnu/packages/admin.scm
+++ b/gnu/packages/admin.scm
@@ -4797,3 +4797,31 @@ setup, maintenance, supervision, or any long-running processes.")
(description "Utility to convert @code{lsof} output to a graph showing
FIFO and UNIX interprocess communication.")
(license license:bsd-2))))
+
+(define-public runitor
+ (package
+ (name "runitor")
+ (version "0.8.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/bdd/runitor")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0vjfbyrbp5ywgzdz9j3x0qgjvnq7nw7193x8v9yy6k2cih1zsacn"))))
+ (build-system go-build-system)
+ (arguments
+ `(#:unpack-path "bdd.fi/x/runitor"
+ #:go ,go-1.17
+ #:build-flags '(,(string-append "-ldflags=-X main.Version=" version))
+ #:import-path "bdd.fi/x/runitor/cmd/runitor"
+ #:install-source? #f))
+ (home-page "https://github.com/bdd/runitor")
+ (synopsis "Command runner with healthchecks.io integration")
+ (description
+ "Runitor runs the supplied command, captures its output, and based on its
+exit code reports successful or failed execution to
+@url{https://healthchecks.io,https://healthchecks.io} or your private instance.")
+ (license license:bsd-0)))
--
2.20.1
L
L
Ludovic Courtès wrote on 13 Oct 2021 11:10
(name . Stephen Paul Weber)(address . singpolyma@singpolyma.net)(address . 50794-done@debbugs.gnu.org)
874k9ls322.fsf@gnu.org
Stephen Paul Weber <singpolyma@singpolyma.net> skribis:

Toggle quote (2 lines)
> * gnu/packages/admin.scm (runitor): New variable.

Applied, thanks!

Ludo’.
Closed
?