[PATCH] m4: Don't require courage on unsupported systems.

  • Done
  • quality assurance status badge
Details
2 participants
  • Efraim Flashner
  • Ludovic Courtès
Owner
unassigned
Submitted by
Efraim Flashner
Severity
normal
E
E
Efraim Flashner wrote on 24 Sep 2021 15:39
(address . guix-patches@gnu.org)(address . ludo@gnu.org)
6cef6643c809f73110b9d74db74c6511be000ee4.1632490595.git.efraim@flashner.co.il
* m4/guix.m4 (GUIX_ASSERT_SUPPORTED_SYSTEM): Don't error if building on
an unsupported system.
* doc/guix.texi (GNU Distribution): Relabel mips64el-linux as
unsupported.
---

As we discussed previously with the powerpc-linux patches, I've gotten
around to changing the m4 error to a warning. Also, I didn't change
i586-gnu to say unsupported next to it in GNU Distribution in the
manual, although I suppose the other option would be to add i586-gnu to
supported in m4/guix.m4.

---
doc/guix.texi | 2 +-
m4/guix.m4 | 17 +++--------------
2 files changed, 4 insertions(+), 15 deletions(-)

Toggle diff (58 lines)
diff --git a/doc/guix.texi b/doc/guix.texi
index 9bb91b94fd..5cec6c0645 100644
--- a/doc/guix.texi
+++ b/doc/guix.texi
@@ -525,7 +525,7 @@ way for you to give it a try is by setting up an instance of
(@pxref{transparent-emulation-qemu, @code{hurd-vm-service-type}}).
@xref{Contributing}, on how to help!
-@item mips64el-linux (deprecated)
+@item mips64el-linux (unsupported)
little-endian 64-bit MIPS processors, specifically the Loongson series,
n32 ABI, and Linux-Libre kernel. This configuration is no longer fully
supported; in particular, there is no ongoing work to ensure that this
diff --git a/m4/guix.m4 b/m4/guix.m4
index 05d409a674..7a5eaa47f9 100644
--- a/m4/guix.m4
+++ b/m4/guix.m4
@@ -1,7 +1,7 @@
dnl GNU Guix --- Functional package management for GNU
dnl Copyright © 2012, 2013, 2014, 2015, 2016, 2018, 2019, 2020, 2021 Ludovic Courtès <ludo@gnu.org>
dnl Copyright © 2014 Mark H Weaver <mhw@netris.org>
-dnl Copyright © 2017 Efraim Flashner <efraim@flashner.co.il>
+dnl Copyright © 2017, 2021 Efraim Flashner <efraim@flashner.co.il>
dnl Copyright © 2021 Chris Marusich <cmmarusich@gmail.com>
dnl
dnl This file is part of GNU Guix.
@@ -79,25 +79,14 @@ dnl Assert that this is a system to which the distro is ported.
AC_DEFUN([GUIX_ASSERT_SUPPORTED_SYSTEM], [
AC_REQUIRE([GUIX_SYSTEM_TYPE])
- AC_ARG_WITH([courage], [AS_HELP_STRING([--with-courage],
- [Assert that even if this platform is unsupported, you will be
-courageous and port the GNU System distribution to it (see
-"GNU Distribution" in the manual.)])],
- [guix_courageous="$withval"],
- [guix_courageous="no"])
-
# Currently only Linux-based systems are supported, and only on some
# platforms.
case "$guix_system" in
x86_64-linux|i686-linux|armhf-linux|aarch64-linux|powerpc64le-linux)
;;
*)
- if test "x$guix_courageous" = "xyes"; then
- AC_MSG_WARN([building Guix on `$guix_system', which is not supported])
- else
- AC_MSG_ERROR([`$guix_system' is not a supported platform.
-See "GNU Distribution" in the manual, or try `--with-courage'.])
- fi
+ AC_MSG_WARN([`$guix_system' IS NOT A SUPPORTED PLATFORM.
+See "GNU Distribution" in the manual, for more information.])
;;
esac
])

base-commit: a7b6c5a1270e52385a70b4192ee40ac6eb3b7c27
--
2.33.0
-----BEGIN PGP SIGNATURE-----

iQIzBAABCgAdFiEEoov0DD5VE3JmLRT3Qarn3Mo9g1EFAmFN1R0ACgkQQarn3Mo9
g1EL8Q//SaSxfRy+aQKUxf3VZv2g1G6DFIi0brN0AokOXVrc8T4PGfcYT+I7gBdE
+m8xApcfcOKdGYnbIeJ3nC8JTkbM3I4984FSHVgvyY3elszlfPCHriKEmDGsg5Rd
9Arrdo0+Z7wyRwjdEgae/4H4gysiramIqpXH+iCJCa2vW0yVUq4XXoFK6LY3haJH
GI2Nlx3lKVD4xQpMX7pC1c3dO+ZjO867Rgh1SWdU/AHLeIMRGs38VZ2/doLxusev
QC0aFuF6tK/w/RDl1EoHRaVUVYt1HgMW5SCJ4f/inff1Tl+9yTxtBvdf373nxVDH
yVwoj/2qZy7Y/H8zZU/ATZeiKNildyJJmm0ppQDiBotD1ZzVezf+k4Pm+ySmDueR
sMSGQZJkGIAwn2XJzEsaX9QiSD+SCZBTNo15Vg3qwMXikx+AUOash0LlNVRrqKQ6
K+iIAVSHDjQ14ij0Zg/KSLz2dBmV53ag+PmYTKPh5poZoPbJKwWiJ2cJOQ9OCyXj
WUhb5GDId2Pnd6dOtYSpGG2MOiMaps4VC6N7Tk0DrjX5qhX+abfJZd/EMwJHs4Vp
QB8WCBlKEnjMH2Mxa7MY/XIF8oZ1UK4QrvudRwq2DZ1xSsr1Ls/18B4OELNiv0zj
usmzL3vT1RkSMO1rCWzHYpVVUVpd3CO1lOIFlG0A0qf3tcOwfjA=
=D1tc
-----END PGP SIGNATURE-----


L
L
Ludovic Courtès wrote on 13 Oct 2021 11:00
(address . 50778@debbugs.gnu.org)
87h7dls3j3.fsf@gnu.org
Efraim Flashner <efraim@flashner.co.il> skribis:

Toggle quote (12 lines)
> * m4/guix.m4 (GUIX_ASSERT_SUPPORTED_SYSTEM): Don't error if building on
> an unsupported system.
> * doc/guix.texi (GNU Distribution): Relabel mips64el-linux as
> unsupported.
> ---
>
> As we discussed previously with the powerpc-linux patches, I've gotten
> around to changing the m4 error to a warning. Also, I didn't change
> i586-gnu to say unsupported next to it in GNU Distribution in the
> manual, although I suppose the other option would be to add i586-gnu to
> supported in m4/guix.m4.

Yes, I’d rather mark i586-gnu as supported in m4/guix.m4 (it should have
been the case long ago) and keep the error and ‘--with-courage’ flag.

WDYT?

Toggle quote (3 lines)
> -@item mips64el-linux (deprecated)
> +@item mips64el-linux (unsupported)

Good idea. :-)

Thanks!

Ludo’.
E
E
Efraim Flashner wrote on 17 Oct 2021 09:20
Re: [bug#50778] [PATCH] m4: Don't require courage on unsupported systems.
(name . Ludovic Courtès)(address . ludo@gnu.org)(address . 50778@debbugs.gnu.org)
YWvOzaqr3beHD1kZ@3900XT
On Wed, Oct 13, 2021 at 11:00:16AM +0200, Ludovic Courtès wrote:
Toggle quote (19 lines)
> Efraim Flashner <efraim@flashner.co.il> skribis:
>
> > * m4/guix.m4 (GUIX_ASSERT_SUPPORTED_SYSTEM): Don't error if building on
> > an unsupported system.
> > * doc/guix.texi (GNU Distribution): Relabel mips64el-linux as
> > unsupported.
> > ---
> >
> > As we discussed previously with the powerpc-linux patches, I've gotten
> > around to changing the m4 error to a warning. Also, I didn't change
> > i586-gnu to say unsupported next to it in GNU Distribution in the
> > manual, although I suppose the other option would be to add i586-gnu to
> > supported in m4/guix.m4.
>
> Yes, I’d rather mark i586-gnu as supported in m4/guix.m4 (it should have
> been the case long ago) and keep the error and ‘--with-courage’ flag.
>
> WDYT?

I'm OK with changing i586-gnu to supported in m4/guix.m4. However, part
of the plan was to make it so that we didn't have to have the
--with-courage flag when building for mips64el, and so we could remove
powerpc-linux so it would also say that it is unsupported but we
wouldn't need people to make special versions of the guix package so
they can try to build it. I can make it bigger and flashier, so it looks
more like

****************************************

WARNING: YOU ARE ATTEMPTING TO BUILD GUIX ON AN UNSUPPORTED PLATFORM!
PROCEED AT YOUR OWN RISK!!! YOU HAVE BEEN WARNED! HERE BE DRAGONS!!!!

****************************************

Toggle quote (12 lines)
> > -@item mips64el-linux (deprecated)
> > +@item mips64el-linux (unsupported)
>
> Good idea. :-)
>
> Thanks!
>
> Ludo’.
>
>
>

--
Efraim Flashner <efraim@flashner.co.il> ????? ?????
GPG key = A28B F40C 3E55 1372 662D 14F7 41AA E7DC CA3D 8351
Confidentiality cannot be guaranteed on emails sent or received unencrypted
-----BEGIN PGP SIGNATURE-----

iQIzBAABCgAdFiEEoov0DD5VE3JmLRT3Qarn3Mo9g1EFAmFrzsgACgkQQarn3Mo9
g1FRCg//ZtuKj6NlO+HMxpk01QnWv81e20LXwwV+y2v4j/84DzdfElxeGPGJz5C/
Wqy4kFSl+FyUCdrW7UkSjuYtnN0YCHSZ3CS+J3KXl7Hvs2rK0aBE4I1sEmqQH+MA
kRvTLVQXpVibTLt+DoTwLAh7kvqD40hvhbzvCgISVhVS5qLHbKcRPmLl/SdrQIY/
JoAlsrFHj+86uhY911tgHDHQvMwaWwtrz1fulpwA8dau8o2x+B7dw3O++7Cer0EA
V5fPAMV0xy1kOeg7aJU98H/F+P4j5ccPHXBy6bDTodS6klsL10ar2Dcg/NOE91rR
/ndzINUB4Kvc7lidmSzgVEXg+piLuKqsA4SFAyV1hvmGvd8F9LyqJ6YPtL20Z2wP
wKeeuPtnp5Fx+pDdK7d8mrtN1Cdv4aoAw2E1x2Snx8zuBmyIi8VHo00pIrx0ugBl
VRxzicYJpmCmQ9omxCgLygG/Gw0wtjR8ODGB1H+zpvOT1Nps1BTkrdw21OlUefWE
Sm5biLcEIqIlIdBWxMh2CMp16jrP27Z64FGpLl9w/M5Ksb1OXu+sS8skK80w9mHj
ukgodZ26EMMi96sR6/izmEtHKxUazXFLp0/o1DzVW87MtaqqQQkK+nSw09Kvk+O4
11hGQ3xjmrZ7Q/zcWVXtC0+ILqpSE6q6v0C4+0eEAUUCFCY/nvw=
=4Ku8
-----END PGP SIGNATURE-----


L
L
Ludovic Courtès wrote on 18 Oct 2021 10:43
(name . Efraim Flashner)(address . efraim@flashner.co.il)(address . 50778@debbugs.gnu.org)
87mtn6bu45.fsf@gnu.org
Hello!

Efraim Flashner <efraim@flashner.co.il> skribis:

Toggle quote (2 lines)
> On Wed, Oct 13, 2021 at 11:00:16AM +0200, Ludovic Courtès wrote:

[...]

Toggle quote (13 lines)
>> Yes, I’d rather mark i586-gnu as supported in m4/guix.m4 (it should have
>> been the case long ago) and keep the error and ‘--with-courage’ flag.
>>
>> WDYT?
>
> I'm OK with changing i586-gnu to supported in m4/guix.m4. However, part
> of the plan was to make it so that we didn't have to have the
> --with-courage flag when building for mips64el, and so we could remove
> powerpc-linux so it would also say that it is unsupported but we
> wouldn't need people to make special versions of the guix package so
> they can try to build it. I can make it bigger and flashier, so it looks
> more like

Ah! So I think you’re asking that there be three levels:

1. Fully supported (should include i586-gnu).

2. “Half supported” or “in the works”, like mips64el-linux and
powerpc-linux: in that case, maybe just emit a warning with
AC_MSG_WARN?

3. Unsupported: error asking users to pass ‘--with-courage’.

How does that sound?

Ludo’.
E
E
Efraim Flashner wrote on 18 Oct 2021 14:15
(name . Ludovic Courtès)(address . ludo@gnu.org)(address . 50778@debbugs.gnu.org)
YW1leipsxkUyeWEC@3900XT
On Mon, Oct 18, 2021 at 10:43:54AM +0200, Ludovic Courtès wrote:
Toggle quote (33 lines)
> Hello!
>
> Efraim Flashner <efraim@flashner.co.il> skribis:
>
> > On Wed, Oct 13, 2021 at 11:00:16AM +0200, Ludovic Courtès wrote:
>
> [...]
>
> >> Yes, I’d rather mark i586-gnu as supported in m4/guix.m4 (it should have
> >> been the case long ago) and keep the error and ‘--with-courage’ flag.
> >>
> >> WDYT?
> >
> > I'm OK with changing i586-gnu to supported in m4/guix.m4. However, part
> > of the plan was to make it so that we didn't have to have the
> > --with-courage flag when building for mips64el, and so we could remove
> > powerpc-linux so it would also say that it is unsupported but we
> > wouldn't need people to make special versions of the guix package so
> > they can try to build it. I can make it bigger and flashier, so it looks
> > more like
>
> Ah! So I think you’re asking that there be three levels:
>
> 1. Fully supported (should include i586-gnu).
>
> 2. “Half supported” or “in the works”, like mips64el-linux and
> powerpc-linux: in that case, maybe just emit a warning with
> AC_MSG_WARN?
>
> 3. Unsupported: error asking users to pass ‘--with-courage’.
>
> How does that sound?

I hadn't really planned on keeping the third category, but thinking
about it more it would make sense to keep it for architectures that we
don't even have bootstrap binaries for. Vagrant said he was able to
build the guix package for riscv64-linux, I think without even adding my
patches for adding the bootstrap binaries. By forcing people to pass
--with-courage it goes past "it doesn't really work" and all the way
into "really really unsupported"

So yes, I like the idea of the three levels.

--
Efraim Flashner <efraim@flashner.co.il> ????? ?????
GPG key = A28B F40C 3E55 1372 662D 14F7 41AA E7DC CA3D 8351
Confidentiality cannot be guaranteed on emails sent or received unencrypted
-----BEGIN PGP SIGNATURE-----

iQIzBAABCgAdFiEEoov0DD5VE3JmLRT3Qarn3Mo9g1EFAmFtZXcACgkQQarn3Mo9
g1GaxBAAlocSjXpAKRaRiN1Hk/pcFEjzH6E2Nf5hrv76RbtbzXVEOEr4iGfYSCjV
ZMKmYwPZibXNglzPGguBLXxiPNPu5rllwulnGPR7Ij6Zlww+C0QPjjpj75EHT6TW
j1MZG8s10Zy79QuZ5rhTmJExip7GnQZ/IF1FEXpoxsmmQm42d3UFPOFacB0X+cWW
fmkLOgOCCNne/rUIfdv/tHXtl7scKPNxK6E86Yt2JuY1G6kuVAhdWaaG8vKmTOpA
hL1moXx9pEhq+oZWwyRO58qwKbsDA/j+S1yX0WGPe96OWikkchBghqBWi9ou20JQ
0Ixbzld5NGE4LE3p6flCF4mu9syG/FTGDkIBMb0fhD9tTD+cYcGgZfhCnibbHw/i
/iadjGUslhqwBN13BVvcvbag7Pt/AyTy26FQQmXxSfMsUFitnP4IwK8IZ3C6pW8U
03obQOEWYKUvpPz83j3E0w0pJjYrahMuwPO6UhJ2lrHID83dHN9QpcL0AStvKZxX
nL/piIALnwSXxVnnUHQmcpmJ3GJQoougCWLMnnE3Yr1X9YE8MIPq7Fermp64TABD
+g9IM96j94mQWQrhReQAme8ETPz2NWXtVw+roMdgSXFEQy1Hpk93xE/cgOtw/QYm
97Cbwtdkhs+lwn+9O2r6+CaUuv1LIaY8f+/Jq2nV8+s/Dzzw7H4=
=hZVP
-----END PGP SIGNATURE-----


L
L
Ludovic Courtès wrote on 19 Oct 2021 12:15
(name . Efraim Flashner)(address . efraim@flashner.co.il)(address . 50778@debbugs.gnu.org)
87k0i99v7u.fsf@gnu.org
Howdy!

Efraim Flashner <efraim@flashner.co.il> skribis:

Toggle quote (2 lines)
> On Mon, Oct 18, 2021 at 10:43:54AM +0200, Ludovic Courtès wrote:

[...]

Toggle quote (22 lines)
>> Ah! So I think you’re asking that there be three levels:
>>
>> 1. Fully supported (should include i586-gnu).
>>
>> 2. “Half supported” or “in the works”, like mips64el-linux and
>> powerpc-linux: in that case, maybe just emit a warning with
>> AC_MSG_WARN?
>>
>> 3. Unsupported: error asking users to pass ‘--with-courage’.
>>
>> How does that sound?
>
> I hadn't really planned on keeping the third category, but thinking
> about it more it would make sense to keep it for architectures that we
> don't even have bootstrap binaries for. Vagrant said he was able to
> build the guix package for riscv64-linux, I think without even adding my
> patches for adding the bootstrap binaries. By forcing people to pass
> --with-courage it goes past "it doesn't really work" and all the way
> into "really really unsupported"
>
> So yes, I like the idea of the three levels.

Alright. Can you send (or push) an updated patch?

Thanks!

Ludo’.
E
E
Efraim Flashner wrote on 14 Dec 2021 17:36
YbjIICzphn2XTdZd@3900XT
Finally took care of this today.

On Mon, Oct 18, 2021 at 03:15:54PM +0300, Efraim Flashner wrote:
Toggle quote (51 lines)
> On Mon, Oct 18, 2021 at 10:43:54AM +0200, Ludovic Courtès wrote:
> > Hello!
> >
> > Efraim Flashner <efraim@flashner.co.il> skribis:
> >
> > > On Wed, Oct 13, 2021 at 11:00:16AM +0200, Ludovic Courtès wrote:
> >
> > [...]
> >
> > >> Yes, I’d rather mark i586-gnu as supported in m4/guix.m4 (it should have
> > >> been the case long ago) and keep the error and ‘--with-courage’ flag.
> > >>
> > >> WDYT?
> > >
> > > I'm OK with changing i586-gnu to supported in m4/guix.m4. However, part
> > > of the plan was to make it so that we didn't have to have the
> > > --with-courage flag when building for mips64el, and so we could remove
> > > powerpc-linux so it would also say that it is unsupported but we
> > > wouldn't need people to make special versions of the guix package so
> > > they can try to build it. I can make it bigger and flashier, so it looks
> > > more like
> >
> > Ah! So I think you’re asking that there be three levels:
> >
> > 1. Fully supported (should include i586-gnu).
> >
> > 2. “Half supported” or “in the works”, like mips64el-linux and
> > powerpc-linux: in that case, maybe just emit a warning with
> > AC_MSG_WARN?
> >
> > 3. Unsupported: error asking users to pass ‘--with-courage’.
> >
> > How does that sound?
>
> I hadn't really planned on keeping the third category, but thinking
> about it more it would make sense to keep it for architectures that we
> don't even have bootstrap binaries for. Vagrant said he was able to
> build the guix package for riscv64-linux, I think without even adding my
> patches for adding the bootstrap binaries. By forcing people to pass
> --with-courage it goes past "it doesn't really work" and all the way
> into "really really unsupported"
>
> So yes, I like the idea of the three levels.
>
> --
> Efraim Flashner <efraim@flashner.co.il> ????? ?????
> GPG key = A28B F40C 3E55 1372 662D 14F7 41AA E7DC CA3D 8351
> Confidentiality cannot be guaranteed on emails sent or received unencrypted



--
Efraim Flashner <efraim@flashner.co.il> ????? ?????
GPG key = A28B F40C 3E55 1372 662D 14F7 41AA E7DC CA3D 8351
Confidentiality cannot be guaranteed on emails sent or received unencrypted
-----BEGIN PGP SIGNATURE-----

iQIzBAABCgAdFiEEoov0DD5VE3JmLRT3Qarn3Mo9g1EFAmG4yB8ACgkQQarn3Mo9
g1EDzRAAg/xvpOzoNhO/cJhAGk1Z2tckYJNPVtEo5K5noP3UidobhGPyqKs+u/F6
OGAvBu+D/p13QR6E3ZBXhzPRAoRQqTPfui+SPf63FQ+AJKXgN7WtpBdQgHUdE5UE
BtLqUUJN5PHW2OY2oBHVXCWhZnf7uyOFDimcqw2S0rBHgtpuK0wcCex0xqmLEZ01
yjEHrwyVNPT/OowZ/j0jSsWuZeqZqlySKCtRftyNx89j2XxnjMScw6c8uORJ6na/
iVN489wQ2gdwfEX/wf2uP4XYQPs+Lk0FBYGSy53OZElJRo87M7xoiPXLeyf1OKIG
rfnE33mnORPbvKoeQip+UqJRsr6KEPOS/4fcDQUIgLTdZRFVa/Tf/8wAFn4e+TDQ
5Z1VsmPgNkCccPB2IAddfDQx4WhQMz5jRSzXqi04L8+NE52k9GN7Iwlt3c2mwLk8
GvAV+Eq7mpwZCc4nGQ6Zu2yjEHrD6+bAGYi1QTo6jSqrO03EUcPYr5qt5Z2lLNdf
FFnAjLxFpK54KUybA2Ehq07EnP8uIW4i3BeU45s5wQHM8oh4bbkvnSP16e9sh2sF
1WUX8xgzFhbrPeZFpS0aJKKok4M4TQUezA9F13pszfAlpcuJXFgNqlgwGE3/wqIF
GNv4NTeWEqNP81EqjkbokLBZTjMFWKv6arIcTe04j7mxvC5c71k=
=SmXz
-----END PGP SIGNATURE-----


Closed
?