GtkSourceView

  • Done
  • quality assurance status badge
Details
2 participants
  • Maxime Devos
  • Raghav Gururajan
Owner
unassigned
Submitted by
Raghav Gururajan
Severity
normal
R
R
R
Raghav Gururajan wrote on 7 Sep 2021 03:02
[PATCHES wip-gnome v1 1/4] gnu: gtksourceview: Update to 4.8.1 and change build-system.
(address . 50445@debbugs.gnu.org)(name . Raghav Gururajan)(address . rg@raghavgururajan.name)
20210907010217.12746-1-rg@raghavgururajan.name
* gnu/packages/gtk.scm (gtksourceview)[version]: Update to 4.8.1.
[build-system]: Change from gnu to meson.
---
gnu/packages/gtk.scm | 6 +++---
1 file changed, 3 insertions(+), 3 deletions(-)

Toggle diff (26 lines)
diff --git a/gnu/packages/gtk.scm b/gnu/packages/gtk.scm
index 1bdd6a2ac0..b05529ac98 100644
--- a/gnu/packages/gtk.scm
+++ b/gnu/packages/gtk.scm
@@ -538,7 +538,7 @@ printing and other features typical of a source code editor.")
(define-public gtksourceview
(package
(name "gtksourceview")
- (version "4.2.0")
+ (version "4.8.1")
(source (origin
(method url-fetch)
(uri (string-append "mirror://gnome/sources/gtksourceview/"
@@ -546,8 +546,8 @@ printing and other features typical of a source code editor.")
"gtksourceview-" version ".tar.xz"))
(sha256
(base32
- "0xgnjj7jd56wbl99s76sa1vjq9bkz4mdsxwgwlcphg689liyncf4"))))
- (build-system gnu-build-system)
+ "1hcswszqnsyqzzf5zk8iflxdvkfvvcg89pf6xsqwbyyabwdxfqyi"))))
+ (build-system meson-build-system)
(arguments
'(#:phases
(modify-phases %standard-phases
--
2.33.0
R
R
Raghav Gururajan wrote on 7 Sep 2021 03:02
[PATCHES wip-gnome v1 2/4] gnu: gtksourceview: Add missing input as per pkg-config file.
(address . 50445@debbugs.gnu.org)(name . Raghav Gururajan)(address . rg@raghavgururajan.name)
20210907010217.12746-2-rg@raghavgururajan.name
* gnu/packages/gtk.scm (gtksourceview)[propagated-inputs]: Add fribidi.
---
gnu/packages/gtk.scm | 3 ++-
1 file changed, 2 insertions(+), 1 deletion(-)

Toggle diff (16 lines)
diff --git a/gnu/packages/gtk.scm b/gnu/packages/gtk.scm
index b05529ac98..fa3a69d46d 100644
--- a/gnu/packages/gtk.scm
+++ b/gnu/packages/gtk.scm
@@ -573,7 +573,8 @@ printing and other features typical of a source code editor.")
("shared-mime-info" ,shared-mime-info)))
(propagated-inputs
;; gtksourceview-3.0.pc refers to all these.
- `(("glib" ,glib)
+ `(("fribidi" ,fribidi)
+ ("glib" ,glib)
("gtk+" ,gtk+)
("libxml2" ,libxml2)))
(home-page "https://wiki.gnome.org/Projects/GtkSourceView")
--
2.33.0
R
R
Raghav Gururajan wrote on 7 Sep 2021 03:02
[PATCHES wip-gnome v1 3/4] gnu: gtksourceview: Enable documentation.
(address . 50445@debbugs.gnu.org)(name . Raghav Gururajan)(address . rg@raghavgururajan.name)
20210907010217.12746-3-rg@raghavgururajan.name
* gnu/packages/gtk.scm (gtksourceview)[outputs]: New output "doc".
[configure-flags](gtk-doc): New flag.
[phases](patch-docbook-xml,move-doc): New phases.
[native-inputs]: Add docbook-xml-4.3, docbook-xsl, gtk-doc and libxslt.
---
gnu/packages/gtk.scm | 33 ++++++++++++++++++++++++++++++---
1 file changed, 30 insertions(+), 3 deletions(-)

Toggle diff (59 lines)
diff --git a/gnu/packages/gtk.scm b/gnu/packages/gtk.scm
index fa3a69d46d..0a80671629 100644
--- a/gnu/packages/gtk.scm
+++ b/gnu/packages/gtk.scm
@@ -548,9 +548,24 @@ printing and other features typical of a source code editor.")
(base32
"1hcswszqnsyqzzf5zk8iflxdvkfvvcg89pf6xsqwbyyabwdxfqyi"))))
(build-system meson-build-system)
+ (outputs '("out" "doc"))
(arguments
- '(#:phases
+ `(#:configure-flags
+ (list
+ ,@(if (%current-target-system)
+ ;; If true, gtkdoc-scangobj will try to execute a
+ ;; cross-compiled binary.
+ '("-Dgtk_doc=false")
+ '("-Dgtk_doc=true")))
+ #:phases
(modify-phases %standard-phases
+ (add-after 'unpack 'patch-docbook-xml
+ (lambda* (#:key inputs native-inputs outputs #:allow-other-keys)
+ (substitute* (find-files "docs" "\\.xml\\.in$")
+ (("http://www.oasis-open.org/docbook/xml/4.3/")
+ (string-append
+ (assoc-ref (or native-inputs inputs) "docbook-xml-4.3")
+ "/xml/dtd/docbook/")))))
(add-before
'check 'pre-check
(lambda* (#:key inputs #:allow-other-keys)
@@ -560,12 +575,24 @@ printing and other features typical of a source code editor.")
(setenv "DISPLAY" ":1")
;; For the missing /etc/machine-id.
(setenv "DBUS_FATAL_WARNINGS" "0")
- #t))))))
+ #t)))
+ (add-after 'install 'move-doc
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let* ((out (assoc-ref outputs "out"))
+ (doc (assoc-ref outputs "doc")))
+ (mkdir-p (string-append doc "/share/gtk-doc"))
+ (rename-file
+ (string-append out "/share/gtk-doc")
+ (string-append doc "/share/gtk-doc"))))))))
(native-inputs
- `(("glib:bin" ,glib "bin") ; for glib-genmarshal, etc.
+ `(("docbook-xml-4.3" ,docbook-xml-4.3)
+ ("docbook-xsl" ,docbook-xsl)
+ ("glib:bin" ,glib "bin") ; for glib-genmarshal, etc.
+ ("gtk-doc" ,gtk-doc)
("intltool" ,intltool)
("itstool" ,itstool)
("gobject-introspection" ,gobject-introspection)
+ ("libxslt" ,libxslt)
("pkg-config" ,pkg-config)
("vala" ,vala)
;; For testing.
--
2.33.0
R
R
Raghav Gururajan wrote on 7 Sep 2021 03:02
[PATCHES wip-gnome v1 4/4] gnu: gtksourceview@3: Adjust inherited fields and update to 3.24.11.
(address . 50445@debbugs.gnu.org)(name . Raghav Gururajan)(address . rg@raghavgururajan.name)
20210907010217.12746-4-rg@raghavgururajan.name
* gnu/packages/gtk.scm (gtksourceview-3)[version]: Update to 3.24.11.
[build-system]: New field.
[arguments]: New field.
---
gnu/packages/gtk.scm | 36 ++++++++++++++++++++++++++++++++++--
1 file changed, 34 insertions(+), 2 deletions(-)

Toggle diff (56 lines)
diff --git a/gnu/packages/gtk.scm b/gnu/packages/gtk.scm
index 0a80671629..c12ac512bc 100644
--- a/gnu/packages/gtk.scm
+++ b/gnu/packages/gtk.scm
@@ -614,7 +614,7 @@ highlighting and other features typical of a source code editor.")
(define-public gtksourceview-3
(package (inherit gtksourceview)
(name "gtksourceview")
- (version "3.24.10")
+ (version "3.24.11")
(source (origin
(method url-fetch)
(uri (string-append "mirror://gnome/sources/" name "/"
@@ -622,7 +622,39 @@ highlighting and other features typical of a source code editor.")
name "-" version ".tar.xz"))
(sha256
(base32
- "16ym7jwiki4s1pilwr4incx0yg7ll94f1cajrnpndkxxs36hcm5b"))))))
+ "1zbpj283b5ycz767hqz5kdq02wzsga65pp4fykvhg8xj6x50f6v9"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:configure-flags
+ (list
+ ,@(if (%current-target-system)
+ ;; If true, gtkdoc-scangobj will try to execute a
+ ;; cross-compiled binary.
+ '("--disable-gtk-doc")
+ '("--enable-gtk-doc"))
+ (string-append "--with-html-dir="
+ (assoc-ref %outputs "doc")
+ "/share/gtk-doc/html"))
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'patch-docbook-xml
+ (lambda* (#:key inputs native-inputs outputs #:allow-other-keys)
+ (substitute* (find-files "docs" "\\.xml\\.in$")
+ (("http://www.oasis-open.org/docbook/xml/4.3/")
+ (string-append
+ (assoc-ref (or native-inputs inputs) "docbook-xml-4.3")
+ "/xml/dtd/docbook/")))))
+ (add-before 'check 'pre-check
+ (lambda _
+ ;; Tests require a running X server.
+ (system "Xvfb :1 +extension GLX &")
+ (setenv "DISPLAY" ":1")
+ ;; Tests write to $HOME.
+ (setenv "HOME" (getcwd))
+ ;; Tests look for $XDG_RUNTIME_DIR.
+ (setenv "XDG_RUNTIME_DIR" (getcwd))
+ ;; For missing '/etc/machine-id'.
+ (setenv "DBUS_FATAL_WARNINGS" "0"))))))))
(define-public gdk-pixbuf
(package
--
2.33.0
M
M
Maxime Devos wrote on 7 Sep 2021 16:05
Re: [bug#50445] [PATCHES wip-gnome v1 3/4] gnu: gtksourceview: Enable documentation.
e9416b8ac0e7a58ab3de57b9bb94bc17d017718d.camel@telenet.be
Hi,

Toggle quote (9 lines)
> - '(#:phases
> + `(#:configure-flags
> + (list
> + ,@(if (%current-target-system)
> + ;; If true, gtkdoc-scangobj will try to execute a
> + ;; cross-compiled binary.
> + '("-Dgtk_doc=false")
> + '("-Dgtk_doc=true")))

These two lines above need to be indented.

Otherwise, this patch series looks good to me, but I didn't test it.

Greetings,
Maxime.
-----BEGIN PGP SIGNATURE-----

iI0EABYKADUWIQTB8z7iDFKP233XAR9J4+4iGRcl7gUCYTdxjxccbWF4aW1lZGV2
b3NAdGVsZW5ldC5iZQAKCRBJ4+4iGRcl7rNyAP47ubJYbBwWItA3AiqmxaIrK0/A
IqJh2YNvk3AtVpBDswEA3n3fuv4XfBe0rLIiMRvS+re/0a5Pqnltu5B4Wwye6A4=
=E2bo
-----END PGP SIGNATURE-----


R
R
Raghav Gururajan wrote on 7 Sep 2021 21:21
38c046cb-67f2-baaa-01b7-faeb500befdf@raghavgururajan.name
Hi Maxime!

Toggle quote (4 lines)
> These two lines above need to be indented.
>
> Otherwise, this patch series looks good to me, but I didn't test it.

Thanks.

Regards,
RG.
Attachment: OpenPGP_signature
R
Closed
?