[PATCH 1/2] gnu: Add node-irc-colors.

  • Done
  • quality assurance status badge
Details
2 participants
  • Efraim Flashner
  • Ron Nazarov
Owner
unassigned
Submitted by
Ron Nazarov
Severity
normal
R
R
Ron Nazarov wrote on 29 Aug 2021 21:39
(address . guix-patches@gnu.org)(name . Ron Nazarov)(address . noisytoot@disroot.org)
20210829193930.8890-1-noisytoot@disroot.org
* gnu/packages/node-xyz.scm (node-irc-colors): New variable.
---
gnu/packages/node-xyz.scm | 29 +++++++++++++++++++++++++++++
1 file changed, 29 insertions(+)

Toggle diff (39 lines)
diff --git a/gnu/packages/node-xyz.scm b/gnu/packages/node-xyz.scm
index cbb68f77d6..7339970f68 100644
--- a/gnu/packages/node-xyz.scm
+++ b/gnu/packages/node-xyz.scm
@@ -357,3 +357,32 @@ function with browser support.")
Subsequent calls will either return the cached previous value or throw an error
if desired.")
(license license:isc)))
+
+(define-public node-irc-colors
+ (package
+ (name "node-irc-colors")
+ (version "1.5.0")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/fent/irc-colors.js")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0q3y34rbnlc55jcakmdxkicwazyvyph9r6gaf6hi8k7wj2nfwfli"))))
+ (build-system node-build-system)
+ (arguments
+ '(#:tests? #f ; FIXME: tests depend on node-istanbul
+ #:phases
+ (modify-phases %standard-phases
+ ;; The default configure phase fails due to various packages
+ ;; being missing, as we don't have them packaged yet.
+ (delete 'configure))))
+ (home-page "https://github.com/fent/irc-colors.js")
+ (synopsis "Node.js module providing color and formatting for IRC")
+ (description "@code{node-irc-colors} is a Node.js module that
+allows you to easily use colored output and formatting in IRC bots.
+It contains functions for colours as well as more complex formatting
+such as rainbows.")
+ (license license:expat)))
--
2.33.0
R
R
Ron Nazarov wrote on 29 Aug 2021 21:41
[PATCH 2/2] gnu: Add node-irc.
(address . 50257@debbugs.gnu.org)(name . Ron Nazarov)(address . noisytoot@disroot.org)
20210829194152.9298-1-noisytoot@disroot.org
* gnu/packages/node-xyz.scm (node-irc): New variable.
---
gnu/packages/node-xyz.scm | 29 +++++++++++++++++++++++++++++
1 file changed, 29 insertions(+)

Toggle diff (39 lines)
diff --git a/gnu/packages/node-xyz.scm b/gnu/packages/node-xyz.scm
index 7339970f68..2b8fe036f8 100644
--- a/gnu/packages/node-xyz.scm
+++ b/gnu/packages/node-xyz.scm
@@ -386,3 +386,32 @@ allows you to easily use colored output and formatting in IRC bots.
It contains functions for colours as well as more complex formatting
such as rainbows.")
(license license:expat)))
+
+(define-public node-irc
+ (package
+ (name "node-irc")
+ (version "0.5.2")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/martynsmith/node-irc")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1ln4qfx20jbwg4cp8lp0vf27m5281z2sz16d15xd6150n26cbi4x"))))
+ (build-system node-build-system)
+ (arguments
+ '(#:tests? #f ; FIXME: tests depend on node-faucet
+ #:phases
+ (modify-phases %standard-phases
+ ;; The default configure phase fails due to various packages
+ ;; being missing, as we don't have them packaged yet.
+ (delete 'configure))))
+ (inputs
+ `(("node-irc-colors" ,node-irc-colors)))
+ (home-page "https://github.com/martynsmith/node-irc")
+ (synopsis "IRC client library for Node.js")
+ (description "@code{node-irc} is an IRC client library for Node.js.
+It has functions for joining, parting, talking, and many other IRC commands.")
+ (license license:gpl3+)))
--
2.33.0
E
E
Efraim Flashner wrote on 23 Sep 2021 09:49
Re: [bug#50257] [PATCH 1/2] gnu: Add node-irc-colors.
(name . Ron Nazarov)(address . noisytoot@disroot.org)(address . 50257-done@debbugs.gnu.org)
YUwxjil78E9H4gQ4@3900XT
Thanks. Patches pushed.

--
Efraim Flashner <efraim@flashner.co.il> ????? ?????
GPG key = A28B F40C 3E55 1372 662D 14F7 41AA E7DC CA3D 8351
Confidentiality cannot be guaranteed on emails sent or received unencrypted
-----BEGIN PGP SIGNATURE-----

iQIzBAABCgAdFiEEoov0DD5VE3JmLRT3Qarn3Mo9g1EFAmFMMY4ACgkQQarn3Mo9
g1FSVA/+IcTG2FvRfXA7h3Pr8XrGS92Jl0dnIp1gs4rqJlOdAz+CcV2lLnUR27bk
Ilw7YdC6XRktcW0B3ZqEpNIaTrLtN4ISMdn7vigZFxMPa0jKH58Cc95EPjPZ/bB+
uzQQn6p71bMgI60h3eeHRkzh8Xxowp4P1qKc/obhKWqiGr22MD7bucofsV1SRNdW
ulVC7n+nGTk5Qf/qbL0ErwWzPJhpnDNyCFUg6ALvgZcWfc5jgosVnBDsOdRR5jP9
YYcoDikj7SDFU6GJ2hTRJbw2cce3HYRTGI7t/JlbggHQoIZ3nvhJMJmjr/Hmtzz1
L3bKo1bk8mU560fUrovZ7g4Qmd0ae26XFKXrhMgmBBVOMAEcKXi0dJBSDQjX68xQ
g39SBgFO7mCVKhexCT1Hlj8LOWPc3e2J1KKSoBB9rWPvQgBcKWAOuS/CD3RcIXcp
t3lXhi3+LfmcF1D+woT2GC5CJZbVddst6lvORkR1/4K/PqPTXIDYv4yGu/furhpR
YnbjdPoPbFBfCjoLspG7n1IVsQiAYrOdRWnkAiRmvx5FrYoxO8BTDVb9AzDsUvwY
lD7euIUN2+a9PnrRyLSs1OQhlB3h9Ga7uHqcGdiYNgxJSeasHMfWIxkXs+2rNS1c
LnJatB79yT4EKnS9Whmj/WcpWxRq/ZCvffjZXv89N2OyDvzkVJY=
=54Jo
-----END PGP SIGNATURE-----


Closed
?