[PATCH 1/3] gnu: go-torproject-org-pluggable-transports-goptlib: Fix import path.

  • Done
  • quality assurance status badge
Details
2 participants
  • Sarah Morgensen
  • Sharlatan Hellseher
Owner
unassigned
Submitted by
Sarah Morgensen
Severity
normal
S
S
Sarah Morgensen wrote on 10 Aug 2021 23:07
(address . guix-patches@gnu.org)
8f8a2f210151bdeb437bb3a12b67f43c76286aa4.1628629367.git.iskarian@mgsn.dev
* gnu/packages/golang.scm (go-torproject-org-pluggable-transports-goptlib)
[arguments]<#:import-path>: Use actual module name from go.mod.
---
Hello Guix,

Just a little fix for this import path, so dependents don't have to patch its
name.

Tested to build on x86_64, which since this is just a change in import path
name, should have caught any issues.

--
Sarah
gnu/packages/golang.scm | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)

Toggle diff (17 lines)
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 15f3ea46c4..ca029345e2 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -822,7 +822,7 @@ parsing and encoding support for STUN and TURN protocols.")
(base32 "1lh938194hvkf8pqgnxwf6hvjv9rv0j3kasi07r2ckrj8sxzk4jc"))))
(build-system go-build-system)
(arguments
- `(#:import-path "git.torproject.org/pluggable-transports/goptlib"))
+ `(#:import-path "git.torproject.org/pluggable-transports/goptlib.git"))
(home-page "https://gitweb.torproject.org/pluggable-transports/goptlib.git/")
(synopsis "Go pluggable transports library")
(description "GoPtLib is a library for writing Tor pluggable transports in

base-commit: c8e2be3b32fe784a9db52d8a1a12902ab12ae7cb
--
2.31.1
S
S
Sarah Morgensen wrote on 10 Aug 2021 23:10
[PATCH 2/3] gnu: go-github-com-operatorfoundation-shapeshifter-transports: Remove goptlib patch.
(address . 49989@debbugs.gnu.org)
f7039c390b695c0bf076bb1caeca3ecd16ff7d24.1628629367.git.iskarian@mgsn.dev
* gnu/packages/golang.scm (go-github-com-operatorfoundation-shapeshifter-transports)
[arguments]<#:phases>: Remove obsolete 'patch' phase for goptlib.
---
gnu/packages/golang.scm | 5 -----
1 file changed, 5 deletions(-)

Toggle diff (18 lines)
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index ca029345e2..166f578ee8 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -127,11 +127,6 @@ filtering devices.")
`(#:unpack-path "github.com/OperatorFoundation/shapeshifter-transports"
#:phases
(modify-phases %standard-phases
- (add-after 'unpack 'patch
- (lambda _
- (substitute* (find-files "." "\\.go$")
- ;; To drop '.git' suffix in import path of goptlib.
- (("goptlib\\.git") "goptlib"))))
(replace 'build
(lambda arguments
(for-each
--
2.31.1
S
S
Sarah Morgensen wrote on 10 Aug 2021 23:10
[PATCH 3/3] gnu: go-github-com-operatorfoundation-obfs4: Remove goptlib patch.
(address . 49989@debbugs.gnu.org)
60046061358961a17be6db7787648653358a6ef7.1628629367.git.iskarian@mgsn.dev
* gnu/packages/golang.scm (go-github-com-operatorfoundation-obfs4)
[arguments]<#:phases>: Remove obsolete 'patch' phase for goptlib.
---
gnu/packages/golang.scm | 5 -----
1 file changed, 5 deletions(-)

Toggle diff (18 lines)
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 166f578ee8..9d49a3130e 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -666,11 +666,6 @@ protocol from the Pluggable Transports 2.0 specification.")
`(#:unpack-path "github.com/OperatorFoundation/obfs4"
#:phases
(modify-phases %standard-phases
- (add-after 'unpack 'patch
- (lambda _
- (substitute* (find-files "." "\\.go$")
- ;; To drop '.git' suffix in import path of goptlib.
- (("goptlib\\.git") "goptlib"))))
(replace 'build
(lambda arguments
(for-each
--
2.31.1
S
S
Sarah Morgensen wrote on 13 Aug 2021 06:37
[PATCH v2] gnu: go-torproject-org-pluggable-transports-goptlib: Fix import path.
(address . 49989@debbugs.gnu.org)
ee0f780a53c9888f85cebc76d6c8cf8e0264a91b.1628829129.git.iskarian@mgsn.dev
* gnu/packages/golang.scm (go-torproject-org-pluggable-transports-goptlib)
[arguments]<#:import-path>: Use actual module name from go.mod.
(go-github-com-operatorfoundation-shapeshifter-transports)[arguments]
<#:phases>: Remove obsolete 'patch phase for goptlib.
(go-github-com-operatorfoundation-obfs4)[arguments]<#:phases>: Likewise.
---
Since it will break builds if these are applied separately, I went ahead and
merged these into one commit.

gnu/packages/golang.scm | 12 +-----------
1 file changed, 1 insertion(+), 11 deletions(-)

Toggle diff (41 lines)
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index f4cd30c662..20c8a519dc 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -661,11 +661,6 @@ filtering devices.")
`(#:unpack-path "github.com/OperatorFoundation/shapeshifter-transports"
#:phases
(modify-phases %standard-phases
- (add-after 'unpack 'patch
- (lambda _
- (substitute* (find-files "." "\\.go$")
- ;; To drop '.git' suffix in import path of goptlib.
- (("goptlib\\.git") "goptlib"))))
(replace 'build
(lambda arguments
(for-each
@@ -1205,11 +1200,6 @@ protocol from the Pluggable Transports 2.0 specification.")
`(#:unpack-path "github.com/OperatorFoundation/obfs4"
#:phases
(modify-phases %standard-phases
- (add-after 'unpack 'patch
- (lambda _
- (substitute* (find-files "." "\\.go$")
- ;; To drop '.git' suffix in import path of goptlib.
- (("goptlib\\.git") "goptlib"))))
(replace 'build
(lambda arguments
(for-each
@@ -1356,7 +1346,7 @@ parsing and encoding support for STUN and TURN protocols.")
(base32 "1lh938194hvkf8pqgnxwf6hvjv9rv0j3kasi07r2ckrj8sxzk4jc"))))
(build-system go-build-system)
(arguments
- `(#:import-path "git.torproject.org/pluggable-transports/goptlib"))
+ `(#:import-path "git.torproject.org/pluggable-transports/goptlib.git"))
(home-page "https://gitweb.torproject.org/pluggable-transports/goptlib.git/")
(synopsis "Go pluggable transports library")
(description "GoPtLib is a library for writing Tor pluggable transports in

base-commit: d87d6d68128c53a95fe09c3a4381575646c0f368
--
2.31.1
S
S
Sharlatan Hellseher wrote on 31 Jan 21:23 +0100
[PATCH 1/3] gnu: go-torproject-org-pluggable-transports-goptlib: Fix import path.
(address . 49989-done@debbugs.gnu.org)
87plxhs14f.fsf@gmail.com
Hi,

Pushed v2 as 849f219b72b5638b6abaf7d143654976ad99042e to master.

Thanks,
Oleg
-----BEGIN PGP SIGNATURE-----

iQIzBAEBCgAdFiEEmEeB3micIcJkGAhndtcnv/Ys0rUFAmW6rFAACgkQdtcnv/Ys
0rUKzhAA0YHlZ6/7krkxoYkZHVYG8fNJxwENkDz3rM5T7ACwFDXMcoPSyh8M4IOr
jsDt01NP9yQU2qbKVIpzeklWwKvyKOr++R4fI8QoZeYz24LL0z+VLgSguLQKF5LY
egpbdYsigX+zIu8YN72q70+FW4rfGA7cCmpF6mmy8sPTmRhAtZrtSdUoP9cjXYDy
LlkkDQh21FD8IfmupI6USmoKh7zOZooAZBLsDm5qqstdPHwLz2FmW4ypCSgvECNN
JAjGZeRJ70q7TMLzXvBodnQlafgW5VWoBhBbhOnyihwCH+06K8yJSvj7X29DN8Jv
MmmrmJR+rREH3iJv7ODET8oYNrK6yClGnF8rdhzVkgB1RjekH8FG5YPweuPOblRe
8TdOxtIGn2llv2fiV55MQtU8PWzdJaKsSWD5B4UHW8EnEIXBy+cXuZ6zADAtZk/f
L5EcuJdsemE+GAHLP/gFW4lTinA6Z0MS1ddsKN92MbRvhESdaXkqlTJN4/2fKbTT
QCxrDMzU9rjWvnU8+qW/9TGjuNzhUE6a32Tlpp0EBdX/xJEKP/stoaOgYIUiGGjP
bH7DcSwTNVybDZ9hIzmua4tnEakQfZvOreHu9brPq9VEK63zRxG9OX7YSvbseMFX
c7V4+e+oH9jO4iXaZmZWxTDMBtkU+iUUzw9rxURGbw0jTDV3UaQ=
=jydW
-----END PGP SIGNATURE-----

Closed
?