[PATCH 1/3] gnu: go-github-com-mattn-go-shellwords: Update to 1.0.12.

  • Done
  • quality assurance status badge
Details
2 participants
  • Sarah Morgensen
  • Sharlatan Hellseher
Owner
unassigned
Submitted by
Sarah Morgensen
Severity
normal
S
S
Sarah Morgensen wrote on 6 Aug 2021 20:55
(address . guix-patches@gnu.org)
38f52b13a45c8e0792433861748499f1f5638cf7.1628275842.git.iskarian@mgsn.dev
* gnu/packages/golang.scm (go-github-com-mattn-go-shellwords): Update to 1.0.12.
---
Hello Guix,

I came across this package in my codebase travels; I've updated it and
re-enabled tests.

I verified that dependents go-github-com-junegunn-fzf@0.25.0 and ytfzf@1.2.0
build on x86-64.

--
Sarah
gnu/packages/golang.scm | 71 ++++++++++++++++++++---------------------
1 file changed, 34 insertions(+), 37 deletions(-)

Toggle diff (91 lines)
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 15f3ea46c4..c32324f235 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -5257,48 +5257,45 @@ systems.")
(license license:expat))))
(define-public go-github-com-mattn-go-shellwords
- (let ((commit "2444a32a19f450fabaa0bb3e96a703f15d9a97d2")
- (version "1.0.5")
- (revision "1"))
- (package
- (name "go-github-com-mattn-go-shellwords")
- (version (git-version version revision commit))
- (source
- (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/mattn/go-shellwords")
- (commit commit)))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "08zcgr1az1n8zaxzwdd205j86hczgyc52nxfnw5avpw7rrkf7v0d"))))
- (build-system go-build-system)
- (arguments
- `(#:import-path "github.com/mattn/go-shellwords"
- ;; TODO: can't make homeless-shelter:
- ;; go: disabling cache (/homeless-shelter/.cache/go-build) due to
- ;; initialization failure: mkdir /homeless-shelter: permission denied
+ (package
+ (name "go-github-com-mattn-go-shellwords")
+ (version "1.0.12")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/mattn/go-shellwords")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0l0l5s4hlsrm4z6hygig2pp1qirk5ycrzn9z27ay3yvg9k7zafzx"))))
+ (build-system go-build-system)
+ (arguments
+ `(#:import-path "github.com/mattn/go-shellwords"
+ ;; TODO: can't make homeless-shelter:
+ ;; go: disabling cache (/homeless-shelter/.cache/go-build) due to
+ ;; initialization failure: mkdir /homeless-shelter: permission denied
- ;; This doesn't seem to work:
+ ;; This doesn't seem to work:
- ;; #:phases
- ;; (modify-phases %standard-phases
- ;; (replace 'check
- ;; (lambda* (#:key import-path #:allow-other-keys)
- ;; (setenv "HOME" "/tmp")
- ;; (invoke "go" "test" import-path))))
+ ;; #:phases
+ ;; (modify-phases %standard-phases
+ ;; (replace 'check
+ ;; (lambda* (#:key import-path #:allow-other-keys)
+ ;; (setenv "HOME" "/tmp")
+ ;; (invoke "go" "test" import-path))))
- ;; TODO: There are also a couple of tests that have stymied Debian in
- ;; the past. They seem to work when run locally.
+ ;; TODO: There are also a couple of tests that have stymied Debian in
+ ;; the past. They seem to work when run locally.
- #:tests? #f
- ))
- (home-page "https://github.com/mattn/go-shellwords")
- (synopsis "Parse lines into shell words")
- (description "This package parses text into shell arguments. Based on
+ #:tests? #f
+ ))
+ (home-page "https://github.com/mattn/go-shellwords")
+ (synopsis "Parse lines into shell words")
+ (description "This package parses text into shell arguments. Based on
the @code{cpan} module @code{Parse::CommandLine}.")
- (license license:expat))))
+ (license license:expat)))
(define-public go-github-com-burntsushi-locker
(let ((commit "a6e239ea1c69bff1cfdb20c4b73dadf52f784b6a")

base-commit: c8e2be3b32fe784a9db52d8a1a12902ab12ae7cb
--
2.31.1
S
S
Sarah Morgensen wrote on 6 Aug 2021 20:57
[PATCH 2/3] gnu: go-github-com-mattn-go-shellwords: Fix sh path.
(address . 49915@debbugs.gnu.org)
291625dd0fc68e516af6d6707fe37ab6f8c86b6c.1628275842.git.iskarian@mgsn.dev
* gnu/packages/golang.scm (go-github-com-mattn-go-shellwords)[arguments]
<#:phases>{patch-sh-path}: New phase.
[inputs]: Add bash.
---
gnu/packages/golang.scm | 25 ++++++++-----------------
1 file changed, 8 insertions(+), 17 deletions(-)

Toggle diff (46 lines)
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index c32324f235..b46f9e9bbf 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -58,6 +58,7 @@
#:use-module (gnu packages)
#:use-module (gnu packages admin)
#:use-module (gnu packages base)
+ #:use-module (gnu packages bash)
#:use-module ((gnu packages bootstrap) #:select (glibc-dynamic-linker))
#:use-module (gnu packages gcc)
#:use-module (gnu packages glib)
@@ -5273,24 +5274,14 @@ systems.")
(build-system go-build-system)
(arguments
`(#:import-path "github.com/mattn/go-shellwords"
- ;; TODO: can't make homeless-shelter:
- ;; go: disabling cache (/homeless-shelter/.cache/go-build) due to
- ;; initialization failure: mkdir /homeless-shelter: permission denied
-
- ;; This doesn't seem to work:
-
- ;; #:phases
- ;; (modify-phases %standard-phases
- ;; (replace 'check
- ;; (lambda* (#:key import-path #:allow-other-keys)
- ;; (setenv "HOME" "/tmp")
- ;; (invoke "go" "test" import-path))))
-
- ;; TODO: There are also a couple of tests that have stymied Debian in
- ;; the past. They seem to work when run locally.
-
#:tests? #f
- ))
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'patch-sh-path
+ (lambda* (#:key inputs #:allow-other-keys)
+ (substitute* "src/github.com/mattn/go-shellwords/util_posix.go"
+ (("/bin/sh") (which "sh"))))))))
+ (inputs `(("bash" ,bash)))
(home-page "https://github.com/mattn/go-shellwords")
(synopsis "Parse lines into shell words")
(description "This package parses text into shell arguments. Based on
--
2.31.1
S
S
Sarah Morgensen wrote on 6 Aug 2021 20:57
[PATCH 3/3] gnu: go-github-com-mattn-go-shellwords: Enable tests.
(address . 49915@debbugs.gnu.org)
ba70c616f97301db54ea5925d2ca722efcab1316.1628275842.git.iskarian@mgsn.dev
Tests fixed by previous commit.

* gnu/packages/golang.scm (go-github-com-mattn-go-shellwords)[arguments]
<#:tests?>: Enable tests.
---
gnu/packages/golang.scm | 1 -
1 file changed, 1 deletion(-)

Toggle diff (14 lines)
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index b46f9e9bbf..2b18b6ed18 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -5274,7 +5274,6 @@ systems.")
(build-system go-build-system)
(arguments
`(#:import-path "github.com/mattn/go-shellwords"
- #:tests? #f
#:phases
(modify-phases %standard-phases
(add-after 'unpack 'patch-sh-path
--
2.31.1
S
S
Sharlatan Hellseher wrote on 15 Feb 22:30 +0100
[PATCH 1/3] gnu: go-github-com-mattn-go-shellwords: Update to 1.0.12.
(address . 49915-done@debbugs.gnu.org)
87a5o1wh46.fsf@gmail.com
Hi,

I've fixed patch apply failure, added one intermediate patch to fix
indentation and move the package to golang-xyz.

Pushed as 008811aef6..8c9bc0e710 to master.

--
Oleg
-----BEGIN PGP SIGNATURE-----

iQIzBAEBCgAdFiEEmEeB3micIcJkGAhndtcnv/Ys0rUFAmXOglkACgkQdtcnv/Ys
0rXSqBAAmtZuRboXpIM4oOg3/WllHKHDSePoeeF4dMgkzofy7sqBynOOsXrtGY7d
2gEQgv7D14VcFAsrnoHhsP/rLDecgNwfRH8ZF6sLwr7l64V077DtkiZpRzmbGnmc
J99Haq7pRl0sjU8xWLULf8ttn19Djdyc3BPN0eAn5n/gFhRUgvA/E0cH0Yj8snCR
nmwWBoQWT94tsh33zv1/qmKmQior9grbOT5ci/z6loFYkM/2caJUODKzLHglDU9e
LS919hcW3uNSSHsnO3nyeZgD6GGEBnBAKyj2xzFf9d7Pu7RsP1s0xTgthrQ3HfrX
MMxGrIMrIlXcVrWx8dK0cHUUJ/Uxf5LJ/HvY+1Af8pE2ByJNaMLQG6+qdLz8WTWP
Ftut/AU8cErD3jBvdGKlheCpR5p/acbleMLCx6nd1KoDO2NId/7c+wllnQFZ7nqs
Qbc+JmVU/GLbdza4ETCXIYn/MAZhTK2LQ9kzmhQKuhnRjIcT0ruqYqiXO1MlSjHS
/18PE0rXreUsLdet8DXBI/MnHSk2hadn4/tb3yf/qxjVyZVQsMBsYYZzMyFb1+tO
2O81zrzHRSZFEUcKgfo2R7uAt9eC2m//PEvKOkigti7ZFS6TrhrZoo+oYlY7zw5E
rej6eGDRqzbRbtAX0tQf++XmSk4D2ZzkpZDQCNwmtIYz8nYIIGo=
=XMLm
-----END PGP SIGNATURE-----

Closed
?