[PATCH 2/3] gnu: VDE 2: Update to 2.3.2-0.8599321.

  • Done
  • quality assurance status badge
Details
One participant
  • Leo Famulari
Owner
unassigned
Submitted by
Leo Famulari
Severity
normal
L
L
Leo Famulari wrote on 4 Aug 2021 03:07
(address . guix-patches@gnu.org)
4bd1f59c75dd59d9d68a642040ddf0147bc4f7d1.1628039226.git.leo@famulari.name
Updating to this unreleased revision allows us to package VDE 2 with
wolfSSL instead of the obsolete OpenSSL 1.0:


* gnu/packages/networking.scm (vde2): Update to 2.3.2-0.8599321.
[source]: Use git-fetch.
[native-inputs]: Add autoconf, automake, and libtool
[inputs]: Replace openssl-1.0 with wolfssl.
[arguments]: Add a 'fix-configure' phase.
---
gnu/packages/networking.scm | 35 +++++++++++++++++++++++++++--------
1 file changed, 27 insertions(+), 8 deletions(-)

Toggle diff (72 lines)
diff --git a/gnu/packages/networking.scm b/gnu/packages/networking.scm
index 05fd092b23..2263d26c41 100644
--- a/gnu/packages/networking.scm
+++ b/gnu/packages/networking.scm
@@ -13,7 +13,7 @@
;;; Copyright © 2016 Benz Schenk <benz.schenk@uzh.ch>
;;; Copyright © 2016, 2017 Pjotr Prins <pjotr.guix@thebird.nl>
;;; Copyright © 2017 Mathieu Othacehe <m.othacehe@gmail.com>
-;;; Copyright © 2017, 2020 Leo Famulari <leo@famulari.name>
+;;; Copyright © 2017, 2020, 2021 Leo Famulari <leo@famulari.name>
;;; Copyright © 2017, 2018, 2019, 2020 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2017, 2018, 2019 Rutger Helling <rhelling@mykolab.com>
;;; Copyright © 2017, 2019 Gábor Boskovits <boskovits@gmail.com>
@@ -3833,22 +3833,41 @@ some traces for unprivileged users.")
license:lgpl2.1+)))) ;for the libsupp subdirectory
(define-public vde2
+ (let ((commit "8599321526d0a31925fe55cabbe132b752cb268a")
+ (revision "0"))
(package
(name "vde2")
- (version "2.3.2")
+ (version (git-version "2.3.2" revision commit))
(source
(origin
- (method url-fetch)
- (uri "mirror://sourceforge/vde/vde2/2.3.2/vde2-2.3.2.tar.gz")
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/virtualsquare/vde-2")
+ (commit commit)))
+ (file-name (git-file-name name version))
(sha256
- (base32 "14xga0ib6p1wrv3hkl4sa89yzjxv7f1vfqaxsch87j6scdm59pr2"))))
+ (base32 "1dirkcbjh7c5kz7d065g1yq7vg8jl93hql3brfxd84k8hc8nqjb2"))))
(build-system gnu-build-system)
(arguments
- `(#:parallel-build? #f)) ; Build fails if #t.
+ `(#:parallel-build? #f ; Build fails if #t.
+ #:phases
+ (modify-phases %standard-phases
+ ;; Although VDE-2 has been updated upstream to use wolfSSL
+ ;; instead of OpenSSL, the configure script was not updated to
+ ;; check for wolfSSL instead of OpenSSL.
+ (add-after 'unpack 'fix-wolfssl-configuration
+ (lambda _
+ (substitute* "configure.ac"
+ (("crypto") "wolfssl")
+ (("EVP_EncryptInit") "wc_Chacha_Process")))))))
+ (native-inputs
+ `(("autoconf" ,autoconf)
+ ("automake" ,automake)
+ ("libtool" ,libtool)))
(inputs
`(("python" ,python)
("libpcap" ,libpcap)
- ("openssl" ,openssl-1.0))) ; Build fails with 1.1.
+ ("wolfssl" ,wolfssl)))
(home-page "https://github.com/virtualsquare/vde-2")
(synopsis "Virtual Distributed Ethernet")
(description "VDE is a set of programs to provide virtual software-defined
@@ -3860,7 +3879,7 @@ cables.")
license:lgpl2.1 ; libvdeplug
(license:non-copyleft ; slirpvde
"file://COPYING.slirpvde"
- "See COPYING.slirpvde in the distribution.")))))
+ "See COPYING.slirpvde in the distribution."))))))
(define-public haproxy
(package
--
2.32.0
L
L
Leo Famulari wrote on 4 Aug 2021 03:08
(no subject)
(address . control@debbugs.gnu.org)
YQnolFsXpvZoK0wX@jasmine.lan
close 49856
close 49857
close 49858
?