[PATCH] gnu: Add bitwise.

  • Done
  • quality assurance status badge
Details
2 participants
  • Efraim Flashner
  • jgart
Owner
unassigned
Submitted by
jgart
Severity
normal
J
J
jgart wrote on 1 Aug 2021 02:29
(address . guix-patches@gnu.org)
20210801002907.4291-1-jgart@dismail.de
From: Guix Together <jgart@dismail.de>

* gnu/packages/maths.scm (bitwise): New variable.

Co-authored-by: jgart <jgart@dismail.de>
Co-authored-by: Julien Lepiller <julien@lepiller.eu>
Co-authored-by: Ryan Prior <rprior@protonmail.com>
---
gnu/packages/maths.scm | 36 ++++++++++++++++++++++++++++++++++++
1 file changed, 36 insertions(+)

Toggle diff (56 lines)
diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index 1afe72659a..b0ba18c5c1 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -124,6 +124,7 @@
#:use-module (gnu packages m4)
#:use-module (gnu packages mpi)
#:use-module (gnu packages multiprecision)
+ #:use-module (gnu packages ncurses)
#:use-module (gnu packages netpbm)
#:use-module (gnu packages ocaml)
#:use-module (gnu packages onc-rpc)
@@ -175,6 +176,41 @@ beginners.")
(license license:gpl3+)
(home-page "https://www.gnu.org/software/aris/")))
+(define-public bitwise
+ (package
+ (name "bitwise")
+ (version "0.42")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/mellowcandle/bitwise")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256 (base32
+ "154y0sn3z64z56k84ghsazkyihbkaz40hfwxcxdymnhvhh6m9f3g"))))
+ (build-system gnu-build-system)
+ (inputs `(("ncurses" ,ncurses)
+ ("readline" ,readline)))
+ (native-inputs
+ `(("autoconf" ,autoconf)
+ ("automake" ,automake)
+ ("cunit" ,cunit)
+ ("pkg-config" ,pkg-config)))
+ (synopsis "Terminal based bit manipulator in ncurses")
+ (description "Bitwise is a multi base interactive calculator supporting dynamic base
+conversion and bit manipulation. It's a handy tool for low level hackers,
+kernel developers and device drivers developers.
+
+Some of the features include:
+@itemize
+@item Interactive ncurses interface
+@item Command line calculator supporting all bitwise operations.
+@item Individual bit manipulator.
+@item Bitwise operations such as NOT, OR, AND, XOR, and shifts.
+@end itemize")
+ (license license:gpl3+)
+ (home-page "https://github.com/mellowcandle/bitwise/")))
+
(define-public c-graph
(package
(name "c-graph")
--
2.32.0
J
J
jgart wrote on 1 Aug 2021 02:44
(address . 49802@debbugs.gnu.org)
20210731204458.GB5390@gac.attlocal.net
< Hello Guixers! >
----------------
\ ^__^
\ (oo)\_______
(__)\ )\/\
||----w |
|| ||

Above is the package we worked on from today's guix packaging meetup.

The package is co-authored with Ryan and roptat.


Bitwise is a multi base interactive calculator supporting dynamic base conversion and bit manipulation.

It's a handy tool for low level hackers, kernel developers and device drivers developers.

Some of the features include:

Interactive ncurses interface
Command line calculator supporting all bitwise operations.
Individual bit manipulator.
Bitwise operations such as NOT, OR, AND, XOR, and shifts.
E
E
Efraim Flashner wrote on 4 Aug 2021 09:57
Re: [bug#49802] [PATCH] gnu: Add bitwise.
(name . jgart)(address . jgart@dismail.de)
YQpIV40/qvJi4fHQ@3900XT
I changed it to use the release tarball, which allowed me to drop
autoconf/automake. Patch pushed!

--
Efraim Flashner <efraim@flashner.co.il> ????? ?????
GPG key = A28B F40C 3E55 1372 662D 14F7 41AA E7DC CA3D 8351
Confidentiality cannot be guaranteed on emails sent or received unencrypted
-----BEGIN PGP SIGNATURE-----

iQIzBAABCgAdFiEEoov0DD5VE3JmLRT3Qarn3Mo9g1EFAmEKSFcACgkQQarn3Mo9
g1EGexAArUBDYMn9BQbbLSg7KYLIxcxBdIjC6dTI5ZAjbDzP0K4/vFPxFg0DQX22
XD/oJhHHHtKJ1ZSIvFI7vARRqpCXb7UsWTeQvuLHAbzvGFilwlQ3m52CPeSLJRjl
4TfIEuLBLEHqhJLlN1MSciy26v+aaGC+JpdSFVoZBZkfPg9kdDgo9VRawxkF5zmL
aiakND9XWMkUb6/bAiOnxz4lDbdSXffz7BCLl+5VYgDX4o39WY0KCTIBpwJ5gjsx
oVDpDgT+bZYVzpFuv6ZIb+mxrIy/b03+z2BLqUwr2H/lofEaPz2x1mHwCiW2J5r8
ZHNqbd3EFneI3oRsPAT5uSuCk6AztOAs73hHSIDu/jk7pZBwYxWs3XdCX0ZGTxCw
Xm5cyY/0EWcKYeS5E1pD36SxQvJfrqqXgq9fTc3Tpy/mLPOHzI47Z6XRfWmTzp5T
ft+i9y9DZPo4+CcXvjoeXkKjhrfoEPpGCO0HHUEDtZPlZMMlnFqt3Of/YhPJzlrT
iL54tRff5ZBNHbfwiUEMS5TIAMtLSnXj07ltXohxsarlEHz5yogAh8KN3NcsQCZB
QrvjBw7RiU+EJKUpDtpfgkVc9JI2rb5eiG5a29lpGryMWaPaep7vj3Q1unYo5tKP
ZX9D1BptKsEshu+ADNmrW7lRr7c0Z8u7axXgab8FFK9u/WN13WA=
=wBnR
-----END PGP SIGNATURE-----


Closed
?