[PATCH] gnu: Add r-ggh4x.

  • Done
  • quality assurance status badge
Details
3 participants
  • Ricardo Wurmus
  • Wiktor ?elazny
  • zimoun
Owner
unassigned
Submitted by
Wiktor ?elazny
Severity
normal
W
W
Wiktor ?elazny wrote on 31 Jul 2021 14:48
(address . guix-patches@gnu.org)
20210731124851.3168-1-wz@freeshell.de
* gnu/packages/cran.scm (r-ggh4x): New variable.
---
gnu/packages/cran.scm | 32 +++++++++++++++++++++++++++++++-
1 file changed, 31 insertions(+), 1 deletion(-)

Toggle diff (51 lines)
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 25a6f71ca4..b2b86995ca 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -17,7 +17,7 @@
;;; Copyright © 2018 Marius Bakke <mbakke@fastmail.com>
;;; Copyright © 2018, 2019 Brett Gilio <brettg@gnu.org>
;;; Copyright © 2019 Nicolò Balzarotti <anothersms@gmail.com>
-;;; Copyright © 2019, 2020 Wiktor ?elazny <wzelazny@vurv.cz>
+;;; Copyright © 2019, 2020, 2021 Wiktor ?elazny <wzelazny@vurv.cz>
;;; Copyright © 2019 Arne Babenhauserheide <arne_bab@web.de>
;;; Copyright © 2019, 2020 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2020 Todor Kondi? <tk.code@protonmail.com>
@@ -29958,3 +29958,33 @@ applications. The OpenCPU server runs either as a single-user development
server within the interactive R session, or as a multi-user stack based on
Apache2.")
(license license:asl2.0)))
+
+(define-public r-ggh4x
+ (package
+ (name "r-ggh4x")
+ (version "0.1.2.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "ggh4x" version))
+ (sha256
+ (base32
+ "1a3aiyc1shw5hlf3m90dc528dsx4li6mqrh9g5i7s353yck226mj"))))
+ (properties `((upstream-name . "ggh4x")))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-ggplot2" ,r-ggplot2)
+ ("r-gtable" ,r-gtable)
+ ("r-rlang" ,r-rlang)
+ ("r-scales" ,r-scales)
+ ("r-vctrs" ,r-vctrs)))
+ (native-inputs
+ `(("r-knitr" ,r-knitr)))
+ (home-page "https://github.com/teunbrand/ggh4x")
+ (synopsis "Hacks for ggplot2")
+ (description "This package provides a @code{ggplot2} extension that does a
+variety of little helpful things. The package extends @code{ggplot2} facets
+through customisation, by setting individual scales per panel, resizing panels
+and providing nested facets. Also allows multiple colour and fill scales per
+plot. Also hosts a smaller collection of stats, geoms and axis guides.")
+ (license license:expat)))

base-commit: 9f48f71398d7e95c496ecca6936e431811d3a1de
--
2.32.0
Z
Z
zimoun wrote on 18 Aug 2021 16:03
(name . Ricardo Wurmus)(address . rekado@elephly.net)
867dgiluis.fsf@gmail.com
Hi,

CC Ricardo in case they miss it. ;-)

On Sat, 31 Jul 2021 at 14:48, Wiktor ?elazny <wz@freeshell.de> wrote:

Toggle quote (2 lines)
> + (synopsis "Hacks for ggplot2")

Instead of “Hacks”, I would write “Extension”.

Toggle quote (6 lines)
> + (description "This package provides a @code{ggplot2} extension that does a
> +variety of little helpful things. The package extends @code{ggplot2} facets
> +through customisation, by setting individual scales per panel, resizing panels
> +and providing nested facets. Also allows multiple colour and fill scales per
> +plot. Also hosts a smaller collection of stats, geoms and axis guides.")

I would write something like that:

(description "This package is a @code{ggplot2} extension. It
provides some utility functions that do not entirely fit within the
grammar of graphics concept. The package extends @code{ggpplots}
facets through customisation, by setting individual scales per
panel, resizing panels and providing nested facets. It also allows
multiple colour, fill scales per plot and hosts a smaller collection
of stats, geoms and axis guides.")


All the best,
simon
W
W
Wiktor ?elazny wrote on 2 Sep 2021 18:43
(name . zimoun)(address . zimon.toutoune@gmail.com)
20210902164320.6thj2pzjnwvxwuyk@wzguix
On Wed, Aug 18, 2021 at 04:03:39PM +0200, zimoun wrote:

Toggle quote (4 lines)
> Instead of “Hacks”, I would write “Extension”.

> I would write something like that:

Hi simon,

Thanks for taking a look. I will resubmit the definition modified
according to your suggestions sometime later this month. It’s currently
holidays time for me.

Bye,

W?
-----BEGIN PGP SIGNATURE-----

iQKTBAABCgB9FiEEvcl0zdnJun12Glc9xzWoxqtgedUFAmEw/yhfFIAAAAAALgAo
aXNzdWVyLWZwckBub3RhdGlvbnMub3BlbnBncC5maWZ0aGhvcnNlbWFuLm5ldEJE
Qzk3NENERDlDOUJBN0Q3NjFBNTczREM3MzVBOEM2QUI2MDc5RDUACgkQxzWoxqtg
edVuEQ/8DZWsjU9726twL2HJ5pK/MlKZkKZue5DQFYvBPNOxPreRr4/OOU3lz1qy
mKEFynTwQMUsbSRIcZcFXm2SvBCk27Ht/rRJMxuGp4InPl58i/ya0LlRbhZ6gbCa
sEvVbT1lPu1tuIbnjMiZ0GTsDYIv7UQ8OynzjEWX5Km16awQ/x/RGqDTDzU4WDKT
tSxV0C5Ym6opmrK0t1gy++tUIT3f9RqJxnkL/Y/PZnDay489P6CrgjdiZe0fYYNS
5S1P23r4vEQUy1IC94GS5zPQY/4u7Zfu22mGThT5eIkaIXaYHKaHEVaWaHXNZ/IZ
AlSy9afoTgavN2mIAC4P5BaUQRQA/NQVXyhfBAdIFpOnbg9eW09n6eWBclTHzNGe
GZq8dbAJatpO4B8kacvynF4QnhFP+0a+uPVK2PT5faJDnthmNK3ffKoAJTr4/KhT
q53JPdqE6ylw6Iw+rPrid5I7EsSMGTK63l5YGYBQpt13jo0jd6Oth2FZM2NkAdZJ
HSaTGXXO2GZWfdrXEWQL8ucx9wtadE9EWsuN3Z1xKMQ5wP6IUCnC6VrpF6WGfiNz
3uzImKcCDPvX+KuK85K6v/FazyG9G8QGk6EaGpMxuId36XkvsrfO1FfQRyPhib2w
4yoGWIiOT3fEIU32Jvgkthlt3EnUWi7F3O6ixHtDmfvdnZJOwjw=
=JRTA
-----END PGP SIGNATURE-----


W
W
Wiktor ?elazny wrote on 17 Sep 2021 20:17
[PATCH v2] gnu: Add r-ggh4x.
(address . 49792@debbugs.gnu.org)
20210917181741.2031-1-wz@freeshell.de
* gnu/packages/cran.scm (r-ggh4x): New variable.
---
gnu/packages/cran.scm | 33 ++++++++++++++++++++++++++++++++-
1 file changed, 32 insertions(+), 1 deletion(-)

Toggle diff (52 lines)
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index f80256c901..7c25d17fbf 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -17,7 +17,7 @@
;;; Copyright © 2018 Marius Bakke <mbakke@fastmail.com>
;;; Copyright © 2018, 2019 Brett Gilio <brettg@gnu.org>
;;; Copyright © 2019 Nicolò Balzarotti <anothersms@gmail.com>
-;;; Copyright © 2019, 2020 Wiktor ?elazny <wzelazny@vurv.cz>
+;;; Copyright © 2019, 2020, 2021 Wiktor ?elazny <wzelazny@vurv.cz>
;;; Copyright © 2019 Arne Babenhauserheide <arne_bab@web.de>
;;; Copyright © 2019, 2020 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2020 Todor Kondi? <tk.code@protonmail.com>
@@ -31842,3 +31842,34 @@ deleting and uploading forecast data, and downloading scores.")
regression and obtain Bayesian inference of the model via the Markov Chain
Monte Carlo approach implemented in JAGS.")
(license license:gpl3+)))
+
+(define-public r-ggh4x
+ (package
+ (name "r-ggh4x")
+ (version "0.2.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "ggh4x" version))
+ (sha256
+ (base32
+ "0gv9ckkdqbcjknzsv8h3955wnikawdfypr279v74hvwyq86af29r"))))
+ (properties `((upstream-name . "ggh4x")))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-ggplot2" ,r-ggplot2)
+ ("r-gtable" ,r-gtable)
+ ("r-rlang" ,r-rlang)
+ ("r-scales" ,r-scales)
+ ("r-vctrs" ,r-vctrs)))
+ (native-inputs
+ `(("r-knitr" ,r-knitr)))
+ (home-page "https://github.com/teunbrand/ggh4x")
+ (synopsis "Extension for ggplot2")
+ (description "This package is a @code{ggplot2} extension. It provides some
+utility functions that do not entirely fit within the grammar of graphics
+concept. The package extends @code{ggpplots} facets through customisation, by
+setting individual scales per panel, resizing panels and providing nested
+facets. It also allows multiple colour, fill scales per plot and hosts a
+smaller collection of stats, geoms and axis guides.")
+ (license license:expat)))

base-commit: 05605998b2f70403c360ad5e27d942cef2b9502c
--
2.33.0
R
R
Ricardo Wurmus wrote on 18 Sep 2021 23:41
(name . Wiktor ?elazny)(address . wz@freeshell.de)
87wnnd7e9i.fsf@elephly.net
Wiktor ?elazny <wz@freeshell.de> writes:

Toggle quote (2 lines)
> * gnu/packages/cran.scm (r-ggh4x): New variable.

Thank you. I applied it with commit
337b7f5a13b8fd8b5ee320fd5a850ede1ad63b6d.

--
Ricardo
Closed
?