[PATCH][core-updates] build-system: asdf: Remove %build-inputs reference.

  • Done
  • quality assurance status badge
Details
2 participants
  • Ludovic Courtès
  • Mathieu Othacehe
Owner
unassigned
Submitted by
Mathieu Othacehe
Severity
normal
M
M
Mathieu Othacehe wrote on 28 Jul 2021 16:13
(address . guix-patches@gnu.org)(name . Mathieu Othacehe)(address . othacehe@gnu.org)
20210728141326.29770-1-othacehe@gnu.org
This is a follow-up of 7d873f194ca69d6096d28d7a224ab78e83e34fe1 that removes
the %build-inputs variable.

* guix/build-system/asdf.scm (asdf-build): Remove %build-inputs reference.
---
Hello,

This fixes the asdf based builds on core-updates.

Thanks,

Mathieu

guix/build-system/asdf.scm | 9 +++++----
1 file changed, 5 insertions(+), 4 deletions(-)

Toggle diff (29 lines)
diff --git a/guix/build-system/asdf.scm b/guix/build-system/asdf.scm
index 79de2ee5ba..f4ad7252df 100644
--- a/guix/build-system/asdf.scm
+++ b/guix/build-system/asdf.scm
@@ -28,7 +28,8 @@
#:use-module (guix search-paths)
#:use-module ((guix build utils)
#:select ((package-name->name+version
- . hyphen-separated-name->name+version)))
+ . hyphen-separated-name->name+version)
+ search-input-file))
#:use-module (guix build-system)
#:use-module (guix build-system gnu)
#:use-module (ice-9 match)
@@ -295,9 +296,9 @@ set up using CL source package conventions."
(with-imported-modules imported-modules
#~(begin
(use-modules #$@(sexp->gexp modules))
- (parameterize ((%lisp (string-append
- (assoc-ref %build-inputs #$lisp-type)
- "/bin/" #$lisp-type))
+ (parameterize ((%lisp (search-input-file
+ #$(input-tuples->gexp inputs)
+ (string-append "bin/" #$lisp-type)))
(%lisp-type #$lisp-type))
(asdf-build #:name #$name
#:source #+source
--
2.32.0
M
M
Mathieu Othacehe wrote on 28 Jul 2021 16:20
(address . 49756@debbugs.gnu.org)
87r1fia5aa.fsf@gnu.org
Toggle quote (5 lines)
> #:select ((package-name->name+version
> - . hyphen-separated-name->name+version)))
> + . hyphen-separated-name->name+version)
> + search-input-file))

This hunk is not needed.

Mathieu
L
L
Ludovic Courtès wrote on 29 Jul 2021 10:18
Re: bug#49756: [PATCH][core-updates] build-system: asdf: Remove %build-inputs reference.
(name . Mathieu Othacehe)(address . othacehe@gnu.org)(address . 49756@debbugs.gnu.org)
87sfzx1qjf.fsf@gnu.org
Hi,

Mathieu Othacehe <othacehe@gnu.org> skribis:

Toggle quote (5 lines)
> This is a follow-up of 7d873f194ca69d6096d28d7a224ab78e83e34fe1 that removes
> the %build-inputs variable.
>
> * guix/build-system/asdf.scm (asdf-build): Remove %build-inputs reference.

LGTM! (modulo the unnecessary hunk)

Note that I left ‘%build-inputs’ in the “main” build systems, but
semi-intentionally left it out in other build systems, the idea being
that we should no longer need it now, and it was already rarely used.

Thanks,
Ludo’.
M
M
Mathieu Othacehe wrote on 29 Jul 2021 10:29
(name . Ludovic Courtès)(address . ludo@gnu.org)(address . 49756-done@debbugs.gnu.org)
87mtq5ikuf.fsf_-_@gnu.org
Hey,

Toggle quote (4 lines)
> Note that I left ‘%build-inputs’ in the “main” build systems, but
> semi-intentionally left it out in other build systems, the idea being
> that we should no longer need it now, and it was already rarely used.

I see, thanks for explaining!

Closing this one,

Mathieu
Closed
?