[PATCH] gnu: Add emacs-nasm-mode.

  • Done
  • quality assurance status badge
Details
2 participants
  • Nicolas Goaziou
  • Ron Nazarov
Owner
unassigned
Submitted by
Ron Nazarov
Severity
normal
R
R
Ron Nazarov wrote on 25 Jul 2021 23:44
(address . guix-patches@gnu.org)(name . Ron Nazarov)(address . noisytoot@disroot.org)
20210725214440.21002-1-noisytoot@disroot.org
* gnu/packages/emacs-xyz.scm (emacs-nasm-mode): New variable.
---
gnu/packages/emacs-xyz.scm | 24 ++++++++++++++++++++++++
1 file changed, 24 insertions(+)

Toggle diff (41 lines)
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index a26a023a2b..83a59ca3a4 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -101,6 +101,7 @@
;;; Copyright © 2021 David Dashyan <mail@davie.li>
;;; Copyright © 2021 Dhruvin Gandhi <contact@dhruvin.dev>
;;; Copyright © 2021 Matthew James Kraai <kraai@ftbfs.org>
+;;; Copyright © 2021 Noisytoot <noisytoot@disroot.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -29037,3 +29038,26 @@ Believing} is a ruby gem to evaluate Ruby code, recording the results of each
line. This minor mode provides an easy way to run it from Emacs on the
current region or entire buffer.")
(license license:gpl3+))))
+
+(define-public emacs-nasm-mode
+ (package
+ (name "emacs-nasm-mode")
+ (version "20190410.342")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://melpa.org/packages/nasm-mode-"
+ version
+ ".el"))
+ (sha256
+ (base32
+ "10js4bdgqgvlhpk3mgq3rjglmkgkxchj1bny16bkl7glw5mqwl8c"))))
+ (build-system emacs-build-system)
+ (home-page "https://github.com/skeeto/nasm-mode")
+ (synopsis "NASM x86 assembly major mode")
+ (description
+ "@code{nasm-mode} is a major mode for editing NASM x86 assembly programs.
+It includes syntax highlighting, automatic indentation, and imenu integration.
+Unlike Emacs' generic @code{asm-mode}, it understands NASM-specific syntax.")
+ (license license:unlicense)))
--
2.32.0
N
N
Nicolas Goaziou wrote on 27 Jul 2021 19:43
(name . Ron Nazarov via Guix-patches via)(address . guix-patches@gnu.org)
87r1fjps8t.fsf@nicolasgoaziou.fr
Hello,

Ron Nazarov via Guix-patches via <guix-patches@gnu.org> writes:

Toggle quote (2 lines)
> * gnu/packages/emacs-xyz.scm (emacs-nasm-mode): New variable.

Thank you.

Toggle quote (12 lines)
> +(define-public emacs-nasm-mode
> + (package
> + (name "emacs-nasm-mode")
> + (version "20190410.342")
> + (source
> + (origin
> + (method url-fetch)
> + (uri (string-append
> + "https://melpa.org/packages/nasm-mode-"
> + version
> + ".el"))

Please use Github repository instead of MELPA. The latter has a strange
versioning scheme, and source is not stable.

Toggle quote (9 lines)
> + (sha256
> + (base32
> + "10js4bdgqgvlhpk3mgq3rjglmkgkxchj1bny16bkl7glw5mqwl8c"))))
> + (build-system emacs-build-system)
> + (home-page "https://github.com/skeeto/nasm-mode")
> + (synopsis "NASM x86 assembly major mode")
> + (description
> + "@code{nasm-mode} is a major mode for editing NASM x86 assembly programs.

I would write NASM mode is ...

Toggle quote (3 lines)
> +It includes syntax highlighting, automatic indentation, and imenu integration.
> +Unlike Emacs' generic @code{asm-mode}, it understands NASM-specific syntax.")

ditto: ASM mode.

Could you send an updated patch?

Regards,
--
Nicolas Goaziou
R
R
Ron Nazarov wrote on 28 Jul 2021 17:35
[PATCH v2] gnu: Add emacs-nasm-mode.
(address . 49736@debbugs.gnu.org)(name . Ron Nazarov)(address . noisytoot@disroot.org)
20210728153548.12024-1-noisytoot@disroot.org
* gnu/packages/emacs-xyz.scm (emacs-nasm-mode): New variable.
---
gnu/packages/emacs-xyz.scm | 24 ++++++++++++++++++++++++
1 file changed, 24 insertions(+)

Toggle diff (41 lines)
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index d7c317a076..088266e01b 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -101,6 +101,7 @@
;;; Copyright © 2021 David Dashyan <mail@davie.li>
;;; Copyright © 2021 Dhruvin Gandhi <contact@dhruvin.dev>
;;; Copyright © 2021 Matthew James Kraai <kraai@ftbfs.org>
+;;; Copyright © 2021 Noisytoot <noisytoot@disroot.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -29055,3 +29056,26 @@ Believing} is a ruby gem to evaluate Ruby code, recording the results of each
line. This minor mode provides an easy way to run it from Emacs on the
current region or entire buffer.")
(license license:gpl3+))))
+
+(define-public emacs-nasm-mode
+ (package
+ (name "emacs-nasm-mode")
+ (version "1.1.1")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/skeeto/nasm-mode")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1dyc50a1zskx9fqxl2iy2x74f3bkb2ccz908v0aj13rqfqqnns9j"))))
+ (build-system emacs-build-system)
+ (home-page "https://github.com/skeeto/nasm-mode")
+ (synopsis "NASM x86 assembly major mode")
+ (description
+ "NASM mode is a major mode for editing NASM x86 assembly programs.
+It includes syntax highlighting, automatic indentation, and imenu integration.
+Unlike Emacs' generic ASM mode, it understands NASM-specific syntax.")
+ (license license:unlicense)))
--
2.32.0
N
N
Nicolas Goaziou wrote on 29 Jul 2021 09:42
(name . Ron Nazarov via Guix-patches via)(address . guix-patches@gnu.org)
87wnp9in0e.fsf@nicolasgoaziou.fr
Hello,

Ron Nazarov via Guix-patches via <guix-patches@gnu.org> writes:

Toggle quote (2 lines)
> * gnu/packages/emacs-xyz.scm (emacs-nasm-mode): New variable.

Applied. Thank you!

Please note (for future contributions) that adding package definitions
at the very end of a file is prone to merge conflicts. It is better to
use a random location.

Regards,
--
Nicolas Goaziou
?