[PATCH core-updates] build-system/gnu: Make gzip files writable before resetting timestamps.

  • Done
  • quality assurance status badge
Details
4 participants
  • Attila Lendvai
  • Sarah Morgensen
  • Maxim Cournoyer
  • Maxime Devos
Owner
unassigned
Submitted by
Sarah Morgensen
Severity
normal
S
S
Sarah Morgensen wrote on 25 Jul 2021 08:12
(address . guix-patches@gnu.org)
f45aa05904dcb0cb8718be3d32d9bae9807ed8c0.1627193346.git.iskarian@mgsn.dev
guix/build/gnu-build-system.scm (reset-gzip-timestamps): Ensure gzip
files are writable before resetting their timestamps.
---
Hello Guix,

There have been a number of instances of packages having to add their own phase
before 'reset-gzip-timestamps to make the gzip files writable--perhaps the gnu
build system can take care of this itself? WDYT?

--
Sarah
guix/build/gnu-build-system.scm | 2 ++
1 file changed, 2 insertions(+)

Toggle diff (17 lines)
diff --git a/guix/build/gnu-build-system.scm b/guix/build/gnu-build-system.scm
index d0f7413268..d84411c090 100644
--- a/guix/build/gnu-build-system.scm
+++ b/guix/build/gnu-build-system.scm
@@ -598,6 +598,8 @@ and 'man/'. This phase moves directories to the right place if needed."
(string-suffix? ".tgz" file))
(gzip-file? file)))
#:stat lstat)))
+ ;; Ensure the files are writable.
+ (for-each make-file-writable files)
(for-each reset-gzip-timestamp files)))
(match outputs

base-commit: 7bef3be1d318beebaf48ac6daa3140205ba18e98
--
2.31.1
M
M
Maxime Devos wrote on 25 Jul 2021 17:26
(address . ludo@gnu.org)
4a4d285bafb763b6e6a8c5febc224f178d9a3083.camel@telenet.be
[CC'ing Ludo because Ludo introduced the 'reset-gzip-timestamps' phase]
Sarah Morgensen schreef op za 24-07-2021 om 23:12 [-0700]:
Toggle quote (9 lines)
> guix/build/gnu-build-system.scm (reset-gzip-timestamps): Ensure gzip
> files are writable before resetting their timestamps.
> ---
> Hello Guix,
>
> There have been a number of instances of packages having to add their own phase
> before 'reset-gzip-timestamps to make the gzip files writable--perhaps the gnu
> build system can take care of this itself? WDYT?

This seems reasonable to me. There are 35 package definions referring to
'reset-gzip-timestamps', could you follow up with patches removing the phases
for making gzip files writable?

Greetings,
Maxime.
-----BEGIN PGP SIGNATURE-----

iI0EABYKADUWIQTB8z7iDFKP233XAR9J4+4iGRcl7gUCYP2CvhccbWF4aW1lZGV2
b3NAdGVsZW5ldC5iZQAKCRBJ4+4iGRcl7nGHAP9miEDKAiQV/WaMbi+zOyO6p21B
bBSxBHb1yrdbMudOsAEAwA12n2XQ6H9qmlj81hL6897qEs27oxn26sHD4LhMYw0=
=y7gm
-----END PGP SIGNATURE-----


S
S
Sarah Morgensen wrote on 25 Jul 2021 22:45
Re: bug#49729: [PATCH core-updates] build-system/gnu: Make gzip files writable before resetting timestamps.
(name . Maxime Devos)(address . maximedevos@telenet.be)
86a6map1gf.fsf_-_@mgsn.dev
Hi,

Thanks for taking a look at this.

Maxime Devos <maximedevos@telenet.be> writes:

Toggle quote (15 lines)
> [CC'ing Ludo because Ludo introduced the 'reset-gzip-timestamps' phase]
> Sarah Morgensen schreef op za 24-07-2021 om 23:12 [-0700]:
>> guix/build/gnu-build-system.scm (reset-gzip-timestamps): Ensure gzip
>> files are writable before resetting their timestamps.
>> ---
>> Hello Guix,
>>
>> There have been a number of instances of packages having to add their own phase
>> before 'reset-gzip-timestamps to make the gzip files writable--perhaps the gnu
>> build system can take care of this itself? WDYT?
>
> This seems reasonable to me. There are 35 package definions referring to
> 'reset-gzip-timestamps', could you follow up with patches removing the phases
> for making gzip files writable?

Yes, I intend to. Should I send them to this issue #, or separately?
(And one commit per package, yes?)

--
Sarah
M
M
Maxime Devos wrote on 26 Jul 2021 22:49
(name . Sarah Morgensen)(address . iskarian@mgsn.dev)
0b4f4d6b6b86b05ab31136f0c2d6fceb77f7184d.camel@telenet.be
Hi,

Toggle quote (6 lines)
> > This seems reasonable to me. There are 35 package definions referring to
> > 'reset-gzip-timestamps', could you follow up with patches removing the phases
> > for making gzip files writable?
>
> Yes, I intend to. Should I send them to this issue #, or separately?

Personally, I'd send them to this issue # (easier to test whether this patch
works that way).

Toggle quote (1 lines)
> (And one commit per package, yes?)
Indeed!

Greetings,
Maxime.
-----BEGIN PGP SIGNATURE-----

iI0EABYKADUWIQTB8z7iDFKP233XAR9J4+4iGRcl7gUCYP8f3RccbWF4aW1lZGV2
b3NAdGVsZW5ldC5iZQAKCRBJ4+4iGRcl7sPOAP9I79tMsAnGLsBX0j9S81QL0/S/
lydvt2XE2wxoJB0NjgEApOdC50kCmzW1SMyfRzrqdk19HKn7z2qnVVLLyEtnSAA=
=pbtX
-----END PGP SIGNATURE-----


S
S
Sarah Morgensen wrote on 27 Jul 2021 04:16
[PATCH core-updates 00/20] Remove obsolete phases making gzip files writable.
(address . 49729@debbugs.gnu.org)
cover.1627351168.git.iskarian@mgsn.dev
This follow-up series removes phases some packages added to specifically make
gzip files writable before the 'reset-gzip-timestamps phase. For cpuid, it
removes a similar file permissions tweak to the Makefile.

After this patchset, there are only 7 other packages which reference
'reset-gzip-timestamps', and they delete the 'reset-gzip-timestamps phase. Upon
inspection, I think all should remain unaltered. They have gzip files present
in their sources which should be preserved in their output, and (as far as I
can tell) they do not generate any gzip files or man pages (which would then be
gzipped). For reference, they are:

texlive-pstricks
texlive-xypic
texlive-cm-super
julia-fileio
go-github-com-go-git-go-git-fixtures
cl-uffi
cl-dexador

--
Sarah Morgensen (20):
gnu: python-biom-format: Remove obsolete phase.
gnu: clipper: Remove obsolete phase.
gnu: khmer: Remove obsolete phase.
gnu: cups-minimal: Remove obsolete phase.
gnu: emacs: Remove obsolete phase.
gnu: po4a: Remove obsolete phase.
gnu: go-golang-org-x-crypto: Remove obsolete phase.
gnu: go-github-com-docker-distribution: Remove obsolete phase.
gnu: go-github-com-gdamore-tcell: Remove obsolete phase.
gnu: python-plotly: Remove obsolete phase.
gnu: go-ipfs: Remove obsolete phase.
gnu: python-scikit-learn: Remove obsolete phase.
gnu: jalv-select: Remove obsolete phase.
gnu: lmms: Remove obsolete phase.
gnu: helm: Remove obsolete phase.
gnu: arcanist: Remove obsolete phase.
gnu: python-pdfminer-six: Remove obsolete phase.
gnu: go-github-com-prometheus-common: Remove obsolete phase.
gnu: pre-commit: Remove obsolete phase.
gnu: cpuid: Remove obsolete file permissions change.

gnu/packages/bioinformatics.scm | 31 ++-------------------------
gnu/packages/cups.scm | 9 --------
gnu/packages/emacs.scm | 11 +---------
gnu/packages/gettext.scm | 7 -------
gnu/packages/golang.scm | 35 +++----------------------------
gnu/packages/graph.scm | 9 +-------
gnu/packages/ipfs.scm | 11 +---------
gnu/packages/linux.scm | 7 +------
gnu/packages/machine-learning.scm | 10 +--------
gnu/packages/music.scm | 27 ++----------------------
gnu/packages/phabricator.scm | 8 +------
gnu/packages/python-xyz.scm | 8 +------
gnu/packages/syncthing.scm | 9 --------
gnu/packages/version-control.scm | 9 +-------
14 files changed, 15 insertions(+), 176 deletions(-)


base-commit: e2690a8eb2df2cfc24bd84454dbfe092a6bf5139
prerequisite-patch-id: 89dd022dfbf4b935c4b8ba4002df7995d7a664e1
--
2.31.1
S
S
Sarah Morgensen wrote on 27 Jul 2021 04:56
[PATCH core-updates 02/20] gnu: clipper: Remove obsolete phase.
(address . 49729@debbugs.gnu.org)
43b263936417b9e8ae2725e35c69f9168432c24a.1627351168.git.iskarian@mgsn.dev
* gnu/packages/bioinformatics.scm (clipper)[arguments]<#:phases>: Remove
'make-files-writable phase.
---
gnu/packages/bioinformatics.scm | 11 -----------
1 file changed, 11 deletions(-)

Toggle diff (24 lines)
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index aa9a1328f0..f027da3ce7 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -2303,17 +2303,6 @@ databases.")
(base32
"1bcag4lb5bkzsj2vg7lrq24aw6yfgq275ifrbhd82l7kqgbbjbkv"))))
(build-system python-build-system)
- (arguments
- `(#:phases
- (modify-phases %standard-phases
- (add-before 'reset-gzip-timestamps 'make-files-writable
- (lambda* (#:key outputs #:allow-other-keys)
- ;; Make sure .gz files are writable so that the
- ;; 'reset-gzip-timestamps' phase can do its work.
- (let ((out (assoc-ref outputs "out")))
- (for-each make-file-writable
- (find-files out "\\.gz$"))
- #t))))))
(inputs
`(("htseq" ,htseq)
("python-pybedtools" ,python-pybedtools)
--
2.31.1
S
S
Sarah Morgensen wrote on 27 Jul 2021 04:56
[PATCH core-updates 01/20] gnu: python-biom-format: Remove obsolete phase.
(address . 49729@debbugs.gnu.org)
6c136dc582692dd6fcac4565b8f3d57ee5f6ce72.1627351168.git.iskarian@mgsn.dev
* gnu/packages/bioinformatics.scm (python-biom-format)[arguments]
<#:phases>: Remove 'make-files-writable phase.
---
gnu/packages/bioinformatics.scm | 9 +--------
1 file changed, 1 insertion(+), 8 deletions(-)

Toggle diff (22 lines)
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 002b417b54..aa9a1328f0 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -1012,14 +1012,7 @@ Python.")
(("^(.+)def test_from_hdf5_issue_731" m indent)
(string-append indent
"@npt.dec.skipif(True, msg='Guix')\n"
- m)))
- #t))
- (add-before 'reset-gzip-timestamps 'make-files-writable
- (lambda* (#:key outputs #:allow-other-keys)
- (let ((out (assoc-ref outputs "out")))
- (for-each (lambda (file) (chmod file #o644))
- (find-files out "\\.gz"))
- #t))))))
+ m))))))))
(propagated-inputs
`(("python-numpy" ,python-numpy)
("python-scipy" ,python-scipy)
--
2.31.1
S
S
Sarah Morgensen wrote on 27 Jul 2021 04:56
[PATCH core-updates 03/20] gnu: khmer: Remove obsolete phase.
(address . 49729@debbugs.gnu.org)
4653284d9fd1c732063872170fb197af734b2f2f.1627351168.git.iskarian@mgsn.dev
* gnu/packages/bioinformatics.scm (khmer)[arguments]<#:phases>: Remove
'make-files-writable phase.
---
gnu/packages/bioinformatics.scm | 11 +----------
1 file changed, 1 insertion(+), 10 deletions(-)

Toggle diff (24 lines)
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index f027da3ce7..76a8160aa6 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -4739,16 +4739,7 @@ command, or queried for specific k-mers with @code{jellyfish query}.")
`(#:phases
(modify-phases %standard-phases
(add-after 'unpack 'set-cc
- (lambda _ (setenv "CC" "gcc") #t))
-
- (add-before 'reset-gzip-timestamps 'make-files-writable
- (lambda* (#:key outputs #:allow-other-keys)
- ;; Make sure .gz files are writable so that the
- ;; 'reset-gzip-timestamps' phase can do its work.
- (let ((out (assoc-ref outputs "out")))
- (for-each make-file-writable
- (find-files out "\\.gz$"))
- #t))))))
+ (lambda _ (setenv "CC" "gcc") #t)))))
(native-inputs
`(("python-cython" ,python-cython)
("python-pytest" ,python-pytest)
--
2.31.1
S
S
Sarah Morgensen wrote on 27 Jul 2021 04:56
[PATCH core-updates 04/20] gnu: cups-minimal: Remove obsolete phase.
(address . 49729@debbugs.gnu.org)
7ea06103233a147708ce78b8b200ddf311d46368.1627351168.git.iskarian@mgsn.dev
* gnu/packages/cups.scm (cups-minimal)[arguments]<#:phases>: Remove
'make-manpages-writable phase.
---
gnu/packages/cups.scm | 9 ---------
1 file changed, 9 deletions(-)

Toggle diff (22 lines)
diff --git a/gnu/packages/cups.scm b/gnu/packages/cups.scm
index 0cec211b1b..8357bab50f 100644
--- a/gnu/packages/cups.scm
+++ b/gnu/packages/cups.scm
@@ -311,15 +311,6 @@ filters for the PDF-centric printing workflow introduced by OpenPrinting.")
(("INITDIR.*=.*@INITDIR@") "INITDIR = @prefix@/@INITDIR@")
(("/bin/sh") (which "sh")))
#t))
- ;; Make the compressed manpages writable so that the
- ;; reset-gzip-timestamps phase does not error out.
- (add-before 'reset-gzip-timestamps 'make-manpages-writable
- (lambda* (#:key outputs #:allow-other-keys)
- (let* ((out (assoc-ref outputs "out"))
- (man (string-append out "/share/man")))
- (for-each (lambda (file) (chmod file #o644))
- (find-files man "\\.gz"))
- #t)))
(add-before 'build 'patch-tests
(lambda _
(substitute* "tools/ippeveprinter.c"
--
2.31.1
S
S
Sarah Morgensen wrote on 27 Jul 2021 04:56
[PATCH core-updates 05/20] gnu: emacs: Remove obsolete phase.
(address . 49729@debbugs.gnu.org)
06d930a8b0d89de247db72124d675a556a474bfc.1627351168.git.iskarian@mgsn.dev
* gnu/packages/emacs.scm (emacs)[arguments]<#:phases>: Remove
'make-compressed-files-writable phase.
---
gnu/packages/emacs.scm | 11 +----------
1 file changed, 1 insertion(+), 10 deletions(-)

Toggle diff (24 lines)
diff --git a/gnu/packages/emacs.scm b/gnu/packages/emacs.scm
index 060a253968..36692347ee 100644
--- a/gnu/packages/emacs.scm
+++ b/gnu/packages/emacs.scm
@@ -225,16 +225,7 @@
;; environment variables from emacs.
;; Likewise, we don't need to patch helper binaries
;; like etags, ctags or ebrowse.
- "^emacs(-[0-9]+(\\.[0-9]+)*)?$"))
- #t)))
- (add-before 'reset-gzip-timestamps 'make-compressed-files-writable
- ;; The 'reset-gzip-timestamps phase will throw a permission error
- ;; if gzip files aren't writable then. This phase is needed when
- ;; building from a git checkout.
- (lambda _
- (for-each make-file-writable
- (find-files %output ".*\\.t?gz$"))
- #t)))))
+ "^emacs(-[0-9]+(\\.[0-9]+)*)?$"))))))))
(inputs
`(("gnutls" ,gnutls)
("ncurses" ,ncurses)
--
2.31.1
S
S
Sarah Morgensen wrote on 27 Jul 2021 04:56
[PATCH core-updates 06/20] gnu: po4a: Remove obsolete phase.
(address . 49729@debbugs.gnu.org)
2e01668f03cca0c2e3824ca695523b658ec2e770.1627351168.git.iskarian@mgsn.dev
* gnu/packages/gettext.scm (po4a)[arguments]<#:phases>: Remove 'make-compressed-files-writable phase.
---
gnu/packages/gettext.scm | 7 -------
1 file changed, 7 deletions(-)

Toggle diff (20 lines)
diff --git a/gnu/packages/gettext.scm b/gnu/packages/gettext.scm
index a71af5bbe3..f8392d7677 100644
--- a/gnu/packages/gettext.scm
+++ b/gnu/packages/gettext.scm
@@ -251,13 +251,6 @@ from Markdown files.")
`("PERL5LIB" ":" prefix (,path))))
(find-files bin "\\.*$"))
#t)))
- (add-before 'reset-gzip-timestamps 'make-compressed-files-writable
- (lambda* (#:key outputs #:allow-other-keys)
- (for-each make-file-writable
- (find-files (string-append (assoc-ref outputs "out")
- "/share/man")
- ".*\\.gz$"))
- #t))
(add-after 'unpack 'patch-docbook-xml
(lambda* (#:key inputs #:allow-other-keys)
(substitute* (find-files "." ".*\\.xml(-good)?")
--
2.31.1
S
S
Sarah Morgensen wrote on 27 Jul 2021 04:56
[PATCH core-updates 07/20] gnu: go-golang-org-x-crypto: Remove obsolete phase.
(address . 49729@debbugs.gnu.org)
af7228becdecf592d2eb13b2fc57a338a005ce86.1627351168.git.iskarian@mgsn.dev
* gnu/packages/golang.scm (go-golang-org-x-crypto)[arguments]<#:phases>:
Remove 'make-gzip-archive-writable phase.
---
gnu/packages/golang.scm | 11 +----------
1 file changed, 1 insertion(+), 10 deletions(-)

Toggle diff (24 lines)
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index d3ef39a2e6..c6804cdee3 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -2188,16 +2188,7 @@ Go programming language.")
#:phases
(modify-phases %standard-phases
;; Source-only package
- (delete 'build)
- (add-before 'reset-gzip-timestamps 'make-gzip-archive-writable
- (lambda* (#:key outputs #:allow-other-keys)
- (map (lambda (file)
- (make-file-writable file))
- (find-files
- (string-append (assoc-ref outputs "out")
- "/src/golang.org/x/crypto/ed25519/testdata")
- ".*\\.gz$"))
- #t)))))
+ (delete 'build))))
(propagated-inputs
`(("go-golang-org-x-sys" ,go-golang-org-x-sys)))
(synopsis "Supplementary cryptographic libraries in Go")
--
2.31.1
S
S
Sarah Morgensen wrote on 27 Jul 2021 04:56
[PATCH core-updates 08/20] gnu: go-github-com-docker-distribution: Remove obsolete phase.
(address . 49729@debbugs.gnu.org)
8925b70e487ed2690f96aafc00128133212a6cdb.1627351168.git.iskarian@mgsn.dev
* gnu/packages/golang.scm (go-github-com-docker-distribution)[arguments]
<#:phases>: Remove 'make-gzip-archive-writable phase.
---
gnu/packages/golang.scm | 12 +-----------
1 file changed, 1 insertion(+), 11 deletions(-)

Toggle diff (25 lines)
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index c6804cdee3..e2b557f5ee 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -3391,17 +3391,7 @@ SysVinit, and more.")
("go-golang-org-x-crypto"
,go-golang-org-x-crypto)))
(arguments
- '(#:import-path "github.com/docker/distribution"
- #:phases
- (modify-phases %standard-phases
- (add-before 'reset-gzip-timestamps 'make-gzip-archive-writable
- (lambda* (#:key outputs #:allow-other-keys)
- (map (lambda (file)
- (make-file-writable file))
- (find-files
- (assoc-ref outputs "out")
- ".*\\.gz$"))
- #t)))))
+ '(#:import-path "github.com/docker/distribution"))
(home-page
"https://github.com/docker/distribution")
(synopsis "This package is a Docker toolset to pack, ship, store, and
--
2.31.1
S
S
Sarah Morgensen wrote on 27 Jul 2021 04:56
[PATCH core-updates 09/20] gnu: go-github-com-gdamore-tcell: Remove obsolete phase.
(address . 49729@debbugs.gnu.org)
4d8029049c070d3762fecf430334ba7eb1efa26d.1627351168.git.iskarian@mgsn.dev
* gnu/packages/golang.scm (go-github-com-gdamore-tcell)[arguments]
<#:phases>: Remove 'make-files-writable phase.
---
gnu/packages/golang.scm | 12 +-----------
1 file changed, 1 insertion(+), 11 deletions(-)

Toggle diff (25 lines)
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index e2b557f5ee..232c2fef38 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -5211,17 +5211,7 @@ non-UTF-friendly sources.")
"0il2nnxp2cqiy73m49215dnf9in3vd25ji8qxbmq87c5qy7i1q9d"))))
(build-system go-build-system)
(arguments
- `(#:import-path "github.com/gdamore/tcell"
- #:phases
- (modify-phases %standard-phases
- (add-before 'reset-gzip-timestamps 'make-files-writable
- (lambda* (#:key outputs #:allow-other-keys)
- ;; Make sure .gz files are writable so that the
- ;; 'reset-gzip-timestamps' phase can do its work.
- (let ((out (assoc-ref outputs "out")))
- (for-each make-file-writable
- (find-files out "\\.gz$"))
- #t))))))
+ `(#:import-path "github.com/gdamore/tcell"))
(inputs
`(("go-github.com-mattn-go-runewidth" ,go-github.com-mattn-go-runewidth)
("go-golang-org-colorful" ,go-golang-org-colorful)
--
2.31.1
S
S
Sarah Morgensen wrote on 27 Jul 2021 04:56
[PATCH core-updates 10/20] gnu: python-plotly: Remove obsolete phase.
(address . 49729@debbugs.gnu.org)
59ce03199c7c17e0b0696326776855e70067e698.1627351168.git.iskarian@mgsn.dev
* gnu/packages/graph.scm (python-plotly)[arguments]<#:phases>: Remove
'make-files-writable phase.
---
gnu/packages/graph.scm | 9 +--------
1 file changed, 1 insertion(+), 8 deletions(-)

Toggle diff (22 lines)
diff --git a/gnu/packages/graph.scm b/gnu/packages/graph.scm
index 42bd37a07a..01e9b853ea 100644
--- a/gnu/packages/graph.scm
+++ b/gnu/packages/graph.scm
@@ -183,14 +183,7 @@ lines.")
(invoke "pytest" "-x" "plotly/tests/test_io")
;; FIXME: Add optional dependencies and enable their tests.
;; (invoke "pytest" "-x" "plotly/tests/test_optional")
- (invoke "pytest" "_plotly_utils/tests"))
- #t))
- (add-before 'reset-gzip-timestamps 'make-files-writable
- (lambda* (#:key outputs #:allow-other-keys)
- (let ((out (assoc-ref outputs "out")))
- (for-each (lambda (file) (chmod file #o644))
- (find-files out "\\.gz"))
- #t))))))
+ (invoke "pytest" "_plotly_utils/tests")))))))
(native-inputs
`(("python-ipywidgets" ,python-ipywidgets)
("python-pytest" ,python-pytest)
--
2.31.1
S
S
Sarah Morgensen wrote on 27 Jul 2021 04:56
[PATCH core-updates 11/20] gnu: go-ipfs: Remove obsolete phase.
(address . 49729@debbugs.gnu.org)
21c73a9243ae770d3d94bfac0405cd0df88bccc0.1627351168.git.iskarian@mgsn.dev
* gnu/packages/ipfs.scm (go-ipfs)[arguments]<#:phases>: Remove
'make-files-writable phase.
---
gnu/packages/ipfs.scm | 11 +----------
1 file changed, 1 insertion(+), 10 deletions(-)

Toggle diff (24 lines)
diff --git a/gnu/packages/ipfs.scm b/gnu/packages/ipfs.scm
index 57701991e3..0739c2cf61 100644
--- a/gnu/packages/ipfs.scm
+++ b/gnu/packages/ipfs.scm
@@ -227,16 +227,7 @@ written in Go.")
(build-system go-build-system)
(arguments
'(#:unpack-path "github.com/ipfs/go-ipfs"
- #:import-path "github.com/ipfs/go-ipfs/cmd/ipfs"
- #:phases (modify-phases %standard-phases
- (add-before 'reset-gzip-timestamps 'make-files-writable
- (lambda* (#:key outputs #:allow-other-keys)
- ;; Make sure .gz files are writable so that the
- ;; 'reset-gzip-timestamps' phase can do its work.
- (let ((out (assoc-ref outputs "out")))
- (for-each make-file-writable
- (find-files out "\\.gz$"))
- #t))))))
+ #:import-path "github.com/ipfs/go-ipfs/cmd/ipfs"))
(home-page "https://ipfs.io")
(synopsis "Go implementation of IPFS, a peer-to-peer hypermedia protocol")
(description "IPFS is a global, versioned, peer-to-peer file system. It
--
2.31.1
S
S
Sarah Morgensen wrote on 27 Jul 2021 04:56
[PATCH core-updates 12/20] gnu: python-scikit-learn: Remove obsolete phase.
(address . 49729@debbugs.gnu.org)
1b02f4fc0483562a3cfda85e4f2e5b263a7022ae.1627351168.git.iskarian@mgsn.dev
* gnu/packages/machine-learning.scm (python-scikit-learn)[arguments]
<#:phases>: Remove 'make-files-writable phase.
---
gnu/packages/machine-learning.scm | 10 +---------
1 file changed, 1 insertion(+), 9 deletions(-)

Toggle diff (23 lines)
diff --git a/gnu/packages/machine-learning.scm b/gnu/packages/machine-learning.scm
index 93eee3de88..bfc730f221 100644
--- a/gnu/packages/machine-learning.scm
+++ b/gnu/packages/machine-learning.scm
@@ -812,15 +812,7 @@ computing environments.")
;; Some tests require write access to $HOME.
(setenv "HOME" "/tmp")
- (invoke "pytest" "sklearn" "-m" "not network")))
- (add-before 'reset-gzip-timestamps 'make-files-writable
- (lambda* (#:key outputs #:allow-other-keys)
- ;; Make sure .gz files are writable so that the
- ;; 'reset-gzip-timestamps' phase can do its work.
- (let ((out (assoc-ref outputs "out")))
- (for-each make-file-writable
- (find-files out "\\.gz$"))
- #t))))))
+ (invoke "pytest" "sklearn" "-m" "not network"))))))
(inputs
`(("openblas" ,openblas)))
(native-inputs
--
2.31.1
S
S
Sarah Morgensen wrote on 27 Jul 2021 04:56
[PATCH core-updates 13/20] gnu: jalv-select: Remove obsolete phase.
(address . 49729@debbugs.gnu.org)
a7503c73389ff1e2a00321e80dd38f3c0ea5d29e.1627351168.git.iskarian@mgsn.dev
* gnu/packages/music.scm (jalv-select)[arguments]<#:phases>: Remove
'make-manpages-writable phase.
---
gnu/packages/music.scm | 10 +---------
1 file changed, 1 insertion(+), 9 deletions(-)

Toggle diff (23 lines)
diff --git a/gnu/packages/music.scm b/gnu/packages/music.scm
index 492103b715..f3da49ddd3 100644
--- a/gnu/packages/music.scm
+++ b/gnu/packages/music.scm
@@ -2029,15 +2029,7 @@ Editor. It is compatible with Power Tab Editor 1.7 and Guitar Pro.")
(lambda* (#:key inputs #:allow-other-keys)
(substitute* "jalv.select.cpp"
(("echo \\$PATH.*tr ':'.*xargs ls")
- (string-append "ls -1 " (assoc-ref inputs "jalv") "/bin")))
- #t))
- (add-before 'reset-gzip-timestamps 'make-manpages-writable
- (lambda* (#:key outputs #:allow-other-keys)
- (for-each make-file-writable
- (find-files (string-append (assoc-ref outputs "out")
- "/share/man")
- ".*\\.gz$"))
- #t)))))
+ (string-append "ls -1 " (assoc-ref inputs "jalv") "/bin"))))))))
(inputs
`(("lilv" ,lilv)
("lv2" ,lv2)
--
2.31.1
S
S
Sarah Morgensen wrote on 27 Jul 2021 04:56
[PATCH core-updates 14/20] gnu: lmms: Remove obsolete phase.
(address . 49729@debbugs.gnu.org)
c7cc02f82bc22ae16ce47972a21d2f8ee6bccfca.1627351168.git.iskarian@mgsn.dev
* gnu/packages/music.scm (lmms)[arguments]<#:phases>: Remove
'make-manpages-writable phase.
---
gnu/packages/music.scm | 11 +----------
1 file changed, 1 insertion(+), 10 deletions(-)

Toggle diff (24 lines)
diff --git a/gnu/packages/music.scm b/gnu/packages/music.scm
index f3da49ddd3..b9234d4996 100644
--- a/gnu/packages/music.scm
+++ b/gnu/packages/music.scm
@@ -4632,16 +4632,7 @@ are a C compiler and glib. Full API documentation and examples are included.")
(assoc-ref outputs "out") "/lib/lmms"
":"
(assoc-ref outputs "out") "/lib/lmms/ladspa"
- "\""))
- #t))
- (add-before 'reset-gzip-timestamps 'make-manpages-writable
- (lambda* (#:key outputs #:allow-other-keys)
- (map (lambda (file)
- (make-file-writable file))
- (find-files (string-append (assoc-ref outputs "out")
- "/share/man")
- ".*\\.gz$"))
- #t)))))
+ "\"")))))))
(native-inputs
`(("pkg-config" ,pkg-config)
("qttools" ,qttools)
--
2.31.1
S
S
Sarah Morgensen wrote on 27 Jul 2021 04:56
[PATCH core-updates 15/20] gnu: helm: Remove obsolete phase.
(address . 49729@debbugs.gnu.org)
06030a9455560cd273aa2e2d70fdc2830abf06e4.1627351168.git.iskarian@mgsn.dev
* gnu/packages/music.scm (helm)[arguments]<#:phases>: Remove
'make-gz-files-writable phase.
---
gnu/packages/music.scm | 6 ------
1 file changed, 6 deletions(-)

Toggle diff (19 lines)
diff --git a/gnu/packages/music.scm b/gnu/packages/music.scm
index b9234d4996..f9b93fb199 100644
--- a/gnu/packages/music.scm
+++ b/gnu/packages/music.scm
@@ -6156,12 +6156,6 @@ MIDI drums and comes as two separate drumkits: Black Pearl and Red Zeppelin.")
(substitute* "Makefile"
(("/usr") ""))
#t))
- (add-before 'reset-gzip-timestamps 'make-gz-files-writable
- (lambda* (#:key outputs #:allow-other-keys)
- (for-each make-file-writable
- (find-files (string-append (assoc-ref outputs "out"))
- ".*\\.gz$"))
- #t))
(delete 'configure))))
(inputs
`(("alsa-lib" ,alsa-lib)
--
2.31.1
S
S
Sarah Morgensen wrote on 27 Jul 2021 04:56
[PATCH core-updates 16/20] gnu: arcanist: Remove obsolete phase.
(address . 49729@debbugs.gnu.org)
7bad382096dbaf3f0aca5f7067c3e283d2a918b8.1627351168.git.iskarian@mgsn.dev
* gnu/packages/phabricator.scm (arcanist)[arguments]<#:phases>: Remove
'make-compressed-files-writable phase.
---
gnu/packages/phabricator.scm | 8 +-------
1 file changed, 1 insertion(+), 7 deletions(-)

Toggle diff (21 lines)
diff --git a/gnu/packages/phabricator.scm b/gnu/packages/phabricator.scm
index af95cd93d2..86fc7a0c12 100644
--- a/gnu/packages/phabricator.scm
+++ b/gnu/packages/phabricator.scm
@@ -62,13 +62,7 @@
`("PATH" ":" prefix
(,@(map (lambda (i)
(string-append (assoc-ref %build-inputs i) "/bin"))
- '("php" "git" "mercurial" "subversion"))))))
- #t))
- (add-before 'reset-gzip-timestamps 'make-compressed-files-writable
- (lambda _
- (for-each make-file-writable
- (find-files %output ".*\\.t?gz$"))
- #t)))))
+ '("php" "git" "mercurial" "subversion")))))))))))
(inputs
`(("php" ,php)
("git" ,git)
--
2.31.1
S
S
Sarah Morgensen wrote on 27 Jul 2021 04:56
[PATCH core-updates 17/20] gnu: python-pdfminer-six: Remove obsolete phase.
(address . 49729@debbugs.gnu.org)
d6c94d3d3d85ec50898f3d269eceea77368e07a2.1627351168.git.iskarian@mgsn.dev
* gnu/packages/python-xyz.scm (python-pdfminer-six)[arguments]
<#:phases>: Remove 'make-files-writable phase.
---
gnu/packages/python-xyz.scm | 8 +-------
1 file changed, 1 insertion(+), 7 deletions(-)

Toggle diff (21 lines)
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 60a0ea5f5d..5e99a892d3 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -13597,13 +13597,7 @@ module, adding support for Unicode strings.")
#t))
(replace 'check
(lambda _
- (invoke "make" "test")))
- (add-before 'reset-gzip-timestamps 'make-files-writable
- (lambda* (#:key outputs #:allow-other-keys)
- (let ((out (assoc-ref outputs "out")))
- (for-each make-file-writable
- (find-files out "\\.gz$"))
- #t))))))
+ (invoke "make" "test"))))))
(propagated-inputs
`(("python-chardet" ,python-chardet)
("python-cryptography" ,python-cryptography)
--
2.31.1
S
S
Sarah Morgensen wrote on 27 Jul 2021 04:56
[PATCH core-updates 18/20] gnu: go-github-com-prometheus-common: Remove obsolete phase.
(address . 49729@debbugs.gnu.org)
1aba445c679e00c1d048ecac66be4e2313c8f0dc.1627351168.git.iskarian@mgsn.dev
* gnu/packages/syncthing.scm (go-github-com-prometheus-common)
[arguments]<#:phases>: Remove 'make-gzip-archive-writable phase.
---
gnu/packages/syncthing.scm | 9 ---------
1 file changed, 9 deletions(-)

Toggle diff (22 lines)
diff --git a/gnu/packages/syncthing.scm b/gnu/packages/syncthing.scm
index 5cb8449e44..bc3640be8e 100644
--- a/gnu/packages/syncthing.scm
+++ b/gnu/packages/syncthing.scm
@@ -894,15 +894,6 @@ message streaming.")
#:tests? #f
#:phases
(modify-phases %standard-phases
- (add-before 'reset-gzip-timestamps 'make-gzip-archive-writable
- (lambda* (#:key outputs #:allow-other-keys)
- (map (lambda (file)
- (make-file-writable file))
- (find-files
- (string-append (assoc-ref outputs "out")
- "/src/github.com/prometheus/common/expfmt/testdata/")
- ".*\\.gz$"))
- #t))
;; Source-only package
(delete 'build))))
(propagated-inputs
--
2.31.1
S
S
Sarah Morgensen wrote on 27 Jul 2021 04:56
[PATCH core-updates 19/20] gnu: pre-commit: Remove obsolete phase.
(address . 49729@debbugs.gnu.org)
cce10a4e47a9b6387c720813a22194d3cd2c53c9.1627351168.git.iskarian@mgsn.dev
* gnu/packages/version-control.scm (pre-commit)[arguments]<#:phases>:
Remove 'make-gz-writable phase.
---
gnu/packages/version-control.scm | 9 +--------
1 file changed, 1 insertion(+), 8 deletions(-)

Toggle diff (22 lines)
diff --git a/gnu/packages/version-control.scm b/gnu/packages/version-control.scm
index 8bdac8df53..cae8077909 100644
--- a/gnu/packages/version-control.scm
+++ b/gnu/packages/version-control.scm
@@ -1569,14 +1569,7 @@ control to Git repositories.")
;; be possible to fix them.
"not test_install_existing_hooks_no_overwrite"
" and not test_uninstall_restores_legacy_hooks"
- " and not test_installed_from_venv")))))
- (add-before 'reset-gzip-timestamps 'make-gz-writable
- (lambda* (#:key outputs #:allow-other-keys)
- ;; Make sure .gz files are writable so that the
- ;; 'reset-gzip-timestamps' phase can do its work.
- (let ((out (assoc-ref outputs "out")))
- (for-each make-file-writable
- (find-files out "\\.gz$"))))))))
+ " and not test_installed_from_venv"))))))))
(native-inputs
`(("git" ,git-minimal)
("python-covdefaults" ,python-covdefaults)
--
2.31.1
S
S
Sarah Morgensen wrote on 27 Jul 2021 21:26
[PATCH core-updates 20/20] gnu: cpuid: Remove obsolete file permissions change.
(address . 49729@debbugs.gnu.org)
7ea269be17494a5b957cf20050dd7e8580d6a9fb.1627351168.git.iskarian@mgsn.dev
* gnu/packages/linux.scm (cpuid)[arguments]<#:phases>{fix-makefile}:
Remove Makefile gzip permissions patch.
---
gnu/packages/linux.scm | 7 +------
1 file changed, 1 insertion(+), 6 deletions(-)

Toggle diff (20 lines)
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 9e3ad367e2..d8787c9154 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -7073,12 +7073,7 @@ available in the kernel Linux.")
(add-before 'install 'fix-makefile
(lambda* (#:key outputs #:allow-other-keys)
(substitute* "Makefile"
- (("\\$\\(BUILDROOT\\)/usr") (assoc-ref outputs "out")))
- ;; Make the compressed manpages writable so that the
- ;; reset-gzip-timestamps phase does not error out.
- (substitute* "Makefile"
- (("-m 444") "-m 644"))
- #t)))))
+ (("\\$\\(BUILDROOT\\)/usr") (assoc-ref outputs "out"))))))))
(inputs `(("perl" ,perl)))
(supported-systems '("i686-linux" "x86_64-linux"))
(home-page "http://www.etallen.com/cpuid.html")
--
2.31.1
S
S
Sarah Morgensen wrote on 28 Jul 2021 03:21
Re: bug#49729: [PATCH core-updates] build-system/gnu: Make gzip files writable before resetting timestamps.
(name . Maxime Devos)(address . maximedevos@telenet.be)
864kcfp717.fsf_-_@mgsn.dev
Hello again,

Maxime Devos <maximedevos@telenet.be> writes:

Toggle quote (11 lines)
> Hi,
>
>> > This seems reasonable to me. There are 35 package definions referring to
>> > 'reset-gzip-timestamps', could you follow up with patches removing the phases
>> > for making gzip files writable?
>>
>> Yes, I intend to. Should I send them to this issue #, or separately?
>
> Personally, I'd send them to this issue # (easier to test whether this patch
> works that way).

I've sent a followup patchset; I only found 27 package definitions
referring to 'reset-gzip-timestamps', 7 of which delete the phase for
other reasons, as I've detailed in the cover letter. It's possible some
of these could be unnecessary after this change, but I'm not familiar
enough with the packages to tell.

Toggle quote (7 lines)
>
>> (And one commit per package, yes?)
> Indeed!
>
> Greetings,
> Maxime.

--
Sarah
A
A
Attila Lendvai wrote on 26 Oct 2021 15:14
(No Subject)
(name . 49729@debbugs.gnu.org)(address . 49729@debbugs.gnu.org)
eBJZ_6AmgIvDkXGY1s1gPEiUVYecaX81CvIBKjAubl6zInZl3r-mtGevK5Stz3RfDtOXylD0VeWlvOEoFQS9im-hBUezbgGsR3xW_hRpo7g=@lendvai.name
i'm working on the golang importer (testing it on go-ethereum), and i see multiple packages in its output that have this issue.

any ETA when this will reach master?

- attila
PGP: 5D5F 45C7 DFCD 0A39
Attachment: file
M
M
Maxim Cournoyer wrote on 24 Dec 2021 06:51
Re: bug#49729: [PATCH core-updates] build-system/gnu: Make gzip files writable before resetting timestamps.
(name . Attila Lendvai)(address . attila@lendvai.name)
87r1a2zh2o.fsf_-_@gmail.com
Hello,

Attila Lendvai <attila@lendvai.name> writes:

Toggle quote (7 lines)
> i'm working on the golang importer (testing it on go-ethereum), and i see multiple packages in its output that have this issue.
>
> any ETA when this will reach master?
>
> - attila
> PGP: 5D5F 45C7 DFCD 0A39

I've merged this to my local version-1.4.0 branch that I'll push
shortly, and if everything goes fine it should reach master in about a
week or so.

Thanks,

Maxim
M
M
Maxim Cournoyer wrote on 17 Jan 2022 18:09
(name . Attila Lendvai)(address . attila@lendvai.name)
8735lmjnlf.fsf_-_@gmail.com
Hello,

Maxim Cournoyer <maxim.cournoyer@gmail.com> writes:

Toggle quote (16 lines)
> Hello,
>
> Attila Lendvai <attila@lendvai.name> writes:
>
>> i'm working on the golang importer (testing it on go-ethereum), and
>> i see multiple packages in its output that have this issue.
>>
>> any ETA when this will reach master?
>>
>> - attila
>> PGP: 5D5F 45C7 DFCD 0A39
>
> I've merged this to my local version-1.4.0 branch that I'll push
> shortly, and if everything goes fine it should reach master in about a
> week or so.

This has now been merged back into master.

Closing.

Thank you!

Maxim
M
M
Maxim Cournoyer wrote on 20 Jan 21:50 +0100
control message for bug #49729
(address . control@debbugs.gnu.org)
87zfwzd90r.fsf@gmail.com
close 49729
quit
?