[PATCH] gnu: Update OpenZFS to 2.1.0.

  • Done
  • quality assurance status badge
Details
3 participants
  • Brice Waegeneire
  • Efraim Flashner
  • raid5atemyhomework
Owner
unassigned
Submitted by
raid5atemyhomework
Severity
normal
R
R
raid5atemyhomework wrote on 23 Jul 2021 17:07
(name . bug-guix@gnu.org)(address . bug-guix@gnu.org)
hnWKPsStLroua0pG1kyYHqam2ADsbaqPr1T1e7RdChJWKmXGUgC4YrLFB-tjkZYQvgV2YmOYinqfi9UwUMbh-DkFWHwt5Nh53YdW1FvpRas=@protonmail.com
From 14446422d6f7873b29d2fe04a9528de867b854b8 Mon Sep 17 00:00:00 2001
From: raid5atemyhomework <raid5atemyhomework@protonmail.com>
Date: Fri, 23 Jul 2021 23:01:30 +0800
Subject: [PATCH] gnu: Update OpenZFS to 2.1.0.

* gnu/packages/file-systems.scm [zfs]: Update to 2.1.0, add
support for new compatibility feature.
---
gnu/packages/file-systems.scm | 23 +++++++++++++++++++++--
1 file changed, 21 insertions(+), 2 deletions(-)

Toggle diff (48 lines)
diff --git a/gnu/packages/file-systems.scm b/gnu/packages/file-systems.scm
index b6d0bcbc55..463cc3a8b5 100644
--- a/gnu/packages/file-systems.scm
+++ b/gnu/packages/file-systems.scm
@@ -1171,7 +1171,7 @@ with the included @command{xfstests-check} helper.")
(define-public zfs
(package
(name "zfs")
- (version "2.0.5")
+ (version "2.1.0")
(outputs '("out" "module" "src"))
(source
(origin
@@ -1180,7 +1180,7 @@ with the included @command{xfstests-check} helper.")
"/download/zfs-" version
"/zfs-" version ".tar.gz"))
(sha256
- (base32 "1jbfm18hh9x4a9s5d7si8lapmq2aniphyriif9flrgsff26lj5rs"))))
+ (base32 "0kzkggwznp4m3503f2m4lcinbl99jg50j4asrwfpfk1862vdrgb0"))))
(build-system linux-module-build-system)
(arguments
`(;; The ZFS kernel module should not be downloaded since the license
@@ -1211,6 +1211,25 @@ with the included @command{xfstests-check} helper.")
(util-linux (assoc-ref inputs "util-linux"))
(nfs-utils (assoc-ref inputs "nfs-utils"))
(kmod (assoc-ref inputs "kmod-runtime")))
+ ;; New feature "compatibility=" in 2.1.0.
+ ;; This feature looks up in two locations:
+ ;; /etc/zfs/compatibility.d/
+ ;; /usr/share/zfs/compatibility.d/
+ ;; The first is intended for system-specific compatibility
+ ;; sets, while the second is what is installed with the
+ ;; OpenZFS package, so use the absolute path for the first
+ ;; (which requires patching in the file) and the store path
+ ;; for the second (which it gets by default).
+ (substitute* "include/sys/fs/zfs.h"
+ (("#define\tZPOOL_SYSCONF_COMPAT_D.*$")
+ ; Use absolute path.
+ "#define\tZPOOL_SYSCONF_COMPAT_D\t\"/etc/zfs/compatibility.d\"\n"))
+ ;; Also update the manual, which uses absolute paths, so that
+ ;; /usr/share/zfs/compatibility.d/ is referred via the store.
+ (substitute* '("man/man8/zpoolprops.8"
+ "man/man5/zpool-features.5")
+ (("/usr/share/zfs/compatibility.d")
+ (string-append out "/share/zfs/compatibility.d")))
(substitute* "etc/Makefile.in"
;; This just contains an example configuration file for
;; configuring ZFS on traditional init systems, skip it
--
2.31.1
R
R
raid5atemyhomework wrote on 23 Jul 2021 18:54
[PATCH v2] gnu: Update OpenZFS to 2.1.0.
(name . 49710@debbugs.gnu.org)(address . 49710@debbugs.gnu.org)
soHzScgmThRsvkK4gjjo9HYbXb9iGyOQiK4wMcV5QJXEkuGBwDcC5Gb1sIgTBKlVABQAPtecoiZJjkB2tt5KGHGSOPl0NmQqXtDgtABgDtE=@protonmail.com
Bleah, forgot to *completely* amend the commit that was using the release candidate...


From 14446422d6f7873b29d2fe04a9528de867b854b8 Mon Sep 17 00:00:00 2001
From: raid5atemyhomework <raid5atemyhomework@protonmail.com>
Date: Fri, 23 Jul 2021 23:01:30 +0800
Subject: [PATCH] gnu: Update OpenZFS to 2.1.0.

* gnu/packages/file-systems.scm [zfs]: Update to 2.1.0, add
support for new compatibility feature.
---
gnu/packages/file-systems.scm | 23 +++++++++++++++++++++--
1 file changed, 21 insertions(+), 2 deletions(-)

Toggle diff (48 lines)
diff --git a/gnu/packages/file-systems.scm b/gnu/packages/file-systems.scm
index b6d0bcbc55..463cc3a8b5 100644
--- a/gnu/packages/file-systems.scm
+++ b/gnu/packages/file-systems.scm
@@ -1171,7 +1171,7 @@ with the included @command{xfstests-check} helper.")
(define-public zfs
(package
(name "zfs")
- (version "2.0.5")
+ (version "2.1.0")
(outputs '("out" "module" "src"))
(source
(origin
@@ -1180,7 +1180,7 @@ with the included @command{xfstests-check} helper.")
"/download/zfs-" version
"/zfs-" version ".tar.gz"))
(sha256
- (base32 "1jbfm18hh9x4a9s5d7si8lapmq2aniphyriif9flrgsff26lj5rs"))))
+ (base32 "0kzkggwznp4m3503f2m4lcinbl99jg50j4asrwfpfk1862vdrgb0"))))
(build-system linux-module-build-system)
(arguments
`(;; The ZFS kernel module should not be downloaded since the license
@@ -1211,6 +1211,25 @@ with the included @command{xfstests-check} helper.")
(util-linux (assoc-ref inputs "util-linux"))
(nfs-utils (assoc-ref inputs "nfs-utils"))
(kmod (assoc-ref inputs "kmod-runtime")))
+ ;; New feature "compatibility=" in 2.1.0.
+ ;; This feature looks up in two locations:
+ ;; /etc/zfs/compatibility.d/
+ ;; /usr/share/zfs/compatibility.d/
+ ;; The first is intended for system-specific compatibility
+ ;; sets, while the second is what is installed with the
+ ;; OpenZFS package, so use the absolute path for the first
+ ;; (which requires patching in the file) and the store path
+ ;; for the second (which it gets by default).
+ (substitute* "include/sys/fs/zfs.h"
+ (("#define\tZPOOL_SYSCONF_COMPAT_D.*$")
+ ; Use absolute path.
+ "#define\tZPOOL_SYSCONF_COMPAT_D\t\"/etc/zfs/compatibility.d\"\n"))
+ ;; Also update the manual, which uses absolute paths, so that
+ ;; /usr/share/zfs/compatibility.d/ is referred via the store.
+ (substitute* '("man/man7/zpoolprops.7"
+ "man/man7/zpool-features.7")
+ (("/usr/share/zfs/compatibility.d")
+ (string-append out "/share/zfs/compatibility.d")))
(substitute* "etc/Makefile.in"
;; This just contains an example configuration file for
;; configuring ZFS on traditional init systems, skip it
--
2.31.1
R
R
raid5atemyhomework wrote on 1 Aug 2021 11:41
(name . 49710@debbugs.gnu.org)(address . 49710@debbugs.gnu.org)
8FkzJaxANgiWelAEjjaVDPgriGJ_7KyhPhtcycbFx4vx3-QlFc-45ty6h5nMU5QM94QMYJWwYQCBOX4lImSaiD0h6a4Y2nutgJjeeJiy6L4=@protonmail.com
BUMP
E
E
Efraim Flashner wrote on 2 Aug 2021 18:00
Re: bug#49710: [PATCH v2] gnu: Update OpenZFS to 2.1.0.
(name . raid5atemyhomework)(address . raid5atemyhomework@protonmail.com)(name . 49710-done@debbugs.gnu.org)(address . 49710@debbugs.gnu.org)
YQgWhGr1DJfNEqjy@3900XT
Thanks. Patch pushed.

--
Efraim Flashner <efraim@flashner.co.il> ????? ?????
GPG key = A28B F40C 3E55 1372 662D 14F7 41AA E7DC CA3D 8351
Confidentiality cannot be guaranteed on emails sent or received unencrypted
-----BEGIN PGP SIGNATURE-----

iQIzBAABCgAdFiEEoov0DD5VE3JmLRT3Qarn3Mo9g1EFAmEIFoQACgkQQarn3Mo9
g1HuJQ//XIDdfioSVTDewGKPSwMRHN4Y4l3YsHwPp6SkGtbCSdrK1qpoUtUzbbxN
97u5levdgXwldxaYhsXvXfI7wXBeVFFm3mrZ8gAlvJ7xMwRmRdb1DUVeUY7Hysa7
SfN8nM+P2PMGKNONvydyNyGFFCUlElztPWiCrvUTv8F3L/soA8IU0Wx8YwAaXP6n
0A/C+WxGBzcgF1qvN14M+N78GQ0KW+v2ZrLPBl5txNjPOoeLjOCswDRLBXO/xoxj
FK7Cdn2U+cWu+1x9qMIc3snPq2kbYnbkL9dlts0eExAKhhU90lebpwtqkZLBxM8p
we0aQeMSn2b874t0iL4MXfyObvaP9MQWN3DLrezxNk2qfHVuRSiZHucFGcZQbKg6
s5Tnganw/Leu+tCEPiQ1L49GUnzz3x7tv9QuPhhudxhWuR4S/0y5jhHuEVjlNUwr
QErz2mG0ZUTSw14inlUD2RbouN4IoAgrJOj9MbxgRoNVr5rasxLbpL9RWxsEjWzq
z90XiCUZ62N3QhzNQWhrK+9V8zM+zoQSu1LaMD2LeTSlLASWAa8yIaFdlkGIzzUG
OYZ5JZ8lq3/2mdU08KsqdHu9pqZaBnEupnAgKZwCVzIhpFki/MZCXDfHgA/upfNf
+0P3dGxGCth/Pht27Pdstqwex+XPjJuQpHX8oBc+9Hzy/Adr/TI=
=wkg4
-----END PGP SIGNATURE-----


B
B
Brice Waegeneire wrote on 26 Aug 2021 20:44
control message for bug #49710
(address . control@debbugs.gnu.org)
E1mJKN4-0003AK-V5@debbugs.gnu.org
close 49710
quit
?