[PATCH] gnu: Add swaylock-effects

  • Done
  • quality assurance status badge
Details
2 participants
  • Liliana Marie Prikler
  • phodina
Owner
unassigned
Submitted by
phodina
Severity
normal
P
P
phodina wrote on 23 Jul 2021 05:06
(name . guix-patches@gnu.org)(address . guix-patches@gnu.org)
CwBL6-F6YMX2ra9OLnCpVc0Ut5imO4U3CliYpqHflu7murpjD88BrLqx8Zlknyux3FwttwXK1t2r8wSaP9FqRsbiZaMfJBfX6xe45a7PcYA=@protonmail.com
---
Toggle diff (50 lines)
diff --git a/gnu/packages/wm.scm b/gnu/packages/wm.scm
index 920a7cbb3e..b214e2a31c 100644
--- a/gnu/packages/wm.scm
+++ b/gnu/packages/wm.scm
@@ -45,6 +45,7 @@
;;; Copyright © 2021 Sharlatan Hellseher <sharlatanus@gmail.com>
;;; Copyright © 2021 qblade <qblade@protonmail.com>
;;; Copyright © 2021 lasnesne <lasnesne@lagunposprasihopre.org>
+;;; Copyright © 2021 Petr Hodina <phodina@protonmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -82,6 +83,7 @@
#:use-module (gnu packages bison)
#:use-module (gnu packages build-tools) ;for meson-0.55
#:use-module (gnu packages calendar)
+ #:use-module (gnu packages commencement) ; for gcc>9
#:use-module (gnu packages datastructures)
#:use-module (gnu packages docbook)
#:use-module (gnu packages documentation)
@@ -1578,6 +1580,29 @@ modules for building a Wayland compositor.")
(description "Swaylock is a screen locking utility for Wayland compositors.")
(license license:expat))) ; MIT license

+(define-public swaylock-effects
+(package (inherit swaylock)
+ (name "swaylock-effects")
+ ;; Upstream v1.6-3 released on 16/11/2020
+ (version "5cb9579faaf5662b111f5722311b701eff1c1d00")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/mortie/swaylock-effects")
+ (commit version)))
+ (sha256
+ (base32
+ "036dkhfqgk7g9vbr5pxgrs66h5fz0rwdsc67i1w51aa9v01r35ca"))))
+ ; Requires gcc>=9 see the issue here
+ ; https://github.com/mortie/swaylock-effects/issues/26
+ (native-inputs `(("gcc-toolchain", gcc-toolchain-9)
+ ,@(package-native-inputs swaylock)))
+ (synopsis (string-append (package-synopsis swaylock) " with fancy effects"))
+ (description "Swaylock-effects is a fork of swaylock which adds built-in
+screenshots and image manipulation effects like blurring. It's inspired by
+i3lock-color, although the feature sets aren't perfectly overlapping.")
+ (home-page "https://github.com/mortie/swaylock-effects")))
+
(define-public swaybg
(package
(name "swaybg")
--
2.31.1
P
P
phodina wrote on 18 Sep 2021 10:04
Patch status
(name . 49702@debbugs.gnu.org)(address . 49702@debbugs.gnu.org)
tD_WeS72Cafk2XgCMbTRETFAdYdB5Ouaio6Fzg1QO1vzw-EZ-tmCGF1tPCnUIlf7IFf9y7hKCG3K_S3-PSJClgXRPFInh5BgJnZXWPtt8iY=@protonmail.com
Hi!

Is there anything to be fixed in order to upstream this patch?

Sent with [ProtonMail](https://protonmail.com/)Secure Email.
Attachment: file
L
L
Liliana Marie Prikler wrote on 18 Sep 2021 13:03
Re: [PATCH] gnu: Add swaylock-effects
783cd493b7610240bf7be4a8f94a3f1c2a4be77c.camel@gmail.com
Hi,

Am Freitag, den 23.07.2021, 03:06 +0000 schrieb phodina:
Toggle quote (44 lines)
> ---
> diff --git a/gnu/packages/wm.scm b/gnu/packages/wm.scm
> index 920a7cbb3e..b214e2a31c 100644
> --- a/gnu/packages/wm.scm
> +++ b/gnu/packages/wm.scm
> @@ -45,6 +45,7 @@
> ;;; Copyright © 2021 Sharlatan Hellseher <sharlatanus@gmail.com>
> ;;; Copyright © 2021 qblade <qblade@protonmail.com>
> ;;; Copyright © 2021 lasnesne <lasnesne@lagunposprasihopre.org>
> +;;; Copyright © 2021 Petr Hodina <phodina@protonmail.com>
> ;;;
> ;;; This file is part of GNU Guix.
> ;;;
> @@ -82,6 +83,7 @@
> #:use-module (gnu packages bison)
> #:use-module (gnu packages build-tools) ;for meson-0.55
> #:use-module (gnu packages calendar)
> + #:use-module (gnu packages commencement) ; for gcc>9
> #:use-module (gnu packages datastructures)
> #:use-module (gnu packages docbook)
> #:use-module (gnu packages documentation)
> @@ -1578,6 +1580,29 @@ modules for building a Wayland compositor.")
> (description "Swaylock is a screen locking utility for Wayland
> compositors.")
> (license license:expat))) ; MIT license
>
> +(define-public swaylock-effects
> +(package (inherit swaylock)
> + (name "swaylock-effects")
> + ;; Upstream v1.6-3 released on 16/11/2020
> + (version "5cb9579faaf5662b111f5722311b701eff1c1d00")
> + (source (origin
> + (method git-fetch)
> + (uri (git-reference
> + (url "https://github.com/mortie/swaylock-effects")
> + (commit version)))
> + (sha256
> + (base32
> + "036dkhfqgk7g9vbr5pxgrs66h5fz0rwdsc67i1w51aa9v01r35ca"
> ))))
> + ; Requires gcc>=9 see the issue here
> + ; https://github.com/mortie/swaylock-effects/issues/26
> + (native-inputs `(("gcc-toolchain", gcc-toolchain-9)
> + ,@(package-native-inputs swaylock)))
We don't typically use gcc-toolchain as package input, but rather gcc
itself. gcc-toolchain exists so that users can spawn an environment in
which gcc just works™.
Toggle quote (2 lines)
> + (synopsis (string-append (package-synopsis swaylock) " with fancy
> effects"))
Synopsis should be a simple string.
Toggle quote (6 lines)
> + (description "Swaylock-effects is a fork of swaylock which adds
> built-in
> +screenshots and image manipulation effects like blurring. It's
> inspired by
> +i3lock-color, although the feature sets aren't perfectly
> overlapping.")
It is preferable to describe software in its own terms rather than
other software. What about "Swaylock-effects is a fork of swaylock
with additional features, such as the ability to take a screenshot as
the background image, display a clock or apply image manipulation
techniques to the background image."?
Toggle quote (8 lines)
> +
> (define-public swaybg
> (package
> (name "swaybg")
> --
> 2.31.1
>
P
P
phodina wrote on 18 Sep 2021 14:14
[PATCH v2] gnu: Add swaylock-effects.
(name . Liliana Marie Prikler)(address . liliana.prikler@gmail.com)(address . 49702@debbugs.gnu.org)
yDhBv0fW4Gb-ibDazPjqlKWJttFpqg6ITNcjksm7tOci9iPT0fIGve6JlWm8AvxUCj_XcPOrpGq4CMSOy0hZAeaWya7XpT12sPb20R65RHo=@protonmail.com
Hi Liliana,

thanks for the inputs!

Toggle snippet (49 lines)
* gnu/packages/wm.scm (swaylock-effects): New variable.

diff --git a/gnu/packages/wm.scm b/gnu/packages/wm.scm
index 957c5a0d5a..f5f9583fa3 100644
--- a/gnu/packages/wm.scm
+++ b/gnu/packages/wm.scm
@@ -83,6 +83,7 @@
#:use-module (gnu packages bison)
#:use-module (gnu packages build-tools) ;for meson-0.55
#:use-module (gnu packages calendar)
+ #:use-module (gnu packages commencement) ; for gcc>9
#:use-module (gnu packages datastructures)
#:use-module (gnu packages docbook)
#:use-module (gnu packages documentation)
@@ -1617,6 +1618,30 @@ modules for building a Wayland compositor.")
(description "Swaylock is a screen locking utility for Wayland compositors.")
(license license:expat))) ; MIT license

+(define-public swaylock-effects
+ (package (inherit swaylock)
+ (name "swaylock-effects")
+ ;; Upstream v1.6-3 released on 16/11/2020
+ (version "5cb9579faaf5662b111f5722311b701eff1c1d00")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/mortie/swaylock-effects")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "036dkhfqgk7g9vbr5pxgrs66h5fz0rwdsc67i1w51aa9v01r35ca"))))
+ ; Requires gcc>=9 see the issue here
+ ; https://github.com/mortie/swaylock-effects/issues/26
+ (native-inputs `(("gcc", gcc-9)
+ ,@(package-native-inputs swaylock)))
+ (synopsis "Screen locking utility for Wayland compositors with effects")
+ (description "@code{Swaylock-effects} is a fork of swaylock with additional
+features, such as the ability to take a screenshot as the background image,
+display a clock or apply image manipulation techniques to the background image.")
+ (home-page "https://github.com/mortie/swaylock-effects")))
+
(define-public swaybg
(package
(name "swaybg")
--
2.32.0
L
L
Liliana Marie Prikler wrote on 18 Sep 2021 14:17
(name . phodina)(address . phodina@protonmail.com)(address . 49702@debbugs.gnu.org)
8a4128abf29310407d17d8fb4fba6e394d587aec.camel@gmail.com
Hi,

Am Samstag, den 18.09.2021, 12:14 +0000 schrieb phodina:
Toggle quote (30 lines)
> Hi Liliana,
>
> thanks for the inputs!
>
> --8<---------------cut here---------------start------------->8--
>
> * gnu/packages/wm.scm (swaylock-effects): New variable.
>
> diff --git a/gnu/packages/wm.scm b/gnu/packages/wm.scm
> index 957c5a0d5a..f5f9583fa3 100644
> --- a/gnu/packages/wm.scm
> +++ b/gnu/packages/wm.scm
> @@ -83,6 +83,7 @@
> #:use-module (gnu packages bison)
> #:use-module (gnu packages build-tools) ;for meson-0.55
> #:use-module (gnu packages calendar)
> + #:use-module (gnu packages commencement) ; for gcc>9
> #:use-module (gnu packages datastructures)
> #:use-module (gnu packages docbook)
> #:use-module (gnu packages documentation)
> @@ -1617,6 +1618,30 @@ modules for building a Wayland compositor.")
> (description "Swaylock is a screen locking utility for Wayland
> compositors.")
> (license license:expat))) ; MIT license
>
> +(define-public swaylock-effects
> + (package (inherit swaylock)
> + (name "swaylock-effects")
> + ;; Upstream v1.6-3 released on 16/11/2020
> + (version "5cb9579faaf5662b111f5722311b701eff1c1d00")
2020 isn't that far in the past. More importantly, if you do use
random commits, please follow the (git-version) scheme.
Toggle quote (23 lines)
> + (source (origin
> + (method git-fetch)
> + (uri (git-reference
> + (url "
> https://github.com/mortie/swaylock-effects")
> + (commit version)))
> + (file-name (git-file-name name version))
> + (sha256
> + (base32
> + "036dkhfqgk7g9vbr5pxgrs66h5fz0rwdsc67i1w51aa9
> v01r35ca"))))
> + ; Requires gcc>=9 see the issue here
> + ; https://github.com/mortie/swaylock-effects/issues/26
> + (native-inputs `(("gcc", gcc-9)
> + ,@(package-native-inputs swaylock)))
> + (synopsis "Screen locking utility for Wayland compositors
> with effects")
> + (description "@code{Swaylock-effects} is a fork of
> swaylock with additional
> +features, such as the ability to take a screenshot as the background
> image,
> +display a clock or apply image manipulation techniques to the
> background image.")
Assuming swaylock-effects is a command (is it?), @command{swaylock-
effects} would be the correct first word here.
Toggle quote (8 lines)
> )
> +
> (define-public swaybg
> (package
> (name "swaybg")
> --
> 2.32.0
P
P
phodina wrote on 18 Sep 2021 14:52
[PATCH v3] gnu: Add swaylock-effects.
(name . Liliana Marie Prikler)(address . liliana.prikler@gmail.com)(address . 49702@debbugs.gnu.org)
unDKb1hl1TC0nrOh3T-sINFfnz_1PwO-ag40T0svdOON6e6JxZwJoac-IEQiDH68K7UObeogISq4yP6CY4C69u6gFArBONdk1RjauWJCDG0=@protonmail.com
* gnu/packages/wm.scm (swaylock-effects): New variable.

Toggle diff (44 lines)
diff --git a/gnu/packages/wm.scm b/gnu/packages/wm.scm
index 957c5a0d5a..1cc68388b8 100644
--- a/gnu/packages/wm.scm
+++ b/gnu/packages/wm.scm
@@ -83,6 +83,7 @@
#:use-module (gnu packages bison)
#:use-module (gnu packages build-tools) ;for meson-0.55
#:use-module (gnu packages calendar)
+ #:use-module (gnu packages commencement) ; for gcc>9
#:use-module (gnu packages datastructures)
#:use-module (gnu packages docbook)
#:use-module (gnu packages documentation)
@@ -1617,6 +1618,31 @@ modules for building a Wayland compositor.")
(description "Swaylock is a screen locking utility for Wayland compositors.")
(license license:expat))) ; MIT license

+(define-public swaylock-effects
+ (let ((commit "5cb9579faaf5662b111f5722311b701eff1c1d00")
+ (revision "1"))
+ (package (inherit swaylock)
+ (name "swaylock-effects")
+ (version commit)
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/mortie/swaylock-effects")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "036dkhfqgk7g9vbr5pxgrs66h5fz0rwdsc67i1w51aa9v01r35ca"))))
+ ; Requires gcc>=9 see the issue here
+ ; https://github.com/mortie/swaylock-effects/issues/26
+ (native-inputs `(("gcc", gcc-9)
+ ,@(package-native-inputs swaylock)))
+ (synopsis "Screen locking utility for Wayland compositors with effects")
+ (description "@code{Swaylock-effects} is a fork of swaylock with additional
+features, such as the ability to take a screenshot as the background image,
+display a clock or apply image manipulation techniques to the background image.")
+ (home-page "https://github.com/mortie/swaylock-effects"))))
+
(define-public swaybg
(package
(name "swaybg")
--
2.32.0
L
L
Liliana Marie Prikler wrote on 18 Sep 2021 15:29
(name . phodina)(address . phodina@protonmail.com)(address . 49702@debbugs.gnu.org)
7d727558c666202450cc4f3818faba041d5ac8d4.camel@gmail.com
Pushed with the following changes:

Am Samstag, den 18.09.2021, 12:52 +0000 schrieb phodina:
Toggle quote (11 lines)
> * gnu/packages/wm.scm (swaylock-effects): New variable.
>
> diff --git a/gnu/packages/wm.scm b/gnu/packages/wm.scm
> index 957c5a0d5a..1cc68388b8 100644
> --- a/gnu/packages/wm.scm
> +++ b/gnu/packages/wm.scm
> @@ -83,6 +83,7 @@
> #:use-module (gnu packages bison)
> #:use-module (gnu packages build-tools) ;for meson-0.55
> #:use-module (gnu packages calendar)
> + #:use-module (gnu packages commencement) ; for gcc>9
Dropped, wouldn't be needed as (gnu packages gcc) is already imported.
Toggle quote (14 lines)
> #:use-module (gnu packages datastructures)
> #:use-module (gnu packages docbook)
> #:use-module (gnu packages documentation)
> @@ -1617,6 +1618,31 @@ modules for building a Wayland compositor.")
> (description "Swaylock is a screen locking utility for Wayland
> compositors.")
> (license license:expat))) ; MIT license
>
> +(define-public swaylock-effects
> + (let ((commit "5cb9579faaf5662b111f5722311b701eff1c1d00")
> + (revision "1"))
> + (package (inherit swaylock)
> + (name "swaylock-effects")
> + (version commit)
Used git-version.
Toggle quote (6 lines)
> + (source (origin
> + (method git-fetch)
> + (uri (git-reference
> + (url "
> https://github.com/mortie/swaylock-effects")
> + (commit version)))
Used commit.
Toggle quote (9 lines)
> + (file-name (git-file-name name version))
> + (sha256
> + (base32
> + "036dkhfqgk7g9vbr5pxgrs66h5fz0rwdsc67i1w51a
> a9v01r35ca"))))
> + ; Requires gcc>=9 see the issue here
> + ; https://github.com/mortie/swaylock-effects/issues/26
> + (native-inputs `(("gcc", gcc-9)
> + ,@(package-native-inputs swaylock)))
Dropped, instead configured and patched to not use SSE or mtune=native
for the sake of reproducible builds.
Toggle quote (10 lines)
> + (synopsis "Screen locking utility for Wayland
> compositors with effects")
> + (description "@code{Swaylock-effects} is a fork of
> swaylock with additional
> +features, such as the ability to take a screenshot as the background
> image,
> +display a clock or apply image manipulation techniques to the
> background image.")
> + (home-page "https://github.com/mortie/swaylock-effects"
> ))))
Indentation fixed.

Thanks
P
P
phodina wrote on 30 Oct 2021 23:26
(name . Liliana Marie Prikler)(address . liliana.prikler@gmail.com)(address . 49702@debbugs.gnu.org)
auTVputSCT_CB8QnWJNyExL_UK-g8v7rNWm0C2UBw2dqQ4N5iG8YfymxWvJDd5j7PZ4OGjeIbZ9WsCVMQk7h9Xe25k1JRGbmLYatm10EC-Y=@protonmail.com
Hi,

I'm just going through my open tickets and this one seems to be already merged in commit 511dc6877e0664d83fd800cc601fa94c231a0d0f.

Could you please confirm and close the ticket?
L
L
Liliana Marie Prikler wrote on 30 Oct 2021 23:35
(name . phodina)(address . phodina@protonmail.com)(address . 49702-done@debbugs.gnu.org)
f0ce730fe242ef449cbead823d0be5d285880db5.camel@gmail.com
Am Samstag, den 30.10.2021, 21:26 +0000 schrieb phodina:
Toggle quote (6 lines)
> Hi,
>
> I'm just going through my open tickets and this one seems to be
> already merged in commit 511dc6877e0664d83fd800cc601fa94c231a0d0f.
>
> Could you please confirm and close the ticket?
Indeed, I CC'd the wrong address when I pushed it.
Closed
?