Weston (Wayland Compositor)

  • Done
  • quality assurance status badge
Details
3 participants
  • Efraim Flashner
  • Sarah Morgensen
  • Raghav Gururajan
Owner
unassigned
Submitted by
Raghav Gururajan
Severity
normal
R
R
R
Raghav Gururajan wrote on 20 Jul 2021 16:36
[PATCH v1 1/5] gnu: weston: Update to 9.0.0 and adjust arguments+inputs accordingly.
(address . 49662@debbugs.gnu.org)(name . Raghav Gururajan)(address . rg@raghavgururajan.name)
20210720143657.31826-1-rg@raghavgururajan.name
* gnu/packages/freedesktop.scm (weston)[version]: Update to 9.0.0.
[configure-flags](c_link_args): New flag.
(simple-dmabuf-drm): Remove flag.
[native-inputs]: Add mscgen.
[inputs]: Add pipewire.
---
gnu/packages/freedesktop.scm | 30 +++++++++++++++++++-----------
1 file changed, 19 insertions(+), 11 deletions(-)

Toggle diff (71 lines)
diff --git a/gnu/packages/freedesktop.scm b/gnu/packages/freedesktop.scm
index 24f12a045a..c59efa67b4 100644
--- a/gnu/packages/freedesktop.scm
+++ b/gnu/packages/freedesktop.scm
@@ -75,6 +75,7 @@
#:use-module (gnu packages glib) ;intltool
#:use-module (gnu packages gnome)
#:use-module (gnu packages gperf)
+ #:use-module (gnu packages graph)
#:use-module (gnu packages graphviz)
#:use-module (gnu packages gstreamer)
#:use-module (gnu packages gtk)
@@ -1037,7 +1038,7 @@ applications, X servers (rootless or fullscreen) or other display servers.")
(define-public weston
(package
(name "weston")
- (version "6.0.1")
+ (version "9.0.0")
(source (origin
(method url-fetch)
(uri (string-append
@@ -1045,10 +1046,11 @@ applications, X servers (rootless or fullscreen) or other display servers.")
"weston-" version ".tar.xz"))
(sha256
(base32
- "1d2m658ll8x7prlsfk71qgw89c7dz6y7d6nndfxwl49fmrd6sbxz"))))
+ "1zlql0xgiqc3pvgbpnnvj4xvpd91pwva8qf83xfb23if377ddxaw"))))
(build-system meson-build-system)
(native-inputs
- `(("pkg-config" ,pkg-config)
+ `(("mscgen" ,mscgen)
+ ("pkg-config" ,pkg-config)
("xorg-server" ,xorg-server)))
(inputs
`(("cairo" ,cairo-xcb)
@@ -1069,19 +1071,25 @@ applications, X servers (rootless or fullscreen) or other display servers.")
("mtdev" ,mtdev)
("linux-pam" ,linux-pam)
("pango" ,pango)
+ ("pipewire" ,pipewire)
("wayland" ,wayland)
("wayland-protocols" ,wayland-protocols)
("xorg-server-xwayland" ,xorg-server-xwayland)))
(arguments
`(#:configure-flags
- (list "-Dbackend-rdp=false" ; TODO: Enable.
- "-Dremoting=false" ; TODO: Enable.
- "-Dsimple-dmabuf-drm=auto"
- "-Dsystemd=false"
- (string-append "-Dxwayland-path="
- (assoc-ref %build-inputs "xorg-server-xwayland")
- "/bin/Xwayland"))
- #:parallel-tests? #f ; Parallel tests cause failures.
+ (list
+ ;; Otherwise, the RUNPATH will lack the final path component.
+ (string-append "-Dc_link_args=-Wl,-rpath="
+ (assoc-ref %outputs "out") "/lib:"
+ (assoc-ref %outputs "out") "/lib/weston:"
+ (assoc-ref %outputs "out") "/lib/libweston-9")
+ "-Dbackend-rdp=false" ; TODO: Enable.
+ "-Dremoting=false" ; TODO: Enable.
+ "-Dsystemd=false"
+ (string-append "-Dxwayland-path="
+ (assoc-ref %build-inputs "xorg-server-xwayland")
+ "/bin/Xwayland"))
+ #:parallel-tests? #f ; Parallel tests cause failures.
#:phases
(modify-phases %standard-phases
(add-before 'configure 'use-elogind
--
2.32.0
R
R
Raghav Gururajan wrote on 20 Jul 2021 16:36
[PATCH v1 2/5] gnu: weston: Add missing inputs.
(address . 49662@debbugs.gnu.org)(name . Raghav Gururajan)(address . rg@raghavgururajan.name)
20210720143657.31826-2-rg@raghavgururajan.name
These new inputs are referenced by the package but was missing in
the package definition. Some of these inputs might have been used
by the package indirectly via propagation from other inputs.

* gnu/packages/freedesktop.scm (weston)[inputs]: Add glib, libdrm,
libpng, libx11, libxcb and pixman.
---
gnu/packages/freedesktop.scm | 6 ++++++
1 file changed, 6 insertions(+)

Toggle diff (33 lines)
diff --git a/gnu/packages/freedesktop.scm b/gnu/packages/freedesktop.scm
index c59efa67b4..a6e96dc500 100644
--- a/gnu/packages/freedesktop.scm
+++ b/gnu/packages/freedesktop.scm
@@ -1057,13 +1057,18 @@ applications, X servers (rootless or fullscreen) or other display servers.")
("colord" ,colord)
("dbus" ,dbus)
("elogind" ,elogind)
+ ("glib" ,glib)
("lcms" ,lcms)
+ ("libdrm" ,libdrm)
("libevdev" ,libevdev)
("libinput" ,libinput-minimal)
("libjpeg" ,libjpeg-turbo)
+ ("libpng" ,libpng)
("libunwind" ,libunwind)
("libva" ,libva)
("libwebp" ,libwebp)
+ ("libx11" ,libx11)
+ ("libxcb" ,libxcb)
("libxcursor" ,libxcursor)
("libxkbcommon" ,libxkbcommon)
("libxml2" ,libxml2)
@@ -1072,6 +1077,7 @@ applications, X servers (rootless or fullscreen) or other display servers.")
("linux-pam" ,linux-pam)
("pango" ,pango)
("pipewire" ,pipewire)
+ ("pixman" ,pixman)
("wayland" ,wayland)
("wayland-protocols" ,wayland-protocols)
("xorg-server-xwayland" ,xorg-server-xwayland)))
--
2.32.0
R
R
Raghav Gururajan wrote on 20 Jul 2021 16:36
[PATCH v1 3/5] gnu: freerdp: Propagate some inputs as per pkg-config files.
(address . 49662@debbugs.gnu.org)(name . Raghav Gururajan)(address . rg@raghavgururajan.name)
20210720143657.31826-3-rg@raghavgururajan.name
* gnu/packages/rdesktop.scm (freerdp)[inputs]: Move libxkbcommon,
openssl and wayland to ...
[propagated-inputs]: ... here.
---
gnu/packages/rdesktop.scm | 7 ++++---
1 file changed, 4 insertions(+), 3 deletions(-)

Toggle diff (29 lines)
diff --git a/gnu/packages/rdesktop.scm b/gnu/packages/rdesktop.scm
index 30523deefe..adfbe7de06 100644
--- a/gnu/packages/rdesktop.scm
+++ b/gnu/packages/rdesktop.scm
@@ -108,7 +108,6 @@ to remotely control a user's Windows desktop.")
("libjpeg" ,libjpeg-turbo)
("libusb" ,libusb)
("libx11" ,libx11)
- ("libxkbcommon" ,libxkbcommon)
("libxkbfile" ,libxkbfile)
("libxcursor" ,libxcursor)
("libxext" ,libxext)
@@ -118,10 +117,12 @@ to remotely control a user's Windows desktop.")
("libxrender" ,libxrender)
("libxinerama" ,libxinerama)
("libxshmfence" ,libxshmfence)
- ("openssl" ,openssl)
("pulseaudio" ,pulseaudio)
- ("wayland" ,wayland)
("zlib" ,zlib)))
+ (propagated-inputs
+ `(("libxkbcommon" ,libxkbcommon)
+ ("openssl" ,openssl)
+ ("wayland" ,wayland)))
(arguments
`(#:build-type "RELEASE"
#:configure-flags
--
2.32.0
R
R
Raghav Gururajan wrote on 20 Jul 2021 16:36
[PATCH v1 4/5] gnu: weston: Enable some features.
(address . 49662@debbugs.gnu.org)(name . Raghav Gururajan)(address . rg@raghavgururajan.name)
20210720143657.31826-4-rg@raghavgururajan.name
* gnu/packages/freedesktop.scm (weston)[inputs]: Add freerdp,
gstreamer and gst-plugins-base.
[configure-flags](backend-rdp,remoting): Remove flags.
(backend-default): New flag.
---
gnu/packages/freedesktop.scm | 7 +++++--
1 file changed, 5 insertions(+), 2 deletions(-)

Toggle diff (35 lines)
diff --git a/gnu/packages/freedesktop.scm b/gnu/packages/freedesktop.scm
index a6e96dc500..f05b5927f9 100644
--- a/gnu/packages/freedesktop.scm
+++ b/gnu/packages/freedesktop.scm
@@ -97,6 +97,7 @@
#:use-module (gnu packages python)
#:use-module (gnu packages python-crypto)
#:use-module (gnu packages python-xyz)
+ #:use-module (gnu packages rdesktop)
#:use-module (gnu packages samba)
#:use-module (gnu packages sqlite)
#:use-module (gnu packages valgrind)
@@ -1057,7 +1058,10 @@ applications, X servers (rootless or fullscreen) or other display servers.")
("colord" ,colord)
("dbus" ,dbus)
("elogind" ,elogind)
+ ("freerdp" ,freerdp)
("glib" ,glib)
+ ("gstreamer" ,gstreamer)
+ ("gst-plugins-base" ,gst-plugins-base)
("lcms" ,lcms)
("libdrm" ,libdrm)
("libevdev" ,libevdev)
@@ -1089,8 +1093,7 @@ applications, X servers (rootless or fullscreen) or other display servers.")
(assoc-ref %outputs "out") "/lib:"
(assoc-ref %outputs "out") "/lib/weston:"
(assoc-ref %outputs "out") "/lib/libweston-9")
- "-Dbackend-rdp=false" ; TODO: Enable.
- "-Dremoting=false" ; TODO: Enable.
+ "-Dbackend-default=auto"
"-Dsystemd=false"
(string-append "-Dxwayland-path="
(assoc-ref %build-inputs "xorg-server-xwayland")
--
2.32.0
R
R
Raghav Gururajan wrote on 20 Jul 2021 16:36
[PATCH v1 5/5] gnu: weston: Propagate some inputs as per pkg-config files.
(address . 49662@debbugs.gnu.org)(name . Raghav Gururajan)(address . rg@raghavgururajan.name)
20210720143657.31826-5-rg@raghavgururajan.name
* gnu/packages/freedesktop.scm (weston)[inputs]: Move libxkbcommon,
pixman and wayland to ...
[propagated-inputs]: ... here.
---
gnu/packages/freedesktop.scm | 7 ++++---
1 file changed, 4 insertions(+), 3 deletions(-)

Toggle diff (28 lines)
diff --git a/gnu/packages/freedesktop.scm b/gnu/packages/freedesktop.scm
index f05b5927f9..401d15a2df 100644
--- a/gnu/packages/freedesktop.scm
+++ b/gnu/packages/freedesktop.scm
@@ -1074,17 +1074,18 @@ applications, X servers (rootless or fullscreen) or other display servers.")
("libx11" ,libx11)
("libxcb" ,libxcb)
("libxcursor" ,libxcursor)
- ("libxkbcommon" ,libxkbcommon)
("libxml2" ,libxml2)
("mesa" ,mesa)
("mtdev" ,mtdev)
("linux-pam" ,linux-pam)
("pango" ,pango)
("pipewire" ,pipewire)
- ("pixman" ,pixman)
- ("wayland" ,wayland)
("wayland-protocols" ,wayland-protocols)
("xorg-server-xwayland" ,xorg-server-xwayland)))
+ (propagated-inputs
+ `(("libxkbcommon" ,libxkbcommon)
+ ("pixman" ,pixman)
+ ("wayland" ,wayland)))
(arguments
`(#:configure-flags
(list
--
2.32.0
E
E
Efraim Flashner wrote on 20 Jul 2021 20:25
(name . Raghav Gururajan)(address . rg@raghavgururajan.name)(address . 49662@debbugs.gnu.org)
YPcVBSESTgvSk+js@3900XT
On Tue, Jul 20, 2021 at 10:36:57AM -0400, Raghav Gururajan via Guix-patches via wrote:
Toggle quote (5 lines)
> * gnu/packages/freedesktop.scm (weston)[inputs]: Move libxkbcommon,
> pixman and wayland to ...
> [propagated-inputs]: ... here.
> ---

you added pixman in a previous patch. I would combine the two patches
for adding more inputs and moving others to propagated-inputs with a
'fixup package inputs' or a subject line similar to that.

Toggle quote (36 lines)
> gnu/packages/freedesktop.scm | 7 ++++---
> 1 file changed, 4 insertions(+), 3 deletions(-)
>
> diff --git a/gnu/packages/freedesktop.scm b/gnu/packages/freedesktop.scm
> index f05b5927f9..401d15a2df 100644
> --- a/gnu/packages/freedesktop.scm
> +++ b/gnu/packages/freedesktop.scm
> @@ -1074,17 +1074,18 @@ applications, X servers (rootless or fullscreen) or other display servers.")
> ("libx11" ,libx11)
> ("libxcb" ,libxcb)
> ("libxcursor" ,libxcursor)
> - ("libxkbcommon" ,libxkbcommon)
> ("libxml2" ,libxml2)
> ("mesa" ,mesa)
> ("mtdev" ,mtdev)
> ("linux-pam" ,linux-pam)
> ("pango" ,pango)
> ("pipewire" ,pipewire)
> - ("pixman" ,pixman)
> - ("wayland" ,wayland)
> ("wayland-protocols" ,wayland-protocols)
> ("xorg-server-xwayland" ,xorg-server-xwayland)))
> + (propagated-inputs
> + `(("libxkbcommon" ,libxkbcommon)
> + ("pixman" ,pixman)
> + ("wayland" ,wayland)))
> (arguments
> `(#:configure-flags
> (list
> --
> 2.32.0
>
>
>
>

--
Efraim Flashner <efraim@flashner.co.il> ????? ?????
GPG key = A28B F40C 3E55 1372 662D 14F7 41AA E7DC CA3D 8351
Confidentiality cannot be guaranteed on emails sent or received unencrypted
-----BEGIN PGP SIGNATURE-----

iQIzBAABCgAdFiEEoov0DD5VE3JmLRT3Qarn3Mo9g1EFAmD3FQUACgkQQarn3Mo9
g1FKQQ//UnrZMYsfSEvUKuqwy0+k6zFC5U/aUMDmDLkeeF4WOhEmGX32d2FkZQFy
uIJNL0y0IkEAK+d89gwutT7VRoukGksgHUNPzgJ4C6HJY7OmZTkiaEeZCF2pcf4l
TnDbD8wp16PWqpZYwVKPptjXeDqTW3iaxWtT1iNu7TktO6qiL31JAxNJTLmisEXO
diVvyOTAMob6yZLnucjpl/3ksOaL3I2wYiKqk/sBHtfwQ1j6DxMK76qyid+3ZTWs
A+1ntsqTtEb+CZaCfGs4qat7pN2SQzF6wU+8VrJuNc8LS0FnBq3x5w95umL4DjMR
qPUAO5JtByGl/C8io3DfVmQQrygMC37gJyXdYTAIfeu1efDOuW6Fqj0ihbMkznoI
r4Ib/QuFWdgErzo/j7EkdDGZ6XFWauRx4yGK8WxQXXgkutpMJJoPb/prTuZgnpaz
Ln4G6uVVR8Oi5mV+5esGj/MJ/XiDHi9BLSb+tTvlFa6vmWIzHW+pKL1UbN7fHp+Z
bqhOaIZrNJ5U/BzXGAU9gmpcH9FHBwTSZygaCiZrbS7W+WuI5WrKvacsOjkgkaOV
HEzRIOcbEM+X86LOgOy1uOUKGL0w9JZdu/Ga8gAm7q/qDDD8N7oIS/w6vo5ErEZ8
iev8IAQwM+eKhH36grvl7FGJqff5U4vkVaIC4anAzG95qsVPHPU=
=YwLd
-----END PGP SIGNATURE-----


E
E
Efraim Flashner wrote on 20 Jul 2021 20:27
Re: [bug#49662] [PATCH v1 1/5] gnu: weston: Update to 9.0.0 and adjust arguments+inputs accordingly.
(name . Raghav Gururajan)(address . rg@raghavgururajan.name)(address . 49662@debbugs.gnu.org)
YPcVetvv8grbpJnC@3900XT
On Tue, Jul 20, 2021 at 10:36:53AM -0400, Raghav Gururajan via Guix-patches via wrote:
Toggle quote (69 lines)
> * gnu/packages/freedesktop.scm (weston)[version]: Update to 9.0.0.
> [configure-flags](c_link_args): New flag.
> (simple-dmabuf-drm): Remove flag.
> [native-inputs]: Add mscgen.
> [inputs]: Add pipewire.
> ---
> gnu/packages/freedesktop.scm | 30 +++++++++++++++++++-----------
> 1 file changed, 19 insertions(+), 11 deletions(-)
>
> diff --git a/gnu/packages/freedesktop.scm b/gnu/packages/freedesktop.scm
> index 24f12a045a..c59efa67b4 100644
> --- a/gnu/packages/freedesktop.scm
> +++ b/gnu/packages/freedesktop.scm
> @@ -75,6 +75,7 @@
> #:use-module (gnu packages glib) ;intltool
> #:use-module (gnu packages gnome)
> #:use-module (gnu packages gperf)
> + #:use-module (gnu packages graph)
> #:use-module (gnu packages graphviz)
> #:use-module (gnu packages gstreamer)
> #:use-module (gnu packages gtk)
> @@ -1037,7 +1038,7 @@ applications, X servers (rootless or fullscreen) or other display servers.")
> (define-public weston
> (package
> (name "weston")
> - (version "6.0.1")
> + (version "9.0.0")
> (source (origin
> (method url-fetch)
> (uri (string-append
> @@ -1045,10 +1046,11 @@ applications, X servers (rootless or fullscreen) or other display servers.")
> "weston-" version ".tar.xz"))
> (sha256
> (base32
> - "1d2m658ll8x7prlsfk71qgw89c7dz6y7d6nndfxwl49fmrd6sbxz"))))
> + "1zlql0xgiqc3pvgbpnnvj4xvpd91pwva8qf83xfb23if377ddxaw"))))
> (build-system meson-build-system)
> (native-inputs
> - `(("pkg-config" ,pkg-config)
> + `(("mscgen" ,mscgen)
> + ("pkg-config" ,pkg-config)
> ("xorg-server" ,xorg-server)))
> (inputs
> `(("cairo" ,cairo-xcb)
> @@ -1069,19 +1071,25 @@ applications, X servers (rootless or fullscreen) or other display servers.")
> ("mtdev" ,mtdev)
> ("linux-pam" ,linux-pam)
> ("pango" ,pango)
> + ("pipewire" ,pipewire)
> ("wayland" ,wayland)
> ("wayland-protocols" ,wayland-protocols)
> ("xorg-server-xwayland" ,xorg-server-xwayland)))
> (arguments
> `(#:configure-flags
> - (list "-Dbackend-rdp=false" ; TODO: Enable.
> - "-Dremoting=false" ; TODO: Enable.
> - "-Dsimple-dmabuf-drm=auto"
> - "-Dsystemd=false"
> - (string-append "-Dxwayland-path="
> - (assoc-ref %build-inputs "xorg-server-xwayland")
> - "/bin/Xwayland"))
> - #:parallel-tests? #f ; Parallel tests cause failures.
> + (list
> + ;; Otherwise, the RUNPATH will lack the final path component.
> + (string-append "-Dc_link_args=-Wl,-rpath="
> + (assoc-ref %outputs "out") "/lib:"
> + (assoc-ref %outputs "out") "/lib/weston:"
> + (assoc-ref %outputs "out") "/lib/libweston-9")

rather (untested):
(assoc-ref %outputs "out") "/lib/libweston-" (version-major ,version))

Toggle quote (17 lines)
> + "-Dbackend-rdp=false" ; TODO: Enable.
> + "-Dremoting=false" ; TODO: Enable.
> + "-Dsystemd=false"
> + (string-append "-Dxwayland-path="
> + (assoc-ref %build-inputs "xorg-server-xwayland")
> + "/bin/Xwayland"))
> + #:parallel-tests? #f ; Parallel tests cause failures.
> #:phases
> (modify-phases %standard-phases
> (add-before 'configure 'use-elogind
> --
> 2.32.0
>
>
>
>

--
Efraim Flashner <efraim@flashner.co.il> ????? ?????
GPG key = A28B F40C 3E55 1372 662D 14F7 41AA E7DC CA3D 8351
Confidentiality cannot be guaranteed on emails sent or received unencrypted
-----BEGIN PGP SIGNATURE-----

iQIzBAABCgAdFiEEoov0DD5VE3JmLRT3Qarn3Mo9g1EFAmD3FXoACgkQQarn3Mo9
g1F2qhAAqOX49Z8mpVBnWoIqRccVd2+w7ENcI76LSUVOeuON/iQOE9TvN5FmuRkt
9bmaVAiMA8LuBfJZ3nqXiEnOAIpapRRarm3Dbq4BrrX8j0fyRI+y80AaYv3j7By/
esdsBaO1aFK87UhnbeJozoUOZE5t4YJEu1OzsZlmJ8HrC1j+kMhnnMlOaPQByLNs
JbUCx0Uzmia+4hi7lMJEE88SrzYZ0dXPNx1xm1H3iRpqTSkWpGye4lmLD+1SNLdr
fOFy2MsE90BEqfsOYMnANMnors7waZJglrHuKtop0F8E2CIQJfz2nEmVwNtNp5Lu
WTqgDawf8IUsdqkxs1IK2hMTQZD7/yPbjO4xNj07ZYFtxzhMsZTOrUEZ5bAF2KT3
AscwCE5YZCQ2nUvlB9oS4xlKs1/Y/5Rki8hSqRtum7gC3x8ulb/t+4jSqI/hxHYq
X4OmzVFxORBl+ZZUvuhbMbelJ+mWAg4wyZ7MrY1HUlA3W7EZJeB1hrkjTz14wQlv
jPLmmftmsuFV2f1R6cl3M0LlRjIc5SJ0tjn3qWCYRhwLz1gortOQ7Z33t4QLNU3x
gEVjoTYgXcqfGd+K46ZcrkSijOfu/g7K4pZPGIEl5R3GEFZzlULIszEACPG20nWz
7gzK16Z/zbRAMUJ0miizIEyoAX/5SHuLC9B5se7HhjYPY+Pqsug=
=Kw7H
-----END PGP SIGNATURE-----


S
S
Sarah Morgensen wrote on 21 Jul 2021 21:30
Re: bug#49662: Weston (Wayland Compositor)
(name . Efraim Flashner)(address . efraim@flashner.co.il)
86wnpjsbvu.fsf_-_@mgsn.dev
Efraim Flashner <efraim@flashner.co.il> writes:

[...]

Toggle quote (7 lines)
>> + (assoc-ref %outputs "out") "/lib:"
>> + (assoc-ref %outputs "out") "/lib/weston:"
>> + (assoc-ref %outputs "out") "/lib/libweston-9")
>
> rather (untested):
> (assoc-ref %outputs "out") "/lib/libweston-" (version-major ,version))

Or perhaps more robustly (in case of inheritance):
(assoc-ref %outputs "out") "/lib/libweston-" (version-major
,(package-version this-package))

--
Sarah
E
E
Efraim Flashner wrote on 22 Jul 2021 08:34
(name . Sarah Morgensen)(address . iskarian@mgsn.dev)
YPkRgSq22055xlSQ@3900XT
On Wed, Jul 21, 2021 at 12:30:29PM -0700, Sarah Morgensen wrote:
Toggle quote (16 lines)
> Efraim Flashner <efraim@flashner.co.il> writes:
>
> [...]
>
> >> + (assoc-ref %outputs "out") "/lib:"
> >> + (assoc-ref %outputs "out") "/lib/weston:"
> >> + (assoc-ref %outputs "out") "/lib/libweston-9")
> >
> > rather (untested):
> > (assoc-ref %outputs "out") "/lib/libweston-" (version-major ,version))
>
> Or perhaps more robustly (in case of inheritance):
> (assoc-ref %outputs "out") "/lib/libweston-" (version-major
> ,(package-version this-package))
>

That is nicer. I should get more used to using this-package.

--
Efraim Flashner <efraim@flashner.co.il> ????? ?????
GPG key = A28B F40C 3E55 1372 662D 14F7 41AA E7DC CA3D 8351
Confidentiality cannot be guaranteed on emails sent or received unencrypted
-----BEGIN PGP SIGNATURE-----

iQIzBAABCgAdFiEEoov0DD5VE3JmLRT3Qarn3Mo9g1EFAmD5EX4ACgkQQarn3Mo9
g1GRZA//UQm/AY+ElTrOZ0E/nqMSnKhrRPA98R7UdCm35K7c/R6pfzVzDUSHQXui
Vu7WuNow/+N+ZPPfOp2RSruXKp1kCicjqPtdLUUdDGSTxVHkU609PGakoyJFPZFN
ivX2VNjmnxrvSWKOH77ObwnkG0E4BZXFWRtxraR9BKr72VILHfooxwIxGGWWnhP5
3PqvJw+ThTa5NvEh3WnjT4Jt8ljIHxl4ehbEkPJbTGIy75RF9+6qLLnIUlKf6T2U
aXLoK15V/UF/fuZgCjWDafVwdQpdiQ4fYB8tQonwBAMtY2ppKcYA9OVOASKIgZS4
5mEqR6eT2WPkgriuSjzeZ6OpWhECGTIgwaEflKNWsl+/54GA8SBRi3Paffu4REN2
nSdSvpAe7uEvUmvZUBDph7ERazO06qM65Rd3dg15S1J/TGqar8TCuR2QmfyhP+xv
/Gm0F+IYUWEs1IOnZsyDRCehXzHCFFPIOBMXnQcjNSKGXeNr3O4iLrDN/GqlTYGX
a7GyEqRqCpPik9u7wYvJcqxAy84R6FBcDufX1k6Sio4C4Y3kbCc8SeqbaLLE5RgH
bnaTWnn7gV5UirG+1r+i04vXtr0r1QA9kAxTEo39/LOyc56x9lWDJ3hhv01lGk9U
+XsEK2djRzw1/3vA/11GAvaD+hWT/52eIEbj4lEQICW0uHCWJp0=
=WLCv
-----END PGP SIGNATURE-----


R
R
Raghav Gururajan wrote on 25 Jul 2021 08:18
(no subject)
(address . 49662-done@debbugs.gnu.org)
20210725021823.22032dd5.rg@raghavgururajan.name
@Efraim and @Sarah

Thanks for the suggestions.

Pushed as 45881ea747..f703bef87a to master. Closing.

Regards,
RG.
-----BEGIN PGP SIGNATURE-----

iHUEARYKAB0WIQTNLV6qqYzLN9qR1rBfWBZkf4vlUQUCYP0CLwAKCRBfWBZkf4vl
URdTAPwJqct8W/j/p3UhotEN143LZxsVXHoQy4FjuBijNbq/gAEAzamH6WVVw64d
X1jS3pHncPnATKQdm6w7B19EdLx3wwI=
=0D8A
-----END PGP SIGNATURE-----


Closed
?