[PATCH] gnu: Add r-rpostgres.

  • Done
  • quality assurance status badge
Details
2 participants
  • Peter Lo
  • Ricardo Wurmus
Owner
unassigned
Submitted by
Peter Lo
Severity
normal
P
P
Peter Lo wrote on 18 Jul 2021 13:05
(address . guix-patches@gnu.org)(name . Peter Lo)(address . peterloleungyau@gmail.com)
20210718110546.23602-1-peterloleungyau@gmail.com
* gnu/packages/cran.scm (r-rpostgres): New variable.
---
gnu/packages/cran.scm | 35 +++++++++++++++++++++++++++++++++++
1 file changed, 35 insertions(+)

Toggle diff (48 lines)
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 14177e3a23..203c49c9ca 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -4484,6 +4484,41 @@ to access PostgreSQL database systems.")
;; under the PostgreSQL license.
(license license:gpl2)))
+(define-public r-rpostgres
+ (package
+ (name "r-rpostgres")
+ (version "1.3.3")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "RPostgres" version))
+ (sha256
+ (base32
+ "0a3f7l1c0q732g8shys6g8f3nq2y3q7p840i0wdbyq0i243srfz0"))))
+ (properties `((upstream-name . "RPostgres")))
+ (build-system r-build-system)
+ (inputs
+ `(("postgresql" ,postgresql)))
+ (propagated-inputs
+ `(("r-bit64" ,r-bit64)
+ ("r-blob" ,r-blob)
+ ("r-dbi" ,r-dbi)
+ ("r-hms" ,r-hms)
+ ("r-lubridate" ,r-lubridate)
+ ("r-plogr" ,r-plogr)
+ ("r-rcpp" ,r-rcpp)
+ ("r-withr" ,r-withr)))
+ (native-inputs
+ `(("pkg-config" ,pkg-config)
+ ("r-knitr" ,r-knitr)))
+ (home-page "https://rpostgres.r-dbi.org")
+ (synopsis "Rcpp Interface to PostgreSQL")
+ (description
+ "Fully @code{DBI}-compliant @code{Rcpp}-backed interface to
+@code{PostgreSQL} <https://www.postgresql.org/>, an open-source relational
+database.")
+ (license license:gpl3)))
+
(define-public r-linprog
(package
(name "r-linprog")
--
2.31.1
R
R
Ricardo Wurmus wrote on 29 Dec 2022 22:24
(address . 49618-done@debbugs.gnu.org)
87k0299a2w.fsf@elephly.net
Sorry I didn’t see this earlier. I applied it after changing the
description and upgrading the inputs to the new style.

Thanks!

--
Ricardo
Closed
?