(address . guix-patches@gnu.org)
- Jon 8 Jul 2021 22:48
- Jon 8 Jul 2021 22:50
- Mon 22 Jun 2022 21:43
- Jon 23 Jun 2022 01:54
- Jon 23 Jun 2022 06:12
[PATCH] gnu: Add python-beautysh.
J
(address . 49470@debbugs.gnu.org)(name . jgart)(address . jgart@dismail.de)
20210708205053.6985-1-jgart@dismail.de
* gnu/packages/python-xyz.scm (python-beautysh): New variable.
---
gnu/packages/python-xyz.scm | 26 ++++++++++++++++++++++++++
1 file changed, 26 insertions(+)
Toggle diff (39 lines)
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 2bb33dbd63..bde6ba851a 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -357,6 +357,32 @@ features of the Python's built-in dict.")
from a docstring rather than the other way around.")
(license license:mpl2.0)))
+(define-public python-beautysh
+ (package
+ (name "python-beautysh")
+ (version "6.1.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "beautysh" version))
+ (sha256
+ (base32
+ "0i6mnxhl3v48fx4hnd2q03rxy3wg6v444kjjjrm61lvshz5llswn"))))
+ (build-system python-build-system)
+ ;; Pypi release does not include tests and github release does not include
+ ;; setup.py.
+ (arguments
+ `(#:tests? #f))
+ (propagated-inputs
+ `(("python-colorama" ,python-colorama)))
+ (home-page
+ "https://github.com/lovesegfault/beautysh")
+ (synopsis "Bash beautifier for the masses")
+ (description "@command{beautysh} beautifies bash scripts. @command{beautysh}
+can be called from the command line or used as a module. In tests with large
+Linux system Bash scripts, its error-free score was ~99%.")
+ (license license:expat)))
+
(define-public python-cachetools
(package
(name "python-cachetools")
--
2.31.1
M
(address . 49470@debbugs.gnu.org)
87h74c4h76.fsf@gmail.com
tags 49470 moreinfo
thanks
Hi jgart,
"jgart" <jgart@dismail.de> writes:
Toggle quote (9 lines)
> Hi Guix,
>
> Here is a patch for python-beautysh, a bash beautifier.
>
> Pypi release does not include tests and github release does not
> include a setup.py because it is using poetry instead.
>
> What is the current recommended guix packaging practice for python projects that depend on poetry?
You can use python-pypa-build with python-poetry-core and override the
build and install phases as done in python-isort.
Could you attempt such a build? That we could run the test suite.
Thanks,
Maxim
J
(name . Maxim Cournoyer)(address . maxim.cournoyer@gmail.com)
20220622185406.GB11143@gac
On Wed, 22 Jun 2022 15:43:41 -0400 Maxim Cournoyer <maxim.cournoyer@gmail.com> wrote:
Toggle quote (2 lines)
> Could you attempt such a build? That we could run the test suite.
Hi Maxim,
What branch should I try that from?
If master, do you know of another example package that does that that I can use as a reference?
thanks,
jgart
?