(address . guix-patches@gnu.org)
Hi guix,
These two patches should speed up profile generation
by optimising the 'fonts-dir-file' hook. The first patch
is the most important; from the commit message:
‘Only let the build G-exp refer to inputs that might actually
have fonts. That way, if the list of fonts in the manifest
didn't change and the new manifest is built, the font files
will not be rebuilt.’
The second patch doesn't bring much.
To test, you can test whether things like ...
$ ./pre-inst-env guix environment --ad-hoc --pure lagrange -- lagrange
still work (lagrange is a graphical application using fonts).
Not sure what a good ‘benchmark’ would be.
Unfortunately, this does not help with the "guix package -i" case,
as in that case, the code doesn't have access to all the package objects,
and will have to satisfy itself with the store paths, in which case the
profile code pessimistically assumes the store item has fonts ...
I suppose this restriction could be lifted if/when the gs-fonts package
is renamed to font-ghostscript or something like that ...
However, the optimisation should work in the "guix environment ... --ad-hoc ...",
"guix system reconfigure ..." and (I'd presume) the guix home-manager cases,
though I only tested the first.
Greetings,
Maxime.
From a706b8be4f54530b1cd12c03a1bf3941be43be3c Mon Sep 17 00:00:00 2001
From: Maxime Devos <maximedevos@telenet.be>
Date: Mon, 5 Jul 2021 20:16:22 +0200
Subject: [PATCH 2/2] profiles: Avoid dependency on 'mkfontdir' and friend when
unused.
Avoid depending on on "mkfontdir" and "mkfontscale" if
they won't actually be used, to avoid building the
aforementioned packages when they are updated.
* guix/profiles.scm
(fonts-dir-file)[build]: Note why the '(null? fonts-dir)' check
cannot be removed.
(fonts-dir-file): When the 'relevant-inputs' list is empty,
just build an empty directory.
---
guix/profiles.scm | 25 ++++++++++++++++---------
1 file changed, 16 insertions(+), 9 deletions(-)
Toggle diff (45 lines)
diff --git a/guix/profiles.scm b/guix/profiles.scm
index 0f9df68f42..6cf480ddf2 100644
--- a/guix/profiles.scm
+++ b/guix/profiles.scm
@@ -1544,6 +1544,8 @@ files for the fonts of the @var{manifest} entries."
"/share/fonts")
'#$relevant-inputs))))
(mkdir #$output)
+ ;; has-fonts? can have false positives,
+ ;; so this check is necessary.
(if (null? fonts-dirs)
(exit #t)
(let* ((share-dir (string-append #$output "/share"))
@@ -1585,15 +1587,20 @@ files for the fonts of the @var{manifest} entries."
(delete-file fonts-dir-file))))
directories)))))))
- (gexp->derivation "fonts-dir" build
- #:modules '((guix build utils)
- (guix build union)
- (srfi srfi-26))
- #:local-build? #t
- #:substitutable? #f
- #:properties
- `((type . profile-hook)
- (hook . fonts-dir))))
+ (if (null? relevant-inputs)
+ ;; Avoid depending on on "mkfontdir" and "mkfontscale" if
+ ;; they won't actually be used, to avoid building the aforementioned
+ ;; packages when they are updated.
+ (lower-object (file-union "fonts-dir" '()))
+ (gexp->derivation "fonts-dir" build
+ #:modules '((guix build utils)
+ (guix build union)
+ (srfi srfi-26))
+ #:local-build? #t
+ #:substitutable? #f
+ #:properties
+ `((type . profile-hook)
+ (hook . fonts-dir)))))
(define (manual-database manifest)
"Return a derivation that builds the manual page database (\"mandb\") for
--
2.32.0
-----BEGIN PGP SIGNATURE-----
iI0EABYKADUWIQTB8z7iDFKP233XAR9J4+4iGRcl7gUCYONYOBccbWF4aW1lZGV2
b3NAdGVsZW5ldC5iZQAKCRBJ4+4iGRcl7lJtAP9nvaqaE+zY3PdMOWeNm3KRB0gn
Jg7olk/UOUwGsYucgAEA2flnKzsocky7i3yjttW1kFKdfasoNfjiUnMOziukKw0=
=6xxl
-----END PGP SIGNATURE-----