[PATCH 0/2] Remove unreachable GNA upstream

  • Done
  • quality assurance status badge
Details
2 participants
  • Ludovic Courtès
  • zimoun
Owner
unassigned
Submitted by
zimoun
Severity
normal
Z
Z
zimoun wrote on 2 Jul 2021 18:14
(address . guix-patches@gnu.org)(name . zimoun)(address . zimon.toutoune@gmail.com)
20210702161451.26533-1-zimon.toutoune@gmail.com
Hi,

These trivial patches allow to close the old report 25913 [1].
Since there is no apparent new upstream, the sources are hosted only by
Software Heritage.

To verify all is correct,

tar xf $(guix build -S guile-dbi)
guix hash -r guile-dbi-2.1.6/
09ys5hj7gnj5w1iv1m194j06jk6b8sdhc8j6hcv3bprq1428kyxw

guix hash -r $(./pre-inst-env guix build -S guile-dbi)
09ys5hj7gnj5w1iv1m194j06jk6b8sdhc8j6hcv3bprq1428kyxw

and

tar xf $(guix build -S guile-sqlite3)
guix hash -r guile-dbd-sqlite2-2.1.6/
1rwf3z6ib6nkhfnk2nw8p6fqirdx2pparcrlmsm0i2ii62plpqhb

guix hash -r $(./pre-inst-env guix build -S guile-dbd-sqlite3)
1rwf3z6ib6nkhfnk2nw8p6fqirdx2pparcrlmsm0i2ii62plpqhb


Cheers,
simon


zimoun (2):
gnu: guile-dbi: Replace 'url-fetch' by 'git-fetch'.
gnu: guile-dbd-sqlite3: Replace 'url-fetch' by 'git-fetch'.

gnu/packages/guile-xyz.scm | 26 +++++++++++++++-----------
1 file changed, 15 insertions(+), 11 deletions(-)


base-commit: 468caeb70140f2418cf269e7b1f09d40d6dcf9fb
--
2.32.0
Z
Z
zimoun wrote on 2 Jul 2021 18:18
[PATCH 2/2] gnu: guile-dbd-sqlite3: Replace 'url-fetch' by 'git-fetch'.
(address . 49333@debbugs.gnu.org)(name . zimoun)(address . zimon.toutoune@gmail.com)
20210702161809.26599-2-zimon.toutoune@gmail.com

* gnu/packages/guile-xyz.scm (guile-dbi)[source]: Replace 'url-fetch'
by'git-fetch'.
---
gnu/packages/guile-xyz.scm | 13 ++++++++-----
1 file changed, 8 insertions(+), 5 deletions(-)

Toggle diff (35 lines)
diff --git a/gnu/packages/guile-xyz.scm b/gnu/packages/guile-xyz.scm
index 3ce5b564e1..2a0f8cef98 100644
--- a/gnu/packages/guile-xyz.scm
+++ b/gnu/packages/guile-xyz.scm
@@ -1504,13 +1504,14 @@ It currently supports MySQL, Postgres and SQLite3.")
(name "guile-dbd-sqlite3")
(version "2.1.6")
(source (origin
- (method url-fetch)
- (uri (string-append
- "http://download.gna.org/guile-dbi/guile-dbd-sqlite3-"
- version ".tar.gz"))
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://example.org") ;only hosted on Software Heritage
+ (commit "0758c615e9e85ad76d153d5dc6179881f1f50089")))
+ (file-name (git-file-name name version))
(sha256
(base32
- "0rg71jchxd2y8x496s8zmfmikr5g8zxi8zv2ar3f7a23pph92iw2"))))
+ "1rwf3z6ib6nkhfnk2nw8p6fqirdx2pparcrlmsm0i2ii62plpqhb"))))
(build-system gnu-build-system)
(native-inputs
`(("pkg-config" ,pkg-config)
@@ -1519,6 +1520,8 @@ It currently supports MySQL, Postgres and SQLite3.")
`(("sqlite" ,sqlite)
("zlib" ,(@ (gnu packages compression) zlib))))
(synopsis "Guile DBI driver for SQLite")
+ ;; Unofficial home-page.
+ ;; Added by b9cbfa52f71505de8447fefabd97f16d0a9cbde6 (2016-06)
(home-page "https://github.com/jkalbhenn/guile-dbd-sqlite3")
(description
"guile-dbi is a library for Guile that provides a convenient interface to
--
2.32.0
Z
Z
zimoun wrote on 2 Jul 2021 18:18
[PATCH 1/2] gnu: guile-dbi: Replace 'url-fetch' by 'git-fetch'.
(address . 49333@debbugs.gnu.org)(name . zimoun)(address . zimon.toutoune@gmail.com)
20210702161809.26599-1-zimon.toutoune@gmail.com

* gnu/packages/guile-xyz.scm (guile-dbi)[source]: Replace 'url-fetch'
by'git-fetch'.
[home-page]: Update.
---
gnu/packages/guile-xyz.scm | 13 +++++++------
1 file changed, 7 insertions(+), 6 deletions(-)

Toggle diff (35 lines)
diff --git a/gnu/packages/guile-xyz.scm b/gnu/packages/guile-xyz.scm
index 7d7ffcb221..3ce5b564e1 100644
--- a/gnu/packages/guile-xyz.scm
+++ b/gnu/packages/guile-xyz.scm
@@ -1448,13 +1448,14 @@ library}.")
(name "guile-dbi")
(version "2.1.6")
(source (origin
- (method url-fetch)
- (uri (string-append
- "http://download.gna.org/guile-dbi/guile-dbi-"
- version ".tar.gz"))
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://example.org") ;only hosted on Software Heritage
+ (commit "e19b019e9683faf66c3f385b20fcc112e65f8c6e")))
+ (file-name (git-file-name name version))
(sha256
(base32
- "116njrprhgrsv1qm904sp3b02rq01fx639r433d657gyhw3x159n"))))
+ "09ys5hj7gnj5w1iv1m194j06jk6b8sdhc8j6hcv3bprq1428kyxw"))))
(build-system gnu-build-system)
(arguments
'(#:configure-flags
@@ -1481,7 +1482,7 @@ library}.")
(propagated-inputs
`(("guile" ,guile-2.2)))
(synopsis "Guile database abstraction layer")
- (home-page "http://home.gna.org/guile-dbi/guile-dbi.html")
+ (home-page "https://web.archive.org/web/20160328232717/http://home.gna.org/guile-dbi/guile-dbi.html")
(description
"guile-dbi is a library for Guile that provides a convenient interface to
SQL databases. Database programming with guile-dbi is generic in that the same
--
2.32.0
L
L
Ludovic Courtès wrote on 30 Jul 2021 22:54
Re: bug#49333: [PATCH 0/2] Remove unreachable GNA upstream
(name . zimoun)(address . zimon.toutoune@gmail.com)
87lf5nzfnt.fsf@gnu.org
Hello,

zimoun <zimon.toutoune@gmail.com> skribis:

Toggle quote (22 lines)
> These trivial patches allow to close the old report 25913 [1].
> Since there is no apparent new upstream, the sources are hosted only by
> Software Heritage.
>
> To verify all is correct,
>
> tar xf $(guix build -S guile-dbi)
> guix hash -r guile-dbi-2.1.6/
> 09ys5hj7gnj5w1iv1m194j06jk6b8sdhc8j6hcv3bprq1428kyxw
>
> guix hash -r $(./pre-inst-env guix build -S guile-dbi)
> 09ys5hj7gnj5w1iv1m194j06jk6b8sdhc8j6hcv3bprq1428kyxw
>
> and
>
> tar xf $(guix build -S guile-sqlite3)
> guix hash -r guile-dbd-sqlite2-2.1.6/
> 1rwf3z6ib6nkhfnk2nw8p6fqirdx2pparcrlmsm0i2ii62plpqhb
>
> guix hash -r $(./pre-inst-env guix build -S guile-dbd-sqlite3)
> 1rwf3z6ib6nkhfnk2nw8p6fqirdx2pparcrlmsm0i2ii62plpqhb

Finally applied, thanks!

Ludo’.
Closed
?