[PATCH 0/1] gnu: Add emacs-rustic.

  • Done
  • quality assurance status badge
Details
2 participants
  • Dhruvin Gandhi
  • Nicolas Goaziou
Owner
unassigned
Submitted by
Dhruvin Gandhi
Severity
normal
D
D
Dhruvin Gandhi wrote on 29 Jun 2021 15:25
(address . guix-patches@gnu.org)(name . Dhruvin Gandhi)(address . contact@dhruvin.dev)
20210629132522.9892-1-contact@dhruvin.dev
Adding emacs-rustic package.

Dhruvin Gandhi (1):
gnu: Add emacs-rustic.

gnu/packages/emacs-xyz.scm | 57 ++++++++++++++++++++++++++++++++++++++
1 file changed, 57 insertions(+)

--
2.32.0
D
D
Dhruvin Gandhi wrote on 29 Jun 2021 15:29
[PATCH 1/1] gnu: Add emacs-rustic.
(address . 49273@debbugs.gnu.org)(name . Dhruvin Gandhi)(address . contact@dhruvin.dev)
20210629132935.10068-1-contact@dhruvin.dev
* gnu/packages/emacs-xyz.scm (emacs-rustic): New variable.
---
gnu/packages/emacs-xyz.scm | 57 ++++++++++++++++++++++++++++++++++++++
1 file changed, 57 insertions(+)

Toggle diff (77 lines)
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index ab04992fad..6d8bafceae 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -99,6 +99,7 @@
;;; Copyright © 2021 Eugene Klimov <lipklim@mailbox.org>
;;; Copyright © 2021 Zheng Junjie <873216071@qq.com>
;;; Copyright © 2021 David Dashyan <mail@davie.li>
+;;; Copyright © 2021 Dhruvin Gandhi <contact@dhruvin.dev>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -21039,6 +21040,62 @@ source code.")
(license (list license:expat
license:asl2.0))))
+(define-public emacs-rustic
+ (let ((commit "bbf129cd128105de51b6c242b2551094b8d8987d")
+ (revision "0"))
+ (package
+ (name "emacs-rustic")
+ (version (git-version "1.3" revision commit))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/brotzeit/rustic")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "09dnlvi8kf683n6q3yp4gy9d4idiyg4x6rcij8d90cvygh8i30wd"))))
+ (build-system emacs-build-system)
+ (propagated-inputs
+ `(("emacs-dash" ,emacs-dash)
+ ("emacs-f" ,emacs-f)
+ ("emacs-flycheck" ,emacs-flycheck)
+ ("emacs-lsp-mode" ,emacs-lsp-mode)
+ ("emacs-markdown-mode" ,emacs-markdown-mode)
+ ("emacs-project" ,emacs-project)
+ ("emacs-s" ,emacs-s)
+ ("emacs-spinner" ,emacs-spinner)
+ ("emacs-xterm-color" ,emacs-xterm-color)))
+ (arguments
+ ;; Tests require rust, cargo, rustfmt, and various crates to be
+ ;; vendored.
+ `(#:tests? #f
+ #:phases
+ (modify-phases %standard-phases
+ (add-before 'check 'set-without-cask
+ (lambda _
+ (setenv "WITHOUT_CASK" "1")
+ #t)))))
+ (home-page "https://github.com/brotzeit/rustic")
+ (synopsis "Rust development environment for Emacs")
+ (description "Rustic is a fork of rust-mode.
+
+Differences with rust-mode:
+@itemize
+@item flycheck integration
+@item cargo popup
+@item multiline error parsing
+@item translation of ANSI control sequences through xterm-color
+@item async org babel
+@item custom compilation process
+@item rustfmt errors in a rust compilation mode
+@item automatic LSP configuration with eglot or lsp-mode
+@item optional rust inline documentation
+@item etc.
+@end itemize\n")
+ (license (list license:expat
+ license:asl2.0)))))
+
(define-public emacs-ztree
;; Upstream provides no tag, but the commit below matches latest release.
(let ((commit "c9ad9136d52ca5a81475693864e255d29448f43f"))
--
2.32.0
N
N
Nicolas Goaziou wrote on 2 Jul 2021 09:16
(name . Dhruvin Gandhi via Guix-patches via)(address . guix-patches@gnu.org)
87a6n5w5hr.fsf@nicolasgoaziou.fr
Hello,

Dhruvin Gandhi via Guix-patches via <guix-patches@gnu.org> writes:

Toggle quote (2 lines)
> * gnu/packages/emacs-xyz.scm (emacs-rustic): New variable.

Thank you.

I applied your patch with the following changes:

Toggle quote (4 lines)
> +(define-public emacs-rustic
> + (let ((commit "bbf129cd128105de51b6c242b2551094b8d8987d")
> + (revision "0"))

I added a comment explaining why we're not using a specific tag here.

Toggle quote (5 lines)
> + (add-before 'check 'set-without-cask
> + (lambda _
> + (setenv "WITHOUT_CASK" "1")
> + #t)))))

I removed the #t here.
Toggle quote (18 lines)
> + (synopsis "Rust development environment for Emacs")
> + (description "Rustic is a fork of rust-mode.
> +
> +Differences with rust-mode:
> +@itemize
> +@item flycheck integration
> +@item cargo popup
> +@item multiline error parsing
> +@item translation of ANSI control sequences through xterm-color
> +@item async org babel
> +@item custom compilation process
> +@item rustfmt errors in a rust compilation mode
> +@item automatic LSP configuration with eglot or lsp-mode
> +@item optional rust inline documentation
> +@item etc.
> +@end itemize\n")

I slightly reworded the description so it includes full sentences, with
proper capitalization, and no newline character at its end.

Regards,
--
Nicolas Goaziou
?