[PATCH 0/9] Add ocamlformat and dependencies

  • Done
  • quality assurance status badge
Details
2 participants
  • Julien Lepiller
  • Xinglu Chen
Owner
unassigned
Submitted by
Xinglu Chen
Severity
normal
X
X
Xinglu Chen wrote on 21 Jun 2021 11:56
(address . guix-patches@gnu.org)
cover.1624269361.git.public@yoctocell.xyz
This series add ‘ocamlformat’, a code formatter for OCaml, and some
missing dependencies. It also updates the ‘ocaml-bisect-ppx’ package,
otherwise ‘ocamlformat’ would not build.

Some tests for ‘ocamlformat’ are failing, not sure why, so I have
disabled them for now.

Xinglu Chen (9):
gnu: ocaml-bisect-ppx: Update to 2.6.1.
gnu: Add ocaml-menhir-lib.
gnu: Add ocaml-menhir-sdk.
gnu: Add ocaml-uucd.
gnu: Add ocaml-uucp.
gnu: Add ocaml-uuseg.
gnu: Add ocaml-fix.
gnu: Add ocaml-dune-build-info.
gnu: Add ocamlformat.

gnu/packages/ocaml.scm | 240 ++++++++++++++++++++++++++++++++++++++---
1 file changed, 224 insertions(+), 16 deletions(-)


base-commit: 71c3f954194770956b39d311fab44ee6ddb4f666
--
2.32.0
-----BEGIN PGP SIGNATURE-----

iQJJBAEBCAAzFiEEAVhh4yyK5+SEykIzrPUJmaL7XHkFAmDQYmsVHHB1YmxpY0B5
b2N0b2NlbGwueHl6AAoJEKz1CZmi+1x5sVYP/3B3wlHog7dTdHwOmi4o3eErNYrT
KnIEZZjZEvH/r+7JxUAmqZMUuIpe2iyljK2snnpYBjSRzos9vKWAQw96n+98NPZI
AD58eCtIty287eaWeO4W/AAMtUm3PdLG8Te57rneXz+R/1YRqUP99zEVRqY6fq68
4WequzBcARXT9RQmyovWvVXR6aAOE7yitw6pL0Xwa6oqLq8873Hq0BK4Aif9LcwO
0NXxszslO/OYj7mZE1fu2OZCAnxf6xLOHtZ3jGM6Nkn0ZzIm3zWB1XSiCOgsI5bs
ka1svxsaNJMTnwuWz6nl0cipu8J06M+aoCZ7RCz7jS6iN1yrV/NnDgJKO3eo1JjR
lj2SeJ6ZEDha2j6ereJmdJVUXTivfmxYrNzfHx0pqlv7c38G0FyObela+xp9fl1v
igt49XoQS1qehEZwzrLrQftXsRFMpg1KznzyvQELUIAvG/kcIigCEwWkNrIu8i1C
x6IZ09/2kPtwJrMNbnRIXsY+tIWL0oE6v/82ieu5uE+gQTRAAZY47TQquRRUjgWH
05dR4f/KoNIrx61NoJxSqf7l4895VhcrYGVqhodNPKLjryNN56k6RU1p1vpfQLB+
0TEQTHjV2Tlo9ZrJiUn673e4ddsww5P+A1N3h8hZv3d338tCB+uLfcstEfPhNFXi
9W2x2rsAKfXI77Db
=Yljy
-----END PGP SIGNATURE-----

X
X
Xinglu Chen wrote on 21 Jun 2021 12:01
[PATCH 1/9] gnu: ocaml-bisect-ppx: Update to 2.6.1.
(address . 49150@debbugs.gnu.org)
9891d2ecdc14077d5d808259c2e6658780d55c5f.1624269361.git.public@yoctocell.xyz
* gnu/packages/ocaml.scm (ocaml-bisect-ppx): Update to 2.6.1.
[propagated-inputs]: Adjust accordingly.
[arguments]: Remove unnecessary phase; disable tests.
---
gnu/packages/ocaml.scm | 22 ++++++----------------
1 file changed, 6 insertions(+), 16 deletions(-)

Toggle diff (45 lines)
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index 21d16a46a1..cccbd45dc4 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -6513,7 +6513,7 @@ combinators.")
(define-public ocaml-bisect-ppx
(package
(name "ocaml-bisect-ppx")
- (version "1.4.2")
+ (version "2.6.1")
(source
(origin
(method git-fetch)
@@ -6523,24 +6523,14 @@ combinators.")
(file-name (git-file-name name version))
(sha256
(base32
- "0900vli5kw7s5kdam0n4cqsfsfqb7mdb3azn3i55595gilg1vyn8"))))
+ "1knglw1b2kjr9jnd8cpfzmm581abxxdcx9l3cd2balg6gnac7qk1"))))
(build-system dune-build-system)
(propagated-inputs
- `(("ocaml-migrate-parsetree" ,ocaml-migrate-parsetree-1)
- ("ocaml-ppx-tools-versioned" ,ocaml-ppx-tools-versioned)
- ("ocaml-ounit" ,ocaml-ounit)))
+ `(("ocaml-ppxlib" ,ocaml-ppxlib)
+ ("ocaml-cmdliner" ,ocaml-cmdliner)))
(arguments
- `(#:phases
- (modify-phases %standard-phases
- (add-before 'build 'fix-deprecated
- (lambda _
- ;; Fixed upstream in 22dd1ad9a0c9629f60599c22d82c6488394d6d32, but
- ;; not in a release yet.
- (substitute* "src/ppx/instrument.ml"
- (("module Ast = Ast_405")
- "module Ast = Migrate_parsetree.Ast_405
-module Ast_405 = Ast"))
- #t)))))
+ ;; Tests require ocamlformat which would lead to circular dependencies
+ '(#:tests? #f))
(home-page "https://github.com/aantron/bisect_ppx")
(synopsis "Code coverage for OCaml")
(description "Bisect_ppx helps you test thoroughly. It is a small
--
2.32.0
X
X
Xinglu Chen wrote on 21 Jun 2021 12:01
[PATCH 2/9] gnu: Add ocaml-menhir-lib.
(address . 49150@debbugs.gnu.org)
29255619678ca3cbf239a67cbce611db7274968c.1624269361.git.public@yoctocell.xyz
* gnu/packages/ocaml.scm (ocaml-menhir-lib): New variable.
---
gnu/packages/ocaml.scm | 13 +++++++++++++
1 file changed, 13 insertions(+)

Toggle diff (26 lines)
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index cccbd45dc4..08406a206d 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -1056,6 +1056,19 @@ Knuth’s LR(1) parser construction technique.")
;; are QPL licensed.
(license (list license:gpl2+ license:qpl))))
+(define-public ocaml-menhir-lib
+ (package
+ (inherit ocaml-menhir)
+ (name "ocaml-menhir-lib")
+ (arguments
+ '(#:package "menhirLib"
+ #:tests? #f))
+ (properties
+ `((upstream-name . "menhirLib")))
+ (synopsis "Runtime support library for parsers generated by Menhir")
+ (description "This package provides a runtime support library for parsers
+generated by Menhir.")))
+
(define-public ocaml-bigarray-compat
(package
(name "ocaml-bigarray-compat")
--
2.32.0
X
X
Xinglu Chen wrote on 21 Jun 2021 12:01
[PATCH 3/9] gnu: Add ocaml-menhir-sdk.
(address . 49150@debbugs.gnu.org)
f733b976e1cf78b3d2a80eea904ab7fa5a2c6df4.1624269361.git.public@yoctocell.xyz
* gnu/packages/ocaml.scm (ocaml-menhir-sdk): New variable.
---
gnu/packages/ocaml.scm | 13 +++++++++++++
1 file changed, 13 insertions(+)

Toggle diff (26 lines)
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index 08406a206d..d7d3afd36c 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -1069,6 +1069,19 @@ Knuth’s LR(1) parser construction technique.")
(description "This package provides a runtime support library for parsers
generated by Menhir.")))
+(define-public ocaml-menhir-sdk
+ (package
+ (inherit ocaml-menhir)
+ (name "ocaml-menhir-sdk")
+ (arguments
+ '(#:package "menhirSdk"
+ #:test-target "sdk"))
+ (properties
+ `((upstream-name . "menhirSdk")))
+ (synopsis "Compile-time library for auxiliary tools related to Menhir")
+ (description "This package provides a compile-time library for auxiliary
+tools related to Menhir.")))
+
(define-public ocaml-bigarray-compat
(package
(name "ocaml-bigarray-compat")
--
2.32.0
X
X
Xinglu Chen wrote on 21 Jun 2021 12:01
[PATCH 4/9] gnu: Add ocaml-uucd.
(address . 49150@debbugs.gnu.org)
cc87ecc26a098ed1be51ae773d6a52b09b9dcd58.1624269361.git.public@yoctocell.xyz
* gnu/packages/ocaml.scm (ocaml-uucd): New variable.
---
gnu/packages/ocaml.scm | 33 +++++++++++++++++++++++++++++++++
1 file changed, 33 insertions(+)

Toggle diff (46 lines)
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index d7d3afd36c..34b909bcb1 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -6957,6 +6957,39 @@ provides support to program with time varying values: declarative events and
client chooses the concrete timeline.")
(license license:lgpl2.1+)))
+(define-public ocaml-uucd
+ (package
+ (name "ocaml-uucd")
+ (version "13.0.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://erratique.ch/software/uucd/releases/"
+ "uucd-" version ".tbz"))
+ (sha256
+ (base32
+ "1fg77hg4ibidkv1x8hhzl8z3rzmyymn8m4i35jrdibb8adigi8v2"))))
+ (build-system ocaml-build-system)
+ (arguments
+ '(#:build-flags '("build" "--tests" "true")
+ #:phases
+ (modify-phases %standard-phases
+ (delete 'configure))))
+ (propagated-inputs
+ `(("ocaml-xmlm" ,ocaml-xmlm)))
+ (native-inputs
+ `(("opam" ,opam)
+ ("ocaml-findlib" ,ocaml-findlib)
+ ("ocamlbuild" ,ocamlbuild)
+ ("ocaml-topkg" ,ocaml-topkg)))
+ (home-page "https://erratique.ch/software/uucd")
+ (synopsis "Unicode character database decoder for OCaml")
+ (description "Uucd is an OCaml module to decode the data of the Unicode
+character database from its XML representation. It provides high-level (but
+not necessarily efficient) access to the data so that efficient
+representations can be extracted.")
+ (license license:isc)))
+
(define-public ocaml-bigstringaf
(package
(name "ocaml-bigstringaf")
--
2.32.0
X
X
Xinglu Chen wrote on 21 Jun 2021 12:01
[PATCH 5/9] gnu: Add ocaml-uucp.
(address . 49150@debbugs.gnu.org)
d675405bc10be00886100b507f1fa5d8f05e531a.1624269361.git.public@yoctocell.xyz
* gnu/packages/ocaml.scm (ocaml-uucp): New variable.
---
gnu/packages/ocaml.scm | 32 ++++++++++++++++++++++++++++++++
1 file changed, 32 insertions(+)

Toggle diff (45 lines)
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index 34b909bcb1..8df397fd2e 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -6990,6 +6990,38 @@ not necessarily efficient) access to the data so that efficient
representations can be extracted.")
(license license:isc)))
+(define-public ocaml-uucp
+ (package
+ (name "ocaml-uucp")
+ (version "13.0.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://erratique.ch/software/uucp/releases/"
+ "uucp-" version ".tbz"))
+ (sha256
+ (base32
+ "19kf8ypxaakacgg1dwwfzkc2zicaj88cmw11fw2z7zl24dn4gyiq"))))
+ (build-system ocaml-build-system)
+ (arguments
+ '(#:build-flags '("build" "--tests" "true")
+ #:phases
+ (modify-phases %standard-phases
+ (delete 'configure))))
+ (native-inputs
+ `(("opam" ,opam)
+ ("ocaml-findlib" ,ocaml-findlib)
+ ("ocamlbuild" ,ocamlbuild)
+ ("ocaml-topkg" ,ocaml-topkg)
+ ("ocaml-uucd" ,ocaml-uucd)
+ ("ocaml-uunf" ,ocaml-uunf)
+ ("ocaml-uutf" ,ocaml-uutf)))
+ (home-page "https://erratique.ch/software/uucp")
+ (synopsis "Unicode character properties for OCaml")
+ (description "Uucp is an OCaml library providing efficient access to a
+selection of character properties of the Unicode character database.")
+ (license license:isc)))
+
(define-public ocaml-bigstringaf
(package
(name "ocaml-bigstringaf")
--
2.32.0
X
X
Xinglu Chen wrote on 21 Jun 2021 12:02
[PATCH 9/9] gnu: Add ocamlformat.
(address . 49150@debbugs.gnu.org)
6b6c96975b9ad8872f6cb0f39fb53881af4bca2e.1624269361.git.public@yoctocell.xyz
* gnu/packages/ocaml.scm (ocamlformat): New variable.
---
gnu/packages/ocaml.scm | 46 ++++++++++++++++++++++++++++++++++++++++++
1 file changed, 46 insertions(+)

Toggle diff (59 lines)
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index b78e3ab2fa..ca15b86c8a 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -7103,6 +7103,52 @@ or the list of statically linked libraries with their versions. It supports
reporting the version from the version control system during development to
get an precise reference of when the executable was built.")))
+(define-public ocamlformat
+ (package
+ (name "ocamlformat")
+ (version "0.18.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/ocaml-ppx/ocamlformat")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0n6363km8xr81pvyk453n6h2mb0256c5yxw3p1li4dn83f3lwxr1"))))
+ (build-system dune-build-system)
+ (arguments
+ '(#:package "ocamlformat"
+ ;; FIXME: The expected format is slightly different than what the
+ ;; produced format is for test/cli/stdin.t
+ #:tests? #f))
+ (propagated-inputs
+ `(("ocaml-version" ,ocaml-version)
+ ("ocaml-base" ,ocaml-base)
+ ("ocaml-cmdliner" ,ocaml-cmdliner)
+ ("ocaml-dune-build-info" ,ocaml-dune-build-info)
+ ("ocaml-fix" ,ocaml-fix)
+ ("ocaml-fpath" ,ocaml-fpath)
+ ("ocaml-menhir" ,ocaml-menhir)
+ ("ocaml-menhir-lib" ,ocaml-menhir-lib)
+ ("ocaml-menhir-sdk" ,ocaml-menhir-sdk)
+ ("ocaml-odoc" ,ocaml-odoc)
+ ("ocaml-ppxlib" ,ocaml-ppxlib)
+ ("ocaml-re" ,ocaml-re)
+ ("ocaml-stdio" ,ocaml-stdio)
+ ("ocaml-uuseg" ,ocaml-uuseg)
+ ("ocaml-uutf" ,ocaml-uutf)))
+ (native-inputs
+ `(("ocaml-alcotest" ,ocaml-alcotest)
+ ("ocaml-ocp-indent" ,ocaml-ocp-indent)
+ ("ocaml-bisect-ppx" ,ocaml-bisect-ppx)))
+ (home-page "https://github.com/ocaml-ppx/ocamlformat")
+ (synopsis "Auto-formatter for OCaml code")
+ (description "OCamlFormat is a tool to automatically format OCaml code in
+a uniform style.")
+ (license license:expat)))
+
(define-public ocaml-bigstringaf
(package
(name "ocaml-bigstringaf")
--
2.32.0
X
X
Xinglu Chen wrote on 21 Jun 2021 12:01
[PATCH 6/9] gnu: Add ocaml-uuseg.
(address . 49150@debbugs.gnu.org)
82bd75fc0f53931e04f4fa2eac45f753f9203222.1624269361.git.public@yoctocell.xyz
* gnu/packages/ocaml.scm (ocaml-uuseg): New variable.
---
gnu/packages/ocaml.scm | 39 +++++++++++++++++++++++++++++++++++++++
1 file changed, 39 insertions(+)

Toggle diff (52 lines)
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index 8df397fd2e..c2e1039146 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -7022,6 +7022,45 @@ representations can be extracted.")
selection of character properties of the Unicode character database.")
(license license:isc)))
+(define-public ocaml-uuseg
+ (package
+ (name "ocaml-uuseg")
+ (version "13.0.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://erratique.ch/software/uuseg/releases/"
+ "uuseg-" version ".tbz"))
+ (sha256
+ (base32
+ "1a635j8ra6p27g1ivfln3387lhwqmf6vq4r6bn7b6n1qsqyi1rls"))))
+ (build-system ocaml-build-system)
+ (arguments
+ '(#:build-flags '("build" "--tests" "true")
+ #:phases
+ (modify-phases %standard-phases
+ (delete 'configure))))
+ (propagated-inputs
+ `(("ocaml-uucp" ,ocaml-uucp)
+ ("ocaml-uutf" ,ocaml-uutf)
+ ("ocaml-cmdliner" ,ocaml-cmdliner)))
+ (native-inputs
+ `(("opam" ,opam)
+ ("ocaml-findlib" ,ocaml-findlib)
+ ("ocamlbuild" ,ocamlbuild)
+ ("ocaml-topkg" ,ocaml-topkg)))
+ (home-page "https://erratique.ch/software/uuseg")
+ (synopsis "Unicode text segmentation for OCaml")
+ (description "Uuseg is an OCaml library for segmenting Unicode text. It
+implements the locale independent Unicode text segmentation algorithms to
+detect grapheme cluster, word and sentence boundaries and the Unicode line
+breaking algorithm to detect line break opportunities.
+
+The library is independent from any IO mechanism or Unicode text data
+structure and it can process text without a complete in-memory
+representation.")
+ (license license:isc)))
+
(define-public ocaml-bigstringaf
(package
(name "ocaml-bigstringaf")
--
2.32.0
X
X
Xinglu Chen wrote on 21 Jun 2021 12:02
[PATCH 7/9] gnu: Add ocaml-fix.
(address . 49150@debbugs.gnu.org)
7eb675d085b0656e3db8ebca6d3160a4c5a83c8d.1624269361.git.public@yoctocell.xyz
* gnu/packages/ocaml.scm (ocaml-fix): New variable.
---
gnu/packages/ocaml.scm | 24 ++++++++++++++++++++++++
1 file changed, 24 insertions(+)

Toggle diff (37 lines)
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index c2e1039146..94e5f23ec0 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -7061,6 +7061,30 @@ structure and it can process text without a complete in-memory
representation.")
(license license:isc)))
+(define-public ocaml-fix
+ (package
+ (name "ocaml-fix")
+ (version "20201120")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://gitlab.inria.fr/fpottier/fix")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1j40mg1gy03c0djzx3nzmpvnl984s14n04zwcmp2xnlidq48kvs4"))))
+ (build-system dune-build-system)
+ (arguments
+ ;; No tests.
+ '(#:tests? #f))
+ (home-page "https://gitlab.inria.fr/fpottier/fix")
+ (synopsis "Facilities for memoization and fixed points")
+ (description "This package provides helpers with various constructions
+that involve memoization and recursion.")
+ (license license:lgpl2.0)))
+
(define-public ocaml-bigstringaf
(package
(name "ocaml-bigstringaf")
--
2.32.0
X
X
Xinglu Chen wrote on 21 Jun 2021 12:02
[PATCH 8/9] gnu: Add ocaml-dune-build-info.
(address . 49150@debbugs.gnu.org)
9168948c67bdf6830b4075d0ada0526f03e4168f.1624269361.git.public@yoctocell.xyz
* gnu/packages/ocaml.scm (ocaml-dune-build-info): New variable.
---
gnu/packages/ocaml.scm | 18 ++++++++++++++++++
1 file changed, 18 insertions(+)

Toggle diff (31 lines)
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index 94e5f23ec0..b78e3ab2fa 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -7085,6 +7085,24 @@ representation.")
that involve memoization and recursion.")
(license license:lgpl2.0)))
+(define-public ocaml-dune-build-info
+ (package
+ (inherit dune)
+ (name "ocaml-dune-build-info")
+ (build-system dune-build-system)
+ (arguments
+ '(#:package "dune-build-info"
+ ;; No separate test suite from dune.
+ #:tests? #f))
+ (propagated-inputs
+ `(("ocaml-odoc" ,ocaml-odoc)))
+ (synopsis "Embed build informations inside executable")
+ (description "This package allows one to access information about how the
+executable was built, such as the version of the project at which it was built
+or the list of statically linked libraries with their versions. It supports
+reporting the version from the version control system during development to
+get an precise reference of when the executable was built.")))
+
(define-public ocaml-bigstringaf
(package
(name "ocaml-bigstringaf")
--
2.32.0
J
J
Julien Lepiller wrote on 27 Jun 2021 15:20
Re: [bug#49150] [PATCH 3/9] gnu: Add ocaml-menhir-sdk.
(name . Xinglu Chen)(address . public@yoctocell.xyz)(address . 49150@debbugs.gnu.org)
20210627152004.200120d8@tachikoma.lepiller.eu
Le Mon, 21 Jun 2021 12:01:53 +0200,
Xinglu Chen <public@yoctocell.xyz> a écrit :

Toggle quote (31 lines)
> * gnu/packages/ocaml.scm (ocaml-menhir-sdk): New variable.
> ---
> gnu/packages/ocaml.scm | 13 +++++++++++++
> 1 file changed, 13 insertions(+)
>
> diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
> index 08406a206d..d7d3afd36c 100644
> --- a/gnu/packages/ocaml.scm
> +++ b/gnu/packages/ocaml.scm
> @@ -1069,6 +1069,19 @@ Knuth’s LR(1) parser construction technique.")
> (description "This package provides a runtime support library
> for parsers generated by Menhir.")))
>
> +(define-public ocaml-menhir-sdk
> + (package
> + (inherit ocaml-menhir)
> + (name "ocaml-menhir-sdk")
> + (arguments
> + '(#:package "menhirSdk"
> + #:test-target "sdk"))
> + (properties
> + `((upstream-name . "menhirSdk")))
> + (synopsis "Compile-time library for auxiliary tools related to
> Menhir")
> + (description "This package provides a compile-time library for
> auxiliary +tools related to Menhir.")))
> +
> (define-public ocaml-bigarray-compat
> (package
> (name "ocaml-bigarray-compat")

MenhirLib and MenhirSdk are both already part of the ocaml-menhir
package, so I don't think it is useful to add separate packages for
them. WDYT?
X
X
Xinglu Chen wrote on 27 Jun 2021 15:37
(name . Julien Lepiller)(address . julien@lepiller.eu)(address . 49150@debbugs.gnu.org)
87k0mf4ef5.fsf@yoctocell.xyz
On Sun, Jun 27 2021, Julien Lepiller wrote:

Toggle quote (38 lines)
> Le Mon, 21 Jun 2021 12:01:53 +0200,
> Xinglu Chen <public@yoctocell.xyz> a écrit :
>
>> * gnu/packages/ocaml.scm (ocaml-menhir-sdk): New variable.
>> ---
>> gnu/packages/ocaml.scm | 13 +++++++++++++
>> 1 file changed, 13 insertions(+)
>>
>> diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
>> index 08406a206d..d7d3afd36c 100644
>> --- a/gnu/packages/ocaml.scm
>> +++ b/gnu/packages/ocaml.scm
>> @@ -1069,6 +1069,19 @@ Knuth’s LR(1) parser construction technique.")
>> (description "This package provides a runtime support library
>> for parsers generated by Menhir.")))
>>
>> +(define-public ocaml-menhir-sdk
>> + (package
>> + (inherit ocaml-menhir)
>> + (name "ocaml-menhir-sdk")
>> + (arguments
>> + '(#:package "menhirSdk"
>> + #:test-target "sdk"))
>> + (properties
>> + `((upstream-name . "menhirSdk")))
>> + (synopsis "Compile-time library for auxiliary tools related to
>> Menhir")
>> + (description "This package provides a compile-time library for
>> auxiliary +tools related to Menhir.")))
>> +
>> (define-public ocaml-bigarray-compat
>> (package
>> (name "ocaml-bigarray-compat")
>
> MenhirLib and MenhirSdk are both already part of the ocaml-menhir
> package, so I don't think it is useful to add separate packages for
> them. WDYT?

Ah, then we can probably drop them, but they (Menhir, MenhirLib, and
MenhirSdk) are three separate packages on Opam, so i could also make
sense to restrict ‘ocaml-menhir’ to only the Menhir package.

WDYT?
-----BEGIN PGP SIGNATURE-----

iQJJBAEBCAAzFiEEAVhh4yyK5+SEykIzrPUJmaL7XHkFAmDYfv4VHHB1YmxpY0B5
b2N0b2NlbGwueHl6AAoJEKz1CZmi+1x53tQP/0Z9RARSyYOGfr2zI0w6IGN0iY3n
obbATV8GStDuERa0UK7KEdc6iB3ccoghunIFTAuGlAjNDzDxrzyKh1mEulROtQGk
dZBUwX+DCd3UxiSbD0DQZgOh7/AAAZldVecx49+YJEXXEniWV/cb4Qd5pEzpRjm4
PwQmGmOKe+3K3FVB1vF3FRmyhg4jc494g6cKBjeW8lotBy4C8jOI1SEmwnNrhgYB
c52LddDkYJ6ATJPCF9837HGpGRL1GDr3VAAc5AVWbaU7cY1uDmih4xo7ISSlUvqa
P8uaAUSP/t5fnx18UDeJz341Eeu5rZDVn9pJ3NA2SsyvovBgJf0pmBLLyGq5/hg2
YrJJSXZ0/7De5Od7+vSG2+q2WN6kG2BgliXg15KAkRHQLG1XYrO/ua7FSBsW2/qu
URE0RwZOdNNZ6RvVhBN9tOHSBFzWeqefySFf/TP+IwIl6MlrqzWiT5WZYjkyF4tZ
+YMwz2QwCtJQ0Bs6OvPiaF7XrdWgEoW2xmuzgXYxV7u1KQJtOvA2mNh9givNVCrh
m7Psi6PuyPfK52tjU1SltwI3/HWNWOHXYvzG3jN/kF4Rzu0bmjl3YrBkqn1D7ZUw
afTmwEvTVXKbPIT7PHFaxJK0L7p5twvNG/PmKM6KPg7qQt3fccFy/yqujmQdHd6O
7K/rpKaGDgt4fi8X
=OlZq
-----END PGP SIGNATURE-----

X
X
Xinglu Chen wrote on 4 Aug 2021 10:23
(name . Julien Lepiller)(address . julien@lepiller.eu)(address . 49150@debbugs.gnu.org)
87czqt4nz4.fsf@yoctocell.xyz
On Sun, Jun 27 2021, Xinglu Chen wrote:

Toggle quote (46 lines)
> On Sun, Jun 27 2021, Julien Lepiller wrote:
>
>> Le Mon, 21 Jun 2021 12:01:53 +0200,
>> Xinglu Chen <public@yoctocell.xyz> a écrit :
>>
>>> * gnu/packages/ocaml.scm (ocaml-menhir-sdk): New variable.
>>> ---
>>> gnu/packages/ocaml.scm | 13 +++++++++++++
>>> 1 file changed, 13 insertions(+)
>>>
>>> diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
>>> index 08406a206d..d7d3afd36c 100644
>>> --- a/gnu/packages/ocaml.scm
>>> +++ b/gnu/packages/ocaml.scm
>>> @@ -1069,6 +1069,19 @@ Knuth’s LR(1) parser construction technique.")
>>> (description "This package provides a runtime support library
>>> for parsers generated by Menhir.")))
>>>
>>> +(define-public ocaml-menhir-sdk
>>> + (package
>>> + (inherit ocaml-menhir)
>>> + (name "ocaml-menhir-sdk")
>>> + (arguments
>>> + '(#:package "menhirSdk"
>>> + #:test-target "sdk"))
>>> + (properties
>>> + `((upstream-name . "menhirSdk")))
>>> + (synopsis "Compile-time library for auxiliary tools related to
>>> Menhir")
>>> + (description "This package provides a compile-time library for
>>> auxiliary +tools related to Menhir.")))
>>> +
>>> (define-public ocaml-bigarray-compat
>>> (package
>>> (name "ocaml-bigarray-compat")
>>
>> MenhirLib and MenhirSdk are both already part of the ocaml-menhir
>> package, so I don't think it is useful to add separate packages for
>> them. WDYT?
>
> Ah, then we can probably drop them, but they (Menhir, MenhirLib, and
> MenhirSdk) are three separate packages on Opam, so i could also make
> sense to restrict ‘ocaml-menhir’ to only the Menhir package.
>
> WDYT?

Ping! :)
-----BEGIN PGP SIGNATURE-----

iQJJBAEBCAAzFiEEAVhh4yyK5+SEykIzrPUJmaL7XHkFAmEKTp8VHHB1YmxpY0B5
b2N0b2NlbGwueHl6AAoJEKz1CZmi+1x5KCcP/ih0uTX86eJmy/FkBGOcb9RJs94A
iiLCFr0G49Is36BVrYWJCsb0jef42VxgKzcRHidbt80+04FxC9BIir/L/tJhUBJP
Otv7AqGIGWTjtMjsZ/nmv8PqhmAK0LGxhlAMa5GYuH/j66miSZqfe0C9fv9T5OhX
B/XtVVZVsKxVhPkE+LJaUUDdIan7p2Z197JyfbOlbCI+eduWAOGam/4JJayVybcE
g7/2phNRDkq4BVUICht2IzQxDjTfFZI0payyVFx3cSvnZMGMD+88YHZAmr29utkM
0Z9bI9az8z34+FSiaMyv1NY6f3LwOYequYCX3Pogp3bP0FTLRt87elInLWFN0HGU
+Q5f/9k0eCMDu2Qw/gqPMXSxhrC37J4A3L3ZwVOyhw9NEnQQnU38qzaUL8A+eiOm
EvSQ4oITKAH9QsmOtqMJZg0gt3qtGhaBZG/62Cw8ru1WaWMrlOG79mRF4J0lOD+r
tYuj0M4ypRhv5GLc/yi9TNeYinSGLzNlhPprnZzkXKZCPs3gEUii9yDhTFKUaAw4
Q/Hrud43YQX2syLOhDui98A4evNCZvpxlTmKljrEbyYUsdrGidigQZmCESKP1kR9
ndg7YqVASeU5moURDnliRGoRHSMnaodqGuxWHJarme8dgzbFuNEGexx9JQlTs70e
EIuLiZmymXEppMZ0
=sWYP
-----END PGP SIGNATURE-----

J
J
Julien Lepiller wrote on 8 Aug 2021 22:45
Re: [bug#49150] [PATCH 0/9] Add ocamlformat and dependencies
(name . Xinglu Chen)(address . public@yoctocell.xyz)(address . 49150-done@debbugs.gnu.org)
20210808224541.7ce577ed@tachikoma.lepiller.eu
Le Mon, 21 Jun 2021 11:56:59 +0200,
Xinglu Chen <public@yoctocell.xyz> a écrit :

Toggle quote (25 lines)
> This series add ‘ocamlformat’, a code formatter for OCaml, and some
> missing dependencies. It also updates the ‘ocaml-bisect-ppx’ package,
> otherwise ‘ocamlformat’ would not build.
>
> Some tests for ‘ocamlformat’ are failing, not sure why, so I have
> disabled them for now.
>
> Xinglu Chen (9):
> gnu: ocaml-bisect-ppx: Update to 2.6.1.
> gnu: Add ocaml-menhir-lib.
> gnu: Add ocaml-menhir-sdk.
> gnu: Add ocaml-uucd.
> gnu: Add ocaml-uucp.
> gnu: Add ocaml-uuseg.
> gnu: Add ocaml-fix.
> gnu: Add ocaml-dune-build-info.
> gnu: Add ocamlformat.
>
> gnu/packages/ocaml.scm | 240
> ++++++++++++++++++++++++++++++++++++++--- 1 file changed, 224
> insertions(+), 16 deletions(-)
>
>
> base-commit: 71c3f954194770956b39d311fab44ee6ddb4f666

Sorry for the delay! Pushed as
e473fe1056a8b8089715dff46050355f777ef5ed to
e83fe81be4677aca1f42f0df9c8d2606400a4619, after fixing the
description ocaml-uuseg. I omited patches 2 and 3 and fixed ocamlformat
accordingly.

Thanks!
Closed
X
X
Xinglu Chen wrote on 9 Aug 2021 11:36
Re: bug#49150: [PATCH 0/9] Add ocamlformat and dependencies
(name . Julien Lepiller)(address . julien@lepiller.eu)(address . 49150-done@debbugs.gnu.org)
87r1f3ot87.fsf@yoctocell.xyz
On Sun, Aug 08 2021, Julien Lepiller wrote:

Toggle quote (34 lines)
> Le Mon, 21 Jun 2021 11:56:59 +0200,
> Xinglu Chen <public@yoctocell.xyz> a écrit :
>
>> This series add ‘ocamlformat’, a code formatter for OCaml, and some
>> missing dependencies. It also updates the ‘ocaml-bisect-ppx’ package,
>> otherwise ‘ocamlformat’ would not build.
>>
>> Some tests for ‘ocamlformat’ are failing, not sure why, so I have
>> disabled them for now.
>>
>> Xinglu Chen (9):
>> gnu: ocaml-bisect-ppx: Update to 2.6.1.
>> gnu: Add ocaml-menhir-lib.
>> gnu: Add ocaml-menhir-sdk.
>> gnu: Add ocaml-uucd.
>> gnu: Add ocaml-uucp.
>> gnu: Add ocaml-uuseg.
>> gnu: Add ocaml-fix.
>> gnu: Add ocaml-dune-build-info.
>> gnu: Add ocamlformat.
>>
>> gnu/packages/ocaml.scm | 240
>> ++++++++++++++++++++++++++++++++++++++--- 1 file changed, 224
>> insertions(+), 16 deletions(-)
>>
>>
>> base-commit: 71c3f954194770956b39d311fab44ee6ddb4f666
>
> Sorry for the delay! Pushed as
> e473fe1056a8b8089715dff46050355f777ef5ed to
> e83fe81be4677aca1f42f0df9c8d2606400a4619, after fixing the
> description ocaml-uuseg. I omited patches 2 and 3 and fixed ocamlformat
> accordingly.

Great, thank you!
-----BEGIN PGP SIGNATURE-----

iQJJBAEBCAAzFiEEAVhh4yyK5+SEykIzrPUJmaL7XHkFAmEQ9wgVHHB1YmxpY0B5
b2N0b2NlbGwueHl6AAoJEKz1CZmi+1x5fncP/ihYAhatfsuO7k0VOW6QMxCA4pQZ
EBkU+ZOTQhab/YomzMD84li6bosZGea/MJg+DJDyMRws5lm6q+02sqSfD9PoDjwP
zZwVvpxyRQBaOLXMJFbwsaYzIYGwOyRQUi+eyv919NBxg6B12L7qs8kYajoUr9ct
aAieL/eng4MscRqNgmX7bKeLUTo1vHKRA1VmOwqnvWKxDDfdsvQjmmD5wNweA5Si
2/NUikNp2004zMECkiUKBrq3tsjD09Ecz2FgcWtPQVERB1LLyvsUeQIKv9ep7AQt
fd3PT9kR+UNKVf09vikv2IEPs4eGmzCUW9UH/aIPjgKKSkylFeY2UOHp16fY4G1i
NrgDZncX8UzM9EzQ3YAQ4s/qi5/5Tv95JwSRNqWlp0iXldIsO7MPD+ZTX3VY/y27
oxAJP9o7yLfie4kQgV7X/Ujhh1I7f/M+GnZydvgj4OowBaabrp+q9qkXgSZAdLz5
0UwbPOuXDjJdNWjkykt6avcAEjU22RuXRb5hS83f4ifyjgnwCG3hf/ed3AoVCGpV
qz66ZhmuhpIN8RS9xN6hl2aUMsm/97cfj2ffh6EBJ70EZ0nu302g00TEcZRW9BU3
FeJg4bFcwo6hWGLXG0brqINbyIJs+WPPLG8RDPMpMG/ZuNDUbicEaMDUBNNW5T4S
1ARpg3lIuwPc1Kki
=Xhu5
-----END PGP SIGNATURE-----

Closed
?