[PATCH] gnu: Add video-contact-sheet

  • Done
  • quality assurance status badge
Details
3 participants
  • Sarah Morgensen
  • Leo Famulari
  • Pradana Adrinusa AUMARS
Owner
unassigned
Submitted by
Pradana Adrinusa AUMARS
Severity
normal
Merged with
P
P
Pradana Adrinusa AUMARS wrote on 18 Jun 2021 16:27
(address . guix-patches@gnu.org)
3627c385f0509614621b154cd26dc9ed4f503a51.camel@courrier.dev
From 9851db2b3036ee3d5e8ef85ed8bae2f6398702e0 Mon Sep 17 00:00:00 2001
From: Pradana AUMARS <paumars@courrier.dev>
Date: Fri, 18 Jun 2021 16:13:07 +0200
Subject: [PATCH] gnu: Add video-contact-sheet

---
gnu/packages/video.scm | 31 +++++++++++++++++++++++++++++++
1 file changed, 31 insertions(+)

Toggle diff (65 lines)
diff --git a/gnu/packages/video.scm b/gnu/packages/video.scm
index e3f4f59b4c..ba3035cf45 100644
--- a/gnu/packages/video.scm
+++ b/gnu/packages/video.scm
@@ -51,6 +51,7 @@
;;; Copyright © 2021 Andrew Tropin <andrew@trop.in>
;;; Copyright © 2021 David Wilson <david@daviwil.com>
;;; Copyright © 2021 Maxim Cournoyer <maxim.cournoyer@gmail.com>
+;;; Copyright © 2021 Pradana Aumars <paumars@courrier.dev>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -96,6 +97,7 @@
#:use-module (gnu packages avahi)
#:use-module (gnu packages backup)
#:use-module (gnu packages base)
+ #:use-module (gnu packages bash)
#:use-module (gnu packages bison)
#:use-module (gnu packages boost)
#:use-module (gnu packages cdrom)
@@ -5180,3 +5182,32 @@ information) NALUs (Network Abstraction Layer
Unit) for inclusion into an h.264
elementary stream are provided.")
(home-page "https://github.com/szatmary/libcaption")
(license license:expat)))
+
+(define-public video-contact-sheet
+ (package
+ (name "video-contact-sheet")
+ (version "1.13.4")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "http://p.outlyer.net/vcs/files/vcs-"
version
+ ".tar.gz"))
+ (sha256
+ (base32
+ "0jsl93r0rnybjcipqbww5hwsr9ln6kz1qnf32qfxdvhfw52n27fw"))
))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:phases (modify-phases %standard-phases
+ (delete 'configure)
+ (delete 'build)
+ (delete 'check))
+ #:make-flags (list (string-append "prefix=" (assoc-ref %outputs
"out")))))
+ (inputs
+ `(("bash" ,bash)
+ ("ffmpeg" ,ffmpeg)
+ ("imagemagick" ,imagemagick)))
+ (synopsis "Bash script to create contact sheets (preview images)
from videos")
+ (description "This is a bash script meant to create video contact
sheets (previews) of videos. Any video supported by mplayer and ffmpeg
can be used. A note of warning: Unlike most similar tools it, by
default, makes screenshots the same size as the video, see below for
details on how to change this.
+
+Take a look at the documentation and/or use the –help and –fullhelp
options to learn how to use it.")
+ (home-page "http://p.outlyer.net/vcs/")
+ (license license:lgpl3)))
--
2.32.0
S
S
Sarah Morgensen wrote on 24 Jul 2021 00:40
(name . Pradana Adrinusa AUMARS)(address . paumars@courrier.dev)(address . 49094@debbugs.gnu.org)
861r7or6wt.fsf@mgsn.dev
Hello,

Thank you for the patch. Unfortunately, I cannot apply it because your
mail client has wrapped some lines, corrupting the patch. (Also, adding
to the end of the file rather than the middle tends to cause patches not
to apply, so probably avoid this as well.)

I do still have a few suggestions, annotated below:

Pradana Adrinusa AUMARS <paumars@courrier.dev> writes:

Toggle quote (45 lines)
>>From 9851db2b3036ee3d5e8ef85ed8bae2f6398702e0 Mon Sep 17 00:00:00 2001
> From: Pradana AUMARS <paumars@courrier.dev>
> Date: Fri, 18 Jun 2021 16:13:07 +0200
> Subject: [PATCH] gnu: Add video-contact-sheet
>
> ---
> gnu/packages/video.scm | 31 +++++++++++++++++++++++++++++++
> 1 file changed, 31 insertions(+)
>
> diff --git a/gnu/packages/video.scm b/gnu/packages/video.scm
> index e3f4f59b4c..ba3035cf45 100644
> --- a/gnu/packages/video.scm
> +++ b/gnu/packages/video.scm
> @@ -51,6 +51,7 @@
> ;;; Copyright © 2021 Andrew Tropin <andrew@trop.in>
> ;;; Copyright © 2021 David Wilson <david@daviwil.com>
> ;;; Copyright © 2021 Maxim Cournoyer <maxim.cournoyer@gmail.com>
> +;;; Copyright © 2021 Pradana Aumars <paumars@courrier.dev>
> ;;;
> ;;; This file is part of GNU Guix.
> ;;;
> @@ -96,6 +97,7 @@
> #:use-module (gnu packages avahi)
> #:use-module (gnu packages backup)
> #:use-module (gnu packages base)
> + #:use-module (gnu packages bash)
> #:use-module (gnu packages bison)
> #:use-module (gnu packages boost)
> #:use-module (gnu packages cdrom)
> @@ -5180,3 +5182,32 @@ information) NALUs (Network Abstraction Layer
> Unit) for inclusion into an h.264
> elementary stream are provided.")
> (home-page "https://github.com/szatmary/libcaption")
> (license license:expat)))
> +
> +(define-public video-contact-sheet
> + (package
> + (name "video-contact-sheet")
> + (version "1.13.4")
> + (source (origin
> + (method url-fetch)
> + (uri (string-append "http://p.outlyer.net/vcs/files/vcs-"
> version
> + ".tar.gz"))

Lines should be wrapped at 80 characters when possible. Indentation
should be with spaces instead of tabs.

Also, it looks like 'http://p.outlyer.net/vcs/files/'has a permanent
redirect to 'http://p.outlyer.net/files/vcs/'so that should be updated.

Toggle quote (22 lines)
> + (sha256
> + (base32
> + "0jsl93r0rnybjcipqbww5hwsr9ln6kz1qnf32qfxdvhfw52n27fw"))
> ))
> + (build-system gnu-build-system)
> + (arguments
> + `(#:phases (modify-phases %standard-phases
> + (delete 'configure)
> + (delete 'build)
> + (delete 'check))
> + #:make-flags (list (string-append "prefix=" (assoc-ref %outputs
> "out")))))
> + (inputs
> + `(("bash" ,bash)
> + ("ffmpeg" ,ffmpeg)
> + ("imagemagick" ,imagemagick)))
> + (synopsis "Bash script to create contact sheets (preview images)
> from videos")
> + (description "This is a bash script meant to create video contact
> sheets (previews) of videos. Any video supported by mplayer and ffmpeg
> can be used. A note of warning: Unlike most similar tools it, by
> default, makes screenshots the same size as the video, see below for
^ the manual
Toggle quote (4 lines)
> details on how to change this.
> +
> +Take a look at the documentation and/or use the –help and –fullhelp
> options to learn how to use it.")
This last sentence should probably not be in the description.

Please also wrap these lines at 80 characters as well (see other
packages for examples), and use two spaces between sentences.

Toggle quote (3 lines)
> + (license license:lgpl3)))

--
Sarah
S
S
Sarah Morgensen wrote on 24 Jul 2021 00:47
control message for bug #49093
(address . control@debbugs.gnu.org)
E1m73x1-0004eR-Kq@debbugs.gnu.org
merge 49093 49094
quit
P
L
L
Leo Famulari wrote on 17 Dec 2021 16:13
(no subject)
(address . control@debbugs.gnu.org)
YbypKFGchCrKRMOb@jasmine.lan
merge 49094 50369
?