Improve Dino

  • Done
  • quality assurance status badge
Details
2 participants
  • Jack Hill
  • Raghav Gururajan
Owner
unassigned
Submitted by
Raghav Gururajan
Severity
normal
R
R
R
Raghav Gururajan wrote on 11 Jun 2021 03:01
[PATCH v1 2/3] gnu: dino: Add missing inputs.
(address . 48953@debbugs.gnu.org)(name . Raghav Gururajan)(address . rg@raghavgururajan.name)
20210611010130.27142-2-rg@raghavgururajan.name
These new inputs are referenced by the package but was missing in
the package definition. Some of these inputs might have been used
by the package indirectly via propagation from other inputs.

* gnu/packages/messaging.scm (dino)[native-inputs]: Add gobject-introspection.
[inputs]: Add atk, cairo, gdk-pixbug+svg, libcanberra, libnice and pango.
---
gnu/packages/messaging.scm | 9 ++++++++-
1 file changed, 8 insertions(+), 1 deletion(-)

Toggle diff (34 lines)
diff --git a/gnu/packages/messaging.scm b/gnu/packages/messaging.scm
index d85577e76c..5be733f3a2 100644
--- a/gnu/packages/messaging.scm
+++ b/gnu/packages/messaging.scm
@@ -1246,19 +1246,26 @@ Encryption to Gajim.")
(native-inputs
`(("gettext" ,gettext-minimal)
("glib:bin" ,glib "bin")
+ ("gobject-introspection" ,gobject-introspection)
("gtk+:bin" ,gtk+ "bin")
("pkg-config" ,pkg-config)
("vala" ,vala)))
(inputs
- `(("glib" ,glib)
+ `(("atk" ,atk)
+ ("cairo" ,cairo)
+ ("gdk-pixbuf" ,gdk-pixbuf+svg)
+ ("glib" ,glib)
("glib-networking" ,glib-networking)
("gpgme" ,gpgme)
("gsettings-desktop-schemas" ,gsettings-desktop-schemas)
("gtk+" ,gtk+)
+ ("libcanberra" ,libcanberra)
("libgcrypt" ,libgcrypt)
("libgee" ,libgee)
+ ("libnice" ,libnice)
("libsignal-protocol-c" ,libsignal-protocol-c)
("libsoup" ,libsoup)
+ ("pango" ,pango)
("qrencode" ,qrencode)
("sqlite" ,sqlite)))
(synopsis "Graphical Jabber/XMPP Client using GTK+/Vala")
--
2.31.1
R
R
Raghav Gururajan wrote on 11 Jun 2021 03:01
[PATCH v1 1/3] gnu: dino: Remove duplicate inputs.
(address . 48953@debbugs.gnu.org)(name . Raghav Gururajan)(address . rg@raghavgururajan.name)
20210611010130.27142-1-rg@raghavgururajan.name
* gnu/packages/messaging.scm (dino)[inputs]: Remove duplicate gpgme,
gtk+, glib-networking and gsettings-desktop-schemas.
---
gnu/packages/messaging.scm | 6 +-----
1 file changed, 1 insertion(+), 5 deletions(-)

Toggle diff (19 lines)
diff --git a/gnu/packages/messaging.scm b/gnu/packages/messaging.scm
index 7b91284b10..d85577e76c 100644
--- a/gnu/packages/messaging.scm
+++ b/gnu/packages/messaging.scm
@@ -1260,11 +1260,7 @@ Encryption to Gajim.")
("libsignal-protocol-c" ,libsignal-protocol-c)
("libsoup" ,libsoup)
("qrencode" ,qrencode)
- ("sqlite" ,sqlite)
- ("gpgme" ,gpgme)
- ("gtk+" ,gtk+)
- ("glib-networking" ,glib-networking)
- ("gsettings-desktop-schemas" ,gsettings-desktop-schemas)))
+ ("sqlite" ,sqlite)))
(synopsis "Graphical Jabber/XMPP Client using GTK+/Vala")
(description "Dino is a chat client for the desktop. It focuses on providing
a minimal yet reliable Jabber/XMPP experience and having encryption enabled by
--
2.31.1
R
R
Raghav Gururajan wrote on 11 Jun 2021 03:01
[PATCH v1 3/3] gnu: dino: Enable missing features.
(address . 48953@debbugs.gnu.org)(name . Raghav Gururajan)(address . rg@raghavgururajan.name)
20210611010130.27142-3-rg@raghavgururajan.name
* gnu/packages/messaging.scm (dino)[inputs]: Add gspell, gstreamer,
gst-plugins-base, gst-plugins-good, icu4c, libsrtp and
webrtc-audio-processing.
---
gnu/packages/messaging.scm | 10 +++++++++-
1 file changed, 9 insertions(+), 1 deletion(-)

Toggle diff (39 lines)
diff --git a/gnu/packages/messaging.scm b/gnu/packages/messaging.scm
index 5be733f3a2..e9d2c26902 100644
--- a/gnu/packages/messaging.scm
+++ b/gnu/packages/messaging.scm
@@ -114,6 +114,7 @@
#:use-module (gnu packages sphinx)
#:use-module (gnu packages sqlite)
#:use-module (gnu packages tcl)
+ #:use-module (gnu packages telephony)
#:use-module (gnu packages texinfo)
#:use-module (gnu packages textutils)
#:use-module (gnu packages tls)
@@ -1258,16 +1259,23 @@ Encryption to Gajim.")
("glib-networking" ,glib-networking)
("gpgme" ,gpgme)
("gsettings-desktop-schemas" ,gsettings-desktop-schemas)
+ ("gspell" ,gspell) ; for spell-check support
+ ("gstreamer" ,gstreamer) ; for A/V support
+ ("gst-plugins-base" ,gst-plugins-base)
+ ("gst-plugins-good" ,gst-plugins-good)
("gtk+" ,gtk+)
+ ("icu4c" ,icu4c) ; for emoji support
("libcanberra" ,libcanberra)
("libgcrypt" ,libgcrypt)
("libgee" ,libgee)
("libnice" ,libnice)
("libsignal-protocol-c" ,libsignal-protocol-c)
("libsoup" ,libsoup)
+ ("libsrtp" ,libsrtp) ; for calls support
("pango" ,pango)
("qrencode" ,qrencode)
- ("sqlite" ,sqlite)))
+ ("sqlite" ,sqlite)
+ ("webrtc-audio-processing" ,webrtc-audio-processing))) ; for A/V support
(synopsis "Graphical Jabber/XMPP Client using GTK+/Vala")
(description "Dino is a chat client for the desktop. It focuses on providing
a minimal yet reliable Jabber/XMPP experience and having encryption enabled by
--
2.31.1
R
R
Raghav Gururajan wrote on 11 Jun 2021 03:15
[PATCH v2 1/3] gnu: dino: Remove duplicate inputs.
(address . 48953@debbugs.gnu.org)(name . Raghav Gururajan)(address . rg@raghavgururajan.name)
20210611011550.27628-1-rg@raghavgururajan.name
* gnu/packages/messaging.scm (dino)[inputs]: Remove duplicate gpgme,
gtk+, glib-networking and gsettings-desktop-schemas.
---
gnu/packages/messaging.scm | 6 +-----
1 file changed, 1 insertion(+), 5 deletions(-)

Toggle diff (19 lines)
diff --git a/gnu/packages/messaging.scm b/gnu/packages/messaging.scm
index 7b91284b10..d85577e76c 100644
--- a/gnu/packages/messaging.scm
+++ b/gnu/packages/messaging.scm
@@ -1260,11 +1260,7 @@ Encryption to Gajim.")
("libsignal-protocol-c" ,libsignal-protocol-c)
("libsoup" ,libsoup)
("qrencode" ,qrencode)
- ("sqlite" ,sqlite)
- ("gpgme" ,gpgme)
- ("gtk+" ,gtk+)
- ("glib-networking" ,glib-networking)
- ("gsettings-desktop-schemas" ,gsettings-desktop-schemas)))
+ ("sqlite" ,sqlite)))
(synopsis "Graphical Jabber/XMPP Client using GTK+/Vala")
(description "Dino is a chat client for the desktop. It focuses on providing
a minimal yet reliable Jabber/XMPP experience and having encryption enabled by
--
2.31.1
R
R
Raghav Gururajan wrote on 11 Jun 2021 03:15
[PATCH v2 2/3] gnu: dino: Add missing inputs.
(address . 48953@debbugs.gnu.org)(name . Raghav Gururajan)(address . rg@raghavgururajan.name)
20210611011550.27628-2-rg@raghavgururajan.name
These new inputs are referenced by the package but was missing in
the package definition. Some of these inputs might have been used
by the package indirectly via propagation from other inputs.

* gnu/packages/messaging.scm (dino)[native-inputs]: Add gobject-introspection.
[inputs]: Add atk, cairo, gdk-pixbug+svg, libcanberra, libnice and pango.
---
gnu/packages/messaging.scm | 9 ++++++++-
1 file changed, 8 insertions(+), 1 deletion(-)

Toggle diff (34 lines)
diff --git a/gnu/packages/messaging.scm b/gnu/packages/messaging.scm
index d85577e76c..5be733f3a2 100644
--- a/gnu/packages/messaging.scm
+++ b/gnu/packages/messaging.scm
@@ -1246,19 +1246,26 @@ Encryption to Gajim.")
(native-inputs
`(("gettext" ,gettext-minimal)
("glib:bin" ,glib "bin")
+ ("gobject-introspection" ,gobject-introspection)
("gtk+:bin" ,gtk+ "bin")
("pkg-config" ,pkg-config)
("vala" ,vala)))
(inputs
- `(("glib" ,glib)
+ `(("atk" ,atk)
+ ("cairo" ,cairo)
+ ("gdk-pixbuf" ,gdk-pixbuf+svg)
+ ("glib" ,glib)
("glib-networking" ,glib-networking)
("gpgme" ,gpgme)
("gsettings-desktop-schemas" ,gsettings-desktop-schemas)
("gtk+" ,gtk+)
+ ("libcanberra" ,libcanberra)
("libgcrypt" ,libgcrypt)
("libgee" ,libgee)
+ ("libnice" ,libnice)
("libsignal-protocol-c" ,libsignal-protocol-c)
("libsoup" ,libsoup)
+ ("pango" ,pango)
("qrencode" ,qrencode)
("sqlite" ,sqlite)))
(synopsis "Graphical Jabber/XMPP Client using GTK+/Vala")
--
2.31.1
R
R
Raghav Gururajan wrote on 11 Jun 2021 03:15
[PATCH v2 3/3] gnu: dino: Enable missing features.
(address . 48953@debbugs.gnu.org)(name . Raghav Gururajan)(address . rg@raghavgururajan.name)
20210611011550.27628-3-rg@raghavgururajan.name
* gnu/packages/messaging.scm (dino)[phases](wrap-env): New phase.
[inputs]: Add gspell, gstreamer, gst-plugins-base, gst-plugins-good,
icu4c, libsrtp and webrtc-audio-processing.
---
gnu/packages/messaging.scm | 21 ++++++++++++++++++++-
1 file changed, 20 insertions(+), 1 deletion(-)

Toggle diff (57 lines)
diff --git a/gnu/packages/messaging.scm b/gnu/packages/messaging.scm
index 5be733f3a2..41f26ba8e0 100644
--- a/gnu/packages/messaging.scm
+++ b/gnu/packages/messaging.scm
@@ -114,6 +114,7 @@
#:use-module (gnu packages sphinx)
#:use-module (gnu packages sqlite)
#:use-module (gnu packages tcl)
+ #:use-module (gnu packages telephony)
#:use-module (gnu packages texinfo)
#:use-module (gnu packages textutils)
#:use-module (gnu packages tls)
@@ -1241,6 +1242,17 @@ Encryption to Gajim.")
(guix build glib-or-gtk-build-system))
#:phases
(modify-phases %standard-phases
+ (add-after 'install 'wrap-env
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let ((out (assoc-ref outputs "out")))
+ (for-each
+ (lambda (name)
+ (let ((file (string-append out "/bin/" name))
+ (gst-plugin-path (getenv "GST_PLUGIN_SYSTEM_PATH")))
+ (wrap-program file
+ `("GST_PLUGIN_SYSTEM_PATH" ":" prefix (,gst-plugin-path)))))
+ '("dino")))
+ #t))
(add-after 'install 'glib-or-gtk-wrap
(assoc-ref glib-or-gtk:%standard-phases 'glib-or-gtk-wrap)))))
(native-inputs
@@ -1258,16 +1270,23 @@ Encryption to Gajim.")
("glib-networking" ,glib-networking)
("gpgme" ,gpgme)
("gsettings-desktop-schemas" ,gsettings-desktop-schemas)
+ ("gspell" ,gspell) ; for spell-check support
+ ("gstreamer" ,gstreamer) ; for A/V support
+ ("gst-plugins-base" ,gst-plugins-base)
+ ("gst-plugins-good" ,gst-plugins-good)
("gtk+" ,gtk+)
+ ("icu4c" ,icu4c) ; for emoji support
("libcanberra" ,libcanberra)
("libgcrypt" ,libgcrypt)
("libgee" ,libgee)
("libnice" ,libnice)
("libsignal-protocol-c" ,libsignal-protocol-c)
("libsoup" ,libsoup)
+ ("libsrtp" ,libsrtp) ; for calls support
("pango" ,pango)
("qrencode" ,qrencode)
- ("sqlite" ,sqlite)))
+ ("sqlite" ,sqlite)
+ ("webrtc-audio-processing" ,webrtc-audio-processing))) ; for A/V support
(synopsis "Graphical Jabber/XMPP Client using GTK+/Vala")
(description "Dino is a chat client for the desktop. It focuses on providing
a minimal yet reliable Jabber/XMPP experience and having encryption enabled by
--
2.31.1
J
J
Jack Hill wrote on 11 Jun 2021 05:31
Re: [bug#48953] [PATCH v2 2/3] gnu: dino: Add missing inputs.
(name . Raghav Gururajan)(address . rg@raghavgururajan.name)(address . 48953@debbugs.gnu.org)
alpine.DEB.2.21.2106102325280.2109@marsh.hcoop.net
On Thu, 10 Jun 2021, Raghav Gururajan via Guix-patches via wrote:

Toggle quote (4 lines)
> These new inputs are referenced by the package but was missing in
> the package definition. Some of these inputs might have been used
> by the package indirectly via propagation from other inputs.

Cool, thanks for working on improving Dino.

Toggle quote (11 lines)
> * gnu/packages/messaging.scm (dino)[native-inputs]: Add gobject-introspection.
> [inputs]: Add atk, cairo, gdk-pixbug+svg, libcanberra, libnice and pango.
> ---
> gnu/packages/messaging.scm | 9 ++++++++-
> 1 file changed, 8 insertions(+), 1 deletion(-)
>
> diff --git a/gnu/packages/messaging.scm b/gnu/packages/messaging.scm
> index d85577e76c..5be733f3a2 100644
> --- a/gnu/packages/messaging.scm
> +++ b/gnu/packages/messaging.scm

[…]

Toggle quote (2 lines)
> + ("libcanberra" ,libcanberra)

I think canberra support is disabled by default even if the dependency is
present. I found the following configure-flags enable it:

#:configure-flags (list "-DDINO_PLUGIN_ENABLED_notification-sound=yes")

Now I'm curious to find out from upstream why it's not enabled by default
and if that should affect whether we enable it in Guix.

Best,
Jack
J
J
Jack Hill wrote on 11 Jun 2021 05:35
Re: [bug#48953] [PATCH v2 3/3] gnu: dino: Enable missing features.
(name . Raghav Gururajan)(address . rg@raghavgururajan.name)(address . 48953@debbugs.gnu.org)
alpine.DEB.2.21.2106102331090.2109@marsh.hcoop.net
On Thu, 10 Jun 2021, Raghav Gururajan via Guix-patches via wrote:

Toggle quote (35 lines)
> * gnu/packages/messaging.scm (dino)[phases](wrap-env): New phase.
> [inputs]: Add gspell, gstreamer, gst-plugins-base, gst-plugins-good,
> icu4c, libsrtp and webrtc-audio-processing.
> ---
> gnu/packages/messaging.scm | 21 ++++++++++++++++++++-
> 1 file changed, 20 insertions(+), 1 deletion(-)
>
> diff --git a/gnu/packages/messaging.scm b/gnu/packages/messaging.scm
> index 5be733f3a2..41f26ba8e0 100644
> --- a/gnu/packages/messaging.scm
> +++ b/gnu/packages/messaging.scm
> @@ -114,6 +114,7 @@
> #:use-module (gnu packages sphinx)
> #:use-module (gnu packages sqlite)
> #:use-module (gnu packages tcl)
> + #:use-module (gnu packages telephony)
> #:use-module (gnu packages texinfo)
> #:use-module (gnu packages textutils)
> #:use-module (gnu packages tls)
> @@ -1241,6 +1242,17 @@ Encryption to Gajim.")
> (guix build glib-or-gtk-build-system))
> #:phases
> (modify-phases %standard-phases
> + (add-after 'install 'wrap-env
> + (lambda* (#:key outputs #:allow-other-keys)
> + (let ((out (assoc-ref outputs "out")))
> + (for-each
> + (lambda (name)
> + (let ((file (string-append out "/bin/" name))
> + (gst-plugin-path (getenv "GST_PLUGIN_SYSTEM_PATH")))
> + (wrap-program file
> + `("GST_PLUGIN_SYSTEM_PATH" ":" prefix (,gst-plugin-path)))))
> + '("dino")))
> + #t))

Nitpick of a sort: Can we forgo the #t with the (hopefully soon)
upcoming core-updates merge?

[…]

Toggle quote (5 lines)
> + ("gspell" ,gspell) ; for spell-check support
> + ("gstreamer" ,gstreamer) ; for A/V support
> + ("gst-plugins-base" ,gst-plugins-base)
> + ("gst-plugins-good" ,gst-plugins-good)

[…]

Toggle quote (2 lines)
> + ("webrtc-audio-processing" ,webrtc-audio-processing))) ; for A/V support

Is there actual A/V support in this version of Dino, or is that only
coming in 0.3.0?

Best,
Jack
J
J
Jack Hill wrote on 11 Jun 2021 17:06
Re: [bug#48953] [PATCH v2 2/3] gnu: dino: Add missing inputs.
(name . Raghav Gururajan)(address . rg@raghavgururajan.name)(address . 48953@debbugs.gnu.org)
alpine.DEB.2.21.2106111101360.2109@marsh.hcoop.net
On Thu, 10 Jun 2021, Jack Hill wrote:

Toggle quote (12 lines)
> On Thu, 10 Jun 2021, Raghav Gururajan via Guix-patches via wrote:
>
>> + ("libcanberra" ,libcanberra)
>
> I think canberra support is disabled by default even if the dependency is
> present. I found the following configure-flags enable it:
>
> #:configure-flags (list "-DDINO_PLUGIN_ENABLED_notification-sound=yes")
>
> Now I'm curious to find out from upstream why it's not enabled by default and
> if that should affect whether we enable it in Guix.

I asked about this in Dino's chat room? and they said that the
notification-sound plugin is not ready to be enabled by distros¹.

? <xmpp:chat@dino.im?join>

Best,
Jack
R
R
Raghav Gururajan wrote on 13 Jun 2021 17:34
(no subject)
(address . control@debbugs.gnu.org)
5cad12cd-d4b1-443b-5f83-d7f6ca5135d6@raghavgururajan.name
retitle 48953 Improve Dino
Attachment: OpenPGP_signature
R
R
Raghav Gururajan wrote on 16 Jun 2021 09:17
[PATCH v3 2/3] gnu: dino: Add missing inputs.
(address . 48953@debbugs.gnu.org)(name . Raghav Gururajan)(address . rg@raghavgururajan.name)
20210616071753.14948-2-rg@raghavgururajan.name
These new inputs are referenced by the package but was missing in
the package definition. Some of these inputs might have been used
by the package indirectly via propagation from other inputs.

* gnu/packages/messaging.scm (dino)[native-inputs]: Add gobject-introspection.
[inputs]: Add atk, cairo, gdk-pixbug+svg, libnice and pango.
---
gnu/packages/messaging.scm | 8 +++++++-
1 file changed, 7 insertions(+), 1 deletion(-)

Toggle diff (33 lines)
diff --git a/gnu/packages/messaging.scm b/gnu/packages/messaging.scm
index 0f9fe31772..54d09c4815 100644
--- a/gnu/packages/messaging.scm
+++ b/gnu/packages/messaging.scm
@@ -1246,19 +1246,25 @@ Encryption to Gajim.")
(native-inputs
`(("gettext" ,gettext-minimal)
("glib:bin" ,glib "bin")
+ ("gobject-introspection" ,gobject-introspection)
("gtk+:bin" ,gtk+ "bin")
("pkg-config" ,pkg-config)
("vala" ,vala)))
(inputs
- `(("glib" ,glib)
+ `(("atk" ,atk)
+ ("cairo" ,cairo)
+ ("gdk-pixbuf" ,gdk-pixbuf+svg)
+ ("glib" ,glib)
("glib-networking" ,glib-networking)
("gpgme" ,gpgme)
("gsettings-desktop-schemas" ,gsettings-desktop-schemas)
("gtk+" ,gtk+)
("libgcrypt" ,libgcrypt)
("libgee" ,libgee)
+ ("libnice" ,libnice)
("libsignal-protocol-c" ,libsignal-protocol-c)
("libsoup" ,libsoup)
+ ("pango" ,pango)
("qrencode" ,qrencode)
("sqlite" ,sqlite)))
(synopsis "Graphical Jabber/XMPP Client using GTK+/Vala")
--
2.32.0
R
R
Raghav Gururajan wrote on 16 Jun 2021 09:17
[PATCH v3 1/3] gnu: dino: Remove duplicate inputs.
(address . 48953@debbugs.gnu.org)(name . Raghav Gururajan)(address . rg@raghavgururajan.name)
20210616071753.14948-1-rg@raghavgururajan.name
* gnu/packages/messaging.scm (dino)[inputs]: Remove duplicate gpgme,
gtk+, glib-networking and gsettings-desktop-schemas.
---
gnu/packages/messaging.scm | 6 +-----
1 file changed, 1 insertion(+), 5 deletions(-)

Toggle diff (19 lines)
diff --git a/gnu/packages/messaging.scm b/gnu/packages/messaging.scm
index 499b7a8f3a..0f9fe31772 100644
--- a/gnu/packages/messaging.scm
+++ b/gnu/packages/messaging.scm
@@ -1260,11 +1260,7 @@ Encryption to Gajim.")
("libsignal-protocol-c" ,libsignal-protocol-c)
("libsoup" ,libsoup)
("qrencode" ,qrencode)
- ("sqlite" ,sqlite)
- ("gpgme" ,gpgme)
- ("gtk+" ,gtk+)
- ("glib-networking" ,glib-networking)
- ("gsettings-desktop-schemas" ,gsettings-desktop-schemas)))
+ ("sqlite" ,sqlite)))
(synopsis "Graphical Jabber/XMPP Client using GTK+/Vala")
(description "Dino is a chat client for the desktop. It focuses on providing
a minimal yet reliable Jabber/XMPP experience and having encryption enabled by
--
2.32.0
R
R
Raghav Gururajan wrote on 16 Jun 2021 09:17
[PATCH v3 3/3] gnu: dino: Enable missing features.
(address . 48953@debbugs.gnu.org)(name . Raghav Gururajan)(address . rg@raghavgururajan.name)
20210616071753.14948-3-rg@raghavgururajan.name
* gnu/packages/messaging.scm (dino)[inputs]: Add gspell and icu4c.
---
gnu/packages/messaging.scm | 17 +++++++++++++++++
1 file changed, 17 insertions(+)

Toggle diff (53 lines)
diff --git a/gnu/packages/messaging.scm b/gnu/packages/messaging.scm
index 54d09c4815..c526b7a91a 100644
--- a/gnu/packages/messaging.scm
+++ b/gnu/packages/messaging.scm
@@ -1241,6 +1241,14 @@ Encryption to Gajim.")
(guix build glib-or-gtk-build-system))
#:phases
(modify-phases %standard-phases
+ ;; To be enabled in v0.3.0, for A/V support.
+ ;;(add-after 'install 'wrap
+ ;;(lambda* (#:key outputs #:allow-other-keys)
+ ;;(let* ((out (assoc-ref outputs "out"))
+ ;;(dino (string-append out "/bin/dino"))
+ ;;(gst-plugin-path (getenv "GST_PLUGIN_SYSTEM_PATH")))
+ ;;(wrap-program dino
+ ;;`("GST_PLUGIN_SYSTEM_PATH" ":" prefix (,gst-plugin-path))))))
(add-after 'install 'glib-or-gtk-wrap
(assoc-ref glib-or-gtk:%standard-phases 'glib-or-gtk-wrap)))))
(native-inputs
@@ -1251,6 +1259,7 @@ Encryption to Gajim.")
("pkg-config" ,pkg-config)
("vala" ,vala)))
(inputs
+ ;; NOTE: Commented-out lines are to be enabled in v0.3.0.
`(("atk" ,atk)
("cairo" ,cairo)
("gdk-pixbuf" ,gdk-pixbuf+svg)
@@ -1258,15 +1267,23 @@ Encryption to Gajim.")
("glib-networking" ,glib-networking)
("gpgme" ,gpgme)
("gsettings-desktop-schemas" ,gsettings-desktop-schemas)
+ ("gspell" ,gspell) ;for spell-check support
+ ;;("gstreamer" ,gstreamer) ;for A/V support
+ ;;("gst-plugins-base" ,gst-plugins-base)
+ ;;("gst-plugins-good" ,gst-plugins-good)
("gtk+" ,gtk+)
+ ("icu4c" ,icu4c) ;for emoji support
+ ("libcanberra" ,libcanberra) ;for sound-notification support
("libgcrypt" ,libgcrypt)
("libgee" ,libgee)
("libnice" ,libnice)
("libsignal-protocol-c" ,libsignal-protocol-c)
("libsoup" ,libsoup)
+ ;;("libsrtp" ,libsrtp) ;for calls support
("pango" ,pango)
("qrencode" ,qrencode)
("sqlite" ,sqlite)))
+ ;;("webrtc-audio-processing" ,webrtc-audio-processing))) ;for A/V support
(synopsis "Graphical Jabber/XMPP Client using GTK+/Vala")
(description "Dino is a chat client for the desktop. It focuses on providing
a minimal yet reliable Jabber/XMPP experience and having encryption enabled by
--
2.32.0
R
R
Raghav Gururajan wrote on 16 Jun 2021 09:19
[PATCH v4 1/3] gnu: dino: Remove duplicate inputs.
(address . 48953@debbugs.gnu.org)(name . Raghav Gururajan)(address . rg@raghavgururajan.name)
20210616071951.15064-1-rg@raghavgururajan.name
* gnu/packages/messaging.scm (dino)[inputs]: Remove duplicate gpgme,
gtk+, glib-networking and gsettings-desktop-schemas.
---
gnu/packages/messaging.scm | 6 +-----
1 file changed, 1 insertion(+), 5 deletions(-)

Toggle diff (19 lines)
diff --git a/gnu/packages/messaging.scm b/gnu/packages/messaging.scm
index 499b7a8f3a..0f9fe31772 100644
--- a/gnu/packages/messaging.scm
+++ b/gnu/packages/messaging.scm
@@ -1260,11 +1260,7 @@ Encryption to Gajim.")
("libsignal-protocol-c" ,libsignal-protocol-c)
("libsoup" ,libsoup)
("qrencode" ,qrencode)
- ("sqlite" ,sqlite)
- ("gpgme" ,gpgme)
- ("gtk+" ,gtk+)
- ("glib-networking" ,glib-networking)
- ("gsettings-desktop-schemas" ,gsettings-desktop-schemas)))
+ ("sqlite" ,sqlite)))
(synopsis "Graphical Jabber/XMPP Client using GTK+/Vala")
(description "Dino is a chat client for the desktop. It focuses on providing
a minimal yet reliable Jabber/XMPP experience and having encryption enabled by
--
2.32.0
R
R
Raghav Gururajan wrote on 16 Jun 2021 09:19
[PATCH v4 2/3] gnu: dino: Add missing inputs.
(address . 48953@debbugs.gnu.org)(name . Raghav Gururajan)(address . rg@raghavgururajan.name)
20210616071951.15064-2-rg@raghavgururajan.name
These new inputs are referenced by the package but was missing in
the package definition. Some of these inputs might have been used
by the package indirectly via propagation from other inputs.

* gnu/packages/messaging.scm (dino)[native-inputs]: Add gobject-introspection.
[inputs]: Add atk, cairo, gdk-pixbug+svg, libnice and pango.
---
gnu/packages/messaging.scm | 8 +++++++-
1 file changed, 7 insertions(+), 1 deletion(-)

Toggle diff (33 lines)
diff --git a/gnu/packages/messaging.scm b/gnu/packages/messaging.scm
index 0f9fe31772..54d09c4815 100644
--- a/gnu/packages/messaging.scm
+++ b/gnu/packages/messaging.scm
@@ -1246,19 +1246,25 @@ Encryption to Gajim.")
(native-inputs
`(("gettext" ,gettext-minimal)
("glib:bin" ,glib "bin")
+ ("gobject-introspection" ,gobject-introspection)
("gtk+:bin" ,gtk+ "bin")
("pkg-config" ,pkg-config)
("vala" ,vala)))
(inputs
- `(("glib" ,glib)
+ `(("atk" ,atk)
+ ("cairo" ,cairo)
+ ("gdk-pixbuf" ,gdk-pixbuf+svg)
+ ("glib" ,glib)
("glib-networking" ,glib-networking)
("gpgme" ,gpgme)
("gsettings-desktop-schemas" ,gsettings-desktop-schemas)
("gtk+" ,gtk+)
("libgcrypt" ,libgcrypt)
("libgee" ,libgee)
+ ("libnice" ,libnice)
("libsignal-protocol-c" ,libsignal-protocol-c)
("libsoup" ,libsoup)
+ ("pango" ,pango)
("qrencode" ,qrencode)
("sqlite" ,sqlite)))
(synopsis "Graphical Jabber/XMPP Client using GTK+/Vala")
--
2.32.0
R
R
Raghav Gururajan wrote on 16 Jun 2021 09:19
[PATCH v4 3/3] gnu: dino: Enable missing features.
(address . 48953@debbugs.gnu.org)(name . Raghav Gururajan)(address . rg@raghavgururajan.name)
20210616071951.15064-3-rg@raghavgururajan.name
* gnu/packages/messaging.scm (dino)[inputs]: Add gspell and icu4c.
---
gnu/packages/messaging.scm | 17 +++++++++++++++++
1 file changed, 17 insertions(+)

Toggle diff (53 lines)
diff --git a/gnu/packages/messaging.scm b/gnu/packages/messaging.scm
index 54d09c4815..eb4fc5436c 100644
--- a/gnu/packages/messaging.scm
+++ b/gnu/packages/messaging.scm
@@ -1241,6 +1241,14 @@ Encryption to Gajim.")
(guix build glib-or-gtk-build-system))
#:phases
(modify-phases %standard-phases
+ ;; To be enabled in v0.3.0, for A/V support.
+ ;;(add-after 'install 'wrap
+ ;;(lambda* (#:key outputs #:allow-other-keys)
+ ;;(let* ((out (assoc-ref outputs "out"))
+ ;;(dino (string-append out "/bin/dino"))
+ ;;(gst-plugin-path (getenv "GST_PLUGIN_SYSTEM_PATH")))
+ ;;(wrap-program dino
+ ;;`("GST_PLUGIN_SYSTEM_PATH" ":" prefix (,gst-plugin-path))))))
(add-after 'install 'glib-or-gtk-wrap
(assoc-ref glib-or-gtk:%standard-phases 'glib-or-gtk-wrap)))))
(native-inputs
@@ -1251,6 +1259,7 @@ Encryption to Gajim.")
("pkg-config" ,pkg-config)
("vala" ,vala)))
(inputs
+ ;; NOTE: Commented-out lines are to be enabled in v0.3.0.
`(("atk" ,atk)
("cairo" ,cairo)
("gdk-pixbuf" ,gdk-pixbuf+svg)
@@ -1258,15 +1267,23 @@ Encryption to Gajim.")
("glib-networking" ,glib-networking)
("gpgme" ,gpgme)
("gsettings-desktop-schemas" ,gsettings-desktop-schemas)
+ ("gspell" ,gspell) ;for spell-check support
+ ;;("gstreamer" ,gstreamer) ;for A/V support
+ ;;("gst-plugins-base" ,gst-plugins-base)
+ ;;("gst-plugins-good" ,gst-plugins-good)
("gtk+" ,gtk+)
+ ("icu4c" ,icu4c) ;for emoji support
+ ;;("libcanberra" ,libcanberra) ;for sound-notification support
("libgcrypt" ,libgcrypt)
("libgee" ,libgee)
("libnice" ,libnice)
("libsignal-protocol-c" ,libsignal-protocol-c)
("libsoup" ,libsoup)
+ ;;("libsrtp" ,libsrtp) ;for calls support
("pango" ,pango)
("qrencode" ,qrencode)
("sqlite" ,sqlite)))
+ ;;("webrtc-audio-processing" ,webrtc-audio-processing))) ;for A/V support
(synopsis "Graphical Jabber/XMPP Client using GTK+/Vala")
(description "Dino is a chat client for the desktop. It focuses on providing
a minimal yet reliable Jabber/XMPP experience and having encryption enabled by
--
2.32.0
R
R
Raghav Gururajan wrote on 17 Jun 2021 02:17
Re: [bug#48953] [PATCH v2 2/3] gnu: dino: Add missing inputs.
(name . Jack Hill)(address . jackhill@jackhill.us)(address . 48953@debbugs.gnu.org)
ea5b9f7a-8fb2-a692-32d7-4a7d70e8ab2f@raghavgururajan.name
Hi Jackhill!

Toggle quote (8 lines)
> I think canberra support is disabled by default even if the dependency
> is present. I found the following configure-flags enable it:
>
> #:configure-flags (list "-DDINO_PLUGIN_ENABLED_notification-sound=yes")
>
> Now I'm curious to find out from upstream why it's not enabled by
> default and if that should affect whether we enable it in Guix.

Ah thanks! I have moved this to 3rd patch, for enabling it in v0.3.0 update.

Regards,
RG.
Attachment: OpenPGP_signature
R
R
Raghav Gururajan wrote on 17 Jun 2021 02:19
Re: [bug#48953] [PATCH v2 3/3] gnu: dino: Enable missing features.
(name . Jack Hill)(address . jackhill@jackhill.us)(address . 48953@debbugs.gnu.org)
54ec29a6-7038-27ad-a867-6b057f4c1f4f@raghavgururajan.name
Hi Jackhill!

Toggle quote (3 lines)
> Nitpick of a sort: Can we forgo the #t with the (hopefully soon)
> upcoming core-updates merge?

I just kept that around for testing. Will be removing it in final patch.

Toggle quote (3 lines)
> Is there actual A/V support in this version of Dino, or is that only
> coming in 0.3.0?

Oh no no. It is meant to be commented, for enabling it in v0.3.0
release. I sent the wrong patch. The correct one is in v4.

Regards,
RG.
Attachment: OpenPGP_signature
R
R
Raghav Gururajan wrote on 17 Jun 2021 02:20
[PATCH v5 1/3] gnu: dino: Remove duplicate inputs.
(address . 48953@debbugs.gnu.org)(name . Raghav Gururajan)(address . rg@raghavgururajan.name)
20210617002055.21971-1-rg@raghavgururajan.name
* gnu/packages/messaging.scm (dino)[inputs]: Remove duplicate gpgme,
gtk+, glib-networking and gsettings-desktop-schemas.
---
gnu/packages/messaging.scm | 6 +-----
1 file changed, 1 insertion(+), 5 deletions(-)

Toggle diff (19 lines)
diff --git a/gnu/packages/messaging.scm b/gnu/packages/messaging.scm
index 499b7a8f3a..0f9fe31772 100644
--- a/gnu/packages/messaging.scm
+++ b/gnu/packages/messaging.scm
@@ -1260,11 +1260,7 @@ Encryption to Gajim.")
("libsignal-protocol-c" ,libsignal-protocol-c)
("libsoup" ,libsoup)
("qrencode" ,qrencode)
- ("sqlite" ,sqlite)
- ("gpgme" ,gpgme)
- ("gtk+" ,gtk+)
- ("glib-networking" ,glib-networking)
- ("gsettings-desktop-schemas" ,gsettings-desktop-schemas)))
+ ("sqlite" ,sqlite)))
(synopsis "Graphical Jabber/XMPP Client using GTK+/Vala")
(description "Dino is a chat client for the desktop. It focuses on providing
a minimal yet reliable Jabber/XMPP experience and having encryption enabled by
--
2.32.0
R
R
Raghav Gururajan wrote on 17 Jun 2021 02:20
[PATCH v5 2/3] gnu: dino: Add missing inputs.
(address . 48953@debbugs.gnu.org)(name . Raghav Gururajan)(address . rg@raghavgururajan.name)
20210617002055.21971-2-rg@raghavgururajan.name
These new inputs are referenced by the package but was missing in
the package definition. Some of these inputs might have been used
by the package indirectly via propagation from other inputs.

* gnu/packages/messaging.scm (dino)[native-inputs]: Add gobject-introspection.
[inputs]: Add atk, cairo, gdk-pixbug+svg, libnice and pango.
---
gnu/packages/messaging.scm | 8 +++++++-
1 file changed, 7 insertions(+), 1 deletion(-)

Toggle diff (33 lines)
diff --git a/gnu/packages/messaging.scm b/gnu/packages/messaging.scm
index 0f9fe31772..54d09c4815 100644
--- a/gnu/packages/messaging.scm
+++ b/gnu/packages/messaging.scm
@@ -1246,19 +1246,25 @@ Encryption to Gajim.")
(native-inputs
`(("gettext" ,gettext-minimal)
("glib:bin" ,glib "bin")
+ ("gobject-introspection" ,gobject-introspection)
("gtk+:bin" ,gtk+ "bin")
("pkg-config" ,pkg-config)
("vala" ,vala)))
(inputs
- `(("glib" ,glib)
+ `(("atk" ,atk)
+ ("cairo" ,cairo)
+ ("gdk-pixbuf" ,gdk-pixbuf+svg)
+ ("glib" ,glib)
("glib-networking" ,glib-networking)
("gpgme" ,gpgme)
("gsettings-desktop-schemas" ,gsettings-desktop-schemas)
("gtk+" ,gtk+)
("libgcrypt" ,libgcrypt)
("libgee" ,libgee)
+ ("libnice" ,libnice)
("libsignal-protocol-c" ,libsignal-protocol-c)
("libsoup" ,libsoup)
+ ("pango" ,pango)
("qrencode" ,qrencode)
("sqlite" ,sqlite)))
(synopsis "Graphical Jabber/XMPP Client using GTK+/Vala")
--
2.32.0
R
R
Raghav Gururajan wrote on 17 Jun 2021 02:20
[PATCH v5 3/3] gnu: dino: Enable some features.
(address . 48953@debbugs.gnu.org)(name . Raghav Gururajan)(address . rg@raghavgururajan.name)
20210617002055.21971-3-rg@raghavgururajan.name
* gnu/packages/messaging.scm (dino): Add comments for v0.3.0 release.
[inputs]: Add gspell and icu4c.
---
gnu/packages/messaging.scm | 17 +++++++++++++++++
1 file changed, 17 insertions(+)

Toggle diff (53 lines)
diff --git a/gnu/packages/messaging.scm b/gnu/packages/messaging.scm
index 54d09c4815..eb4fc5436c 100644
--- a/gnu/packages/messaging.scm
+++ b/gnu/packages/messaging.scm
@@ -1241,6 +1241,14 @@ Encryption to Gajim.")
(guix build glib-or-gtk-build-system))
#:phases
(modify-phases %standard-phases
+ ;; To be enabled in v0.3.0, for A/V support.
+ ;;(add-after 'install 'wrap
+ ;;(lambda* (#:key outputs #:allow-other-keys)
+ ;;(let* ((out (assoc-ref outputs "out"))
+ ;;(dino (string-append out "/bin/dino"))
+ ;;(gst-plugin-path (getenv "GST_PLUGIN_SYSTEM_PATH")))
+ ;;(wrap-program dino
+ ;;`("GST_PLUGIN_SYSTEM_PATH" ":" prefix (,gst-plugin-path))))))
(add-after 'install 'glib-or-gtk-wrap
(assoc-ref glib-or-gtk:%standard-phases 'glib-or-gtk-wrap)))))
(native-inputs
@@ -1251,6 +1259,7 @@ Encryption to Gajim.")
("pkg-config" ,pkg-config)
("vala" ,vala)))
(inputs
+ ;; NOTE: Commented-out lines are to be enabled in v0.3.0.
`(("atk" ,atk)
("cairo" ,cairo)
("gdk-pixbuf" ,gdk-pixbuf+svg)
@@ -1258,15 +1267,23 @@ Encryption to Gajim.")
("glib-networking" ,glib-networking)
("gpgme" ,gpgme)
("gsettings-desktop-schemas" ,gsettings-desktop-schemas)
+ ("gspell" ,gspell) ;for spell-check support
+ ;;("gstreamer" ,gstreamer) ;for A/V support
+ ;;("gst-plugins-base" ,gst-plugins-base)
+ ;;("gst-plugins-good" ,gst-plugins-good)
("gtk+" ,gtk+)
+ ("icu4c" ,icu4c) ;for emoji support
+ ;;("libcanberra" ,libcanberra) ;for sound-notification support
("libgcrypt" ,libgcrypt)
("libgee" ,libgee)
("libnice" ,libnice)
("libsignal-protocol-c" ,libsignal-protocol-c)
("libsoup" ,libsoup)
+ ;;("libsrtp" ,libsrtp) ;for calls support
("pango" ,pango)
("qrencode" ,qrencode)
("sqlite" ,sqlite)))
+ ;;("webrtc-audio-processing" ,webrtc-audio-processing))) ;for A/V support
(synopsis "Graphical Jabber/XMPP Client using GTK+/Vala")
(description "Dino is a chat client for the desktop. It focuses on providing
a minimal yet reliable Jabber/XMPP experience and having encryption enabled by
--
2.32.0
J
J
Jack Hill wrote on 21 Jun 2021 19:19
(name . Raghav Gururajan)(address . rg@raghavgururajan.name)(address . 48953@debbugs.gnu.org)
alpine.DEB.2.21.2106211318490.2109@marsh.hcoop.net
Version 5 addresses my comments, so LGTM.

Thanks!
Jack
R
R
Raghav Gururajan wrote on 22 Jun 2021 07:19
(no subject)
(address . 48953-done@debbugs.gnu.org)
59924d9f-6d0b-9f23-d0e7-caa45da4f035@raghavgururajan.name
Pushed as a1c7537548..adf485c815.
Attachment: OpenPGP_signature
Closed
?