[PATCH 00/10] some Python 2 removals.

  • Done
  • quality assurance status badge
Details
2 participants
  • Leo Famulari
  • zimoun
Owner
unassigned
Submitted by
zimoun
Severity
normal
Z
Z
zimoun wrote on 8 Jun 2021 16:35
(address . guix-patches@gnu.org)(name . zimoun)(address . zimon.toutoune@gmail.com)
20210608143543.30193-1-zimon.toutoune@gmail.com
Hi,

Because Python 2 is EOL and these packages fail to build, there are removed.
Well, "guix refresh -l" is checked to ensure they are leaf packages

At the end of the series, "make as-derivation" successes, so everything seems
fine.

Cheers,
simon


zimoun (10):
gnu: python2-bigfloat: Remove package.
gnu: python2-fastimport: Remove package.
gnu: python2-gridmap: Remove package.
gnu: python2-hdf4: Remove package.
gnu: python2-libvirt: Remove package.
gnu: python2-mechanicalsoup: Remove package.
gnu: python2-numpy-documentation: Remove package.
gnu: python2-orator: Remove package.
gnu: python2-partd: Remove package.
gnu: python2-pendulum: Remove package.

gnu/packages/databases.scm | 6 +-----
gnu/packages/python-web.scm | 3 ---
gnu/packages/python-xyz.scm | 22 ----------------------
gnu/packages/time.scm | 3 ---
gnu/packages/virtualization.scm | 3 ---
5 files changed, 1 insertion(+), 36 deletions(-)


base-commit: e3611cc412e7b1c750a56d17fb1b7cde684baa3f
--
2.30.1
Z
Z
zimoun wrote on 8 Jun 2021 16:37
[PATCH 01/10] gnu: python2-bigfloat: Remove package.
(address . 48922@debbugs.gnu.org)
20210608143751.30298-1-zimon.toutoune@gmail.com
* gnu/packages/python-xyz.scm (python2-bigfloat): Delete.
---
gnu/packages/python-xyz.scm | 3 ---
1 file changed, 3 deletions(-)

Toggle diff (16 lines)
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index bd4cd037c2..e7a9a9f16a 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -8893,9 +8893,6 @@ more advanced mathematics.")
multiprecision arithmetic.")
(license license:lgpl3+)))
-(define-public python2-bigfloat
- (package-with-python2 python-bigfloat))
-
(define-public python-sympy
(package
(name "python-sympy")
--
2.30.1
Z
Z
zimoun wrote on 8 Jun 2021 16:37
[PATCH 02/10] gnu: python2-fastimport: Remove package.
(address . 48922@debbugs.gnu.org)
20210608143751.30298-2-zimon.toutoune@gmail.com
* gnu/packages/python-xyz.scm (python2-fastimport): Delete.
---
gnu/packages/python-xyz.scm | 3 ---
1 file changed, 3 deletions(-)

Toggle diff (16 lines)
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index e7a9a9f16a..4b16dba994 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -14402,9 +14402,6 @@ graphviz.")
format.")
(license license:gpl2+)))
-(define-public python2-fastimport
- (package-with-python2 python-fastimport))
-
(define-public python-twisted
(package
(name "python-twisted")
--
2.30.1
Z
Z
zimoun wrote on 8 Jun 2021 16:37
[PATCH 03/10] gnu: python2-gridmap: Remove package.
(address . 48922@debbugs.gnu.org)
20210608143751.30298-3-zimon.toutoune@gmail.com
* gnu/packages/python-xyz.scm (python2-gridmap): Delete.
---
gnu/packages/python-xyz.scm | 3 ---
1 file changed, 3 deletions(-)

Toggle diff (16 lines)
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 4b16dba994..b59b7226f3 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -7103,9 +7103,6 @@ cluster directly from Python. You can directly map Python functions onto the
cluster without needing to write any wrapper code yourself.")
(license license:gpl3+)))
-(define-public python2-gridmap
- (package-with-python2 python-gridmap))
-
(define-public python-honcho
(package
(name "python-honcho")
--
2.30.1
Z
Z
zimoun wrote on 8 Jun 2021 16:37
[PATCH 04/10] gnu: python2-hdf4: Remove package.
(address . 48922@debbugs.gnu.org)
20210608143751.30298-4-zimon.toutoune@gmail.com
* gnu/packages/python-xyz.scm (python2-hdf4): Delete.
---
gnu/packages/python-xyz.scm | 3 ---
1 file changed, 3 deletions(-)

Toggle diff (16 lines)
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index b59b7226f3..182fae8024 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -1120,9 +1120,6 @@ NetCDF files can also be read and modified. Python-HDF4 is a fork of
@url{http://hdfeos.org/software/pyhdf.php,pyhdf}.")
(license license:expat)))
-(define-public python2-hdf4
- (package-with-python2 python-hdf4))
-
(define-public python-h5py
(package
(name "python-h5py")
--
2.30.1
Z
Z
zimoun wrote on 8 Jun 2021 16:37
[PATCH 05/10] gnu: python2-libvirt: Remove package.
(address . 48922@debbugs.gnu.org)
20210608143751.30298-5-zimon.toutoune@gmail.com
* gnu/packages/virtualization.scm (python2-libvirt): Delete.
---
gnu/packages/virtualization.scm | 3 ---
1 file changed, 3 deletions(-)

Toggle diff (16 lines)
diff --git a/gnu/packages/virtualization.scm b/gnu/packages/virtualization.scm
index 5e7dd8a10a..ba105eea11 100644
--- a/gnu/packages/virtualization.scm
+++ b/gnu/packages/virtualization.scm
@@ -1261,9 +1261,6 @@ three libraries:
virtualization library.")
(license license:lgpl2.1+)))
-(define-public python2-libvirt
- (package-with-python2 python-libvirt))
-
(define-public virt-manager
(package
(name "virt-manager")
--
2.30.1
Z
Z
zimoun wrote on 8 Jun 2021 16:37
[PATCH 06/10] gnu: python2-mechanicalsoup: Remove package.
(address . 48922@debbugs.gnu.org)
20210608143751.30298-6-zimon.toutoune@gmail.com
* gnu/packages/python-web.scm (python2-mechanicalsoup): Delete.
---
gnu/packages/python-web.scm | 3 ---
1 file changed, 3 deletions(-)

Toggle diff (16 lines)
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index 81cd4daea2..86a732fa1b 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -826,9 +826,6 @@ websites. It automatically stores and sends cookies, follows redirects, and can
follow links and submit forms. It doesn’t do JavaScript.")
(license license:expat)))
-(define-public python2-mechanicalsoup
- (package-with-python2 python-mechanicalsoup))
-
(define-public python-hyperframe
(package
(name "python-hyperframe")
--
2.30.1
Z
Z
zimoun wrote on 8 Jun 2021 16:37
[PATCH 07/10] gnu: python2-numpy-documentation: Remove package.
(address . 48922@debbugs.gnu.org)
20210608143751.30298-7-zimon.toutoune@gmail.com
* gnu/packages/python-xyz.scm (python2-numpy-documentation): Delete.
---
gnu/packages/python-xyz.scm | 7 -------
1 file changed, 7 deletions(-)

Toggle diff (20 lines)
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 182fae8024..8a8bc431d3 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -5341,13 +5341,6 @@ color scales, and color space conversion easy. It has support for:
(description (package-description python-numpy))
(license (package-license python-numpy))))
-(define-public python2-numpy-documentation
- (let ((numpy-documentation (package-with-python2 python-numpy-documentation)))
- (package
- (inherit numpy-documentation)
- (native-inputs `(("python2-functools32" ,python2-functools32)
- ,@(package-native-inputs numpy-documentation))))))
-
(define-public python-pygit2
(package
(name "python-pygit2")
--
2.30.1
Z
Z
zimoun wrote on 8 Jun 2021 16:37
[PATCH 08/10] gnu: python2-orator: Remove package.
(address . 48922@debbugs.gnu.org)
20210608143751.30298-8-zimon.toutoune@gmail.com
* gnu/packages/database.scm (python2-orator): Delete.
(python-orator)[properties]: Remove.
---
gnu/packages/databases.scm | 6 +-----
1 file changed, 1 insertion(+), 5 deletions(-)

Toggle diff (19 lines)
diff --git a/gnu/packages/databases.scm b/gnu/packages/databases.scm
index cd760ee5ef..23e25f5a66 100644
--- a/gnu/packages/databases.scm
+++ b/gnu/packages/databases.scm
@@ -2793,11 +2793,7 @@ Memory-Mapped Database} (LMDB), a high-performance key-value store.")
(description
"Orator provides a simple ActiveRecord-like Object Relational Mapping
implementation for Python.")
- (license license:expat)
- (properties `((python2-variant . ,(delay python2-orator))))))
-
-(define-public python2-orator
- (package-with-python2 (strip-python2-variant python-orator)))
+ (license license:expat)))
(define-public virtuoso-ose
(package
--
2.30.1
Z
Z
zimoun wrote on 8 Jun 2021 16:37
[PATCH 09/10] gnu: python2-partd: Remove package.
(address . 48922@debbugs.gnu.org)
20210608143751.30298-9-zimon.toutoune@gmail.com
* gnu/packages/python-xyz.scm (python2-partd): Delete.
---
gnu/packages/python-xyz.scm | 3 ---
1 file changed, 3 deletions(-)

Toggle diff (16 lines)
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 8a8bc431d3..970942d880 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -21543,9 +21543,6 @@ This Python package wraps the Blosc library.")
append on old values. Partd excels at shuffling operations.")
(license license:bsd-3)))
-(define-public python2-partd
- (package-with-python2 python-partd))
-
(define-public python-fsspec
(package
(name "python-fsspec")
--
2.30.1
Z
Z
zimoun wrote on 8 Jun 2021 16:37
[PATCH 10/10] gnu: python2-pendulum: Remove package.
(address . 48922@debbugs.gnu.org)
20210608143751.30298-10-zimon.toutoune@gmail.com
* gnu/packages/time.scm (python2-pendulum): Delete.
---
gnu/packages/time.scm | 3 ---
1 file changed, 3 deletions(-)

Toggle diff (16 lines)
diff --git a/gnu/packages/time.scm b/gnu/packages/time.scm
index d6ebb59a1e..651e2e3a29 100644
--- a/gnu/packages/time.scm
+++ b/gnu/packages/time.scm
@@ -169,9 +169,6 @@ standard @code{datetime} all @code{datetime} instances can be replaced by
Pendulum instances.")
(license expat)))
-(define-public python2-pendulum
- (package-with-python2 python-pendulum))
-
(define-public python-dateutil
(package
(name "python-dateutil")
--
2.30.1
L
L
Leo Famulari wrote on 8 Jun 2021 19:12
Re: [bug#48922] [PATCH 00/10] some Python 2 removals.
(name . zimoun)(address . zimon.toutoune@gmail.com)
YL+lGUd//NZIfvc+@jasmine.lan
On Tue, Jun 08, 2021 at 04:35:43PM +0200, zimoun wrote:
Toggle quote (8 lines)
> Hi,
>
> Because Python 2 is EOL and these packages fail to build, there are removed.
> Well, "guix refresh -l" is checked to ensure they are leaf packages
>
> At the end of the series, "make as-derivation" successes, so everything seems
> fine.

Thanks for taking care of this! Pushed as
a9eb39d4eb7a2679fdf387037e2501b054fbaab3
Closed
Z
Z
zimoun wrote on 9 Jun 2021 16:18
(name . Leo Famulari)(address . leo@famulari.name)
CAJ3okZ0EUDkxhEOUA=Jix3waPHNm=ciSjTdyxQ8WWRBLqJ0hpg@mail.gmail.com
Hi Leo,

On Tue, 8 Jun 2021 at 19:13, Leo Famulari <leo@famulari.name> wrote:

Toggle quote (3 lines)
> Thanks for taking care of this! Pushed as
> a9eb39d4eb7a2679fdf387037e2501b054fbaab3

Thanks. More should come. :-)

Cheers,
simon
Closed
?